EZ5 MIB Catalog

JNX-L2TP-MIB

2014-05-02

Provides monitoring information regarding the Layer Two Transport Protocol. This MIB is based on the standard MIB defined in RFC 3371. However, there are significant differences including the INDEX fields of l2tpTunnelStatsTable and l2tpSessionStatsTable.

Download JNX-L2TP-MIB.txt Open JNX-L2TP-MIB.txt in a new tab

SCALARS (13) · TABLES (4)

Scalars (13)

NameOID
jnxL2tpStatsTotalTunnels1.3.6.1.4.1.2636.3.49.1.1.1.1.1
jnxL2tpStatsTotalSessions1.3.6.1.4.1.2636.3.49.1.1.1.1.2
jnxL2tpStatsControlRxOctets1.3.6.1.4.1.2636.3.49.1.1.1.1.3
jnxL2tpStatsControlRxPkts1.3.6.1.4.1.2636.3.49.1.1.1.1.4
jnxL2tpStatsControlTxOctets1.3.6.1.4.1.2636.3.49.1.1.1.1.5
jnxL2tpStatsControlTxPkts1.3.6.1.4.1.2636.3.49.1.1.1.1.6
jnxL2tpStatsPayloadRxOctets1.3.6.1.4.1.2636.3.49.1.1.1.1.7
jnxL2tpStatsPayloadRxPkts1.3.6.1.4.1.2636.3.49.1.1.1.1.8
jnxL2tpStatsPayloadTxOctets1.3.6.1.4.1.2636.3.49.1.1.1.1.9
jnxL2tpStatsPayloadTxPkts1.3.6.1.4.1.2636.3.49.1.1.1.1.10
jnxL2tpStatsErrorTxPkts1.3.6.1.4.1.2636.3.49.1.1.1.1.11
jnxL2tpStatsErrorRxPkts1.3.6.1.4.1.2636.3.49.1.1.1.1.12
jnxL2tpStatsPayloadRxOctets641.3.6.1.4.1.2636.3.49.1.1.1.1.13

Tables (4)

NameOID
jnxL2tpTunnelGroupStatsTable1.3.6.1.4.1.2636.3.49.1.1.2
jnxL2tpTunnelStatsTable1.3.6.1.4.1.2636.3.49.1.1.3
jnxL2tpSessionStatsTable1.3.6.1.4.1.2636.3.49.1.1.4
jnxL2tpMlpppBundleStatsTable1.3.6.1.4.1.2636.3.49.1.1.5

END OF TOC

Scalar details

jnxL2tpStatsTotalTunnels

1.3.6.1.4.1.2636.3.49.1.1.1.1.1

Gauge32

This object returns the total number of tunnels that are currently in the established state. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

jnxL2tpStatsTotalSessions

1.3.6.1.4.1.2636.3.49.1.1.1.1.2

Gauge32

This object returns the total number of sessions that are currently in the established state. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

jnxL2tpStatsControlRxOctets

1.3.6.1.4.1.2636.3.49.1.1.1.1.3

Gauge32

This object returns the number of control channel octets received by the existing tunnels. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

jnxL2tpStatsControlRxPkts

1.3.6.1.4.1.2636.3.49.1.1.1.1.4

Gauge32

This object returns the number of control packets received by the existing tunnels. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

jnxL2tpStatsControlTxOctets

1.3.6.1.4.1.2636.3.49.1.1.1.1.5

Gauge32

This object returns the number of control channel octets that were transmitted to the existing tunnel endpoints. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

jnxL2tpStatsControlTxPkts

1.3.6.1.4.1.2636.3.49.1.1.1.1.6

Gauge32

This object returns the number of control packets that were transmitted to the existing tunnel endpoints.This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

jnxL2tpStatsPayloadRxOctets

1.3.6.1.4.1.2636.3.49.1.1.1.1.7

Gauge32

This object returns the number of payload channel octets that were received on the exisiting tunnels. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying. This is deprecated and replaced by jnxL2tpStatsPayloadRxOctets64

jnxL2tpStatsPayloadRxPkts

1.3.6.1.4.1.2636.3.49.1.1.1.1.8

CounterBasedGauge64The CounterBasedGauge64 type represents a non-negative integer, which may increase or decrease, but shall never exceed a maximum value, nor fall below a minimum value. The maximum value can not be greater than 2^64-1 (18446744073709551615 decimal), and the minimum value can not be smaller than 0. The value of a CounterBasedGauge64 has its maximum value whenever the information being modeled is greater than or equal to its maximum value, and has its minimum value whenever the information being modeled is smaller than or equal to its minimum value. If the information being modeled subsequently decreases below (increases above) the maximum (minimum) value, the CounterBasedGauge64 also decreases (increases). Note that this TC is not strictly supported in SMIv2, because the 'always increasing' and 'counter wrap' semantics associated with the Counter64 base type are not preserved. It is possible that management applications which rely solely upon the (Counter64) ASN.1 tag to determine object semantics will mistakenly operate upon objects of this type as they would for Counter64 objects. This textual convention represents a limited and short-term solution, and may be deprecated as a long term solution is defined and deployed to replace it. (0..18446744073709551615) · Counter64

This object returns the number of payload packets that were received on the existing tunnels. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

jnxL2tpStatsPayloadTxOctets

1.3.6.1.4.1.2636.3.49.1.1.1.1.9

CounterBasedGauge64The CounterBasedGauge64 type represents a non-negative integer, which may increase or decrease, but shall never exceed a maximum value, nor fall below a minimum value. The maximum value can not be greater than 2^64-1 (18446744073709551615 decimal), and the minimum value can not be smaller than 0. The value of a CounterBasedGauge64 has its maximum value whenever the information being modeled is greater than or equal to its maximum value, and has its minimum value whenever the information being modeled is smaller than or equal to its minimum value. If the information being modeled subsequently decreases below (increases above) the maximum (minimum) value, the CounterBasedGauge64 also decreases (increases). Note that this TC is not strictly supported in SMIv2, because the 'always increasing' and 'counter wrap' semantics associated with the Counter64 base type are not preserved. It is possible that management applications which rely solely upon the (Counter64) ASN.1 tag to determine object semantics will mistakenly operate upon objects of this type as they would for Counter64 objects. This textual convention represents a limited and short-term solution, and may be deprecated as a long term solution is defined and deployed to replace it. (0..18446744073709551615) · Counter64

This object returns the number of payload channel octets that were transmitted to the existing tunnel peers. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

jnxL2tpStatsPayloadTxPkts

1.3.6.1.4.1.2636.3.49.1.1.1.1.10

CounterBasedGauge64The CounterBasedGauge64 type represents a non-negative integer, which may increase or decrease, but shall never exceed a maximum value, nor fall below a minimum value. The maximum value can not be greater than 2^64-1 (18446744073709551615 decimal), and the minimum value can not be smaller than 0. The value of a CounterBasedGauge64 has its maximum value whenever the information being modeled is greater than or equal to its maximum value, and has its minimum value whenever the information being modeled is smaller than or equal to its minimum value. If the information being modeled subsequently decreases below (increases above) the maximum (minimum) value, the CounterBasedGauge64 also decreases (increases). Note that this TC is not strictly supported in SMIv2, because the 'always increasing' and 'counter wrap' semantics associated with the Counter64 base type are not preserved. It is possible that management applications which rely solely upon the (Counter64) ASN.1 tag to determine object semantics will mistakenly operate upon objects of this type as they would for Counter64 objects. This textual convention represents a limited and short-term solution, and may be deprecated as a long term solution is defined and deployed to replace it. (0..18446744073709551615) · Counter64

This object returns the number of payload packets that were transmitted to existing tunnel peers. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

jnxL2tpStatsErrorTxPkts

1.3.6.1.4.1.2636.3.49.1.1.1.1.11

CounterBasedGauge64The CounterBasedGauge64 type represents a non-negative integer, which may increase or decrease, but shall never exceed a maximum value, nor fall below a minimum value. The maximum value can not be greater than 2^64-1 (18446744073709551615 decimal), and the minimum value can not be smaller than 0. The value of a CounterBasedGauge64 has its maximum value whenever the information being modeled is greater than or equal to its maximum value, and has its minimum value whenever the information being modeled is smaller than or equal to its minimum value. If the information being modeled subsequently decreases below (increases above) the maximum (minimum) value, the CounterBasedGauge64 also decreases (increases). Note that this TC is not strictly supported in SMIv2, because the 'always increasing' and 'counter wrap' semantics associated with the Counter64 base type are not preserved. It is possible that management applications which rely solely upon the (Counter64) ASN.1 tag to determine object semantics will mistakenly operate upon objects of this type as they would for Counter64 objects. This textual convention represents a limited and short-term solution, and may be deprecated as a long term solution is defined and deployed to replace it. (0..18446744073709551615) · Counter64

This object returns the number of errored packet transmission attempts to the existing tunnel peers. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

jnxL2tpStatsErrorRxPkts

1.3.6.1.4.1.2636.3.49.1.1.1.1.12

CounterBasedGauge64The CounterBasedGauge64 type represents a non-negative integer, which may increase or decrease, but shall never exceed a maximum value, nor fall below a minimum value. The maximum value can not be greater than 2^64-1 (18446744073709551615 decimal), and the minimum value can not be smaller than 0. The value of a CounterBasedGauge64 has its maximum value whenever the information being modeled is greater than or equal to its maximum value, and has its minimum value whenever the information being modeled is smaller than or equal to its minimum value. If the information being modeled subsequently decreases below (increases above) the maximum (minimum) value, the CounterBasedGauge64 also decreases (increases). Note that this TC is not strictly supported in SMIv2, because the 'always increasing' and 'counter wrap' semantics associated with the Counter64 base type are not preserved. It is possible that management applications which rely solely upon the (Counter64) ASN.1 tag to determine object semantics will mistakenly operate upon objects of this type as they would for Counter64 objects. This textual convention represents a limited and short-term solution, and may be deprecated as a long term solution is defined and deployed to replace it. (0..18446744073709551615) · Counter64

This object returns the number of errored packets that were received from the existing tunnel peers. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

jnxL2tpStatsPayloadRxOctets64

1.3.6.1.4.1.2636.3.49.1.1.1.1.13

CounterBasedGauge64The CounterBasedGauge64 type represents a non-negative integer, which may increase or decrease, but shall never exceed a maximum value, nor fall below a minimum value. The maximum value can not be greater than 2^64-1 (18446744073709551615 decimal), and the minimum value can not be smaller than 0. The value of a CounterBasedGauge64 has its maximum value whenever the information being modeled is greater than or equal to its maximum value, and has its minimum value whenever the information being modeled is smaller than or equal to its minimum value. If the information being modeled subsequently decreases below (increases above) the maximum (minimum) value, the CounterBasedGauge64 also decreases (increases). Note that this TC is not strictly supported in SMIv2, because the 'always increasing' and 'counter wrap' semantics associated with the Counter64 base type are not preserved. It is possible that management applications which rely solely upon the (Counter64) ASN.1 tag to determine object semantics will mistakenly operate upon objects of this type as they would for Counter64 objects. This textual convention represents a limited and short-term solution, and may be deprecated as a long term solution is defined and deployed to replace it. (0..18446744073709551615) · Counter64

This object returns the number of payload channel octets that were received on the exisiting tunnels. This is an instantaneously accumulated value which can increase or decrease depending on number of tunnels established at the time of querying.

Table details

jnxL2tpTunnelGroupStatsTable

1.3.6.1.4.1.2636.3.49.1.1.2

Index: IMPLIED jnxL2tpTunnelGroupStatsTnlGrpName

The L2TP tunnel group status and statistics table. This table contains objects that can be used to describe the current status and statistics of a single L2TP tunnel group.

jnxL2tpTunnelGroupStatsTnlGrpName

1.3.6.1.4.1.2636.3.49.1.1.2.1.1

OCTET STRING SIZE (1..128)

This object contains the name of this tunnel group.

jnxL2tpTunnelGroupStatsGatewayAddrType

1.3.6.1.4.1.2636.3.49.1.1.2.1.2

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object contains the type of local IP address for L2TP tunnels that are part of this group.

jnxL2tpTunnelGroupStatsGatewayAddr

1.3.6.1.4.1.2636.3.49.1.1.2.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object contains the local IP address for L2TP tunnels that are part of this group.

jnxL2tpTunnelGroupStatsSvcIntfName

1.3.6.1.4.1.2636.3.49.1.1.2.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the name of the service interface that is hosting this tunnel group.

jnxL2tpTunnelGroupStatsTotalTunnels

1.3.6.1.4.1.2636.3.49.1.1.2.1.5

Gauge32

This object returns the total number of tunnels that are currently in the established state in this tunnel group.

jnxL2tpTunnelGroupStatsTotalSessions

1.3.6.1.4.1.2636.3.49.1.1.2.1.6

Gauge32

This object returns the total number of sessions that are currently in the established state in this tunnel group.

jnxL2tpTunnelStatsTable

1.3.6.1.4.1.2636.3.49.1.1.3

Index: jnxL2tpTunnelStatsLocalTID

The L2TP tunnel status and statistics table. This table contains objects that can be used to describe the current status and statistics of a single L2TP tunnel.

jnxL2tpTunnelStatsLocalTID

1.3.6.1.4.1.2636.3.49.1.1.3.1.1

Integer32 (0..65535)

Reference: RFC 2661, Section 3.1

This object contains the local tunnel Identifier.

jnxL2tpTunnelStatsServiceInterface

1.3.6.1.4.1.2636.3.49.1.1.3.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the name of the service interface on which this tunnel is being hosted.

jnxL2tpTunnelStatsTunnelGroup

1.3.6.1.4.1.2636.3.49.1.1.3.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the name of the tunnel group that this tunnel is part of.

jnxL2tpTunnelStatsRemoteTID

1.3.6.1.4.1.2636.3.49.1.1.3.1.4

Integer32 (0..65535)

Reference: RFC 2661, Section 3.1

This object contains the remote tunnel Identifier.

jnxL2tpTunnelStatsRemoteIpAddrType

1.3.6.1.4.1.2636.3.49.1.1.3.1.5

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object contains the type of the remote end address of this tunnel.

jnxL2tpTunnelStatsRemoteIpAddress

1.3.6.1.4.1.2636.3.49.1.1.3.1.6

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object contains the remote end address of this tunnel.

jnxL2tpTunnelStatsRemoteUdpPort

1.3.6.1.4.1.2636.3.49.1.1.3.1.7

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object contains the remote end UDP port of this tunnel.

jnxL2tpTunnelStatsActiveSessions

1.3.6.1.4.1.2636.3.49.1.1.3.1.8

Gauge32

This object contains the total number of sessions in the established state for this tunnel.

jnxL2tpTunnelStatsState

1.3.6.1.4.1.2636.3.49.1.1.3.1.9

INTEGER1 = cc-responder-accept-new2 = cc-responder-reject-new3 = cc-responder-idle4 = cc-responder-wait-ctl-conn5 = cleanup6 = closed7 = destroyed8 = established9 = terminate10 = unknown · Integer32

This field contains the current state of the control tunnel - one of the internal tunnel state names as described below: cc_responder_accept_new The tunnel has received and accepted the start control connection request (SCCRQ) cc_responder_reject_new The tunnel has received and rejected the SCCRQ cc_responder_idle The tunnel has just been created cc_responder_wait_ctl_conn The tunnel has sent the start control connection response (SCCRP) and is waiting for the start control connection connected (SCCCN) message cleanup The tunnel is being cleaned up closed The tunnel is being closed destroyed The tunnel is being destroyed established The tunnel is operating terminate The tunnel is terminating Unknown The tunnel is not connected to the router.

jnxL2tpTunnelStatsLocalIpAddrType

1.3.6.1.4.1.2636.3.49.1.1.3.1.10

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object contains the type of the local end address of this tunnel.

jnxL2tpTunnelStatsLocalIpAddress

1.3.6.1.4.1.2636.3.49.1.1.3.1.11

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object contains the local end address of this tunnel.

jnxL2tpTunnelStatsLocalUdpPort

1.3.6.1.4.1.2636.3.49.1.1.3.1.12

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object contains the local end UDP port of this tunnel.

jnxL2tpTunnelStatsLocalHostName

1.3.6.1.4.1.2636.3.49.1.1.3.1.13

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the local host name of this tunnel.

jnxL2tpTunnelStatsRemoteHostName

1.3.6.1.4.1.2636.3.49.1.1.3.1.14

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the host name as discovered during the tunnel establishment phase (via the Host Name AVP) of the L2TP peer. If the tunnel is idle this object should maintain its value from the last time it was connected.

jnxL2tpTunnelMaxSessions

1.3.6.1.4.1.2636.3.49.1.1.3.1.15

Integer32

This object represents the maximum number of sessions configured on this tunnel. It could be any positive number or unlimited (0).

jnxL2tpTunnelStatsWindowSize

1.3.6.1.4.1.2636.3.49.1.1.3.1.16

Integer32 (0..65535)

This object contains the send window size for this tunnel.

jnxL2tpTunnelStatsHelloInterval

1.3.6.1.4.1.2636.3.49.1.1.3.1.17

Integer32 (0..65535)

This object contains the hello interval for this tunnel.

jnxL2tpTunnelStatsCreationTime

1.3.6.1.4.1.2636.3.49.1.1.3.1.18

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This object represents the time of creation of this tunnel.

jnxL2tpTunnelStatsUpTime

1.3.6.1.4.1.2636.3.49.1.1.3.1.19

TimeTicks

This object represents the time elapsed since this tunnel was established.

jnxL2tpTunnelStatsIdleTime

1.3.6.1.4.1.2636.3.49.1.1.3.1.20

TimeTicks

This object represents the time elapsed since this tunnel had last data activity (transmission or reception).

jnxL2tpTunnelStatsCollectionStart

1.3.6.1.4.1.2636.3.49.1.1.3.1.21

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This object represents the time at which the statistics gathering started for this tunnel.

jnxL2tpTunnelStatsControlTxPkts

1.3.6.1.4.1.2636.3.49.1.1.3.1.22

Counter32

This object contains the number of control packets that were transmitted to the tunnel peer.

jnxL2tpTunnelStatsControlTxBytes

1.3.6.1.4.1.2636.3.49.1.1.3.1.23

Counter64 (0..18446744073709551615)

This object contains the number of control bytes that were transmitted to the tunnel peer. This is deprecated and replaced by jnxL2tpTunnelStatsControlTxBytes32

jnxL2tpTunnelStatsControlRxPkts

1.3.6.1.4.1.2636.3.49.1.1.3.1.24

Counter32

This object contains the number of control packets received on the tunnel.

jnxL2tpTunnelStatsControlRxBytes

1.3.6.1.4.1.2636.3.49.1.1.3.1.25

Counter64 (0..18446744073709551615)

This object contains the number of control bytes that were received from the tunnel peer. This has been deprecated and replaced by jnxL2tpTunnelStatsControlRxBytes32

jnxL2tpTunnelStatsDataTxPkts

1.3.6.1.4.1.2636.3.49.1.1.3.1.26

Counter32

This object contains the number of data packets transmitted to the tunnel. This has been deprecated and replaced by jnxL2tpTunnelStatsDataTxPkts64

jnxL2tpTunnelStatsDataTxBytes

1.3.6.1.4.1.2636.3.49.1.1.3.1.27

Counter64 (0..18446744073709551615)

This object contains the number of data bytes that were transmitted to the tunnel peer.

jnxL2tpTunnelStatsDataRxPkts

1.3.6.1.4.1.2636.3.49.1.1.3.1.28

Counter32

This object contains the number of data packets received from this tunnel. This is deprecated and replaced by jnxL2tpTunnelStatsDataRxPkts64

jnxL2tpTunnelStatsDataRxBytes

1.3.6.1.4.1.2636.3.49.1.1.3.1.29

Counter64 (0..18446744073709551615)

This object contains the number of data bytes that were received from the tunnel peer.

jnxL2tpTunnelStatsErrorTxPkts

1.3.6.1.4.1.2636.3.49.1.1.3.1.30

Counter32

This object contains the number of error transmit packets on the tunnel.

jnxL2tpTunnelStatsErrorRxPkts

1.3.6.1.4.1.2636.3.49.1.1.3.1.31

Counter32

This object contains the number of error receive packets on the tunnel.

jnxL2tpTunnelStatsControlTxBytes32

1.3.6.1.4.1.2636.3.49.1.1.3.1.32

Counter32

This object contains the number of control bytes that were transmitted to the tunnel peer.

jnxL2tpTunnelStatsControlRxBytes32

1.3.6.1.4.1.2636.3.49.1.1.3.1.33

Counter32

This object contains the number of control bytes that were received from the tunnel peer.

jnxL2tpTunnelStatsDataTxPkts64

1.3.6.1.4.1.2636.3.49.1.1.3.1.34

Counter64 (0..18446744073709551615)

This object contains the number of data packets transmitted to the tunnel.

jnxL2tpTunnelStatsDataRxPkts64

1.3.6.1.4.1.2636.3.49.1.1.3.1.35

Counter64 (0..18446744073709551615)

This object contains the number of data packets received from this tunnel.

jnxL2tpSessionStatsTable

1.3.6.1.4.1.2636.3.49.1.1.4

Index: jnxL2tpSessionStatsLocalTID · jnxL2tpSessionStatsLocalSID

The L2TP session status and statistics table. This table contains the objects that can be used to describe the current status and statistics of a single L2TP tunneled session.

jnxL2tpSessionStatsLocalTID

1.3.6.1.4.1.2636.3.49.1.1.4.1.1

Integer32 (0..65535)

Reference: RFC 2661, Section 3.1

This object contains the local tunnel Identifier.

jnxL2tpSessionStatsLocalSID

1.3.6.1.4.1.2636.3.49.1.1.4.1.2

Integer32 (0..65535)

Reference: RFC 2661, Section 3.1

This object contains the local session Identifier.

jnxL2tpSessionStatsServiceInterface

1.3.6.1.4.1.2636.3.49.1.1.4.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the name of the service interface on which this session is being hosted.

jnxL2tpSessionStatsTunnelGroup

1.3.6.1.4.1.2636.3.49.1.1.4.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the name of the tunnel group that this session is part of.

jnxL2tpSessionStatsRemoteSID

1.3.6.1.4.1.2636.3.49.1.1.4.1.5

Integer32 (0..65535)

Reference: RFC 2661, Section 3.1

This object contains the remote end assigned session identifier for this session. When a session is starting this value may be zero until the remote tunnel endpoint has responded.

jnxL2tpSessionStatsInterfaceUnit

1.3.6.1.4.1.2636.3.49.1.1.4.1.6

Unsigned32

This object contains the interface unit number corresponding to the logical service interface on which the session is being hosted.

jnxL2tpSessionStatsEncapType

1.3.6.1.4.1.2636.3.49.1.1.4.1.7

INTEGER1 = ppp2 = multilink-ppp3 = unknown · Integer32

This object contains the tunnel encapsulation type.

jnxL2tpSessionStatsBundleID

1.3.6.1.4.1.2636.3.49.1.1.4.1.8

Integer32 (1..65536)

This object identifies the bundle that this session is a link of. This field is valid only for tunnel encapsulation type multilink-ppp.

jnxL2tpSessionStatsState

1.3.6.1.4.1.2636.3.49.1.1.4.1.9

INTEGER1 = established2 = closed3 = destroyed4 = cleanup5 = lns-ic-accept-new6 = lns-ic-idle7 = lns-ic-reject-new8 = lns-ic-wait-connect · Integer32

This field contains the current state of the session - one of the internal session related state names as described below: established The session is operating closed The session is being closed destroyed The session is being destroyed cleanup The session is being cleaned up lns_ic_accept_new A new session is being accepted lns_ic_idle The session has been created and is idle lns_ic_reject_new The new session is being rejected lns_ic_wait_connect The session is waiting for the peer's incoming call connected (ICCN) message.

jnxL2tpSessionStatsUserName

1.3.6.1.4.1.2636.3.49.1.1.4.1.10

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object identifies the peer session name on this interface. This is typically the login name of the remote user. If the user name is unknown to the local tunnel peer then this object will contain a null string.

jnxL2tpSessionStatsMode

1.3.6.1.4.1.2636.3.49.1.1.4.1.11

INTEGER1 = shared2 = dedicate3 = unknown · Integer32

This object identifies the configured mode value for this session.

jnxL2tpSessionStatsLocalAddrType

1.3.6.1.4.1.2636.3.49.1.1.4.1.12

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object contains the type of the local end address of the tunnel that is hosting this session.

jnxL2tpSessionStatsLocalAddress

1.3.6.1.4.1.2636.3.49.1.1.4.1.13

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object contains the local end address of the tunnel that is hosting this session.

jnxL2tpSessionStatsLocalUdpPort

1.3.6.1.4.1.2636.3.49.1.1.4.1.14

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object contains the UDP port of the local end of the tunnel that is hosting this session.

jnxL2tpSessionStatsRemoteAddrType

1.3.6.1.4.1.2636.3.49.1.1.4.1.15

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object contains the type of the remote end address of the tunnel hosting this session.

jnxL2tpSessionStatsRemoteAddress

1.3.6.1.4.1.2636.3.49.1.1.4.1.16

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object contains the remote end address of the tunnel hosting this session.

jnxL2tpSessionStatsRemoteUdpPort

1.3.6.1.4.1.2636.3.49.1.1.4.1.17

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object contains the UDP port of the remote end of the tunnel hosting this session.

jnxL2tpSessionStatsLocalHostName

1.3.6.1.4.1.2636.3.49.1.1.4.1.18

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the local host name of the tunnel that is hosting this session.

jnxL2tpSessionStatsRemoteHostName

1.3.6.1.4.1.2636.3.49.1.1.4.1.19

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the host name as discovered during the tunnel establishment phase (via the Host Name AVP) of the L2TP peer.

jnxL2tpSessionAssignedIpAddrType

1.3.6.1.4.1.2636.3.49.1.1.4.1.20

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object contains the type of IP address of PPP client being tunneled as obtained from IPCP configuration during session establishment.

jnxL2tpSessionAssignedIpAddress

1.3.6.1.4.1.2636.3.49.1.1.4.1.21

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object contains the IP address of the PPP client being tunneled as obtained from IPCP configuration during session establishment.

jnxL2tpSessionLocalMRU

1.3.6.1.4.1.2636.3.49.1.1.4.1.22

INTEGER (1..2147483647) · Integer32

The current value of the MRU for the local PPP Entity. This value is the MRU that the remote entity is using when sending packets to this session.

jnxL2tpSessionRemoteMRU

1.3.6.1.4.1.2636.3.49.1.1.4.1.23

INTEGER (1..2147483647) · Integer32

The current value of the MRU for the remote PPP Entity. This value is the MRU that the local entity is using when sending packets to the remote PPP client.

jnxL2tpSessionStatsTxSpeed

1.3.6.1.4.1.2636.3.49.1.1.4.1.24

Unsigned32 · bits per second

This object returns the last known transmit baud rate for this session.

jnxL2tpSessionStatsRxSpeed

1.3.6.1.4.1.2636.3.49.1.1.4.1.25

Unsigned32 · bits per second

This object returns the last known receive baud rate for this session established.

jnxL2tpSessionStatsCallBearerType

1.3.6.1.4.1.2636.3.49.1.1.4.1.26

INTEGER1 = none2 = digital3 = analog · Integer32

This object describes the bearer type of this session.

jnxL2tpSessionStatsFramingType

1.3.6.1.4.1.2636.3.49.1.1.4.1.27

INTEGER1 = none2 = sync3 = async · Integer32

This object describes the framing type of this session.

jnxL2tpSessionStatsLCPRenegotiation

1.3.6.1.4.1.2636.3.49.1.1.4.1.28

INTEGER1 = off2 = on · Integer32

This object returns whether LCP renegotiation is on or off for this session.

jnxL2tpSessionStatsAuthMethod

1.3.6.1.4.1.2636.3.49.1.1.4.1.29

INTEGER1 = none2 = text3 = pppChap4 = pppPap5 = pppEap6 = pppMsChapV17 = pppMsChapV28 = other · Integer32

This object contains the proxy authentication method employed by the LAC for the session.

jnxL2tpSessionStatsNasIpAddrType

1.3.6.1.4.1.2636.3.49.1.1.4.1.30

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object contains the type of IP address of the RADIUS network address server to which the accounting records for this session are being sent to.

jnxL2tpSessionStatsNasIpAddress

1.3.6.1.4.1.2636.3.49.1.1.4.1.31

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object contains the IP address of the RADIUS network address server to which the accounting records for this session are being sent to.

jnxL2tpSessionStatsNasIpPort

1.3.6.1.4.1.2636.3.49.1.1.4.1.32

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

This object contains the port on which RADIUS network address server accounting messages will be sent.

jnxL2tpSessionStatsFramedProtocol

1.3.6.1.4.1.2636.3.49.1.1.4.1.33

INTEGER1 = ppp2 = slip3 = arap4 = gandalf5 = xylogicsIPX-SLIP6 = x75-sync100 = none · Integer32

Reference: RFC 2865, Section 5.7

This object contains the frame protocol attribute obtained from RADIUS server for this session.

jnxL2tpSessionStatsFramedIpAddrType

1.3.6.1.4.1.2636.3.49.1.1.4.1.34

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

Reference: RFC 2865, Section 5.8

This Attribute indicates the type of address to be configured for the user, as provided by the RADIUS server in response to authentication request.

jnxL2tpSessionStatsFramedIpAddress

1.3.6.1.4.1.2636.3.49.1.1.4.1.35

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Reference: RFC 2865, Section 5.8

This Attribute indicates the address to be configured for the user, as provided by the RADIUS server in response to authentication request.

jnxL2tpSessionStatsCallingStationID

1.3.6.1.4.1.2636.3.49.1.1.4.1.36

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Reference: RFC 2865, Section 5.31

This Attribute allows the RADIUS NAS to send in the Access-Request packet the phone number that the call came from, using Automatic Number Identification (ANI) or similar technology. It is only used in Access-Request packets.

jnxL2tpSessionStatsCalledStationID

1.3.6.1.4.1.2636.3.49.1.1.4.1.37

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Reference: RFC 2865, Section 5.30

This Attribute allows the RADIUS NAS to send in the Access-Request packet the phone number that the user called, using Dialed Number Identification (DNIS) or similar technology. It is only used in Access-Request packets.

jnxL2tpSessionStatsAcctDelayTime

1.3.6.1.4.1.2636.3.49.1.1.4.1.38

Integer32 (0..64)

Reference: RFC 2866, Section 5.2

This attribute indicates how many seconds the RADIUS accounting client has been trying to send a record for, and can be subtracted from the time of arrival on the server to find the approximate time of the event generating this Accounting-Request.

jnxL2tpSessionStatsAcctSessionID

1.3.6.1.4.1.2636.3.49.1.1.4.1.39

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

Reference: RFC 2866, Section 5.5

This attribute is a unique Accounting ID to make it easy to match start and stop records in a log file.

jnxL2tpSessionStatsAcctMethod

1.3.6.1.4.1.2636.3.49.1.1.4.1.40

INTEGER1 = radius2 = local · Integer32

This object contains the accounting method employed for this session.

jnxL2tpSessionStatsAcctSessionTime

1.3.6.1.4.1.2636.3.49.1.1.4.1.41

Gauge32

Reference: RFC 2866, Section 5.7

This attribute indicates how many seconds the user has received service for.

jnxL2tpSessionStatsAcctNasPortType

1.3.6.1.4.1.2636.3.49.1.1.4.1.42

INTEGER1 = async2 = sync3 = isdn-sync4 = isdn-asunc-v-1205 = isdn-async-v-1106 = virtual7 = piafs8 = hdlc-clear-channel9 = x-2510 = x-7511 = g-3-fax12 = sdsl13 = adsl-cap14 = adsl-dmt15 = idsl16 = ethernet17 = xdsl18 = cable19 = wireless-other20 = wireless-ieee-802-1 · Integer32

Reference: RFC 2865, Section 5.41

This Attribute indicates the type of the physical port of the NAS which is performing accounting for the user.

jnxL2tpSessionStatsAcctTnlClientEndPoint

1.3.6.1.4.1.2636.3.49.1.1.4.1.43

Integer32 (0..65535)

Reference: RFC 2661, Section 3.1

This object contains the remote tunnel Identifier of the tunnel hosting this session.

jnxL2tpSessionStatsAcctTnlServerEndPoint

1.3.6.1.4.1.2636.3.49.1.1.4.1.44

Integer32 (0..65535)

Reference: RFC 2661, Section 3.1

This object contains the local tunnel Identifier of the tunnel hosting this session.

jnxL2tpSessionStatsAcctTnlClientAuthID

1.3.6.1.4.1.2636.3.49.1.1.4.1.45

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the host name as discovered during the tunnel establishment phase (via the Host Name AVP) of the L2TP peer, for the tunnel that is hosting this session.

jnxL2tpSessionStatsAcctTnlServerAuthID

1.3.6.1.4.1.2636.3.49.1.1.4.1.46

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the local host name of the tunnel that is hosting this session.

jnxL2tpSessionStatsUserProfileName

1.3.6.1.4.1.2636.3.49.1.1.4.1.47

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the configured access profile name that is being used for this session.

jnxL2tpSessionStatsInterfaceID

1.3.6.1.4.1.2636.3.49.1.1.4.1.48

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the interface identification (name) for the session bearing service interface.

jnxL2tpSessionStatsCallSerialNumber

1.3.6.1.4.1.2636.3.49.1.1.4.1.49

Unsigned32

This object contains the serial number that has been assigned to this session.

jnxL2tpSessionStatsCreationTime

1.3.6.1.4.1.2636.3.49.1.1.4.1.50

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This object represents the time of creation of this session.

jnxL2tpSessionStatsUpTime

1.3.6.1.4.1.2636.3.49.1.1.4.1.51

TimeTicks

This object represents the time elapsed since this session was established.

jnxL2tpSessionStatsIdleTime

1.3.6.1.4.1.2636.3.49.1.1.4.1.52

TimeTicks

This object represents the time elapsed since this session had last data activity (transmission or reception).

jnxL2tpSessionStatsCollectionStart

1.3.6.1.4.1.2636.3.49.1.1.4.1.53

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This object represents the time at which the statistics gathering started for this session.

jnxL2tpSessionStatsControlTxPkts

1.3.6.1.4.1.2636.3.49.1.1.4.1.54

Counter32

This object contains the number of control packets that were transmitted to the session peer.

jnxL2tpSessionStatsControlTxBytes

1.3.6.1.4.1.2636.3.49.1.1.4.1.55

Counter64 (0..18446744073709551615)

This object contains the number of control bytes that were transmitted to the session peer. This is deprecated and replaced by jnxL2tpSessionStatsControlTxBytes32

jnxL2tpSessionStatsControlRxPkts

1.3.6.1.4.1.2636.3.49.1.1.4.1.56

Counter32

This object contains the number of control packets received on the session.

jnxL2tpSessionStatsControlRxBytes

1.3.6.1.4.1.2636.3.49.1.1.4.1.57

Counter64 (0..18446744073709551615)

This object contains the number of control bytes that were received from the session peer. This is deprecated and replaced by jnxL2tpSessionStatsControlRxBytes32

jnxL2tpSessionStatsDataTxPkts

1.3.6.1.4.1.2636.3.49.1.1.4.1.58

Counter32

This object contains the number of data packets transmitted to the remote session peer. This is deprecated and replaced by jnxL2tpSessionStatsDataTxPkts64

jnxL2tpSessionStatsDataTxBytes

1.3.6.1.4.1.2636.3.49.1.1.4.1.59

Counter64 (0..18446744073709551615)

This object contains the number of data bytes that were transmitted to the session peer.

jnxL2tpSessionStatsDataRxPkts

1.3.6.1.4.1.2636.3.49.1.1.4.1.60

Counter32

This object contains the number of data packets received on this session. This is deprecated and replaced by jnxL2tpSessionStatsDataRxPkts64

jnxL2tpSessionStatsDataRxBytes

1.3.6.1.4.1.2636.3.49.1.1.4.1.61

Counter64 (0..18446744073709551615)

This object contains the number of data bytes that were received from the session peer.

jnxL2tpSessionStatsErrorTxPkts

1.3.6.1.4.1.2636.3.49.1.1.4.1.62

Counter32

This object contains the number of error transmit packets on the session.

jnxL2tpSessionStatsErrorRxPkts

1.3.6.1.4.1.2636.3.49.1.1.4.1.63

Counter32

This object contains the number of error receive packets on the session.

jnxL2tpSessionStatsControlTxBytes32

1.3.6.1.4.1.2636.3.49.1.1.4.1.64

Counter32

This object contains the number of control bytes that were transmitted to the session peer.

jnxL2tpSessionStatsControlRxBytes32

1.3.6.1.4.1.2636.3.49.1.1.4.1.65

Counter32

This object contains the number of control bytes that were received from the session peer.

jnxL2tpSessionStatsDataTxPkts64

1.3.6.1.4.1.2636.3.49.1.1.4.1.66

Counter64 (0..18446744073709551615)

This object contains the number of data packets transmitted to the remote session peer.

jnxL2tpSessionStatsDataRxPkts64

1.3.6.1.4.1.2636.3.49.1.1.4.1.67

Counter64 (0..18446744073709551615)

This object contains the number of data packets received on this session.

jnxL2tpMlpppBundleStatsTable

1.3.6.1.4.1.2636.3.49.1.1.5

Index: jnxL2tpMlpppBundleStatsBundleID

The L2TP MLPPP bundle status and statistics table. This table contains the objects that can be used to describe the current status and statistics of a single L2TP tunneled multilink PPP bundle.

jnxL2tpMlpppBundleStatsBundleID

1.3.6.1.4.1.2636.3.49.1.1.5.1.1

Integer32 (1..65536)

This object identifies the session's associated bundle.

1.3.6.1.4.1.2636.3.49.1.1.5.1.2

Integer32 (1..8)

This object identifies the current number of links that have joined the bundle.

jnxL2tpMlpppBundleStatsEndpoint

1.3.6.1.4.1.2636.3.49.1.1.5.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object identifies the username of the MLPPP bundle.

jnxL2tpMlpppBundleStatsInputMrru

1.3.6.1.4.1.2636.3.49.1.1.5.1.4

Integer32 (64..4500)

This object identifies the maximum packet size that the input inteface can process.

jnxL2tpMlpppBundleStatsOutputMrru

1.3.6.1.4.1.2636.3.49.1.1.5.1.5

Integer32 (64..4500)

This object identifies the maximum packet size that the output interface can process.

↑ To TOC