EZ5 MIB Catalog

JUNIPER-SIP-COMMON-MIB

2009-02-09

This is Juniper Networks' implementation of enterprise specific MIB for SIP. This module defines objects which may be common to all SIP entities.

Download JUNIPER-SIP-COMMON-MIB.txt Open JUNIPER-SIP-COMMON-MIB.txt in a new tab

TABLES (5)

Tables (5)

NameOID
jnxSipCommonCfgTable1.3.6.1.4.1.2636.3.39.1.15.2.1.1.1
jnxSipCommonPortTable1.3.6.1.4.1.2636.3.39.1.15.2.1.1.2
jnxSipCommonOptionTagTable1.3.6.1.4.1.2636.3.39.1.15.2.1.1.3
jnxSipCommonMethodSupportedTable1.3.6.1.4.1.2636.3.39.1.15.2.1.1.4
jnxSipCommonCfgTimerTable1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5

END OF TOC

Table details

jnxSipCommonCfgTable

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.1

Index: jnxSipCfgApplName

This table contains the common configuration objects applicable to all SIP entities.

jnxSipCfgApplName

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.1.1.1

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The name of the network application which uniquely identifies the application to which this entry is applicable.

jnxSipCommonCfgProtocolVersion

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.1.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object will reflect the version of SIP supported by this SIP entity. It will follow the same format as SIP version information contained in the SIP messages generated by this SIP entity. For example, entities supporting SIP version 2 will return 'SIP/2.0' as dictated by the standard.

jnxSipCommonCfgServiceOperStatus

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.1.1.3

INTEGER1 = unknown2 = up3 = down · Integer32

This object contains the current operational state of the SIP application. unknown : The operational status cannot be determined for some reason. up : The application is operating normally, and is processing (receiving and possibly issuing) SIP requests and responses. down : The application is currently unable to process SIP messages.

jnxSipCommonCfgServiceStartTime

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.1.1.4

TimeTicks

The value of sysUpTime at the time the SIP entity was last started. If started prior to the last re-initialization of the local network management subsystem, then this object contains a zero value.

jnxSipCommonCfgServiceLastChange

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.1.1.5

TimeTicks

The value of sysUpTime at the time the SIP entity entered its current operational state. If the current state was entered prior to the last re-initialization of the local network management subsystem, then this object contains a zero value.

jnxSipCommonCfgOrganization

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.1.1.6

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object contains the organization name which the SIP entity inserts into Organization headers of SIP messages processed by this system. If the string is empty, no Organization header is to be generated.

jnxSipCommonCfgMaxTransactions

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.1.1.7

Unsigned32 (1..4294967295)

This object indicates the maximum number of simultaneous transactions per second that the SIP entity can manage. In general, the value of this object SHOULD reflect a level of transaction processing per second that is considered high enough to impact the system's CPU and/or memory resources to the point of deteriorating SIP call processing but not high enough to cause catastrophic system failure.

jnxSipCommonCfgEntityType

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.1.1.8

BITS

This object identifies the list of SIP entities this row is related to. It is defined as a bit map. Each bit represents a type of SIP entity. If a bit has value 1, the SIP entity represented by this row plays the role of this entity type. If a bit has value 0, the SIP entity represented by this row does not act as this entity type Combinations of bits can be set when the SIP entity plays multiple SIP roles.

jnxSipCommonPortTable

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.2

Index: jnxSipPortApplName · jnxSipCommonPort

This table contains the list of ports that each SIP entity in this system is allowed to use. These ports can be advertised using the Contact header in a REGISTER request or response.

jnxSipPortApplName

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.2.1.1

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The name of the network application which uniquely identifies the application to which this entry is applicable.

jnxSipCommonPort

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.2.1.2

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (1..65535) · Unsigned32 · hint d

This object reflects a particular port that can be used by the SIP application.

jnxSipCommonPortTransportRcv

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.2.1.3

BITS

This object will specify the transport protocol the SIP entity will use to receive SIP messages. This object is a bit map. Each bit represents a transport protocol. If a bit has value 1, then that transport protocol is currently being used. If a bit has value 0, then that transport protocol is currently not being used.

jnxSipCommonOptionTagTable

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.3

Index: jnxSipOptionTagApplName · jnxSipCommonOptionTagIndex

This table contains a list of the SIP option tags (SIP extensions) that either required, supported, or unsupported by the SIP entity. These option tags are used in the Require, Proxy-Require, Supported and Unsupported header fields. Example: if a user agent client supports and requires the server to support reliability of provisional responses (IETF RFC 3262), this table contains a row with the option tag string '100rel' in jnxSipCommonOptionTag and the OCTET STRING value of '1010 0000' or '0xA0' in jnxSipCommonOptionTagHeaderField. If a server does not support the required feature (indicated in a Require header to a UAS, or in a Proxy-Require to a Proxy Server), the server returns a 420 Bad Extension listing the feature in an Unsupported header. Normally the list of such features supported by an entity is static (i.e. will not change over time).

jnxSipOptionTagApplName

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.3.1.1

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The name of the network application which uniquely identifies the application to which this entry is applicable.

jnxSipCommonOptionTagIndex

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.3.1.2

Unsigned32 (1..4294967295)

This object uniquely identifies a conceptual row in the table.

jnxSipCommonOptionTag

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.3.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

This object indicates the SIP option tag. The option tag names are registered with IANA and available at http://www.iana.org/.

jnxSipCommonOptionTagHeaderField

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.3.1.4

BITS

This object indicates whether the SIP option tag is supported (Supported header), unsupported (Unsupported header), required (Require or Proxy-Require header) by the SIP entity. A SIP option tag may be both supported and required.

jnxSipCommonMethodSupportedTable

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.4

Index: jnxSipMethodSupportedApplName · jnxSipCommonMethodSupportedIndex

This table contains a list of methods supported by each SIP entity in this system (see the standard set of SIP methods in Section 7.1 of RFC 3261). Any additional methods that may be incorporated into the SIP protocol can be represented by this table without any requirement to update this MIB module. The table is informational in nature; conveying to the NMS capabilities of the managed system.

jnxSipMethodSupportedApplName

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.4.1.1

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The name of the network application which uniquely identifies the application to which this entry is applicable.

jnxSipCommonMethodSupportedIndex

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.4.1.2

Unsigned32 (1..4294967295)

This object uniquely identifies a conceptual row in the table for a specific SIP method.

jnxSipCommonMethodSupportedName

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.4.1.3

OCTET STRING SIZE (1..100)

This object reflects the supported method's name. The method name MUST be all upper case (e.g, 'INVITE').

jnxSipCommonCfgTimerTable

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5

Index: jnxSipCfgTimerApplName

This table contains timer configuration objects applicable to SIP user agent and SIP stateful Proxy Server entities.

jnxSipCfgTimerApplName

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.1

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The name of the network application which uniquely identifies the application to which this entry is applicable.

jnxSipCommonCfgTimerA

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.2

Unsigned32 (100..1000) · milliseconds

This object reflects the initial value for the retransmit timer for the INVITE method. The retransmit timer doubles after each retransmission, ensuring an exponential backoff in network traffic. This object represents the initial time a SIP entity will wait to receive a provisional response to an INVITE before resending the INVITE request.

jnxSipCommonCfgTimerB

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.3

Unsigned32 (32000..300000) · milliseconds

This object reflects the maximum time a SIP entity will wait to receive a final response to an INVITE. The timer is started upon transmission of the initial INVITE request.

jnxSipCommonCfgTimerC

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.4

Unsigned32 (180000..300000) · milliseconds

This object reflects the maximum time a SIP Proxy Server will wait to receive a provisional response to an INVITE. The Timer C MUST be set for each client transaction when an INVITE request is proxied.

jnxSipCommonCfgTimerD

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.5

Unsigned32 (0..300000) · milliseconds

This object reflects the amount of time that the server transaction can remain in the 'Completed' state when unreliable transports are used. The default value MUST be equal to or greater than 32000 for UDP transport, and its value MUST be 0 for TCP/SCTP transport.

jnxSipCommonCfgTimerE

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.6

Unsigned32 (100..1000) · milliseconds

This object reflects the initial value for the retransmit timer for a non-INVITE method while in 'Trying' state. The retransmit timer doubles after each retransmission until it reaches T2 to ensure an exponential backoff in network traffic. This object represents the initial time a SIP entity will wait to receive a provisional response to the request before resending the non-INVITE request.

jnxSipCommonCfgTimerF

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.7

Unsigned32 (32000..300000) · milliseconds

This object reflects the maximum time a SIP entity will wait to receive a final response to a non-INVITE request. The timer is started upon transmission of the initial request.

jnxSipCommonCfgTimerG

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.8

Unsigned32 (0..1000) · milliseconds

This object reflects the initial value for the retransmit timer for final responses to INVITE requests. If timer G fires, the response is passed to the transport layer again for retransmission, and timer G is set to fire in MIN(2*T1, T2) seconds. From then on, when timer G fires, the response is passed to the transport again for transmission, and timer G is reset with a value that doubles, unless that value exceeds T2, in which case, it is reset with the value of T2. The default value MUST be T1 for UDP transport, and its value MUST be 0 for reliable transport like TCP/SCTP.

jnxSipCommonCfgTimerH

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.9

Unsigned32 (32000..300000) · milliseconds

This object reflects the maximum time a server will wait to receive an ACK before it abandons retransmitting the response. The timer is started upon entering the 'Completed' state.

jnxSipCommonCfgTimerI

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.10

Unsigned32 (0..10000) · milliseconds

This object reflects the maximum time a SIP entity will wait to receive additional ACK message retransmissions. The timer is started upon entering the 'Confirmed' state. The default value MUST be T4 for UDP transport and its value MUST be 0 for reliable transport like TCP/SCTP.

jnxSipCommonCfgTimerJ

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.11

Unsigned32 (32000..300000) · milliseconds

This object reflects the maximum time a SIP server will wait to receive retransmissions of non-INVITE requests. The timer is started upon entering the 'Completed' state for non-INVITE transactions. When timer J fires, the server MUST transition to the 'Terminated' state.

jnxSipCommonCfgTimerK

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.12

Unsigned32 (0..10000) · milliseconds

This object reflects the maximum time a SIP client will wait to receive retransmissions of responses to non-INVITE requests. The timer is started upon entering the 'Completed' state for non-INVITE transactions. When timer K fires, the server MUST transition to the 'Terminated' state. The default value MUST be T4 for UDP transport, and its value MUST be 0 for reliable transport like TCP/SCTP.

jnxSipCommonCfgTimerT1

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.13

Unsigned32 (200..10000) · milliseconds

This object reflects the T1 timer for a SIP entity. T1 is an estimate of the round-trip time (RTT) between the client and server transactions.

jnxSipCommonCfgTimerT2

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.14

Unsigned32 (200..10000) · milliseconds

This object reflects the T2 timer for a SIP entity. T2 is the maximum retransmit interval for non-INVITE requests and INVITE responses. It's used in various parts of the protocol to reset other Timer* objects to this value.

jnxSipCommonCfgTimerT4

1.3.6.1.4.1.2636.3.39.1.15.2.1.1.5.1.15

Unsigned32 (200..10000) · milliseconds

This object reflects the T4 timer for a SIP entity. T4 is the maximum duration a message will remain in the network. It represents the amount of time the network will take to clear messages between client and server transactions. It's used in various parts of the protocol to reset other Timer* objects to this value.

↑ To TOC