EZ5 MIB Catalog

JUNIPER-VMON-MIB

2013-12-09

Implementation of enterprise specific MIB for video monitoring traps.

Download JUNIPER-VMON-MIB.txt Open JUNIPER-VMON-MIB.txt in a new tab

SCALARS (17) · TABLES (5) · TRAPS (5)

Scalars (17)

NameOID
jnxVmonFlowIdentifier1.3.6.1.4.1.2636.3.79.1.1.1
jnxVmonSourceIP1.3.6.1.4.1.2636.3.79.1.1.2
jnxVmonDestinationIP1.3.6.1.4.1.2636.3.79.1.1.3
jnxVmonIPFamily1.3.6.1.4.1.2636.3.79.1.1.4
jnxVmonSourcePort1.3.6.1.4.1.2636.3.79.1.1.5
jnxVmonDestinationPort1.3.6.1.4.1.2636.3.79.1.1.6
jnxVmonFlowType1.3.6.1.4.1.2636.3.79.1.1.7
jnxVmonTrapLevel1.3.6.1.4.1.2636.3.79.1.1.8
jnxVmonFPCSlot1.3.6.1.4.1.2636.3.79.1.1.9
jnxVmonInterfaceName1.3.6.1.4.1.2636.3.79.1.1.10
jnxVmonInterfaceSNMPIndex1.3.6.1.4.1.2636.3.79.1.1.11
jnxVmonTemplateName1.3.6.1.4.1.2636.3.79.1.1.12
jnxVmonFlowDirection1.3.6.1.4.1.2636.3.79.1.1.13
jnxVmonExpectedVal1.3.6.1.4.1.2636.3.79.1.1.14
jnxVmonComputedVal1.3.6.1.4.1.2636.3.79.1.1.15
jnxVmonMDIRecIdx1.3.6.1.4.1.2636.3.79.1.1.16
jnxVmonAlarmMode1.3.6.1.4.1.2636.3.79.1.1.17

Tables (5)

NameOID
jnxmdiStatsTable1.3.6.1.4.1.2636.2.1.1
jnxmdiErrsTable1.3.6.1.4.1.2636.2.1.2
jnxmdiFlowTable1.3.6.1.4.1.2636.2.1.3
jnxmdiFlowMDIRecTable1.3.6.1.4.1.2636.2.1.4
jnxmdiFlowPIDTable1.3.6.1.4.1.2636.2.1.5

Traps (5)

NameOID
jnxVmonMDIDFAlarm1.3.6.1.4.1.2636.3.79.1.0.1
jnxVmonMDIMLRAlarm1.3.6.1.4.1.2636.3.79.1.0.2
jnxVmonMDIMRVAlarm1.3.6.1.4.1.2636.3.79.1.0.3
jnxVmonMDIFlowInsertAlarm1.3.6.1.4.1.2636.3.79.1.0.4
jnxVmonMDIFlowDeleteAlarm1.3.6.1.4.1.2636.3.79.1.0.5

END OF TOC

Scalar details

jnxVmonFlowIdentifier

1.3.6.1.4.1.2636.3.79.1.1.1

Unsigned32

Flow Identifier of the flow for SNMP trap

jnxVmonSourceIP

1.3.6.1.4.1.2636.3.79.1.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Source IP address of the flow for SNMP trap

jnxVmonDestinationIP

1.3.6.1.4.1.2636.3.79.1.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Destination IP address of the flow for SNMP trap

jnxVmonIPFamily

1.3.6.1.4.1.2636.3.79.1.1.4

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

IP address family of the flow for SNMP trap

jnxVmonSourcePort

1.3.6.1.4.1.2636.3.79.1.1.5

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonDestinationPort

1.3.6.1.4.1.2636.3.79.1.1.6

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonFlowType

1.3.6.1.4.1.2636.3.79.1.1.7

JnxVmonFlowTypeThis data type is to indication which type of flow we are talking about i.e. if it is a mpeg flow or rtp flow SIZE (0..30) · OCTET STRING

Flow type for SNMP trap

jnxVmonTrapLevel

1.3.6.1.4.1.2636.3.79.1.1.8

JnxVmonTrapLevel2 = critical4 = warning6 = info8 = clearThis data type is to indicate what is the level of trap being generated. · Integer32 · hint d

Level of the SNMP Trap

jnxVmonFPCSlot

1.3.6.1.4.1.2636.3.79.1.1.9

Integer32 (0..127)

Chassis FPC Slot

jnxVmonInterfaceName

1.3.6.1.4.1.2636.3.79.1.1.10

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Interface Name for the Flow

jnxVmonInterfaceSNMPIndex

1.3.6.1.4.1.2636.3.79.1.1.11

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

SNMP Index of the Flow

jnxVmonTemplateName

1.3.6.1.4.1.2636.3.79.1.1.12

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Template Name of the Flow

jnxVmonFlowDirection

1.3.6.1.4.1.2636.3.79.1.1.13

JnxVmonFlowDirectionThis data type is to indication direction of the flow i.e. if it is a input or output SIZE (6) · OCTET STRING

Flow of the direction

jnxVmonExpectedVal

1.3.6.1.4.1.2636.3.79.1.1.14

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Expected value for the flow

jnxVmonComputedVal

1.3.6.1.4.1.2636.3.79.1.1.15

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Computed value for the flow

jnxVmonMDIRecIdx

1.3.6.1.4.1.2636.3.79.1.1.16

Unsigned32 (0..15)

MDIRecIdx for which the trap is being generated

jnxVmonAlarmMode

1.3.6.1.4.1.2636.3.79.1.1.17

Unsigned32 (0..3)

Alarm mode

Table details

jnxmdiStatsTable

1.3.6.1.4.1.2636.2.1.1

Index: jnxmdiFPCSlotNo

The table lists mdi stats counters.

jnxmdiFPCSlotNo

1.3.6.1.4.1.2636.2.1.1.1.1

Unsigned32 (0..255)

FPC Slot Number

jnxmdiActiveFlowsCount

1.3.6.1.4.1.2636.2.1.1.1.2

Counter64 (0..18446744073709551615)

Total Active Flows.

jnxmdiInsertedFlowsCount

1.3.6.1.4.1.2636.2.1.1.1.3

Counter64 (0..18446744073709551615)

Total Flows Inserted.

jnxmdiDeletedFlowsCount

1.3.6.1.4.1.2636.2.1.1.1.4

Counter64 (0..18446744073709551615)

Total Flows Deleted.

jnxmdiTotalPktsCount

1.3.6.1.4.1.2636.2.1.1.1.5

Counter64 (0..18446744073709551615)

Total Number of Packets.

jnxmdiTotalBytesCount

1.3.6.1.4.1.2636.2.1.1.1.6

Counter64 (0..18446744073709551615)

Total Number of Bytes.

jnxmdiDFTotalAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.7

Counter64 (0..18446744073709551615)

Total Number of Alarm Generated for DF.

jnxmdiDFInfoAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.8

Counter64 (0..18446744073709551615)

Total Number of Info Alarm Generated for DF.

jnxmdiDFWarningAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.9

Counter64 (0..18446744073709551615)

Total Number of Warning Alarm Generated for DF.

jnxmdiDFCriticalAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.10

Counter64 (0..18446744073709551615)

Total Number of Critical Alarm Generated for DF.

jnxmdiMLRTotalAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.11

Counter64 (0..18446744073709551615)

Total Number of Alarm Generated for MLR.

jnxmdiMLRInfoAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.12

Counter64 (0..18446744073709551615)

Total Number of Info Alarm Generated for MLR.

jnxmdiMLRWarningAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.13

Counter64 (0..18446744073709551615)

Total Number of Warning Alarm Generated for MLR.

jnxmdiMLRCriticalAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.14

Counter64 (0..18446744073709551615)

Total Number of Critical Alarm Generated for MLR.

jnxmdiMRVTotalAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.15

Counter64 (0..18446744073709551615)

Total Number of Alarm Generated for MRV.

jnxmdiMRVInfoAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.16

Counter64 (0..18446744073709551615)

Total Number of Info Alarm Generated for MRV.

jnxmdiMRVWarningAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.17

Counter64 (0..18446744073709551615)

Total Number of Warning Alarm Generated for MRV.

jnxmdiMRVCriticalAlarmCount

1.3.6.1.4.1.2636.2.1.1.1.18

Counter64 (0..18446744073709551615)

Total Number of Critical Alarm Generated for MRV.

jnxmdiErrsTable

1.3.6.1.4.1.2636.2.1.2

Index: jnxmdiFPCSlotNo

The table lists mdi errors counters.

jnxmdiErrsFlowInsertErr

1.3.6.1.4.1.2636.2.1.2.1.1

Counter64 (0..18446744073709551615)

Total Number of Flow Insert Errors.

jnxmdiErrsPolicerDrop

1.3.6.1.4.1.2636.2.1.2.1.2

Counter64 (0..18446744073709551615)

Total Number of Policer Drop.

jnxmdiErrsPIDLimitExceed

1.3.6.1.4.1.2636.2.1.2.1.3

Counter64 (0..18446744073709551615)

Total Number of PID Limit Exceed.

jnxmdiErrsUnsupportedMediaPkts

1.3.6.1.4.1.2636.2.1.2.1.4

Counter64 (0..18446744073709551615)

Number of Unsupported media packets.

jnxmdiErrsFragmentedPkts

1.3.6.1.4.1.2636.2.1.2.1.5

Counter64 (0..18446744073709551615)

Number of Fragmented packets.

jnxmdiErrsMaxLabelsExceed

1.3.6.1.4.1.2636.2.1.2.1.6

Counter64 (0..18446744073709551615)

Max Labels exceeded count.

jnxmdiErrsOptionPkt

1.3.6.1.4.1.2636.2.1.2.1.7

Counter64 (0..18446744073709551615)

Option header packet count.

jnxmdiFlowTable

1.3.6.1.4.1.2636.2.1.3

Index: jnxmdiFPCSlotNo · jnxmdiFlowIdentifier

The table lists mdi flows.

jnxmdiFlowIdentifier

1.3.6.1.4.1.2636.2.1.3.1.1

Unsigned32

Flow Identifier for the flow

jnxmdiFlowSrcAddr

1.3.6.1.4.1.2636.2.1.3.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Source IP address for the flow

jnxmdiFlowDstAddr

1.3.6.1.4.1.2636.2.1.3.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Destination IP address for the flow

jnxmdiFlowAddrFamily

1.3.6.1.4.1.2636.2.1.3.1.4

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

Address family for the flow

jnxmdiFlowSrcPort

1.3.6.1.4.1.2636.2.1.3.1.5

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port Number for the flow

jnxmdiFlowDstPort

1.3.6.1.4.1.2636.2.1.3.1.6

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Destination Port Number for the flow

jnxmdiFlowInterfaceName

1.3.6.1.4.1.2636.2.1.3.1.7

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Interface Name for the flow

jnxmdiFlowInterfaceSNMPIndex

1.3.6.1.4.1.2636.2.1.3.1.8

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

Interface SNMP Index for the flow

jnxmdiFlowDirection

1.3.6.1.4.1.2636.2.1.3.1.9

JnxVmonFlowDirectionThis data type is to indication direction of the flow i.e. if it is a input or output SIZE (6) · OCTET STRING

Direction for the flow

jnxmdiFlowType

1.3.6.1.4.1.2636.2.1.3.1.10

JnxVmonFlowTypeThis data type is to indication which type of flow we are talking about i.e. if it is a mpeg flow or rtp flow SIZE (0..30) · OCTET STRING

Type of the flow

jnxmdiFlowLastDF

1.3.6.1.4.1.2636.2.1.3.1.11

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Last DF Value for the flow

jnxmdiFlowLastMLR

1.3.6.1.4.1.2636.2.1.3.1.12

Unsigned32 (0..65535)

Last MLR Value for the flow

jnxmdiFlowLastMRV

1.3.6.1.4.1.2636.2.1.3.1.13

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Last MRV Value for the flow

jnxmdiFlowAvgDF

1.3.6.1.4.1.2636.2.1.3.1.14

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Average DF Value for the flow

jnxmdiFlowAvgMLR

1.3.6.1.4.1.2636.2.1.3.1.15

Unsigned32 (0..65535)

Average MLR Value for the flow

jnxmdiFlowAvgMRV

1.3.6.1.4.1.2636.2.1.3.1.16

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Average MRV Value for the flow

jnxmdiFlowTemplateName

1.3.6.1.4.1.2636.2.1.3.1.17

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Template Name of the Flow

jnxmdiFlowMDIRecCount

1.3.6.1.4.1.2636.2.1.3.1.18

Integer32 (0..65535)

MDI Record Count for the flow

jnxmdiFlowPIDCount

1.3.6.1.4.1.2636.2.1.3.1.19

Integer32 (0..65535)

PID Count for the flow

jnxmdiFlowMPLSLabel0

1.3.6.1.4.1.2636.2.1.3.1.20

Unsigned32

MPLS Label-0

jnxmdiFlowMPLSLabel1

1.3.6.1.4.1.2636.2.1.3.1.21

Unsigned32

MPLS Label-1

jnxmdiFlowMPLSLabel2

1.3.6.1.4.1.2636.2.1.3.1.22

Unsigned32

MPLS Label-2

jnxmdiFlowMDIRecTable

1.3.6.1.4.1.2636.2.1.4

Index: jnxmdiFPCSlotNo · jnxmdiFlowIdentifier · jnxmdiFlowMDIRecIndex

The table lists mdi flow records.

jnxmdiFlowMDIRecIndex

1.3.6.1.4.1.2636.2.1.4.1.1

Unsigned32 (0..65535)

MDI Flow Record Index

jnxmdiFlowMDIRecDF

1.3.6.1.4.1.2636.2.1.4.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

DF Value of the Flow Record Index

jnxmdiFlowMDIRecMLR

1.3.6.1.4.1.2636.2.1.4.1.3

Unsigned32 (0..65535)

MLR Value of the Flow Record Index

jnxmdiFlowMDIRecMRV

1.3.6.1.4.1.2636.2.1.4.1.4

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

MRV Value of the Flow Record Index

jnxmdiFlowPIDTable

1.3.6.1.4.1.2636.2.1.5

Index: jnxmdiFPCSlotNo · jnxmdiFlowIdentifier · jnxmdiFlowMDIRecIndex · jnxmdiFlowPIDValue

The table lists mdi flow PID.

jnxmdiFlowPIDValue

1.3.6.1.4.1.2636.2.1.5.1.1

Unsigned32 (0..65535)

PID Value of the Flow Record Index

jnxmdiFlowPIDMLR

1.3.6.1.4.1.2636.2.1.5.1.2

Unsigned32 (0..65535)

PID MLR Value of the Flow Record Index

Trap details

jnxVmonMDIDFAlarm

1.3.6.1.4.1.2636.3.79.1.0.1

The SNMP trap for the DF Alarm

jnxVmonFlowIdentifier

1.3.6.1.4.1.2636.3.79.1.1.1

Unsigned32

Flow Identifier of the flow for SNMP trap

jnxVmonSourceIP

1.3.6.1.4.1.2636.3.79.1.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Source IP address of the flow for SNMP trap

jnxVmonDestinationIP

1.3.6.1.4.1.2636.3.79.1.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Destination IP address of the flow for SNMP trap

jnxVmonIPFamily

1.3.6.1.4.1.2636.3.79.1.1.4

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

IP address family of the flow for SNMP trap

jnxVmonSourcePort

1.3.6.1.4.1.2636.3.79.1.1.5

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonDestinationPort

1.3.6.1.4.1.2636.3.79.1.1.6

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonFlowType

1.3.6.1.4.1.2636.3.79.1.1.7

JnxVmonFlowTypeThis data type is to indication which type of flow we are talking about i.e. if it is a mpeg flow or rtp flow SIZE (0..30) · OCTET STRING

Flow type for SNMP trap

jnxVmonTrapLevel

1.3.6.1.4.1.2636.3.79.1.1.8

JnxVmonTrapLevel2 = critical4 = warning6 = info8 = clearThis data type is to indicate what is the level of trap being generated. · Integer32 · hint d

Level of the SNMP Trap

jnxVmonFPCSlot

1.3.6.1.4.1.2636.3.79.1.1.9

Integer32 (0..127)

Chassis FPC Slot

jnxVmonInterfaceName

1.3.6.1.4.1.2636.3.79.1.1.10

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Interface Name for the Flow

jnxVmonInterfaceSNMPIndex

1.3.6.1.4.1.2636.3.79.1.1.11

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

SNMP Index of the Flow

jnxVmonTemplateName

1.3.6.1.4.1.2636.3.79.1.1.12

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Template Name of the Flow

jnxVmonFlowDirection

1.3.6.1.4.1.2636.3.79.1.1.13

JnxVmonFlowDirectionThis data type is to indication direction of the flow i.e. if it is a input or output SIZE (6) · OCTET STRING

Flow of the direction

jnxVmonExpectedVal

1.3.6.1.4.1.2636.3.79.1.1.14

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Expected value for the flow

jnxVmonComputedVal

1.3.6.1.4.1.2636.3.79.1.1.15

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Computed value for the flow

jnxVmonMDIRecIdx

1.3.6.1.4.1.2636.3.79.1.1.16

Unsigned32 (0..15)

MDIRecIdx for which the trap is being generated

jnxVmonAlarmMode

1.3.6.1.4.1.2636.3.79.1.1.17

Unsigned32 (0..3)

Alarm mode

jnxVmonMDIMLRAlarm

1.3.6.1.4.1.2636.3.79.1.0.2

The SNMP trap for the MLR Alarm

jnxVmonFlowIdentifier

1.3.6.1.4.1.2636.3.79.1.1.1

Unsigned32

Flow Identifier of the flow for SNMP trap

jnxVmonSourceIP

1.3.6.1.4.1.2636.3.79.1.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Source IP address of the flow for SNMP trap

jnxVmonDestinationIP

1.3.6.1.4.1.2636.3.79.1.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Destination IP address of the flow for SNMP trap

jnxVmonIPFamily

1.3.6.1.4.1.2636.3.79.1.1.4

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

IP address family of the flow for SNMP trap

jnxVmonSourcePort

1.3.6.1.4.1.2636.3.79.1.1.5

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonDestinationPort

1.3.6.1.4.1.2636.3.79.1.1.6

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonFlowType

1.3.6.1.4.1.2636.3.79.1.1.7

JnxVmonFlowTypeThis data type is to indication which type of flow we are talking about i.e. if it is a mpeg flow or rtp flow SIZE (0..30) · OCTET STRING

Flow type for SNMP trap

jnxVmonTrapLevel

1.3.6.1.4.1.2636.3.79.1.1.8

JnxVmonTrapLevel2 = critical4 = warning6 = info8 = clearThis data type is to indicate what is the level of trap being generated. · Integer32 · hint d

Level of the SNMP Trap

jnxVmonFPCSlot

1.3.6.1.4.1.2636.3.79.1.1.9

Integer32 (0..127)

Chassis FPC Slot

jnxVmonInterfaceName

1.3.6.1.4.1.2636.3.79.1.1.10

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Interface Name for the Flow

jnxVmonInterfaceSNMPIndex

1.3.6.1.4.1.2636.3.79.1.1.11

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

SNMP Index of the Flow

jnxVmonTemplateName

1.3.6.1.4.1.2636.3.79.1.1.12

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Template Name of the Flow

jnxVmonFlowDirection

1.3.6.1.4.1.2636.3.79.1.1.13

JnxVmonFlowDirectionThis data type is to indication direction of the flow i.e. if it is a input or output SIZE (6) · OCTET STRING

Flow of the direction

jnxVmonExpectedVal

1.3.6.1.4.1.2636.3.79.1.1.14

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Expected value for the flow

jnxVmonComputedVal

1.3.6.1.4.1.2636.3.79.1.1.15

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Computed value for the flow

jnxVmonMDIRecIdx

1.3.6.1.4.1.2636.3.79.1.1.16

Unsigned32 (0..15)

MDIRecIdx for which the trap is being generated

jnxVmonAlarmMode

1.3.6.1.4.1.2636.3.79.1.1.17

Unsigned32 (0..3)

Alarm mode

jnxVmonMDIMRVAlarm

1.3.6.1.4.1.2636.3.79.1.0.3

The SNMP trap for the MRV Alarm

jnxVmonFlowIdentifier

1.3.6.1.4.1.2636.3.79.1.1.1

Unsigned32

Flow Identifier of the flow for SNMP trap

jnxVmonSourceIP

1.3.6.1.4.1.2636.3.79.1.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Source IP address of the flow for SNMP trap

jnxVmonDestinationIP

1.3.6.1.4.1.2636.3.79.1.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Destination IP address of the flow for SNMP trap

jnxVmonIPFamily

1.3.6.1.4.1.2636.3.79.1.1.4

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

IP address family of the flow for SNMP trap

jnxVmonSourcePort

1.3.6.1.4.1.2636.3.79.1.1.5

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonDestinationPort

1.3.6.1.4.1.2636.3.79.1.1.6

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonFlowType

1.3.6.1.4.1.2636.3.79.1.1.7

JnxVmonFlowTypeThis data type is to indication which type of flow we are talking about i.e. if it is a mpeg flow or rtp flow SIZE (0..30) · OCTET STRING

Flow type for SNMP trap

jnxVmonTrapLevel

1.3.6.1.4.1.2636.3.79.1.1.8

JnxVmonTrapLevel2 = critical4 = warning6 = info8 = clearThis data type is to indicate what is the level of trap being generated. · Integer32 · hint d

Level of the SNMP Trap

jnxVmonFPCSlot

1.3.6.1.4.1.2636.3.79.1.1.9

Integer32 (0..127)

Chassis FPC Slot

jnxVmonInterfaceName

1.3.6.1.4.1.2636.3.79.1.1.10

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Interface Name for the Flow

jnxVmonInterfaceSNMPIndex

1.3.6.1.4.1.2636.3.79.1.1.11

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

SNMP Index of the Flow

jnxVmonTemplateName

1.3.6.1.4.1.2636.3.79.1.1.12

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Template Name of the Flow

jnxVmonFlowDirection

1.3.6.1.4.1.2636.3.79.1.1.13

JnxVmonFlowDirectionThis data type is to indication direction of the flow i.e. if it is a input or output SIZE (6) · OCTET STRING

Flow of the direction

jnxVmonExpectedVal

1.3.6.1.4.1.2636.3.79.1.1.14

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Expected value for the flow

jnxVmonComputedVal

1.3.6.1.4.1.2636.3.79.1.1.15

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Computed value for the flow

jnxVmonMDIRecIdx

1.3.6.1.4.1.2636.3.79.1.1.16

Unsigned32 (0..15)

MDIRecIdx for which the trap is being generated

jnxVmonAlarmMode

1.3.6.1.4.1.2636.3.79.1.1.17

Unsigned32 (0..3)

Alarm mode

jnxVmonMDIFlowInsertAlarm

1.3.6.1.4.1.2636.3.79.1.0.4

The SNMP trap for the New Flow Alarm

jnxVmonFlowIdentifier

1.3.6.1.4.1.2636.3.79.1.1.1

Unsigned32

Flow Identifier of the flow for SNMP trap

jnxVmonSourceIP

1.3.6.1.4.1.2636.3.79.1.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Source IP address of the flow for SNMP trap

jnxVmonDestinationIP

1.3.6.1.4.1.2636.3.79.1.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Destination IP address of the flow for SNMP trap

jnxVmonIPFamily

1.3.6.1.4.1.2636.3.79.1.1.4

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

IP address family of the flow for SNMP trap

jnxVmonSourcePort

1.3.6.1.4.1.2636.3.79.1.1.5

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonDestinationPort

1.3.6.1.4.1.2636.3.79.1.1.6

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonFlowType

1.3.6.1.4.1.2636.3.79.1.1.7

JnxVmonFlowTypeThis data type is to indication which type of flow we are talking about i.e. if it is a mpeg flow or rtp flow SIZE (0..30) · OCTET STRING

Flow type for SNMP trap

jnxVmonFPCSlot

1.3.6.1.4.1.2636.3.79.1.1.9

Integer32 (0..127)

Chassis FPC Slot

jnxVmonInterfaceName

1.3.6.1.4.1.2636.3.79.1.1.10

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Interface Name for the Flow

jnxVmonInterfaceSNMPIndex

1.3.6.1.4.1.2636.3.79.1.1.11

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

SNMP Index of the Flow

jnxVmonTemplateName

1.3.6.1.4.1.2636.3.79.1.1.12

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Template Name of the Flow

jnxVmonFlowDirection

1.3.6.1.4.1.2636.3.79.1.1.13

JnxVmonFlowDirectionThis data type is to indication direction of the flow i.e. if it is a input or output SIZE (6) · OCTET STRING

Flow of the direction

jnxVmonMDIFlowDeleteAlarm

1.3.6.1.4.1.2636.3.79.1.0.5

The SNMP trap for the New Flow Alarm

jnxVmonFlowIdentifier

1.3.6.1.4.1.2636.3.79.1.1.1

Unsigned32

Flow Identifier of the flow for SNMP trap

jnxVmonSourceIP

1.3.6.1.4.1.2636.3.79.1.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Source IP address of the flow for SNMP trap

jnxVmonDestinationIP

1.3.6.1.4.1.2636.3.79.1.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

Destination IP address of the flow for SNMP trap

jnxVmonIPFamily

1.3.6.1.4.1.2636.3.79.1.1.4

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

IP address family of the flow for SNMP trap

jnxVmonSourcePort

1.3.6.1.4.1.2636.3.79.1.1.5

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonDestinationPort

1.3.6.1.4.1.2636.3.79.1.1.6

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

Source Port number of the flow for SNMP trap

jnxVmonFlowType

1.3.6.1.4.1.2636.3.79.1.1.7

JnxVmonFlowTypeThis data type is to indication which type of flow we are talking about i.e. if it is a mpeg flow or rtp flow SIZE (0..30) · OCTET STRING

Flow type for SNMP trap

jnxVmonFPCSlot

1.3.6.1.4.1.2636.3.79.1.1.9

Integer32 (0..127)

Chassis FPC Slot

jnxVmonInterfaceName

1.3.6.1.4.1.2636.3.79.1.1.10

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Interface Name for the Flow

jnxVmonInterfaceSNMPIndex

1.3.6.1.4.1.2636.3.79.1.1.11

InterfaceIndexOrZeroThis textual convention is an extension of the InterfaceIndex convention. The latter defines a greater than zero value used to identify an interface or interface sub-layer in the managed system. This extension permits the additional value of zero. the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero might include situations where interface was unknown, or when none or all interfaces need to be referenced. (0..2147483647) · Integer32 · hint d

SNMP Index of the Flow

jnxVmonTemplateName

1.3.6.1.4.1.2636.3.79.1.1.12

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Template Name of the Flow

jnxVmonFlowDirection

1.3.6.1.4.1.2636.3.79.1.1.13

JnxVmonFlowDirectionThis data type is to indication direction of the flow i.e. if it is a input or output SIZE (6) · OCTET STRING

Flow of the direction

↑ To TOC