This MIB contains common managed object definitions for multicast in Layer 2 and Layer 3 VPNs, defined by [I-D.ietf-l2vpn-vpls-mcast] and RFC 6513/6514. Copyright (C) The Internet Society (2012).
This table is for advertised/received PMSI attributes, to be referred to by I-PMSI or S-PMSI table entries
jnxL2L3VpnMcastPmsiTunnelAttributeFlags
1.3.6.1.4.1.2636.5.11.1.1.1.1.1.1
OCTET STRING SIZE (1)
For UDP-based S-PMSI signaling for PIM-MVPN, this is 0. For BGP-based I/S-PMSI signaling, per RFC 6514 section 5, 'PMSI Tunnel Attribute':
The Flags field has the following format:
0 1 2 3 4 5 6 7 +-+-+-+-+-+-+-+-+
| reserved |L|
+-+-+-+-+-+-+-+-+
This document defines the following flags:
+ Leaf Information Required (L)
jnxL2L3VpnMcastPmsiTunnelAttributeType
1.3.6.1.4.1.2636.5.11.1.1.1.1.1.2
JnxL2L3VpnMcastProviderTunnelType0 = unconfigured1 = rsvp-p2mp2 = ldp-p2mp3 = pim-ssm4 = pim-asm5 = pim-bidir6 = ingress-replication7 = ldp-mp2mpTypes of provider tunnels used for multicast in a l2/l3vpn. · Integer32
For BGP-based I/S-PMSI signaling for either PIM or BGP-MVPN, per RFC 6514 section 5, 'PMSI Tunnel Attribute':
The Tunnel Type identifies the type of the tunneling technology used to establish the PMSI tunnel. The type determines the syntax and semantics of the Tunnel Identifier field. This document defines the following Tunnel Types:
0 - No tunnel information present 1 - RSVP-TE P2MP LSP 2 - mLDP P2MP LSP 3 - PIM-SSM Tree 4 - PIM-SM Tree 5 - PIM-Bidir Tree 6 - Ingress Replication 7 - mLDP MP2MP LSP
For UDP-based S-PMSI signaling for PIM-MVPN, RFC 6513 does not specify if a PIM provider tunnel is SSM, SM or Bidir, and an agent can use either type 3, 4, or 5 based on its best knowledge.
jnxL2L3VpnMcastPmsiTunnelAttributeLabel
1.3.6.1.4.1.2636.5.11.1.1.1.1.1.3
MplsLabelThis value represents an MPLS label as defined in
[RFC3031], [RFC3032], [RFC3034], [RFC3035] and
[RFC3471].
The label contents are specific to the label being represented, such as:
* The label carried in an MPLS shim header (for LDP this is the Generic Label) is a 20-bit number represented by 4 octets. Bits 0-19 contain a label or a reserved label value. Bits 20-31 MUST be zero.
The following is quoted directly from [RFC3032]. There are several reserved label values:
i. A value of 0 represents the 'IPv4 Explicit NULL Label'. This label value is only legal at the bottom of the label stack. It indicates that the label stack must be popped, and the forwarding of the packet must then be based on the IPv4 header. ii. A value of 1 represents the 'Router Alert Label'. This label value is legal anywhere in the label stack except at the bottom. When a received packet contains this label value at the top of the label stack, it is delivered to a local software module for processing. The actual forwarding of the packet is determined by the label beneath it in the stack. However, if the packet is forwarded further, the Router Alert Label should be pushed back onto the label stack before forwarding. The use of this label is analogous to the use of the 'Router Alert Option' in IP packets [RFC2113]. Since this label cannot occur at the bottom of the stack, it is not associated with a particular network layer protocol.
iii. A value of 2 represents the 'IPv6 Explicit NULL Label'. This label value is only legal at the bottom of the label stack. It indicates that the label stack must be popped, and the forwarding of the packet must then be based on the IPv6 header.
iv. A value of 3 represents the 'Implicit NULL Label'. This is a label that an LSR may assign and distribute, but which never actually appears in the encapsulation. When an LSR would otherwise replace the label at the top of the stack with a new label, but the new label is 'Implicit NULL', the LSR will pop the stack instead of doing the replacement. Although this value may never appear in the encapsulation, it needs to be specified in the Label Distribution Protocol, so a value is reserved.
v. Values 4-15 are reserved.
* The frame relay label can be either 10-bits or 23-bits depending on the DLCI field size and the upper 22-bits or upper 9-bits must be zero, respectively.
* For an ATM label the lower 16-bits represents the VCI, the next 12-bits represents the VPI and the remaining bits MUST be zero.
* The Generalized-MPLS (GMPLS) label contains a value greater than 2^24-1 and used in GMPLS as defined in [RFC3471].Reference: Multiprotocol Label Switching Architecture, RFC3031.
MPLS Label Stack Encoding, [RFC3032].
Use of Label Switching on Frame Relay Networks, RFC3034.
MPLS using LDP and ATM VC Switching, RFC3035. Generalized Multiprotocol Label Switching (GMPLS) Architecture, [RFC3471]. · Unsigned32
For BGP-based I/S-PMSI signaling, per RFC 6514 section 5, 'PMSI Tunnel Attribute':
If the MPLS Label field is non-zero, then it contains an MPLS label encoded as 3 octets, where the high-order 20 bits contain the label value. Absence of MPLS Label is indicated by setting the MPLS Label field to zero.
For UDP-based S-PMSI signaling for PIM-MVPN, this is not applicable for now, as RFC 6513 does not specify mpls encapsulation and tunnel aggregation with UDP-based signaling.
jnxL2L3VpnMcastPmsiTunnelAttributeId
1.3.6.1.4.1.2636.5.11.1.1.1.1.1.4
OCTET STRING SIZE (0..37)
For BGP-based signaling, as defined in RFC 6514 section 5, 'PMSI Tunnel Attribute'.
For UDP-based S-PMSI signaling for PIM-MVPN, RFC 6513 only specifies the 'P-Group' address, and that is filled into the first four octets of this field.
jnxL2L3VpnMcastPmsiTunnelPointer
1.3.6.1.4.1.2636.5.11.1.1.1.1.1.5
RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row.
For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER
If the tunnel exists in some MIB table, this is the row pointer to it.
jnxL2L3VpnMcastPmsiTunnelIf
1.3.6.1.4.1.2636.5.11.1.1.1.1.1.6
RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row.
For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER
If the tunnel has a corresponding interface, this is the row pointer to the ifName table.