This MIB module defines a table representing the attribute information of the provider tunnels (P-tunnels) on a PE router. This MIB module will be used by other MIB modules designed for monitoring and/or configuring Border Gateway Protocol/Multiprotocol Label Switching Layer 2 and Layer 3 Virtual Private Network that support multicast (L2L3VpnMCast network).
Copyright (c) 2018 IETF Trust and the persons identified as authors of the code. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).
An entry in this table corresponds to the attribute information of a specific P-tunnel on a PE router. A part of the attributes corresponds to fields in a Provider Multicast Service Interface (PMSI) Tunnel attribute advertised and received by a PE router. The entries will be referred to by other MIB modules for monitoring and/or configuring L2L3VpnMCast networks. Reference: RFC 6514, Section 5
l2L3VpnMcastPmsiTunnelAttributeType
1.3.6.1.2.1.245.1.1.1.1
L2L3VpnMcastProviderTunnelType0 = noTunnelInfo1 = rsvpP2mp2 = ldpP2mp3 = pimSsm4 = pimAsm5 = pimBidir6 = ingressReplication7 = ldpMp2mp8 = transportTunnelThis textual convention enumerates values representing the type of a provider tunnel (P-tunnel) used for L2L3VpnMCast networks. These labeled numbers are aligned with the definition of Tunnel Types in Section 5 of RFC 6514 and Section 14.1 of RFC 7524.
The enumerated values and the corresponding P-tunnel types are as follows:
noTunnelInfo (0) : No tunnel information RFC 6514
rsvpP2mp (1) : RSVP-TE P2MP LSP RFC 4875
ldpP2mp (2) : mLDP P2MP LSP RFC 6388
pimSsm (3) : PIM-SSM Tree RFC 7761
pimAsm (4) : PIM-SM Tree RFC 7761
pimBidir (5) : BIDIR-PIM Tree RFC 5015
ingressReplication (6) : Ingress Replication RFC 6513
ldpMp2mp (7) : mLDP MP2MP LSP RFC 6388
transportTunnel (8) : Transport Tunnel RFC 7524
These numbers are registered at IANA. A current list of assignments can be found at <https://www.iana.org/assignments/bgp-parameters/>.Reference: RFC 4875 RFC 5015 RFC 6388 RFC 6513 RFC 6514, Section 5 RFC 7524, Section 14.1 RFC 7761 · Integer32
This object indicates the type of tunneling technology used to establish the P-tunnel corresponding to this entry.
When BGP-based PMSI signaling is used, the value of this object corresponds to the Tunnel Type field in the PMSI Tunnel attribute advertised/received in a PMSI auto-discovery (A-D) route. Reference: RFC 6514, Section 5
l2L3VpnMcastPmsiTunnelAttributeId
1.3.6.1.2.1.245.1.1.1.2
L2L3VpnMcastProviderTunnelIdThis textual convention represents the Tunnel Identifier of a P-tunnel.
The size of the identifier depends on the address family (IPv4 or IPv6) and the value of the corresponding L2L3VpnMcastProviderTunnelType object.
The corresponding L2L3VpnMcastProviderTunnelType object represents the type of tunneling technology used to establish the P-tunnel.
The size of the identifier for each tunneling technology is summarized below.
L2L3VpnMcastProviderTunnelType Size (in octets)
(tunneling technology) IPv4 IPv6
-----------------------------------------------------------
noTunnelInfo (No tunnel information) 0 0
rsvpP2mp (RSVP-TE P2MP LSP) 12 24
ldpP2mp (mLDP P2MP LSP) 17 29
pimSsm (PIM-SSM Tree) 8 32
pimAsm (PIM-SM Tree) 8 32
pimBidir (BIDIR-PIM Tree) 8 32
ingressReplication (Ingress Replication) 4 16
ldpMp2mp (mLDP MP2MP LSP) 17 29
transportTunnel (Transport Tunnel) 8 32
The Tunnel Type is set to 'No tunnel information' when the PMSI Tunnel attribute carries no tunnel information (there is no Tunnel Identifier). The value of the corresponding L2L3VpnMcastProviderTunnelId object will be a string of length zero. For Tunnel Type rsvpP2mp(1), the corresponding Tunnel Identifier is composed of an Extended Tunnel ID (4 octets in IPv4, 16 octets in IPv6), 2 unused (Reserved) octets that of value zero, a Tunnel ID (2 octets), and a Point-to-Multipoint (P2MP) ID (4 octets). The size of the corresponding L2L3VpnMcastProviderTunnelId object will be 12 octets in IPv4 and 24 octets in IPv6.
For Tunnel Type ldpP2mp(2), the corresponding Tunnel Identifier is the P2MP Forwarding Equivalence Class (FEC) Element (RFC 6388). The size of the corresponding L2L3VpnMcastProviderTunnelId object will be 17 octets in IPv4 and 29 octets in IPv6.
For Tunnel Types pimSsm(3), PimAsm(4), and PimBidir(5), the corresponding Tunnel Identifier is composed of the source IP address and the group IP address. The size of the corresponding L2L3VpnMcastProviderTunnelId object will be 8 octets in IPv4 and 32 octets in IPv6.
For Tunnel Type ingressReplication(6), the Tunnel Identifier is the unicast tunnel endpoint IP address of the local PE. The size of the corresponding L2L3VpnMcastProviderTunnelId object will be 4 octets in IPv4 and 16 octets in IPv6.
For Tunnel Type ldpMp2mp(7), the Tunnel Identifier is a Multipoint-to-Multipoint (MP2MP) FEC Element (RFC 6388). The size of the corresponding L2L3VpnMcastProviderTunnelId object will be 17 octets in IPv4 and 29 octets in IPv6.
For Tunnel Type transportTunnel(8), the Tunnel Identifier is a tuple of Source PE Address and Local Number, which is a number that is unique to the Source PE (RFC 7524). Both Source PE Address and Local Number are 4 octets in IPv4 and 16 octets in IPv6. The size of the corresponding L2L3VpnMcastProviderTunnelId object will be 8 octets in IPv4 and 32 octets in IPv6.Reference: RFC 6514, Section 5 RFC 4875, Section 19.1 RFC 6388, Sections 2.2 and 3.2 RFC 7524, Section 14.1 SIZE (0 | 4 | 8 | 12 | 16 | 17 | 24 | 29 | 32) · OCTET STRING
This object represents the Tunnel Identifier field, which uniquely identifies a P-tunnel, in the PMSI Tunnel attribute of the P-tunnel corresponding to this entry.
The size of the identifier depends on the address family (IPv4 or IPv6) and the value of the corresponding l2L3VpnMcastPmsiTunnelAttributeType object, i.e., the type of tunneling technology used to establish the P-tunnel. Reference: RFC 6514, Section 5
When the value of this object is set to 1 (true), it indicates that the PE that originated the PMSI Tunnel attribute of the P-tunnel corresponding to this entry requests receivers to originate a new Leaf A-D route.
A value of zero (false) indicates that there is no such request.
When the P-tunnel does not have a corresponding PMSI Tunnel attribute, the value of this object will be 2 (notAvailable). In the case of multicast in MPLS/BGP IP VPNs, this object represents the 'Leaf Information Required flag' (RFC 6514) in the Flags field in the PMSI Tunnel attribute of the P-tunnel corresponding to this entry. Reference: RFC 6514, Section 5
l2L3VpnMcastPmsiTunnelAttributeMplsLabel
1.3.6.1.2.1.245.1.1.1.4
MplsLabelThis value represents an MPLS label as defined in
[RFC3031], [RFC3032], [RFC3034], [RFC3035] and
[RFC3471].
The label contents are specific to the label being represented, such as:
* The label carried in an MPLS shim header (for LDP this is the Generic Label) is a 20-bit number represented by 4 octets. Bits 0-19 contain a label or a reserved label value. Bits 20-31 MUST be zero.
The following is quoted directly from [RFC3032]. There are several reserved label values:
i. A value of 0 represents the 'IPv4 Explicit NULL Label'. This label value is only legal at the bottom of the label stack. It indicates that the label stack must be popped, and the forwarding of the packet must then be based on the IPv4 header. ii. A value of 1 represents the 'Router Alert Label'. This label value is legal anywhere in the label stack except at the bottom. When a received packet contains this label value at the top of the label stack, it is delivered to a local software module for processing. The actual forwarding of the packet is determined by the label beneath it in the stack. However, if the packet is forwarded further, the Router Alert Label should be pushed back onto the label stack before forwarding. The use of this label is analogous to the use of the 'Router Alert Option' in IP packets [RFC2113]. Since this label cannot occur at the bottom of the stack, it is not associated with a particular network layer protocol.
iii. A value of 2 represents the 'IPv6 Explicit NULL Label'. This label value is only legal at the bottom of the label stack. It indicates that the label stack must be popped, and the forwarding of the packet must then be based on the IPv6 header.
iv. A value of 3 represents the 'Implicit NULL Label'. This is a label that an LSR may assign and distribute, but which never actually appears in the encapsulation. When an LSR would otherwise replace the label at the top of the stack with a new label, but the new label is 'Implicit NULL', the LSR will pop the stack instead of doing the replacement. Although this value may never appear in the encapsulation, it needs to be specified in the Label Distribution Protocol, so a value is reserved.
v. Values 4-15 are reserved.
* The frame relay label can be either 10-bits or 23-bits depending on the DLCI field size and the upper 22-bits or upper 9-bits must be zero, respectively.
* For an ATM label the lower 16-bits represents the VCI, the next 12-bits represents the VPI and the remaining bits MUST be zero.
* The Generalized-MPLS (GMPLS) label contains a value greater than 2^24-1 and used in GMPLS as defined in [RFC3471].Reference: Multiprotocol Label Switching Architecture, RFC3031.
MPLS Label Stack Encoding, [RFC3032].
Use of Label Switching on Frame Relay Networks, RFC3034.
MPLS using LDP and ATM VC Switching, RFC3035. Generalized Multiprotocol Label Switching (GMPLS) Architecture, [RFC3471]. · Unsigned32
This object represents the MPLS Label in the PMSI Tunnel attribute of the P-tunnel corresponding to this entry.
When BGP-based PMSI signaling is used, the PMSI Tunnel attribute of the P-tunnel will be advertised/received in a PMSI A-D route. The value of this object corresponds to the MPLS Label in the attribute.
When the P-tunnel does not have a PMSI tunnel attribute, the value of this object will be zero. Reference: RFC 6514, Section 5
l2L3VpnMcastPmsiTunnelPointer
1.3.6.1.2.1.245.1.1.1.5
RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row.
For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER
Details of a P-tunnel identified by l2L3VpnMcastPmsiTunnelAttributeId may be present in some other table, e.g., mplsTunnelTable (RFC 3812). This object specifies the pointer to the row that pertains to the entry in the table.
If no such entry exists, the value of this object will be zeroDotZero. Reference: RFC 3812, Sections 6.1 and 11
l2L3VpnMcastPmsiTunnelIf
1.3.6.1.2.1.245.1.1.1.6
RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row.
For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER
If the P-tunnel identified by l2L3VpnMcastPmsiTunnelAttributeId has a corresponding entry in ifXTable (RFC 2863), this object will point to the row in ifXTable that pertains to the entry. Otherwise, the value of this object will be zeroDotZero. Reference: RFC 2863, Section 6