The LLDP Management Information Base extension module for IEEE 802.3 organizationally defined discovery information.
In order to assure the uniqueness of the LLDP-MIB, lldpV2Xdot3MIB is branched from lldpV2Extensions using OUI value as the node. An OUI/'company_id' is a 24 bit globally unique assigned number referenced by various standards.
Unless otherwise indicated, the references in this MIB module are to IEEE 802.1AB-2009.
Copyright (C) IEEE (2009). This version of this MIB module is published as Annex F.6.5 of IEEE Std 802.1AB-2009; see the standard itself for full legal notices.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index value used to identify the port associated with this entry. Its value is an index into the interfaces MIB.
The value of this object is used as an index to the lldpV2PortConfigTable.
lldpV2PortConfigDestAddressIndex
LldpV2DestAddressTableIndexAn index value, used as the index to the table of destination MAC addresses used both as the destination addresses on transmitted LLDPDUs and on received LLDPDUs. This index value is also used as a secondary index value in tables indexed
by fields of type ifIndex, in order to associate
a destination address with each row of the table. (1..4096) · Unsigned32 · hint d
The index value used to identify the destination MAC address associated with this entry. Its value identifies the row in the lldpV2DestAddressTable where the MAC address can be found.
The value of this object is used as an index to the lldpV2PortConfigTable.
lldpV2Xdot3PortConfigTLVsTxEnable
1.3.111.2.802.1.1.13.1.5.4623.1.1.1.1.1
BITS
The lldpV2Xdot3PortConfigTLVsTxEnable, defined as a bitmap, includes the IEEE 802.3 organizationally defined set of LLDP TLVs whose transmission is allowed on the local LLDP agent by the network management. Each bit in the bitmap corresponds to an IEEE 802.3 subtype associated with a specific IEEE 802.3 optional TLV. The bit 0 is not used since there is no corresponding subtype.
The bit 'macPhyConfigStatus(0)' indicates that LLDP agent should transmit 'MAC/PHY configuration/status TLV'.
The bit 'powerViaMDI(1)' indicates that LLDP agent should transmit 'Power via MDI TLV'.
The bit 'unused(2)' is no longer used; this was used for the 'Link Aggregation TLV' in the previous version.
The bit 'maxFrameSize(3)' indicates that LLDP agent should transmit 'Maximum-frame-size TLV'.
The default value for lldpV2Xdot3PortConfigTLVsTxEnable object is an empty set, which means no enumerated values are set.
The value of this object is restored from non-volatile storage after a re-initialization of the management system. Reference: 9.1.2.1
lldpV2Xdot3LocPortTable
1.3.111.2.802.1.1.13.1.5.4623.1.2.1
Index: lldpV2LocPortIfIndex
This table contains one row per port of Ethernet port information (as a part of the LLDP 802.3 organizational extension) on the local system known to this agent.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index value used to identify the port associated with this entry. Its value is an index into the interfaces MIB.
The value of this object is used as an index to the lldpV2LocPortTable.
lldpV2Xdot3LocPortAutoNegSupported
1.3.111.2.802.1.1.13.1.5.4623.1.2.1.1.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The truth value used to indicate whether the given port (associated with the local system) supports Auto-negotiation. Reference: F.2.1
lldpV2Xdot3LocPortAutoNegEnabled
1.3.111.2.802.1.1.13.1.5.4623.1.2.1.1.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The truth value used to indicate whether port Auto-negotiation is enabled on the given port associated with the local system. Reference: F.2.1
lldpV2Xdot3LocPortAutoNegAdvertisedCap
1.3.111.2.802.1.1.13.1.5.4623.1.2.1.1.3
OCTET STRING SIZE (2)
This object contains the value (bitmap) of the ifMauAutoNegCapAdvertisedBits object (defined in IETF RFC 3636) which is associated with the given port on the local system. Reference: F.2.2
lldpV2Xdot3LocPortOperMauType
1.3.111.2.802.1.1.13.1.5.4623.1.2.1.1.4
Unsigned32 (0..2147483647)
An integer value that indicates the operational MAU type of the given port on the local system.
This object contains the integer value derived from the list position of the corresponding dot3MauType as listed in IETF RFC 4836 (or subsequent revisions) and is equal to the last number in the respective dot3MauType OID.
For example, if the ifMauType object is dot3MauType1000BaseTHD which corresponds to {dot3MauType 29}, the numerical value of this field is 29. For MAU types not listed in RFC 4836 (or subsequent revisions), the value of this field shall be set to zero. Reference: F.2.3
lldpV2Xdot3LocPowerTable
1.3.111.2.802.1.1.13.1.5.4623.1.2.2
Index: lldpV2LocPortIfIndex
This table contains one row per port of power ethernet information (as a part of the LLDP 802.3 organizational extension) on the local system known to this agent.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index value used to identify the port associated with this entry. Its value is an index into the interfaces MIB.
The value of this object is used as an index to the lldpV2LocPortTable.
lldpV2Xdot3LocPowerPortClass
1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.1
LldpV2PowerPortClass1 = pClassPSE2 = pClassPDThis TC describes the Power over Ethernet (PoE) port class. · Integer32
The value that identifies the port Class of the given port associated with the local system. Reference: F.3.1
lldpV2Xdot3LocPowerMDISupported
1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The truth value used to indicate whether the MDI power is supported on the given port associated with the local system. Reference: F.3.1
lldpV2Xdot3LocPowerMDIEnabled
1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The truth value used to identify whether MDI power is enabled on the given port associated with the local system. Reference: F.3.1
lldpV2Xdot3LocPowerPairControlable
1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.4
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The truth value is derived from the value of pethPsePortPowerPairsControlAbility object (defined in IETF RFC 3621) and is used to indicate whether the pair selection can be controlled on the given port associated with the local system. Reference: F.3.1
lldpV2Xdot3LocPowerPairs
1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.5
Unsigned32 (1 | 2)
This object contains the value of the pethPsePortPowerPairs object (defined in IETF RFC 3621) which is associated with the given port on the local system. Reference: F.3.2
lldpV2Xdot3LocPowerClass
1.3.111.2.802.1.1.13.1.5.4623.1.2.2.1.6
Unsigned32 (1 | 2 | 3 | 4 | 5)
This object contains the value of the pethPsePortPowerClassifications object (defined in IETF RFC 3621) which is associated with the given port on the local system. Reference: F.3.3
lldpV2Xdot3LocMaxFrameSizeTable
1.3.111.2.802.1.1.13.1.5.4623.1.2.3
Index: lldpV2LocPortIfIndex
This table contains one row per port of maximum frame size information (as a part of the LLDP 802.3 organizational extension) on the local system known to this agent.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index value used to identify the port associated with this entry. Its value is an index into the interfaces MIB.
The value of this object is used as an index to the lldpV2LocPortTable.
lldpV2Xdot3LocMaxFrameSize
1.3.111.2.802.1.1.13.1.5.4623.1.2.3.1.1
Unsigned32 (0..65535)
An integer value indicating the maximum supported frame size in octets on the given port of the local system. Reference: F.4.1
TimeFilterTo be used for the index to a table. Allows an application to download only those rows changed since a particular time.
Note that this is not a history mechanism. Only current values of underlying objects are returned; saved instance values associated with particular values of sysUpTime are not.
An entry is considered changed if the value of any object in the entry changes, if the row is created, or if any object in the entry is created or deleted. Note that deleted entries cannot be detected or downloaded.
A time-filtered conceptual table is created by inserting a single object of SYNTAX TimeFilter as the first INDEX component in a copy of an existing basic conceptual table (i.e., any SEQUENCE without a TimeFilter INDEX component). Thus, for each conceptual entry 'I' in the basic table, there exists N conceptual entries in the time-filtered version, indexed N.I, where 'N' is equal to the value of sysUpTime.
When an application retrieves conceptual instances from a time-filtered table, and an INDEX value is provided for the TimeFilter INDEX component 'N', the agent will only consider returning basic conceptual entries (e.g., 'fooColumn.N.I') if any column within the basic conceptual entry has changed since sysUpTime 'N'. If not, the basic conceptual entry will be ignored for the particular retrieval operation.
When sysUpTime is equal to zero, this table shall be empty.
One conceptual entry exists for each past value of sysUpTime, except that the whole table is purged should sysUpTime wrap.
As an entry in a time-filtered table is updated (i.e., one of the columns in the basic conceptual table is changed), new conceptual entries are also created in the time-filtered version (which still shares the now updated object values with all other instances). The number of unique time-filtered instances that are created is determined by the value of sysUpTime at which the basic entry was last updated. One unique instance will exist for each value of sysUpTime at the last update time for the row. However, a new TimeFilter index instance is created for each new sysUpTime value. The TimeFilter index values not associated with entry updates are called duplicate time-filtered instances.
After some deployment experience, it has been determined that a time-filtered table is more efficient if the agent stops a MIB walk operation by skipping over rows with a TimeFilter index value higher than the value in the received GetNext/GetBulk request. That is, instead of incrementing a TimeFilter index value, the agent will continue to the next object or table. As a consequence, GetNext or GetBulk operations will provide only one pass through a time-filtered table.
It is suggested that an agent implement a time-filtered table in this manner to improve performance and avoid a MIB walk getting stuck in time-filtered tables. It is, however, still acceptable for an agent to implement a time-filtered table in the traditional manner (i.e., every conceptual time-filtered instance is returned in GetNext and GetBulk PDU responses), and management applications must be able to deal with such traditional implementations.
See the appendix for further discussion of this textual convention.
The following example is provided to demonstrate TimeFilter behavior:
Consider the following basic conceptual table, basicFooTable. (Note that the basic version of a time-filtered table may not actually be defined.)
basicFooTable:
basicFooTable ... INDEX { fooIndex }
BasicFooEntry {
fooIndex Integer32,
fooCounts Counter32
}
For this example, the basicFooTable contains two static conceptual entries (fooIndex equals '1' and '2'), created at time zero. It also contains one dynamic conceptual entry (fooIndex equals '3'), which is created at time '3' and deleted at time '7'.
The time-filtered version of the basicFooTable could be defined as follows:
FooTable:
fooTable ... INDEX { fooTimeMark, fooIndex }
FooEntry {
fooTimeMark TimeFilter,
fooIndex Integer32,
fooCounts Counter32
}
Note that entries exist in the time-filtered conceptual table only if they actually exist in the underlying (basic) table.
For this example, the fooTable will have three underlying basic entries (fooIndex == 1, 2, and 3), with the following activity (for sysUpTime equal 0 to 9):
- fooEntry.N.1 is created at time '0' and most recently updated at time '6' to the value '5'. - fooEntry.N.2 is created at time '0' and most recently updated at time '8' to the value '9'. - fooEntry.N.3 is created at time '3', updated at time '5' to the value '17', and deleted at time '7'.
The following tables show the values that would be returned for MIB walk operations with various TimeFilter values, done at different times. An application issues a retrieval request at time 'T', with a TimeFilter value, 'N' (typically set to a lower value, such as the value of sysUpTime at the last polling cycle).
The following values would be returned in a MIB walk of fooCounts.N if T equals '0' and N equals '0':
fooCounts.N.I Value
==========================
fooCounts.0.1 0
fooCounts.0.2 0
Note that nothing is returned for fooCounts.0.3, since that entry does not exist at sysUpTime equals '0'.
The following values would be returned in a full (traditional) MIB walk of fooCounts.N if T equals '3' and N equals '0':
fooCounts.N.I Value
=======================
fooCounts.0.1 0
fooCounts.0.2 0
fooCounts.0.3 0
fooCounts.1.3 0
fooCounts.2.3 0
fooCounts.3.3 0
Note that there are no instances for T equals 1 or 2 for the first two values of N, as these entries did not change since they were created at time '0'.
Note that the current value for 'fooCounts.N.3' is returned here, even for values of N less than '3' (when the entry was created). The agent only considers the current existence of an entry in the TimeFilter algorithm, not the time when the entry was created.
Note that the instances 'fooCounts.0.3', 'fooCounts.1.3', and 'fooCounts.2.3' are duplicates and can be suppressed by the agent in a MIB walk.
The following values would be returned in a full (traditional) MIB walk of fooCounts.N if T equals '6' and N equals '3':
fooCounts.N.I Value
=======================
fooCounts.3.1 5
fooCounts.3.3 17
fooCounts.4.1 5
fooCounts.4.3 17
fooCounts.5.1 5
fooCounts.5.3 17
fooCounts.6.1 5
Note that no instances for entry 'fooCounts.N.2' are returned, since it has not changed since time '3'.
Note that all instances except 'fooCounts.5.3' and 'fooCounts.6.1' are duplicates and can be suppressed by the agent in a MIB walk.
The following values would be returned in a full (traditional) MIB walk of fooCounts.N if T equals '9' and N equals '6':
fooCounts.N.I Value
=======================
fooCounts.6.1 5
fooCounts.6.2 9
fooCounts.7.2 9
fooCounts.8.2 9
Note that no instances for entry 'fooCounts.N.3' are returned, since it was deleted at time '7'.
Note that instances 'fooCounts.6.2' and 'fooCounts.7.2' are duplicates and can be suppressed by the agent in a MIB walk. · TimeTicks
A TimeFilter for this entry. See the TimeFilter textual convention in IETF RFC 4502 and http://www.ietf.org/IESG/Implementations/RFC2021-Implementation.txt to see how TimeFilter works. Reference: IETF RFC 4502 section 6
lldpV2RemLocalIfIndex
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index value used to identify the port associated with this entry. Its value is an index into the interfaces MIB
The value of this object is used as an index to the lldpV2RemTable.
lldpV2RemLocalDestMACAddress
LldpV2DestAddressTableIndexAn index value, used as the index to the table of destination MAC addresses used both as the destination addresses on transmitted LLDPDUs and on received LLDPDUs. This index value is also used as a secondary index value in tables indexed
by fields of type ifIndex, in order to associate
a destination address with each row of the table. (1..4096) · Unsigned32 · hint d
The index value used to identify the destination MAC address associated with this entry. Its value identifies the row in the lldpV2DestAddressTable where the MAC address can be found.
The value of this object is used as an index to the lldpV2RemTable.
lldpV2RemIndex
Unsigned32 (1..2147483647)
This object represents an arbitrary local integer value used by this agent to identify a particular connection instance, unique only for the indicated remote system.
An agent is encouraged to assign monotonically increasing index values to new entries, starting with one, after each reboot. It is considered unlikely that the lldpRemIndex can wrap between reboots.
lldpV2Xdot3RemPortAutoNegSupported
1.3.111.2.802.1.1.13.1.5.4623.1.3.1.1.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The truth value used to indicate whether the given port (associated with remote system) supports Auto-negotiation. Reference: F.2.1
lldpV2Xdot3RemPortAutoNegEnabled
1.3.111.2.802.1.1.13.1.5.4623.1.3.1.1.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The truth value used to indicate whether port Auto-negotiation is enabled on the given port associated with the remote system. Reference: F.2.1
lldpV2Xdot3RemPortAutoNegAdvertisedCap
1.3.111.2.802.1.1.13.1.5.4623.1.3.1.1.3
OCTET STRING SIZE (2)
This object contains the value (bitmap) of the ifMauAutoNegCapAdvertisedBits object (defined in IETF RFC 3636) which is associated with the given port on the remote system. Reference: F.2.2
lldpV2Xdot3RemPortOperMauType
1.3.111.2.802.1.1.13.1.5.4623.1.3.1.1.4
Unsigned32 (0..2147483647)
An integer value that indicates the operational MAU type of the sending device.
This object contains the integer value derived from the list position of the corresponding dot3MauType as listed in in IETF RFC 4836 (or subsequent revisions) and is equal to the last number in the respective dot3MauType OID.
For example, if the ifMauType object is dot3MauType1000BaseTHD which corresponds to {dot3MauType 29}, the numerical value of this field is 29. For MAU types not listed in RFC 4836 (or subsequent revisions), the value of this field shall be set to zero. Reference: F.2.3
TimeFilterTo be used for the index to a table. Allows an application to download only those rows changed since a particular time.
Note that this is not a history mechanism. Only current values of underlying objects are returned; saved instance values associated with particular values of sysUpTime are not.
An entry is considered changed if the value of any object in the entry changes, if the row is created, or if any object in the entry is created or deleted. Note that deleted entries cannot be detected or downloaded.
A time-filtered conceptual table is created by inserting a single object of SYNTAX TimeFilter as the first INDEX component in a copy of an existing basic conceptual table (i.e., any SEQUENCE without a TimeFilter INDEX component). Thus, for each conceptual entry 'I' in the basic table, there exists N conceptual entries in the time-filtered version, indexed N.I, where 'N' is equal to the value of sysUpTime.
When an application retrieves conceptual instances from a time-filtered table, and an INDEX value is provided for the TimeFilter INDEX component 'N', the agent will only consider returning basic conceptual entries (e.g., 'fooColumn.N.I') if any column within the basic conceptual entry has changed since sysUpTime 'N'. If not, the basic conceptual entry will be ignored for the particular retrieval operation.
When sysUpTime is equal to zero, this table shall be empty.
One conceptual entry exists for each past value of sysUpTime, except that the whole table is purged should sysUpTime wrap.
As an entry in a time-filtered table is updated (i.e., one of the columns in the basic conceptual table is changed), new conceptual entries are also created in the time-filtered version (which still shares the now updated object values with all other instances). The number of unique time-filtered instances that are created is determined by the value of sysUpTime at which the basic entry was last updated. One unique instance will exist for each value of sysUpTime at the last update time for the row. However, a new TimeFilter index instance is created for each new sysUpTime value. The TimeFilter index values not associated with entry updates are called duplicate time-filtered instances.
After some deployment experience, it has been determined that a time-filtered table is more efficient if the agent stops a MIB walk operation by skipping over rows with a TimeFilter index value higher than the value in the received GetNext/GetBulk request. That is, instead of incrementing a TimeFilter index value, the agent will continue to the next object or table. As a consequence, GetNext or GetBulk operations will provide only one pass through a time-filtered table.
It is suggested that an agent implement a time-filtered table in this manner to improve performance and avoid a MIB walk getting stuck in time-filtered tables. It is, however, still acceptable for an agent to implement a time-filtered table in the traditional manner (i.e., every conceptual time-filtered instance is returned in GetNext and GetBulk PDU responses), and management applications must be able to deal with such traditional implementations.
See the appendix for further discussion of this textual convention.
The following example is provided to demonstrate TimeFilter behavior:
Consider the following basic conceptual table, basicFooTable. (Note that the basic version of a time-filtered table may not actually be defined.)
basicFooTable:
basicFooTable ... INDEX { fooIndex }
BasicFooEntry {
fooIndex Integer32,
fooCounts Counter32
}
For this example, the basicFooTable contains two static conceptual entries (fooIndex equals '1' and '2'), created at time zero. It also contains one dynamic conceptual entry (fooIndex equals '3'), which is created at time '3' and deleted at time '7'.
The time-filtered version of the basicFooTable could be defined as follows:
FooTable:
fooTable ... INDEX { fooTimeMark, fooIndex }
FooEntry {
fooTimeMark TimeFilter,
fooIndex Integer32,
fooCounts Counter32
}
Note that entries exist in the time-filtered conceptual table only if they actually exist in the underlying (basic) table.
For this example, the fooTable will have three underlying basic entries (fooIndex == 1, 2, and 3), with the following activity (for sysUpTime equal 0 to 9):
- fooEntry.N.1 is created at time '0' and most recently updated at time '6' to the value '5'. - fooEntry.N.2 is created at time '0' and most recently updated at time '8' to the value '9'. - fooEntry.N.3 is created at time '3', updated at time '5' to the value '17', and deleted at time '7'.
The following tables show the values that would be returned for MIB walk operations with various TimeFilter values, done at different times. An application issues a retrieval request at time 'T', with a TimeFilter value, 'N' (typically set to a lower value, such as the value of sysUpTime at the last polling cycle).
The following values would be returned in a MIB walk of fooCounts.N if T equals '0' and N equals '0':
fooCounts.N.I Value
==========================
fooCounts.0.1 0
fooCounts.0.2 0
Note that nothing is returned for fooCounts.0.3, since that entry does not exist at sysUpTime equals '0'.
The following values would be returned in a full (traditional) MIB walk of fooCounts.N if T equals '3' and N equals '0':
fooCounts.N.I Value
=======================
fooCounts.0.1 0
fooCounts.0.2 0
fooCounts.0.3 0
fooCounts.1.3 0
fooCounts.2.3 0
fooCounts.3.3 0
Note that there are no instances for T equals 1 or 2 for the first two values of N, as these entries did not change since they were created at time '0'.
Note that the current value for 'fooCounts.N.3' is returned here, even for values of N less than '3' (when the entry was created). The agent only considers the current existence of an entry in the TimeFilter algorithm, not the time when the entry was created.
Note that the instances 'fooCounts.0.3', 'fooCounts.1.3', and 'fooCounts.2.3' are duplicates and can be suppressed by the agent in a MIB walk.
The following values would be returned in a full (traditional) MIB walk of fooCounts.N if T equals '6' and N equals '3':
fooCounts.N.I Value
=======================
fooCounts.3.1 5
fooCounts.3.3 17
fooCounts.4.1 5
fooCounts.4.3 17
fooCounts.5.1 5
fooCounts.5.3 17
fooCounts.6.1 5
Note that no instances for entry 'fooCounts.N.2' are returned, since it has not changed since time '3'.
Note that all instances except 'fooCounts.5.3' and 'fooCounts.6.1' are duplicates and can be suppressed by the agent in a MIB walk.
The following values would be returned in a full (traditional) MIB walk of fooCounts.N if T equals '9' and N equals '6':
fooCounts.N.I Value
=======================
fooCounts.6.1 5
fooCounts.6.2 9
fooCounts.7.2 9
fooCounts.8.2 9
Note that no instances for entry 'fooCounts.N.3' are returned, since it was deleted at time '7'.
Note that instances 'fooCounts.6.2' and 'fooCounts.7.2' are duplicates and can be suppressed by the agent in a MIB walk. · TimeTicks
A TimeFilter for this entry. See the TimeFilter textual convention in IETF RFC 4502 and http://www.ietf.org/IESG/Implementations/RFC2021-Implementation.txt to see how TimeFilter works. Reference: IETF RFC 4502 section 6
lldpV2RemLocalIfIndex
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index value used to identify the port associated with this entry. Its value is an index into the interfaces MIB
The value of this object is used as an index to the lldpV2RemTable.
lldpV2RemLocalDestMACAddress
LldpV2DestAddressTableIndexAn index value, used as the index to the table of destination MAC addresses used both as the destination addresses on transmitted LLDPDUs and on received LLDPDUs. This index value is also used as a secondary index value in tables indexed
by fields of type ifIndex, in order to associate
a destination address with each row of the table. (1..4096) · Unsigned32 · hint d
The index value used to identify the destination MAC address associated with this entry. Its value identifies the row in the lldpV2DestAddressTable where the MAC address can be found.
The value of this object is used as an index to the lldpV2RemTable.
lldpV2RemIndex
Unsigned32 (1..2147483647)
This object represents an arbitrary local integer value used by this agent to identify a particular connection instance, unique only for the indicated remote system.
An agent is encouraged to assign monotonically increasing index values to new entries, starting with one, after each reboot. It is considered unlikely that the lldpRemIndex can wrap between reboots.
lldpV2Xdot3RemPowerPortClass
1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.1
LldpV2PowerPortClass1 = pClassPSE2 = pClassPDThis TC describes the Power over Ethernet (PoE) port class. · Integer32
The value that identifies the port Class of the given port associated with the remote system. Reference: F.3.1
lldpV2Xdot3RemPowerMDISupported
1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The truth value used to indicate whether the MDI power is supported on the given port associated with the remote system. Reference: F.3.1
lldpV2Xdot3RemPowerMDIEnabled
1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The truth value used to identify whether MDI power is enabled on the given port associated with the remote system. Reference: F.3.1
lldpV2Xdot3RemPowerPairControlable
1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.4
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
The truth value is derived from the value of pethPsePortPowerPairsControlAbility object (defined in IETF RFC 3621) and is used to indicate whether the pair selection can be controlled on the given port associated with the remote system. Reference: F.3.1
lldpV2Xdot3RemPowerPairs
1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.5
Unsigned32 (1 | 2)
This object contains the value of the pethPsePortPowerPairs object (defined in IETF RFC 3621) which is associated with the given port on the remote system. Reference: F.3.2
lldpV2Xdot3RemPowerClass
1.3.111.2.802.1.1.13.1.5.4623.1.3.2.1.6
Unsigned32 (1 | 2 | 3 | 4 | 5)
This object contains the value of the pethPsePortPowerClassifications object (defined in IETF RFC 3621) which is associated with the given port on the remote system. Reference: F.3.3
This table contains one row per port/destination address pair of maximum frame size information (as a part of the LLDP IEEE 802.3 organizational extension) of the remote system.
TimeFilterTo be used for the index to a table. Allows an application to download only those rows changed since a particular time.
Note that this is not a history mechanism. Only current values of underlying objects are returned; saved instance values associated with particular values of sysUpTime are not.
An entry is considered changed if the value of any object in the entry changes, if the row is created, or if any object in the entry is created or deleted. Note that deleted entries cannot be detected or downloaded.
A time-filtered conceptual table is created by inserting a single object of SYNTAX TimeFilter as the first INDEX component in a copy of an existing basic conceptual table (i.e., any SEQUENCE without a TimeFilter INDEX component). Thus, for each conceptual entry 'I' in the basic table, there exists N conceptual entries in the time-filtered version, indexed N.I, where 'N' is equal to the value of sysUpTime.
When an application retrieves conceptual instances from a time-filtered table, and an INDEX value is provided for the TimeFilter INDEX component 'N', the agent will only consider returning basic conceptual entries (e.g., 'fooColumn.N.I') if any column within the basic conceptual entry has changed since sysUpTime 'N'. If not, the basic conceptual entry will be ignored for the particular retrieval operation.
When sysUpTime is equal to zero, this table shall be empty.
One conceptual entry exists for each past value of sysUpTime, except that the whole table is purged should sysUpTime wrap.
As an entry in a time-filtered table is updated (i.e., one of the columns in the basic conceptual table is changed), new conceptual entries are also created in the time-filtered version (which still shares the now updated object values with all other instances). The number of unique time-filtered instances that are created is determined by the value of sysUpTime at which the basic entry was last updated. One unique instance will exist for each value of sysUpTime at the last update time for the row. However, a new TimeFilter index instance is created for each new sysUpTime value. The TimeFilter index values not associated with entry updates are called duplicate time-filtered instances.
After some deployment experience, it has been determined that a time-filtered table is more efficient if the agent stops a MIB walk operation by skipping over rows with a TimeFilter index value higher than the value in the received GetNext/GetBulk request. That is, instead of incrementing a TimeFilter index value, the agent will continue to the next object or table. As a consequence, GetNext or GetBulk operations will provide only one pass through a time-filtered table.
It is suggested that an agent implement a time-filtered table in this manner to improve performance and avoid a MIB walk getting stuck in time-filtered tables. It is, however, still acceptable for an agent to implement a time-filtered table in the traditional manner (i.e., every conceptual time-filtered instance is returned in GetNext and GetBulk PDU responses), and management applications must be able to deal with such traditional implementations.
See the appendix for further discussion of this textual convention.
The following example is provided to demonstrate TimeFilter behavior:
Consider the following basic conceptual table, basicFooTable. (Note that the basic version of a time-filtered table may not actually be defined.)
basicFooTable:
basicFooTable ... INDEX { fooIndex }
BasicFooEntry {
fooIndex Integer32,
fooCounts Counter32
}
For this example, the basicFooTable contains two static conceptual entries (fooIndex equals '1' and '2'), created at time zero. It also contains one dynamic conceptual entry (fooIndex equals '3'), which is created at time '3' and deleted at time '7'.
The time-filtered version of the basicFooTable could be defined as follows:
FooTable:
fooTable ... INDEX { fooTimeMark, fooIndex }
FooEntry {
fooTimeMark TimeFilter,
fooIndex Integer32,
fooCounts Counter32
}
Note that entries exist in the time-filtered conceptual table only if they actually exist in the underlying (basic) table.
For this example, the fooTable will have three underlying basic entries (fooIndex == 1, 2, and 3), with the following activity (for sysUpTime equal 0 to 9):
- fooEntry.N.1 is created at time '0' and most recently updated at time '6' to the value '5'. - fooEntry.N.2 is created at time '0' and most recently updated at time '8' to the value '9'. - fooEntry.N.3 is created at time '3', updated at time '5' to the value '17', and deleted at time '7'.
The following tables show the values that would be returned for MIB walk operations with various TimeFilter values, done at different times. An application issues a retrieval request at time 'T', with a TimeFilter value, 'N' (typically set to a lower value, such as the value of sysUpTime at the last polling cycle).
The following values would be returned in a MIB walk of fooCounts.N if T equals '0' and N equals '0':
fooCounts.N.I Value
==========================
fooCounts.0.1 0
fooCounts.0.2 0
Note that nothing is returned for fooCounts.0.3, since that entry does not exist at sysUpTime equals '0'.
The following values would be returned in a full (traditional) MIB walk of fooCounts.N if T equals '3' and N equals '0':
fooCounts.N.I Value
=======================
fooCounts.0.1 0
fooCounts.0.2 0
fooCounts.0.3 0
fooCounts.1.3 0
fooCounts.2.3 0
fooCounts.3.3 0
Note that there are no instances for T equals 1 or 2 for the first two values of N, as these entries did not change since they were created at time '0'.
Note that the current value for 'fooCounts.N.3' is returned here, even for values of N less than '3' (when the entry was created). The agent only considers the current existence of an entry in the TimeFilter algorithm, not the time when the entry was created.
Note that the instances 'fooCounts.0.3', 'fooCounts.1.3', and 'fooCounts.2.3' are duplicates and can be suppressed by the agent in a MIB walk.
The following values would be returned in a full (traditional) MIB walk of fooCounts.N if T equals '6' and N equals '3':
fooCounts.N.I Value
=======================
fooCounts.3.1 5
fooCounts.3.3 17
fooCounts.4.1 5
fooCounts.4.3 17
fooCounts.5.1 5
fooCounts.5.3 17
fooCounts.6.1 5
Note that no instances for entry 'fooCounts.N.2' are returned, since it has not changed since time '3'.
Note that all instances except 'fooCounts.5.3' and 'fooCounts.6.1' are duplicates and can be suppressed by the agent in a MIB walk.
The following values would be returned in a full (traditional) MIB walk of fooCounts.N if T equals '9' and N equals '6':
fooCounts.N.I Value
=======================
fooCounts.6.1 5
fooCounts.6.2 9
fooCounts.7.2 9
fooCounts.8.2 9
Note that no instances for entry 'fooCounts.N.3' are returned, since it was deleted at time '7'.
Note that instances 'fooCounts.6.2' and 'fooCounts.7.2' are duplicates and can be suppressed by the agent in a MIB walk. · TimeTicks
A TimeFilter for this entry. See the TimeFilter textual convention in IETF RFC 4502 and http://www.ietf.org/IESG/Implementations/RFC2021-Implementation.txt to see how TimeFilter works. Reference: IETF RFC 4502 section 6
lldpV2RemLocalIfIndex
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index value used to identify the port associated with this entry. Its value is an index into the interfaces MIB
The value of this object is used as an index to the lldpV2RemTable.
lldpV2RemLocalDestMACAddress
LldpV2DestAddressTableIndexAn index value, used as the index to the table of destination MAC addresses used both as the destination addresses on transmitted LLDPDUs and on received LLDPDUs. This index value is also used as a secondary index value in tables indexed
by fields of type ifIndex, in order to associate
a destination address with each row of the table. (1..4096) · Unsigned32 · hint d
The index value used to identify the destination MAC address associated with this entry. Its value identifies the row in the lldpV2DestAddressTable where the MAC address can be found.
The value of this object is used as an index to the lldpV2RemTable.
lldpV2RemIndex
Unsigned32 (1..2147483647)
This object represents an arbitrary local integer value used by this agent to identify a particular connection instance, unique only for the indicated remote system.
An agent is encouraged to assign monotonically increasing index values to new entries, starting with one, after each reboot. It is considered unlikely that the lldpRemIndex can wrap between reboots.
lldpV2Xdot3RemMaxFrameSize
1.3.111.2.802.1.1.13.1.5.4623.1.3.3.1.1
Unsigned32 (0..65535)
An integer value indicating the maximum supported frame size in octets on the port component associated with the remote system. Reference: F.4.1