mplsMldpP2mpCapable
1.3.6.1.4.1.2636.5.13.1.1.1
INTEGER1 = enable2 = disable · Integer32
Reference: Section 2.1 of [RFC6388].
This object provides the P2MP capability of the LSR.
2016-09-26
Copyright (c) 2009 IETF Trust and the persons identified as the document authors. All rights reserved. This document is subject to BCP 78 and the IETF Trust's Legal Provisions Relating to IETF Documents in effect on the date of publication of this document (http://trustee.ietf.org/license-info). Please review these documents carefully, as they describe your rights and restrictions with respect to this document. The initial version of this MIB module was published in RFC XXXX. For full legal notices see the RFC itself or see: http://www.ietf.org/copyrights/ianamib.html -- RFC Editor. Please replace XXXX with the RFC number for this -- document and remove this note. This MIB module contains managed object definitions for mLDP LSPS defined in Label Distribution Protocol Extensions Point-to-Multipoint and Multipoint-to-Multipoint Label Switched Paths, RFC 6388, November 2011.
Download MPLS-MLDP-STD-MIB.txt Open MPLS-MLDP-STD-MIB.txt in a new tab
SCALARS (10) · TABLES (6) · TRAPS (3)
| Name | OID |
|---|---|
| mplsMldpFecUp | 1.3.6.1.4.1.2636.5.13.1.0.1 |
| mplsMldpFecDown | 1.3.6.1.4.1.2636.5.13.1.0.2 |
| mplsMldpMoFrrStatusChange | 1.3.6.1.4.1.2636.5.13.1.0.3 |
END OF TOC
1.3.6.1.4.1.2636.5.13.1.1.1
INTEGER1 = enable2 = disable · Integer32
Reference: Section 2.1 of [RFC6388].
This object provides the P2MP capability of the LSR.
1.3.6.1.4.1.2636.5.13.1.1.2
INTEGER1 = enable2 = disable · Integer32
Reference: Section 3.1 of [RFC6388].
This object provides MP2MP capability of the LSR.
1.3.6.1.4.1.2636.5.13.1.1.3
INTEGER1 = enable2 = disable · Integer32
Reference: Section 8.3 of [RFC6388].
This object provides MBB (make before break) capability of the LSR.
1.3.6.1.4.1.2636.5.13.1.1.4
Unsigned32 (1..300) · seconds
The 32-bit unsigned integer value provides the time for waiting MBB Ack from upstream node.
1.3.6.1.4.1.2636.5.13.1.1.5
Unsigned32
The number of active and passive mLdp Fecs on this device.
1.3.6.1.4.1.2636.5.13.1.1.6
Unsigned32
The number of mLdp FECs Active on this device. The mLDP FEC is considered active if the mplsMldpFecOperStatus is up(1).
1.3.6.1.4.1.2636.5.13.1.1.7
INTEGER1 = enable2 = disable · Integer32
Reference: Section 5.1 of [I-D.ietf-mpls-mldp-node-protection].
This object provides Point of Local Repair (PLR) capability of the LSR.
1.3.6.1.4.1.2636.5.13.1.1.8
INTEGER1 = enable2 = disable · Integer32
Reference: Section 5.2 of [I-D.ietf-mpls-mldp-node-protection].
This object provides Merge Point (MPT) capability of the LSR.
1.3.6.1.4.1.2636.5.13.1.1.9
INTEGER1 = enable2 = disable · Integer32
Reference: Section 5.3 of [I-D.ietf-mpls-mldp-node-protection].
This object provides Protected LSR capability.
1.3.6.1.4.1.2636.5.13.1.1.10
INTEGER1 = enable2 = disable · Integer32
Reference: Section 5.3 of [I-D.ietf-mpls-mldp-node-protection].
This object provides Node Protection capability of the LSR.
1.3.6.1.4.1.2636.5.13.1.2.1
Index: mplsLdpEntityLdpId · mplsLdpEntityIndex · mplsMldpPeerLdpId
This table will have learned information relating to Mldp.
from MPLS-LDP-STD-MIB
MplsLdpIdentifierThe LDP identifier is a six octet quantity which is used to identify a Label Switching Router (LSR) label space. The first four octets identify the LSR and must be a globally unique value, such as a 32-bit router ID assigned to the LSR, and the last two octets identify a specific label space within the LSR. SIZE (6) · OCTET STRING · hint 1d.1d.1d.1d:2d
Reference: RFC3036, LDP Specification, Section on LDP Identifiers.
The LDP identifier.
IndexIntegerAn integer which may be used as a table index. (1..4294967295) · Unsigned32 · hint d
This index is used as a secondary index to uniquely identify this row. Before creating a row in this table, the 'mplsLdpEntityIndexNext' object should be retrieved. That value should be used for the value of this index when creating a row in this table. NOTE: if a value of zero (0) is retrieved, that indicates that no rows can be created in this table at this time. A secondary index (this object) is meaningful to some but not all, LDP implementations. For example an LDP implementation which uses PPP would use this index to differentiate PPP sub-links. Another way to use this index is to give this the value of ifIndex. However, this is dependant on the implementation.
1.3.6.1.4.1.2636.5.13.1.2.1.1.1
MplsLdpIdentifierThe LDP identifier is a six octet quantity which is used to identify a Label Switching Router (LSR) label space. The first four octets identify the LSR and must be a globally unique value, such as a 32-bit router ID assigned to the LSR, and the last two octets identify a specific label space within the LSR. SIZE (6) · OCTET STRING · hint 1d.1d.1d.1d:2d
The LDP identifier of this LDP Peer.
1.3.6.1.4.1.2636.5.13.1.2.1.1.2
BITS
Reference: RFC6388, Section 2.1 for P2MP Capability TLV. and the section 3.1 for MP2MP Capability TLV. The RFC6388 for MBB Capability TLV. RFC5561 Section 9 for Dynamic Capability Announcement TLV. RFC6389 Section 3 for Upstream Label Assignment Capability TLV. Section 5 of [I-D.ietf-mpls-mldp-node-protection] describes for Point of Local Repair (plr) capability, Merge Point (mpt) capability, The Protected LSR (port-lsr) and Node Protection (node-prot) Capability.
This will indicate the LDP capability information about peer. The p2mp indicates peer supports P2MP Capability. The mp2mp indicates peer supports MP2MP Capability. The mbb indicates peer supports MBB Capability. The upstream-label-assignment indicates peer supports Upstream label assignment Capability. The dynamic indicates peer supports dynamic Capability. The plr indicates Point of Local Repair Capability. The mpt indicates Point of Merge Point Capability. The prot-lsr indicates Protected LSR Capability. The node-prot indicates Node Protection LSR Capability.
1.3.6.1.4.1.2636.5.13.1.2.2
Index: mplsLdpEntityLdpId · mplsLdpEntityIndex · mplsLdpPeerLdpId
A table of statistics related to mLDP on Sessions. This table AUGMENTS the mplsLdpSessionStatsTable.
from MPLS-LDP-STD-MIB
MplsLdpIdentifierThe LDP identifier is a six octet quantity which is used to identify a Label Switching Router (LSR) label space. The first four octets identify the LSR and must be a globally unique value, such as a 32-bit router ID assigned to the LSR, and the last two octets identify a specific label space within the LSR. SIZE (6) · OCTET STRING · hint 1d.1d.1d.1d:2d
Reference: RFC3036, LDP Specification, Section on LDP Identifiers.
The LDP identifier.
IndexIntegerAn integer which may be used as a table index. (1..4294967295) · Unsigned32 · hint d
This index is used as a secondary index to uniquely identify this row. Before creating a row in this table, the 'mplsLdpEntityIndexNext' object should be retrieved. That value should be used for the value of this index when creating a row in this table. NOTE: if a value of zero (0) is retrieved, that indicates that no rows can be created in this table at this time. A secondary index (this object) is meaningful to some but not all, LDP implementations. For example an LDP implementation which uses PPP would use this index to differentiate PPP sub-links. Another way to use this index is to give this the value of ifIndex. However, this is dependant on the implementation.
MplsLdpIdentifierThe LDP identifier is a six octet quantity which is used to identify a Label Switching Router (LSR) label space. The first four octets identify the LSR and must be a globally unique value, such as a 32-bit router ID assigned to the LSR, and the last two octets identify a specific label space within the LSR. SIZE (6) · OCTET STRING · hint 1d.1d.1d.1d:2d
The LDP identifier of this LDP Peer.
1.3.6.1.4.1.2636.5.13.1.2.2.1.1
Counter32
This object counts the number of mLDP FECs sent on this session. If the FEC is withdrawn, then this number is decremented. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of mplsLdpSessionDiscontinuityTime.
1.3.6.1.4.1.2636.5.13.1.2.2.1.2
Counter32
This object counts the number of mLDP FECs sent on this session and waiting for MBB Ack. This counter will get incremented when MBB req sent for a label on this session and will get decremented when the MBB Ack received.
1.3.6.1.4.1.2636.5.13.1.2.2.1.3
Counter32
This object counts the number of mLDP FECs received on this session. If the FEC is withdrawn from the downstream session, then this is decremented. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of mplsLdpSessionDiscontinuityTime.
1.3.6.1.4.1.2636.5.13.1.2.2.1.4
Counter32
This object counts the number of mLDP FECs received on this session and waiting for sending MBB Ack. This counter will get incremented when MBB req is received for a label on this session and will get decremented when the MBB Ack sent.
1.3.6.1.4.1.2636.5.13.1.2.2.1.5
Counter32
This object counts the number mLDP FECs for which the MBB Ack is reset by MBB timer, in which the LSR is waiting for MBB ack.
1.3.6.1.4.1.2636.5.13.1.2.3
Index: mplsLdpEntityLdpId · mplsLdpEntityIndex · mplsMldpFecIndex
This table represents the FEC (Forwarding Equivalence Class) Information associated with an mLDP LSP.
from MPLS-LDP-STD-MIB
MplsLdpIdentifierThe LDP identifier is a six octet quantity which is used to identify a Label Switching Router (LSR) label space. The first four octets identify the LSR and must be a globally unique value, such as a 32-bit router ID assigned to the LSR, and the last two octets identify a specific label space within the LSR. SIZE (6) · OCTET STRING · hint 1d.1d.1d.1d:2d
Reference: RFC3036, LDP Specification, Section on LDP Identifiers.
The LDP identifier.
IndexIntegerAn integer which may be used as a table index. (1..4294967295) · Unsigned32 · hint d
This index is used as a secondary index to uniquely identify this row. Before creating a row in this table, the 'mplsLdpEntityIndexNext' object should be retrieved. That value should be used for the value of this index when creating a row in this table. NOTE: if a value of zero (0) is retrieved, that indicates that no rows can be created in this table at this time. A secondary index (this object) is meaningful to some but not all, LDP implementations. For example an LDP implementation which uses PPP would use this index to differentiate PPP sub-links. Another way to use this index is to give this the value of ifIndex. However, this is dependant on the implementation.
1.3.6.1.4.1.2636.5.13.1.2.3.1.1
IndexIntegerAn integer which may be used as a table index. (1..4294967295) · Unsigned32 · hint d
The index which uniquely identifies this entry.
1.3.6.1.4.1.2636.5.13.1.2.3.1.2
INTEGER6 = p2mp7 = mp2mpUpstream8 = mp2mpDownstream · Integer32
Reference: RFC6388, Section 2.2. The P2MP FEC Element and the section 3.3 for the MP2MP Fec elements.
The type of the FEC. If the value of this object is 6, then it is P2MP Fec Type, and 7, 8 are correspond to MP2MP upstream and downstream type.
1.3.6.1.4.1.2636.5.13.1.2.3.1.3
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
Reference: RFC6388, Section 2.2. The P2MP FEC Element and the section 3.3 for the MP2MP Fec elements.
The value of this object is the type of the Internet address. The value of this object, decides how the value of the mplsMldpFecRootAddr object is interpreted.
1.3.6.1.4.1.2636.5.13.1.2.3.1.4
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
Reference: RFC6388, Section 2.2. The P2MP FEC Element and the section 3.3 for the MP2MP Fec elements.
The value of this object is interpreted based on the value of the mplsMldpFecRootAddrType object. This is ingress node address for the mLDP LSP.
1.3.6.1.4.1.2636.5.13.1.2.3.1.5
INTEGER1 = genericLspId3 = transitIpv4Source4 = transitIpv6Source5 = transitIpv4Bidir6 = transitIpv6Bidir · Integer32
This is opaque type of the mLDP FEC. The value of this object is shown below. 1 - The Generic LSP Identifier 3 - Transit IPv4 Source TLV 4 - Transit IPv6 Source TLV 5 - Transit IPv4 Bidir TLV 6 - Transit IPv6 Bidir TLV.
1.3.6.1.4.1.2636.5.13.1.2.3.1.6
Unsigned32
Reference: RFC6388, Section 2.3.1.
The 32-bit unsigned integer value which is to represent Generic LSP ID. This value is only valid if the mplsMldpFecOpaqueType is genericLspId(1), otherwise 0 must be returned.
1.3.6.1.4.1.2636.5.13.1.2.3.1.7
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
Reference: RFC6826, Section 3.1.
The value of this object is the type of the Internet address. The value of this object, decides how the value of the mplsMldpFecOpaqueTransitSourceOrBidirAddr object is interpreted.
1.3.6.1.4.1.2636.5.13.1.2.3.1.8
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
Reference: RFC6826, Section 3.1.
The value of this object is interpreted based on the value of the mplsMldpFecOpaqueTransitSourceOrBidirAddrType object. This is source node address for the mLDP inband LSP.
1.3.6.1.4.1.2636.5.13.1.2.3.1.9
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
Reference: RFC6826, Section 3.2.
The value of this object is the type of the Internet address. The value of this object, decides how the value of the mplsMldpFecOpaqueTransitGroupAddr object is interpreted.
1.3.6.1.4.1.2636.5.13.1.2.3.1.10
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
Reference: RFC6826, Section 3.2.
The value of this object is interpreted based on the value of the mplsMldpFecOpaqueTransitGroupAddrType object. This is group node address for the mLDP inband LSP.
1.3.6.1.4.1.2636.5.13.1.2.3.1.11
INTEGER1 = up2 = down · Integer32
Indicates the admin status of this mLDP FEC.
1.3.6.1.4.1.2636.5.13.1.2.3.1.12
INTEGER1 = up2 = down · Integer32
Indicates the actual operational status of this mLDP Fec.
1.3.6.1.4.1.2636.5.13.1.2.3.1.13
INTEGER1 = enable2 = disable · Integer32
This object provides whether MoFRR enabled for this mLDP FEC. on this mLDP FEC. As mentioned in the section 3.2 of [I-D.ietf-rtgwg-mofrr], When this is enabled, then mLDP may select two upstream sessions, one is primary and other one is backup. The backup traffic is discarded when the primary upstream session is UP. When the primary upstream session goes down, the traffic from the backup upstream session will be forwarded to downstream.
1.3.6.1.4.1.2636.5.13.1.2.3.1.14
INTEGER1 = egress2 = bud3 = transit4 = ingress · Integer32
Indicates the role of FEC either egress, bud, transit or ingress
1.3.6.1.4.1.2636.5.13.1.2.3.1.15
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
This values shows Fec UP time. This is time since mplsMldpFecOperStatus is UP.
1.3.6.1.4.1.2636.5.13.1.2.4
Index: mplsLdpEntityIndex · mplsMldpFecBranchFecIndex · mplsMldpFecBranchOutSegIndex
This table provides mLDP Fec branch MPLS Traffic Stats information.
from MPLS-LDP-STD-MIB
IndexIntegerAn integer which may be used as a table index. (1..4294967295) · Unsigned32 · hint d
This index is used as a secondary index to uniquely identify this row. Before creating a row in this table, the 'mplsLdpEntityIndexNext' object should be retrieved. That value should be used for the value of this index when creating a row in this table. NOTE: if a value of zero (0) is retrieved, that indicates that no rows can be created in this table at this time. A secondary index (this object) is meaningful to some but not all, LDP implementations. For example an LDP implementation which uses PPP would use this index to differentiate PPP sub-links. Another way to use this index is to give this the value of ifIndex. However, this is dependant on the implementation.
1.3.6.1.4.1.2636.5.13.1.2.4.1.1
MplsIndexTypeThis is an octet string that can be used as a table index in cases where a large addressable space is required such as on an LSR where many applications may be provisioning labels. Note that the string containing the single octet with the value 0x00 is a reserved value used to represent special cases. When this TEXTUAL-CONVENTION is used as the SYNTAX of an object, the DESCRIPTION clause MUST specify if this special value is valid and if so what the special meaning is. In systems that provide write access to the MPLS-LSR-STD MIB, mplsIndexType SHOULD be used as a simple multi-digit integer encoded as an octet string. No further overloading of the meaning of an index SHOULD be made. In systems that do not offer write access to the MPLS-LSR-STD MIB, the mplsIndexType may contain implicit formatting that is specific to the implementation to convey additional information such as interface index, physical card or device, or application id. The interpretation of this additional formatting is implementation dependent and not covered in this document. Such formatting MUST NOT impact the basic functionality of read-only access to the MPLS-LSR-STD MIB by management applications that are not aware of the formatting rules. SIZE (1..24) · OCTET STRING
This index identifies the mLDP FEC entry in the mplsMldpFecTable. This is same as mplsMldpFecIndex.
1.3.6.1.4.1.2636.5.13.1.2.4.1.2
MplsIndexTypeThis is an octet string that can be used as a table index in cases where a large addressable space is required such as on an LSR where many applications may be provisioning labels. Note that the string containing the single octet with the value 0x00 is a reserved value used to represent special cases. When this TEXTUAL-CONVENTION is used as the SYNTAX of an object, the DESCRIPTION clause MUST specify if this special value is valid and if so what the special meaning is. In systems that provide write access to the MPLS-LSR-STD MIB, mplsIndexType SHOULD be used as a simple multi-digit integer encoded as an octet string. No further overloading of the meaning of an index SHOULD be made. In systems that do not offer write access to the MPLS-LSR-STD MIB, the mplsIndexType may contain implicit formatting that is specific to the implementation to convey additional information such as interface index, physical card or device, or application id. The interpretation of this additional formatting is implementation dependent and not covered in this document. Such formatting MUST NOT impact the basic functionality of read-only access to the MPLS-LSR-STD MIB by management applications that are not aware of the formatting rules. SIZE (1..24) · OCTET STRING
This object identifies an outgoing branch from this mLDP LSP Its value is unique within the context of the mLDP LSP. This contains the same value as the mplsOutSegmentIndex in the MPLS-LSR-STD-MIBs mplsOutSegmentTable.
1.3.6.1.4.1.2636.5.13.1.2.4.1.3
MplsLdpIdentifierThe LDP identifier is a six octet quantity which is used to identify a Label Switching Router (LSR) label space. The first four octets identify the LSR and must be a globally unique value, such as a 32-bit router ID assigned to the LSR, and the last two octets identify a specific label space within the LSR. SIZE (6) · OCTET STRING · hint 1d.1d.1d.1d:2d
This object identifies an outgoing branch peer LDP ID for this mLDP LSP. Its value is unique within the context of the mLDP LSP. On Egress node, this value could be 0.0.0.0:00 as there will no downstream LDP session.
1.3.6.1.4.1.2636.5.13.1.2.4.1.4
Counter64 (0..18446744073709551615)
This object represent the 64-bit value, which gives the number of packets forwarded by the mLDP LSP onto this branch. This object should be read in conjunction with mplsMldpFecBranchStatsDiscontinuityTime.
1.3.6.1.4.1.2636.5.13.1.2.4.1.5
Counter64 (0..18446744073709551615)
This object represent the 64-bit value, which gives the number of bytes forwarded by the mLDP LSP onto this branch. This object should be read in conjunction with mplsMldpFecBranchStatsDiscontinuityTime.
1.3.6.1.4.1.2636.5.13.1.2.4.1.6
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime on the most recent occasion at which any one or more of this rows Counter32 or Counter64 objects experienced a discontinuity. If no such discontinuity has occurred since the last re-initialization of the local management subsystem, then this object contains a zero value.
1.3.6.1.4.1.2636.5.13.1.2.5
Index: mplsLdpEntityLdpId · mplsLdpEntityIndex · mplsMldpFecUpstreamSessFecIndex · mplsMldpFecUpstreamSessInSegIndex
This table provides mLDP Fec upstream Session information.
from MPLS-LDP-STD-MIB
MplsLdpIdentifierThe LDP identifier is a six octet quantity which is used to identify a Label Switching Router (LSR) label space. The first four octets identify the LSR and must be a globally unique value, such as a 32-bit router ID assigned to the LSR, and the last two octets identify a specific label space within the LSR. SIZE (6) · OCTET STRING · hint 1d.1d.1d.1d:2d
Reference: RFC3036, LDP Specification, Section on LDP Identifiers.
The LDP identifier.
IndexIntegerAn integer which may be used as a table index. (1..4294967295) · Unsigned32 · hint d
This index is used as a secondary index to uniquely identify this row. Before creating a row in this table, the 'mplsLdpEntityIndexNext' object should be retrieved. That value should be used for the value of this index when creating a row in this table. NOTE: if a value of zero (0) is retrieved, that indicates that no rows can be created in this table at this time. A secondary index (this object) is meaningful to some but not all, LDP implementations. For example an LDP implementation which uses PPP would use this index to differentiate PPP sub-links. Another way to use this index is to give this the value of ifIndex. However, this is dependant on the implementation.
1.3.6.1.4.1.2636.5.13.1.2.5.1.1
MplsIndexTypeThis is an octet string that can be used as a table index in cases where a large addressable space is required such as on an LSR where many applications may be provisioning labels. Note that the string containing the single octet with the value 0x00 is a reserved value used to represent special cases. When this TEXTUAL-CONVENTION is used as the SYNTAX of an object, the DESCRIPTION clause MUST specify if this special value is valid and if so what the special meaning is. In systems that provide write access to the MPLS-LSR-STD MIB, mplsIndexType SHOULD be used as a simple multi-digit integer encoded as an octet string. No further overloading of the meaning of an index SHOULD be made. In systems that do not offer write access to the MPLS-LSR-STD MIB, the mplsIndexType may contain implicit formatting that is specific to the implementation to convey additional information such as interface index, physical card or device, or application id. The interpretation of this additional formatting is implementation dependent and not covered in this document. Such formatting MUST NOT impact the basic functionality of read-only access to the MPLS-LSR-STD MIB by management applications that are not aware of the formatting rules. SIZE (1..24) · OCTET STRING
This index identifies the mLDP FEC entry in the mplsMldpFecTable.
1.3.6.1.4.1.2636.5.13.1.2.5.1.2
MplsIndexTypeThis is an octet string that can be used as a table index in cases where a large addressable space is required such as on an LSR where many applications may be provisioning labels. Note that the string containing the single octet with the value 0x00 is a reserved value used to represent special cases. When this TEXTUAL-CONVENTION is used as the SYNTAX of an object, the DESCRIPTION clause MUST specify if this special value is valid and if so what the special meaning is. In systems that provide write access to the MPLS-LSR-STD MIB, mplsIndexType SHOULD be used as a simple multi-digit integer encoded as an octet string. No further overloading of the meaning of an index SHOULD be made. In systems that do not offer write access to the MPLS-LSR-STD MIB, the mplsIndexType may contain implicit formatting that is specific to the implementation to convey additional information such as interface index, physical card or device, or application id. The interpretation of this additional formatting is implementation dependent and not covered in this document. Such formatting MUST NOT impact the basic functionality of read-only access to the MPLS-LSR-STD MIB by management applications that are not aware of the formatting rules. SIZE (1..24) · OCTET STRING
This object identifies an upstream session from this mLDP LSP Its value is unique within the context of the mLDP LSP. This contains the same value as the mplsInSegmentIndex in the MPLS-LSR-STD-MIBs mplsInSegmentTable.
1.3.6.1.4.1.2636.5.13.1.2.5.1.3
MplsLdpIdentifierThe LDP identifier is a six octet quantity which is used to identify a Label Switching Router (LSR) label space. The first four octets identify the LSR and must be a globally unique value, such as a 32-bit router ID assigned to the LSR, and the last two octets identify a specific label space within the LSR. SIZE (6) · OCTET STRING · hint 1d.1d.1d.1d:2d
This object identifies an upstream session peer LDP ID for this mLDP LSP. Its value is unique within the context of the mLDP LSP.
1.3.6.1.4.1.2636.5.13.1.2.5.1.4
INTEGER1 = primary2 = backup · Integer32
This indicated wether the received traffic from upstream is primary or backup. This is valid only if the MoFRR (mplsMldpFecMoFrr) is enabled on this FEC.
1.3.6.1.4.1.2636.5.13.1.2.5.1.5
INTEGER1 = active2 = inactive · Integer32
This indicates whether the upstream session is active, means the LSR programmed the forwarding engine to receive the traffic from this upstream session. This will be Inactive if the LSR is wating for MBB Ack.
1.3.6.1.4.1.2636.5.13.1.2.5.1.6
Counter64 (0..18446744073709551615)
This object represent the 64-bit value, which gives the number of packets received by the mLDP LSP from this upstream session. This object should be read in conjunction with mplsMldpFecUpstreamSessDiscontinuityTime.
1.3.6.1.4.1.2636.5.13.1.2.5.1.7
Counter64 (0..18446744073709551615)
This object represent the 64-bit value, which gives the number of bytes received by the mLDP LSP from this upstream session. This object should be read in conjunction with mplsMldpFecUpstreamSessDiscontinuityTime.
1.3.6.1.4.1.2636.5.13.1.2.5.1.8
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime on the most recent occasion at which any one or more of this rows Counter32 or Counter64 objects experienced a discontinuity. If no such discontinuity has occurred since the last re-initialization of the local management subsystem, then this object contains a zero value.
1.3.6.1.4.1.2636.5.13.1.2.6
Index: mplsMldpInterfaceIndex
This table provides mLDP Traffic Stats on specified interface.
1.3.6.1.4.1.2636.5.13.1.2.6.1.1
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
This index identifies the specific interface.
1.3.6.1.4.1.2636.5.13.1.2.6.1.2
Counter64 (0..18446744073709551615)
This is 64 bit value, which gives the number of packets forwarded by all mLDP LSPs onto this interface.
1.3.6.1.4.1.2636.5.13.1.2.6.1.3
Counter64 (0..18446744073709551615)
This is 64 bit value, which gives the number of bytes forwarded by all mLDP LSPs onto this interface.
1.3.6.1.4.1.2636.5.13.1.2.6.1.4
Counter64 (0..18446744073709551615)
This is 64 bit value, which gives the number of packets received by all mLDP LSPs from this interface.
1.3.6.1.4.1.2636.5.13.1.2.6.1.5
Counter64 (0..18446744073709551615)
This is 64 bit value, which gives the number of bytes received by all mLDP LSPs from this interface.
1.3.6.1.4.1.2636.5.13.1.0.1
This notification is generated when a mplsMldpFecOperStatus object changes from down to up.
1.3.6.1.4.1.2636.5.13.1.2.3.1.11
INTEGER1 = up2 = down · Integer32
Indicates the admin status of this mLDP FEC.
1.3.6.1.4.1.2636.5.13.1.2.3.1.12
INTEGER1 = up2 = down · Integer32
Indicates the actual operational status of this mLDP Fec.
1.3.6.1.4.1.2636.5.13.1.0.2
This notification is generated when a mplsMldpFecOperStatus object changes from up to down.
1.3.6.1.4.1.2636.5.13.1.2.3.1.11
INTEGER1 = up2 = down · Integer32
Indicates the admin status of this mLDP FEC.
1.3.6.1.4.1.2636.5.13.1.2.3.1.12
INTEGER1 = up2 = down · Integer32
Indicates the actual operational status of this mLDP Fec.
1.3.6.1.4.1.2636.5.13.1.0.3
This notification is generated when a mplsMldpFecUpstreamSessPrimary object changes from primary to backup and vice versa.
1.3.6.1.4.1.2636.5.13.1.2.5.1.4
INTEGER1 = primary2 = backup · Integer32
This indicated wether the received traffic from upstream is primary or backup. This is valid only if the MoFRR (mplsMldpFecMoFrr) is enabled on this FEC.