EZ5 MIB Catalog

MPLS-TE-EXT-STD-MIB

2015-02-02

Download MPLS-TE-EXT-STD-MIB.txt Open MPLS-TE-EXT-STD-MIB.txt in a new tab

This MIB module contains generic object definitions for extending the MPLS Traffic Engineering tunnels in transport networks. Copyright (c) 2015 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).

SCALARS (1) · TABLES (4)

Scalars (1)

NameOID
mplsTunnelExtNodeConfigLocalIdNext1.3.6.1.2.1.10.166.20.0.1

Tables (4)

NameOID
mplsTunnelExtNodeConfigTable1.3.6.1.2.1.10.166.20.0.2
mplsTunnelExtNodeIpMapTable1.3.6.1.2.1.10.166.20.0.3
mplsTunnelExtNodeIccMapTable1.3.6.1.2.1.10.166.20.0.4
mplsTunnelExtTable1.3.6.1.2.1.10.166.20.0.5

END OF TOC

Scalar details

mplsTunnelExtNodeConfigLocalIdNext

1.3.6.1.2.1.10.166.20.0.1

IndexIntegerNextFreeAn integer which may be used as a new Index in a table. The special value of 0 indicates that no more new entries can be created in the relevant table. When a MIB is used for configuration, an object with this SYNTAX always contains a legal value (if non-zero) for an index that is not currently used in the relevant table. The Command Generator (Network Management Application) reads this variable and uses the (non-zero) value read when creating a new row with an SNMP SET. When the SET is performed, the Command Responder (agent) must determine whether the value is indeed still unused; Two Network Management Applications may attempt to create a row (configuration entry) simultaneously and use the same value. If it is currently unused, the SET succeeds and the Command Responder (agent) changes the value of this object, according to an implementation-specific algorithm. If the value is in use, however, the SET fails. The Network Management Application must then re-read this variable to obtain a new usable value. An OBJECT-TYPE definition using this SYNTAX MUST specify the relevant table for which the object is providing this functionality. (0..16777215) · Unsigned32 · hint d

This object contains an unused value for mplsTunnelExtNodeConfigLocalId, or a zero to indicate that none exist. Negative values are not allowed, as they do not correspond to valid values of mplsTunnelExtNodeConfigLocalId.

Table details

mplsTunnelExtNodeConfigTable

1.3.6.1.2.1.10.166.20.0.2

Index: mplsTunnelExtNodeConfigLocalId

This table allows the operator to map a node or LSR identifier (IP-compatible [Global_ID::Node_ID] or ICC-based [ICC_Operator_ID::Node_ID]) with a local identifier. This table is created to reuse the existing mplsTunnelTable for MPLS-based transport network tunnels also. Since the MPLS tunnel's Ingress/Egress LSR identifiers' size (Unsigned32) value is not compatible for MPLS-TP Tunnel, i.e., Global_ID::Node_ID of size 8 bytes and ICC_Operator_ID::Node_ID of size 12 bytes, there exists a need to map the Global_ID::Node_ID or ICC_Operator_ID::Node_ID with the local identifier of size 4 bytes (Unsigned32) value in order to index (Ingress/Egress LSR identifier) the existing mplsTunnelTable.

mplsTunnelExtNodeConfigLocalId

1.3.6.1.2.1.10.166.20.0.2.1.1

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

This object is used in accommodating the bigger- size Global_ID::Node_ID and/or the ICC_Operator_ID::Node_ID with the smaller-size LSR identifier in order to index the mplsTunnelTable. The local identifier is configured between 0 and 16777215, as the valid IP address range starts from 16777216(01.00.00.00). This range is chosen to determine whether the mplsTunnelTable's Ingress/Egress LSR ID is an IP address or local identifier. If the configured range is not an IP address, the operator is expected to retrieve the complete information (Global_ID::Node_ID or ICC_Operator_ID::Node_ID) from mplsTunnelExtNodeConfigTable. This way, the existing mplsTunnelTable is reused for bidirectional tunnel extensions for MPLS-based transport networks. The local identifier allows the operator to assign a unique identifier to map Global_ID::Node_ID and/or ICC_Operator_ID::Node_ID. As this local identifier is unique within the node and the same syntax of this object can be used for MPLS-TE tunnel also, it is up to the operator/local management entity to choose a non-conflicting value for indexing the MPLS and MPLS-TP tunnel entries.

mplsTunnelExtNodeConfigGlobalId

1.3.6.1.2.1.10.166.20.0.2.1.2

MplsGlobalIdThis object contains the Textual Convention for an IP-based operator-unique identifier (Global_ID). The Global_ID can contain the 2-octet or 4-octet value of the operator's Autonomous System Number (ASN). When the Global_ID is derived from a 2-octet ASN, the two high-order octets of this 4-octet identifier MUST be set to zero (0x00). Further, ASN 0 is reserved. The size of the Global_ID string MUST be zero if the Global_ID is invalid. Note that a Global_ID of zero is limited to entities contained within a single operator and MUST NOT be used across a Network-to-Network Interface (NNI). A non-zero Global_ID MUST be derived from an ASN owned by the operator.Reference: MPLS Transport Profile (MPLS-TP) Identifiers, RFC 6370, Section 3 SIZE (4) · OCTET STRING

This object indicates the Global Operator Identifier. This object has no meaning when mplsTunnelExtNodeConfigIccValid is set true.

mplsTunnelExtNodeConfigCcId

1.3.6.1.2.1.10.166.20.0.2.1.3

MplsCcIdThe CC (Country Code) is a string of two characters, each being an uppercase Basic Latin alphabetic (i.e., A-Z). The characters are encoded using ITU-T Recommendation T.50. The size of the CC string MUST be zero if the CC identifier is invalid.Reference: MPLS-TP Identifiers Following ITU-T Conventions, RFC 6923, Section 3. International Reference Alphabet (IRA) (Formerly International Alphabet No. 5 or IA5) - Information technology - 7-bit coded character set for information exchange, ITU-T Recommendation T.50, September 1992. SIZE (0 | 2) · OCTET STRING

This object allows the operator or service provider to configure a unique MPLS-TP ITU-T Country Code (CC) either for Ingress ID or Egress ID. This object has no meaning when mplsTunnelExtNodeConfigIccValid is set to false.

mplsTunnelExtNodeConfigIccId

1.3.6.1.2.1.10.166.20.0.2.1.4

MplsIccIdThe ICC is a string of one to six characters, each an uppercase Basic Latin alphabetic (i.e., A-Z) or numeric (i.e., 0-9). The characters are encoded using ITU-T Recommendation T.50. The size of the ICC string MUST be zero if the ICC identifier is invalid.Reference: MPLS-TP Identifiers Following ITU-T Conventions, RFC 6923, Section 3. International Reference Alphabet (IRA) (Formerly International Alphabet No. 5 or IA5) - Information technology - 7-bit coded character set for information exchange, ITU-T Recommendation T.50, September 1992. SIZE (0 | 1..6) · OCTET STRING

This object allows the operator or service provider to configure a unique MPLS-TP ITU-T Carrier Code (ICC) either for Ingress ID or Egress ID. This object has no meaning when mplsTunnelExtNodeConfigIccValid is set to false.

mplsTunnelExtNodeConfigNodeId

1.3.6.1.2.1.10.166.20.0.2.1.5

MplsNodeIdThe Node_ID is assigned within the scope of the Global_ID/ICC_Operator_ID. When IPv4 addresses are in use, the value of this object can be derived from the LSR's IPv4 loopback address. When IPv6 addresses are in use, the value of this object can be a 32-bit value unique within the scope of a Global_ID. Note that, when IP reachability is not needed, the 32-bit Node_ID is not required to have any association with the IPv4 address space. The value of 0 indicates an invalid Node_ID.Reference: MPLS Transport Profile (MPLS-TP) Identifiers, RFC 6370, Section 4 (0 | 1..4294967295) · Unsigned32 · hint d

This object indicates the Node_ID within the scope of a Global_ID or ICC_Operator_ID.

mplsTunnelExtNodeConfigIccValid

1.3.6.1.2.1.10.166.20.0.2.1.6

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Denotes whether or not this entry uses mplsTunnelExtNodeConfigCcId, mplsTunnelExtNodeConfigIccId, and mplsTunnelExtNodeConfigNodeId for mapping the ICC-based identifiers with the local identifier. Note that if this variable is set to false, then the mplsTunnelExtNodeConfigGlobalId and mplsTunnelExtNodeConfigNodeId objects should have the valid information.

mplsTunnelExtNodeConfigStorageType

1.3.6.1.2.1.10.166.20.0.2.1.7

StorageType1 = other2 = volatile3 = nonVolatile4 = permanent5 = readOnlyDescribes the memory realization of a conceptual row. A row which is volatile(2) is lost upon reboot. A row which is either nonVolatile(3), permanent(4) or readOnly(5), is backed up by stable storage. A row which is permanent(4) can be changed but not deleted. A row which is readOnly(5) cannot be changed nor deleted. If the value of an object with this syntax is either permanent(4) or readOnly(5), it cannot be written. Conversely, if the value is either other(1), volatile(2) or nonVolatile(3), it cannot be modified to be permanent(4) or readOnly(5). (All illegal modifications result in a 'wrongValue' error.) Every usage of this textual convention is required to specify the columnar objects which a permanent(4) row must at a minimum allow to be writable. · Integer32

This variable indicates the storage type for this object. Conceptual rows having the value 'permanent' need not allow write-access to any columnar objects in the row.

mplsTunnelExtNodeConfigRowStatus

1.3.6.1.2.1.10.166.20.0.2.1.8

RowStatus1 = active2 = notInService3 = notReady4 = createAndGo5 = createAndWait6 = destroyThe RowStatus textual convention is used to manage the creation and deletion of conceptual rows, and is used as the value of the SYNTAX clause for the status column of a conceptual row (as described in Section 7.7.1 of [2].) The status column has six defined values: - `active', which indicates that the conceptual row is available for use by the managed device; - `notInService', which indicates that the conceptual row exists in the agent, but is unavailable for use by the managed device (see NOTE below); 'notInService' has no implication regarding the internal consistency of the row, availability of resources, or consistency with the current state of the managed device; - `notReady', which indicates that the conceptual row exists in the agent, but is missing information necessary in order to be available for use by the managed device (i.e., one or more required columns in the conceptual row have not been instanciated); - `createAndGo', which is supplied by a management station wishing to create a new instance of a conceptual row and to have its status automatically set to active, making it available for use by the managed device; - `createAndWait', which is supplied by a management station wishing to create a new instance of a conceptual row (but not make it available for use by the managed device); and, - `destroy', which is supplied by a management station wishing to delete all of the instances associated with an existing conceptual row. Whereas five of the six values (all except `notReady') may be specified in a management protocol set operation, only three values will be returned in response to a management protocol retrieval operation: `notReady', `notInService' or `active'. That is, when queried, an existing conceptual row has only three states: it is either available for use by the managed device (the status column has value `active'); it is not available for use by the managed device, though the agent has sufficient information to attempt to make it so (the status column has value `notInService'); or, it is not available for use by the managed device, and an attempt to make it so would fail because the agent has insufficient information (the state column has value `notReady'). NOTE WELL This textual convention may be used for a MIB table, irrespective of whether the values of that table's conceptual rows are able to be modified while it is active, or whether its conceptual rows must be taken out of service in order to be modified. That is, it is the responsibility of the DESCRIPTION clause of the status column to specify whether the status column must not be `active' in order for the value of some other column of the same conceptual row to be modified. If such a specification is made, affected columns may be changed by an SNMP set PDU if the RowStatus would not be equal to `active' either immediately before or after processing the PDU. In other words, if the PDU also contained a varbind that would change the RowStatus value, the column in question may be changed if the RowStatus was not equal to `active' as the PDU was received, or if the varbind sets the status to a value other than 'active'. Also note that whenever any elements of a row exist, the RowStatus column must also exist. To summarize the effect of having a conceptual row with a status column having a SYNTAX clause value of RowStatus, consider the following state diagram: STATE +--------------+-----------+-------------+------------- | A | B | C | D | |status col.|status column| |status column | is | is |status column ACTION |does not exist| notReady | notInService| is active --------------+--------------+-----------+-------------+------------- set status |noError ->D|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndGo |inconsistent- | | | | Value| | | --------------+--------------+-----------+-------------+------------- set status |noError see 1|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndWait |wrongValue | | | --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError column to | Value| entValue| | active | | | | | | or | | | | | | | |see 2 ->D|see 8 ->D| ->D --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError ->C column to | Value| entValue| | notInService | | | | | | or | | or | | | | | |see 3 ->C| ->C|see 6 --------------+--------------+-----------+-------------+------------- set status |noError |noError |noError |noError ->A column to | | | | or destroy | ->A| ->A| ->A|see 7 --------------+--------------+-----------+-------------+------------- set any other |see 4 |noError |noError |see 5 column to some| | | | value | | see 1| ->C| ->D --------------+--------------+-----------+-------------+------------- (1) goto B or C, depending on information available to the agent. (2) if other variable bindings included in the same PDU, provide values for all columns which are missing but required, and all columns have acceptable values, then return noError and goto D. (3) if other variable bindings included in the same PDU, provide legal values for all columns which are missing but required, then return noError and goto C. (4) at the discretion of the agent, the return value may be either: inconsistentName: because the agent does not choose to create such an instance when the corresponding RowStatus instance does not exist, or inconsistentValue: if the supplied value is inconsistent with the state of some other MIB object's value, or noError: because the agent chooses to create the instance. If noError is returned, then the instance of the status column must also be created, and the new state is B or C, depending on the information available to the agent. If inconsistentName or inconsistentValue is returned, the row remains in state A. (5) depending on the MIB definition for the column/table, either noError or inconsistentValue may be returned. (6) the return value can indicate one of the following errors: wrongValue: because the agent does not support notInService (e.g., an agent which does not support createAndWait), or inconsistentValue: because the agent is unable to take the row out of service at this time, perhaps because it is in use and cannot be de-activated. (7) the return value can indicate the following error: inconsistentValue: because the agent is unable to remove the row at this time, perhaps because it is in use and cannot be de-activated. (8) the transition to D can fail, e.g., if the values of the conceptual row are inconsistent, then the error code would be inconsistentValue. NOTE: Other processing of (this and other varbinds of) the set request may result in a response other than noError being returned, e.g., wrongValue, noCreation, etc. Conceptual Row Creation There are four potential interactions when creating a conceptual row: selecting an instance-identifier which is not in use; creating the conceptual row; initializing any objects for which the agent does not supply a default; and, making the conceptual row available for use by the managed device. Interaction 1: Selecting an Instance-Identifier The algorithm used to select an instance-identifier varies for each conceptual row. In some cases, the instance- identifier is semantically significant, e.g., the destination address of a route, and a management station selects the instance-identifier according to the semantics. In other cases, the instance-identifier is used solely to distinguish conceptual rows, and a management station without specific knowledge of the conceptual row might examine the instances present in order to determine an unused instance-identifier. (This approach may be used, but it is often highly sub-optimal; however, it is also a questionable practice for a naive management station to attempt conceptual row creation.) Alternately, the MIB module which defines the conceptual row might provide one or more objects which provide assistance in determining an unused instance-identifier. For example, if the conceptual row is indexed by an integer-value, then an object having an integer-valued SYNTAX clause might be defined for such a purpose, allowing a management station to issue a management protocol retrieval operation. In order to avoid unnecessary collisions between competing management stations, `adjacent' retrievals of this object should be different. Finally, the management station could select a pseudo-random number to use as the index. In the event that this index was already in use and an inconsistentValue was returned in response to the management protocol set operation, the management station should simply select a new pseudo-random number and retry the operation. A MIB designer should choose between the two latter algorithms based on the size of the table (and therefore the efficiency of each algorithm). For tables in which a large number of entries are expected, it is recommended that a MIB object be defined that returns an acceptable index for creation. For tables with small numbers of entries, it is recommended that the latter pseudo-random index mechanism be used. Interaction 2: Creating the Conceptual Row Once an unused instance-identifier has been selected, the management station determines if it wishes to create and activate the conceptual row in one transaction or in a negotiated set of interactions. Interaction 2a: Creating and Activating the Conceptual Row The management station must first determine the column requirements, i.e., it must determine those columns for which it must or must not provide values. Depending on the complexity of the table and the management station's knowledge of the agent's capabilities, this determination can be made locally by the management station. Alternately, the management station issues a management protocol get operation to examine all columns in the conceptual row that it wishes to create. In response, for each column, there are three possible outcomes: - a value is returned, indicating that some other management station has already created this conceptual row. We return to interaction 1. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it should supply a value for this column when the conceptual row is to be created. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. Once the column requirements have been determined, a management protocol set operation is accordingly issued. This operation also sets the new instance of the status column to `createAndGo'. When the agent processes the set operation, it verifies that it has sufficient information to make the conceptual row available for use by the managed device. The information available to the agent is provided by two sources: the management protocol set operation which creates the conceptual row, and, implementation-specific defaults supplied by the agent (note that an agent must provide implementation-specific defaults for at least those objects which it implements as read-only). If there is sufficient information available, then the conceptual row is created, a `noError' response is returned, the status column is set to `active', and no further interactions are necessary (i.e., interactions 3 and 4 are skipped). If there is insufficient information, then the conceptual row is not created, and the set operation fails with an error of `inconsistentValue'. On this error, the management station can issue a management protocol retrieval operation to determine if this was because it failed to specify a value for a required column, or, because the selected instance of the status column already existed. In the latter case, we return to interaction 1. In the former case, the management station can re-issue the set operation with the additional information, or begin interaction 2 again using `createAndWait' in order to negotiate creation of the conceptual row. NOTE WELL Regardless of the method used to determine the column requirements, it is possible that the management station might deem a column necessary when, in fact, the agent will not allow that particular columnar instance to be created or written. In this case, the management protocol set operation will fail with an error such as `noCreation' or `notWritable'. In this case, the management station decides whether it needs to be able to set a value for that particular columnar instance. If not, the management station re-issues the management protocol set operation, but without setting a value for that particular columnar instance; otherwise, the management station aborts the row creation algorithm. Interaction 2b: Negotiating the Creation of the Conceptual Row The management station issues a management protocol set operation which sets the desired instance of the status column to `createAndWait'. If the agent is unwilling to process a request of this sort, the set operation fails with an error of `wrongValue'. (As a consequence, such an agent must be prepared to accept a single management protocol set operation, i.e., interaction 2a above, containing all of the columns indicated by its column requirements.) Otherwise, the conceptual row is created, a `noError' response is returned, and the status column is immediately set to either `notInService' or `notReady', depending on whether it has sufficient information to (attempt to) make the conceptual row available for use by the managed device. If there is sufficient information available, then the status column is set to `notInService'; otherwise, if there is insufficient information, then the status column is set to `notReady'. Regardless, we proceed to interaction 3. Interaction 3: Initializing non-defaulted Objects The management station must now determine the column requirements. It issues a management protocol get operation to examine all columns in the created conceptual row. In the response, for each column, there are three possible outcomes: - a value is returned, indicating that the agent implements the object-type associated with this column and had sufficient information to provide a value. For those columns to which the agent provides read-create access (and for which the agent allows their values to be changed after their creation), a value return tells the management station that it may issue additional management protocol set operations, if it desires, in order to change the value associated with this column. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. However, the agent does not have sufficient information to provide a value, and until a value is provided, the conceptual row may not be made available for use by the managed device. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it must issue additional management protocol set operations, in order to provide a value associated with this column. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. If the value associated with the status column is `notReady', then the management station must first deal with all `noSuchInstance' columns, if any. Having done so, the value of the status column becomes `notInService', and we proceed to interaction 4. Interaction 4: Making the Conceptual Row Available Once the management station is satisfied with the values associated with the columns of the conceptual row, it issues a management protocol set operation to set the status column to `active'. If the agent has sufficient information to make the conceptual row available for use by the managed device, the management protocol set operation succeeds (a `noError' response is returned). Otherwise, the management protocol set operation fails with an error of `inconsistentValue'. NOTE WELL A conceptual row having a status column with value `notInService' or `notReady' is unavailable to the managed device. As such, it is possible for the managed device to create its own instances during the time between the management protocol set operation which sets the status column to `createAndWait' and the management protocol set operation which sets the status column to `active'. In this case, when the management protocol set operation is issued to set the status column to `active', the values held in the agent supersede those used by the managed device. If the management station is prevented from setting the status column to `active' (e.g., due to management station or network failure) the conceptual row will be left in the `notInService' or `notReady' state, consuming resources indefinitely. The agent must detect conceptual rows that have been in either state for an abnormally long period of time and remove them. It is the responsibility of the DESCRIPTION clause of the status column to indicate what an abnormally long period of time would be. This period of time should be long enough to allow for human response time (including `think time') between the creation of the conceptual row and the setting of the status to `active'. In the absence of such information in the DESCRIPTION clause, it is suggested that this period be approximately 5 minutes in length. This removal action applies not only to newly-created rows, but also to previously active rows which are set to, and left in, the notInService state for a prolonged period exceeding that which is considered normal for such a conceptual row. Conceptual Row Suspension When a conceptual row is `active', the management station may issue a management protocol set operation which sets the instance of the status column to `notInService'. If the agent is unwilling to do so, the set operation fails with an error of `wrongValue' or `inconsistentValue'. Otherwise, the conceptual row is taken out of service, and a `noError' response is returned. It is the responsibility of the DESCRIPTION clause of the status column to indicate under what circumstances the status column should be taken out of service (e.g., in order for the value of some other column of the same conceptual row to be modified). Conceptual Row Deletion For deletion of conceptual rows, a management protocol set operation is issued which sets the instance of the status column to `destroy'. This request may be made regardless of the current value of the status column (e.g., it is possible to delete conceptual rows which are either `notReady', `notInService' or `active'.) If the operation succeeds, then all instances associated with the conceptual row are immediately removed. · Integer32

This object allows the operator to create, modify, and/or delete a row in this table.

mplsTunnelExtNodeIpMapTable

1.3.6.1.2.1.10.166.20.0.3

Index: mplsTunnelExtNodeIpMapGlobalId · mplsTunnelExtNodeIpMapNodeId

This read-only table allows the operator to retrieve the local identifier for a given Global_ID::Node_ID in an IP-compatible operator environment. This table MAY be used in on-demand and/or proactive OAM operations to get the Ingress/Egress LSR identifier (local identifier) from Src-Global_Node_ID or Dst-Global_Node_ID. The Ingress and Egress LSR identifiers are used to retrieve the tunnel entry. This table returns nothing when the associated entry is not defined in mplsTunnelExtNodeConfigTable.

mplsTunnelExtNodeIpMapGlobalId

1.3.6.1.2.1.10.166.20.0.3.1.1

MplsGlobalIdThis object contains the Textual Convention for an IP-based operator-unique identifier (Global_ID). The Global_ID can contain the 2-octet or 4-octet value of the operator's Autonomous System Number (ASN). When the Global_ID is derived from a 2-octet ASN, the two high-order octets of this 4-octet identifier MUST be set to zero (0x00). Further, ASN 0 is reserved. The size of the Global_ID string MUST be zero if the Global_ID is invalid. Note that a Global_ID of zero is limited to entities contained within a single operator and MUST NOT be used across a Network-to-Network Interface (NNI). A non-zero Global_ID MUST be derived from an ASN owned by the operator.Reference: MPLS Transport Profile (MPLS-TP) Identifiers, RFC 6370, Section 3 SIZE (4) · OCTET STRING

This object indicates the Global_ID.

mplsTunnelExtNodeIpMapNodeId

1.3.6.1.2.1.10.166.20.0.3.1.2

MplsNodeIdThe Node_ID is assigned within the scope of the Global_ID/ICC_Operator_ID. When IPv4 addresses are in use, the value of this object can be derived from the LSR's IPv4 loopback address. When IPv6 addresses are in use, the value of this object can be a 32-bit value unique within the scope of a Global_ID. Note that, when IP reachability is not needed, the 32-bit Node_ID is not required to have any association with the IPv4 address space. The value of 0 indicates an invalid Node_ID.Reference: MPLS Transport Profile (MPLS-TP) Identifiers, RFC 6370, Section 4 (0 | 1..4294967295) · Unsigned32 · hint d

This object indicates the Node_ID within the operator.

mplsTunnelExtNodeIpMapLocalId

1.3.6.1.2.1.10.166.20.0.3.1.3

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

This object contains an IP-compatible local identifier that is defined in mplsTunnelExtNodeConfigTable.

mplsTunnelExtNodeIccMapTable

1.3.6.1.2.1.10.166.20.0.4

Index: mplsTunnelExtNodeIccMapCcId · mplsTunnelExtNodeIccMapIccId · mplsTunnelExtNodeIccMapNodeId

This read-only table allows the operator to retrieve the local identifier for a given ICC_Operator_ID::Node_ID in an ICC operator environment. This table MAY be used in on-demand and/or proactive OAM operations to get the Ingress/Egress LSR identifier (local identifier) from Src-ICC or Dst-ICC. The Ingress and Egress LSR identifiers are used to retrieve the tunnel entry. This table returns nothing when the associated entry is not defined in mplsTunnelExtNodeConfigTable.

mplsTunnelExtNodeIccMapCcId

1.3.6.1.2.1.10.166.20.0.4.1.1

MplsCcIdThe CC (Country Code) is a string of two characters, each being an uppercase Basic Latin alphabetic (i.e., A-Z). The characters are encoded using ITU-T Recommendation T.50. The size of the CC string MUST be zero if the CC identifier is invalid.Reference: MPLS-TP Identifiers Following ITU-T Conventions, RFC 6923, Section 3. International Reference Alphabet (IRA) (Formerly International Alphabet No. 5 or IA5) - Information technology - 7-bit coded character set for information exchange, ITU-T Recommendation T.50, September 1992. SIZE (0 | 2) · OCTET STRING

This object allows the operator or service provider to configure a unique MPLS-TP ITU-T Country Code (CC) either for Ingress or Egress LSR ID. The CC is a string of two alphabetic characters represented with uppercase letters (i.e., A-Z).

mplsTunnelExtNodeIccMapIccId

1.3.6.1.2.1.10.166.20.0.4.1.2

MplsIccIdThe ICC is a string of one to six characters, each an uppercase Basic Latin alphabetic (i.e., A-Z) or numeric (i.e., 0-9). The characters are encoded using ITU-T Recommendation T.50. The size of the ICC string MUST be zero if the ICC identifier is invalid.Reference: MPLS-TP Identifiers Following ITU-T Conventions, RFC 6923, Section 3. International Reference Alphabet (IRA) (Formerly International Alphabet No. 5 or IA5) - Information technology - 7-bit coded character set for information exchange, ITU-T Recommendation T.50, September 1992. SIZE (0 | 1..6) · OCTET STRING

This object allows the operator or service provider to configure a unique MPLS-TP ITU-T Carrier Code (ICC) either for Ingress or Egress LSR ID. The ICC is a string of one to six characters, each character being either alphabetic (i.e., A-Z) or numeric (i.e., 0-9) characters. Alphabetic characters in the ICC should be represented with uppercase letters.

mplsTunnelExtNodeIccMapNodeId

1.3.6.1.2.1.10.166.20.0.4.1.3

MplsNodeIdThe Node_ID is assigned within the scope of the Global_ID/ICC_Operator_ID. When IPv4 addresses are in use, the value of this object can be derived from the LSR's IPv4 loopback address. When IPv6 addresses are in use, the value of this object can be a 32-bit value unique within the scope of a Global_ID. Note that, when IP reachability is not needed, the 32-bit Node_ID is not required to have any association with the IPv4 address space. The value of 0 indicates an invalid Node_ID.Reference: MPLS Transport Profile (MPLS-TP) Identifiers, RFC 6370, Section 4 (0 | 1..4294967295) · Unsigned32 · hint d

This object indicates the Node_ID within the ICC-based operator.

mplsTunnelExtNodeIccMapLocalId

1.3.6.1.2.1.10.166.20.0.4.1.4

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

This object contains an ICC-based local identifier that is defined in mplsTunnelExtNodeConfigTable.

mplsTunnelExtTable

1.3.6.1.2.1.10.166.20.0.5

Index: mplsTunnelIndex · mplsTunnelInstance · mplsTunnelIngressLSRId · mplsTunnelEgressLSRId

This table represents extensions to mplsTunnelTable in order to support MPLS-TP Tunnels. As per MPLS-TP Identifiers (RFC 6370), LSP_ID for IP-based co-routed bidirectional tunnel: A1-{Global_ID::Node_ID::Tunnel_Num}::Z9-{Global_ID:: Node_ID::Tunnel_Num}::LSP_Num LSP_ID for IP based associated bidirectional tunnel: A1-{Global_ID::Node_ID::Tunnel_Num::LSP_Num}:: Z9-{Global_ID::Node_ID::Tunnel_Num::LSP_Num} mplsTunnelTable is reused for forming the LSP_ID as follows: Source Tunnel_Num is mapped with mplsTunnelIndex, Source Node_ID is mapped with mplsTunnelIngressLSRId, Destination Node_ID is mapped with mplsTunnelEgressLSRId, and LSP_Num is mapped with mplsTunnelInstance. Source Global_ID::Node_ID and/or ICC_Operator_ID::Node_ID and Destination Global_ID::Node_ID and/or ICC_Operator_ID::Node-ID are maintained in the mplsTunnelExtNodeConfigTable. mplsTunnelExtNodeConfigLocalId is used to create an entry in mplsTunnelTable.

from MPLS-TE-STD-MIB

mplsTunnelIndex

MplsTunnelIndexA unique index into mplsTunnelTable. For tunnels signaled using RSVP, this value should correspond to the RSVP Tunnel ID used for the RSVP-TE session. (0..65535) · Unsigned32

Uniquely identifies a set of tunnel instances between a pair of ingress and egress LSRs. Managers should obtain new values for row creation in this table by reading mplsTunnelIndexNext. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the value signaled in the Tunnel Id of the Session object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the value signaled in the LSP ID.

mplsTunnelInstance

MplsTunnelInstanceIndexThe tunnel entry with instance index 0 should refer to the configured tunnel interface (if one exists). Values greater than 0, but less than or equal to 65535, should be used to indicate signaled (or backup) tunnel LSP instances. For tunnel LSPs signaled using RSVP, this value should correspond to the RSVP LSP ID used for the RSVP-TE LSP. Values greater than 65535 apply to FRR detour instances. (0 | 1..65535 | 65536..4294967295) · Unsigned32

Uniquely identifies a particular instance of a tunnel between a pair of ingress and egress LSRs. It is useful to identify multiple instances of tunnels for the purposes of backup and parallel tunnels. When the MPLS signaling protocol is rsvp(2) this value SHOULD be equal to the LSP Id of the Sender Template object. When the signaling protocol is crldp(3) there is no equivalent signaling object.

mplsTunnelIngressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Identity of the ingress LSR associated with this tunnel instance. When the MPLS signalling protocol is rsvp(2) this value SHOULD be equal to the Tunnel Sender Address in the Sender Template object and MAY be equal to the Extended Tunnel Id field in the SESSION object. When the MPLS signalling protocol is crldp(3) this value SHOULD be equal to the Ingress LSR Router ID field in the LSPID TLV object.

mplsTunnelEgressLSRId

MplsExtendedTunnelIdA unique identifier for an MPLS Tunnel. This may represent an IPv4 address of the ingress or egress LSR for the tunnel. This value is derived from the Extended Tunnel Id in RSVP or the Ingress Router ID for CR-LDP.Reference: RSVP-TE: Extensions to RSVP for LSP Tunnels, [RFC3209]. Constraint-Based LSP Setup using LDP, [RFC3212]. · Unsigned32

Identity of the egress LSR associated with this tunnel instance.

mplsTunnelExtOppositeDirPtr

1.3.6.1.2.1.10.166.20.0.5.1.1

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

This object points to the opposite-direction tunnel entry.

mplsTunnelExtOppositeDirTnlValid

1.3.6.1.2.1.10.166.20.0.5.1.2

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Denotes whether or not this tunnel uses mplsTunnelExtOppositeDirPtr for identifying the opposite- direction tunnel information. Note that if this variable is set to true, then the mplsTunnelExtOppositeDirPtr should point to the first accessible row of the valid opposite- direction tunnel.

mplsTunnelExtDestTnlIndex

1.3.6.1.2.1.10.166.20.0.5.1.3

MplsTunnelIndexA unique index into mplsTunnelTable. For tunnels signaled using RSVP, this value should correspond to the RSVP Tunnel ID used for the RSVP-TE session. (0..65535) · Unsigned32

This object is applicable only for the bidirectional tunnel that has the forward and reverse LSPs in the different tunnel entries. The values of this object and the mplsTunnelExtDestTnlLspIndex object together can be used to identify an opposite-direction LSP, i.e., if the mplsTunnelIndex and mplsTunnelInstance hold the value for forward LSP, this object and mplsTunnelExtDestTnlLspIndex can be used to retrieve the reverse-direction LSP and vice versa. This object and mplsTunnelExtDestTnlLspIndex values provide the first two indices of tunnel entry, and the remaining indices can be derived as follows: the Ingress and Egress Identifiers should be swapped in order to index the other direction tunnel.

mplsTunnelExtDestTnlLspIndex

1.3.6.1.2.1.10.166.20.0.5.1.4

MplsTunnelInstanceIndexThe tunnel entry with instance index 0 should refer to the configured tunnel interface (if one exists). Values greater than 0, but less than or equal to 65535, should be used to indicate signaled (or backup) tunnel LSP instances. For tunnel LSPs signaled using RSVP, this value should correspond to the RSVP LSP ID used for the RSVP-TE LSP. Values greater than 65535 apply to FRR detour instances. (0 | 1..65535 | 65536..4294967295) · Unsigned32

This object is applicable only for the bidirectional tunnel that has the forward and reverse LSPs in the different tunnel entries. This object holds the instance index of the opposite-direction tunnel.

mplsTunnelExtDestTnlValid

1.3.6.1.2.1.10.166.20.0.5.1.5

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Denotes whether or not this tunnel uses mplsTunnelExtDestTnlIndex and mplsTunnelExtDestTnlLspIndex for identifying the opposite-direction tunnel information. Note that if this variable is set to true, then the mplsTunnelExtDestTnlIndex and mplsTunnelExtDestTnlLspIndex objects should have the valid opposite-direction tunnel indices.

mplsTunnelExtIngressLSRLocalIdValid

1.3.6.1.2.1.10.166.20.0.5.1.6

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object denotes whether the mplsTunnelIngressLSRId contains the local value that is used to reference the complete Ingress Global_ID::Node_ID or ICC_Operator_ID from the mplsTunnelExtNodeConfigTable. If this object is set to FALSE, mplsTunnelExtNodeConfigTable will not contain an entry to reference the local identifier with Global_ID::Node_ID or ICC_Operator_ID::Node_ID value. This object is set to FALSE for legacy implementations like MPLS TE tunnels where mplsTunnelIngressId itself provides the complete Ingress LSR ID.

mplsTunnelExtEgressLSRLocalIdValid

1.3.6.1.2.1.10.166.20.0.5.1.7

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object denotes whether the mplsTunnelEgressLSRId contains the local value, which is used to reference the complete Egress Global_ID::Node_ID or ICC_Operator_ID::Node_ID from the mplsTunnelExtNodeConfigTable. If this object is set to FALSE, mplsTunnelExtNodeConfigTable will not contain an entry to reference the local identifier with Global_ID::Node_ID or ICC_Operator_ID::Node_ID value. This object is set to FALSE for legacy implementations like MPLS TE tunnels where mplsTunnelEgressId itself provides the complete Egress LSR ID.

↑ To TOC