nemoCapabilities
1.3.6.1.2.1.184.1.1.1.1
BITS
This object indicates the NEMO functions that are supported by this managed entity. Multiple NEMO functions may be supported by a single entity. Reference: RFC 3963: Section 3
2009-03-10
Download NEMO-MIB.txt Open NEMO-MIB.txt in a new tab
Copyright (c) 2009 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: - Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. - Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. - Neither the name of Internet Society, IETF or IETF Trust, nor the names of specific contributors, may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 'AS IS' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. This version of this MIB module is part of RFC 5488; see the RFC itself for full legal notices.
SCALARS (27) · TABLES (5) · TRAPS (2)
| Name | OID |
|---|---|
| nemoHomeTunnelEstablished | 1.3.6.1.2.1.184.0.1 |
| nemoHomeTunnelReleased | 1.3.6.1.2.1.184.0.2 |
END OF TOC
1.3.6.1.2.1.184.1.1.1.1
BITS
This object indicates the NEMO functions that are supported by this managed entity. Multiple NEMO functions may be supported by a single entity. Reference: RFC 3963: Section 3
1.3.6.1.2.1.184.1.1.1.2
INTEGER1 = enabled2 = disabled · Integer32
This object indicates whether the NEMO function is enabled for the managed entity. If it is enabled, the agent discovery and registration functions will be operational. Changing the status from enabled(1) to disabled(2) will terminate the agent discovery and registration functions. On the other hand, changing the status from disabled(2) to enabled(1) will start the agent discovery and registration functions. The value of this object MUST remain unchanged across reboots of the managed entity.
1.3.6.1.2.1.184.1.1.4.1
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime on the most recent occasion at which any one or more of this NEMO entity's counters, viz., counters with OID prefix 'nemoMrConf', 'nemoMrRegnCounters', 'nemoMrGlobalStats', or 'nemoHaGlobalStats', suffered a discontinuity. If no such discontinuities have occurred since the last re-initialization of the local management subsystem, then this object will have a zero value.
1.3.6.1.2.1.184.1.2.2.1
Counter32
Total number of Modified Dynamic Home Agent Address Discovery Requests, with Mobile Router Support Flag set, sent by the mobile router. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3775: Sections 10.5, 11.4.1 RFC 3963: Section 7.1
1.3.6.1.2.1.184.1.2.2.2
Counter32
Total number of Modified Dynamic Home Agent Address Discovery Replies, with Mobile Router Support Flag set, received by the mobile router. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3775: Sections 10.5, 11.4.1 RFC 3963: Section 7.2
1.3.6.1.2.1.184.1.2.2.3
Counter32
Total number of Modified Dynamic Home Agent Address Discovery Replies, with Mobile Router Support Flag set to 0 although the flag in the corresponding request is set to 1. It implies that there is no home agent that supports mobile router functionality in the home network. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3775: Sections 10.5, 11.4.1 RFC 3963: Section 7.2
1.3.6.1.2.1.184.1.2.2.4
Counter32
Number of times the mobile router has detected movement from a foreign network to its home network. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 3
1.3.6.1.2.1.184.1.2.2.5
Counter32
Number of times the mobile router has detected movement to a foreign network from the home network, has acquired a care-of address, and has initiated the care-of address registration process. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 3
1.3.6.1.2.1.184.1.2.2.6
Counter32
Number of times the mobile router has detected movement to/from a foreign network from/to another foreign network. Note that 'movement' implies movement in layer 3, i.e., the mobile router's care-of address changed, and it initiated the care-of address registration process. If there are multiple egress interfaces, this counter counts the total number of movements. The movement as a mobile node of the mobile entity is not counted. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 3
1.3.6.1.2.1.184.1.2.2.7
Counter32
Number of times the NEMO entity has found an egress interface with better priority. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime.
1.3.6.1.2.1.184.1.2.3.2.1
Counter32
The total number of mobility messages, i.e., IPv6 datagrams with Mobility Header, sent by the mobile node. This will include Binding Updates sent by a mobile router with the Mobile Router Flag set. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3775: Sections 4.2, 6.1 RFC 3963: Section 4.1
1.3.6.1.2.1.184.1.2.3.2.2
Counter32
The total number of mobility messages, i.e., IPv6 datagrams with Mobility Header, received by the mobile node. This will include Binding Acknowledgements with Mobile Router Flag set that are sent to a mobile router. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3775: Sections 4.2, 6.1 RFC 3963: Sections 4.1, 4.2
1.3.6.1.2.1.184.1.2.3.3
INTEGER1 = implicitMode2 = explicitMode · Integer32
This object indicates the mode in which the mobile network prefixes will be registered with the home agent. implicitMode(1): the Mobile Network Prefix Option will not be included in the Binding Update by the mobile router. explicitMode(2): the mobile router will include one or more Mobile Network Prefix Options in the Binding Update. The value of this object MUST remain unchanged across reboots of the managed entity. Reference: RFC 3963: Section 5.2
1.3.6.1.2.1.184.1.2.4.1
Counter32
The total number of Binding Acknowledgements without NEMO support received by the mobile router. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 5.3
1.3.6.1.2.1.184.1.2.4.2
Counter32
The total number of Binding Acknowledgements received by the mobile router with status code indicating 'Registration type change disallowed' (Code 139). Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3775: Section 9.5.1 RFC 3963: Section 6.2
1.3.6.1.2.1.184.1.2.4.3
Counter32
The total number of Binding Acknowledgements received by the mobile router with status code indicating 'Mobile Router Operation not permitted' (Code 140). Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 6.6
1.3.6.1.2.1.184.1.2.4.4
Counter32
The total number of Binding Acknowledgements received by the mobile router with status code indicating 'Invalid Prefix' (Code 141). Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 6.6
1.3.6.1.2.1.184.1.2.4.5
Counter32
The total number of Binding Acknowledgements received by the mobile router with status code indicating 'Not Authorized for Prefix' (Code 142). Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963 : Section 6.6
1.3.6.1.2.1.184.1.2.4.6
Counter32
The total number of Binding Acknowledgements received by the mobile router with status code indicating 'Forwarding Setup failed' (Code 143). Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 6.6
1.3.6.1.2.1.184.1.2.4.7
Counter32
The total number of Binding Acknowledgements received by the mobile router (Mobile Router Flag is set) with status code other than: successfully processed --(Code 0 ) mobileRouterOperationNotPermitted (140) --(Code 140) invalidPrefix (141) --(Code 141) notAuthorizedForPrefix (142) --(Code 142) forwardingSetupFailed (143) --(Code 143) Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963 : Section 6.6
1.3.6.1.2.1.184.1.4.2.1.1
Counter32
The total number of Binding Acknowledgements without NEMO support sent by the home agent. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 5.3
1.3.6.1.2.1.184.1.4.2.1.2
Counter32
The total number of Binding Update requests rejected by the home agent with status code in the Binding Acknowledgement indicating 'Registration type change disallowed' (Code 139). Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3775: Section 9.5.1 RFC 3963: Section 6.2
1.3.6.1.2.1.184.1.4.2.1.3
Counter32
The total number of Binding Update requests rejected by the home agent with status code in the Binding Acknowledgement indicating 'Mobile Router Operation not permitted' (Code 140). Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 6.6
1.3.6.1.2.1.184.1.4.2.1.4
Counter32
The total number of Binding Update requests rejected by the home agent with status code in the Binding Acknowledgement indicating 'Invalid Prefix' (Code 141). Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 6.6
1.3.6.1.2.1.184.1.4.2.1.5
Counter32
The total number of Binding Update requests rejected by the home agent with status code in the Binding Acknowledgement indicating 'Not Authorized for Prefix' (Code 142). Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 6.6
1.3.6.1.2.1.184.1.4.2.1.6
Counter32
The total number of Binding Update requests rejected by the home agent with status code in the Binding Acknowledgement indicating 'Forwarding Setup failed' (Code 143). Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 6.6
1.3.6.1.2.1.184.1.4.2.1.7
Counter32
The total number of Binding Update requests from mobile routers (Mobile Router Flag is set) rejected by the home agent with status code other than: mobileRouterOperationNotPermitted (140) invalidPrefix (141) notAuthorizedForPrefix (142) forwardingSetupFailed (143) Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoCounterDiscontinuityTime. Reference: RFC 3963: Section 6.6
1.3.6.1.2.1.184.1.1.2.1
augments mip6BindingCacheTable (MOBILEIPV6-MIB)
Index: mip6BindingHomeAddressType · mip6BindingHomeAddress
This table models the Binding Cache that includes NEMO-related information and that is maintained by the home agent. Entries in this table are not required to survive a reboot of the home agent. Reference: RFC 3775: Sections 4.5, 9.1, 10.1, RFC 3963: Section 6.1
from MOBILEIPV6-MIB
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mip6BindingHomeAddress that follows.
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The home address of the mobile node corresponding to the Binding Cache entry. This field is used as the key for searching the mobile node's current care-of address in the Binding Cache. The type of the address represented by this object is specified by the corresponding mip6BindingHomeAddressType object. Reference: RFC 3775 : Section 9.1
1.3.6.1.2.1.184.1.1.2.1.1.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
true(1): indicates that the Binding Cache entry is from an entity acting as a mobile router. false(2): implies that the Binding Cache entry is from an entity acting as a mobile node. Reference: RFC 3963: Sections 6.1.1, 6.2
1.3.6.1.2.1.184.1.1.2.1.1.2
INTEGER1 = implicitMode2 = explicitMode · Integer32
implicitMode(1): the Mobile Network Prefix Option is not included in the Binding Update by the mobile router. explicitMode(2): the mobile router included one or more Mobile Network Prefix Options in the Binding Update. Reference: RFC 3963: Sections 5.2, 6.1.1, 6.2
1.3.6.1.2.1.184.1.2.1.1
Index: nemoMrEgressIfIndex
A table representing the egress interfaces that will be used by the mobile router for roaming to foreign networks. Each entry in this table represents a configured egress interface.
1.3.6.1.2.1.184.1.2.1.1.1.1
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The index of the interface on the mobile router.
1.3.6.1.2.1.184.1.2.1.1.1.2
Unsigned32 (0..255)
The priority configured to the egress interface. This value will be configured to a value between 0 and 255.
1.3.6.1.2.1.184.1.2.1.1.1.3
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
A human-readable textual description of the egress interface on the mobile router.
1.3.6.1.2.1.184.1.2.1.1.1.4
Gauge32 · seconds
This object indicates the time for which the egress interface will be held down during roaming to avoid interface flapping.
1.3.6.1.2.1.184.1.2.3.1
augments mip6MnBLTable (MOBILEIPV6-MIB)
Index: mip6MnHomeAddressType · mip6MnHomeAddress · mip6MnBLNodeAddressType · mip6MnBLNodeAddress
This table corresponds to the Binding Update List (BL) that includes NEMO-related information and that is maintained by the mobile router. The table holds a row for every binding that the mobile router has established or is trying to establish. Entries from the table are deleted as the lifetime of the binding expires. Reference: RFC 3775: Sections 4.5, 11.1 RFC 3963: Section 5.2
from MOBILEIPV6-MIB
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mip6MnHomeAddress that follows.
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
A unicast routable address assigned to the mobile node. This is used as the 'permanent address' of the mobile node in the sense that it remains unchanged regardless of the mobile node's current point of attachment. If mobile node doesn't have a home address assigned yet, then this object will take the default 'unspecified' value ::0. The type of the address represented by this object is specified by the corresponding mip6MnHomeAddressType object. Reference: RFC 3775 : Section 3.2
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mip6MnBLNodeAddress that follows.
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The address of the agent as used in the destination address of the Binding Update. The agent may be a home agent or a correspondent node. The type of the address represented by this object is specified by the corresponding mip6MnBLNodeAddressType object. Reference: RFC 3775 : Section 11.1
1.3.6.1.2.1.184.1.2.3.1.1.1
INTEGER1 = implicitMode2 = explicitMode · Integer32
implicitMode(1): the Mobile Network Prefix Option is not included in the Binding Update by the mobile router. explicitMode(2): the mobile router included one or more Mobile Network Prefix Options in the Binding Update. Reference: RFC 3963: Section 5.2
1.3.6.1.2.1.184.1.2.3.1.1.2
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
true(1): the mobile router sent the Binding Update with Mobile Router Flag set. false(2): the mobile router did not send the Binding Update with Mobile Router Flag set. This implies that the mobile router is acting as a mobile node. Reference: RFC 3963: Sections 4.1, 5.1
1.3.6.1.2.1.184.1.2.3.1.1.3
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The prefix length of the mobile router's home network. Reference: RFC 3963: Section 3
1.3.6.1.2.1.184.1.2.3.1.1.4
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The prefix length of the care-of address of the mobile router. Reference: RFC 3963: Section 3
1.3.6.1.2.1.184.1.2.3.1.1.5
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index of the currently active egress interface. Reference: RFC 3963: Section 5.5
1.3.6.1.2.1.184.1.2.3.1.1.6
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index of the tunnel established between the mobile router and the home agent for NEMO traffic. Reference: RFC 3963: Section 5.5
1.3.6.1.2.1.184.1.4.2.2
Index: mip6BindingHomeAddressType · mip6BindingHomeAddress
A table containing registration statistics for all mobile routers registered with the home agent.
from MOBILEIPV6-MIB
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mip6BindingHomeAddress that follows.
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The home address of the mobile node corresponding to the Binding Cache entry. This field is used as the key for searching the mobile node's current care-of address in the Binding Cache. The type of the address represented by this object is specified by the corresponding mip6BindingHomeAddressType object. Reference: RFC 3775 : Section 9.1
1.3.6.1.2.1.184.1.4.2.2.1.1
Counter32
Total number of Binding Update requests from the mobile router accepted by the home agent. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoHaCtrDiscontinuityTime.
1.3.6.1.2.1.184.1.4.2.2.1.2
Counter32
Total number of Binding Update requests from the mobile router rejected by the home agent. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of nemoHaCtrDiscontinuityTime.
1.3.6.1.2.1.184.1.4.2.2.1.3
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The time when the current Binding Cache entry was created for the mobile router. An implementation MUST return all 11 bytes of the DateAndTime textual-convention so that a manager may retrieve the offset from GMT time.
1.3.6.1.2.1.184.1.4.2.2.1.4
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The time at which the last Binding Update was accepted by the home agent for this mobile router. An implementation MUST return all 11 bytes of the DateAndTime textual-convention so that a manager may retrieve the offset from GMT time.
1.3.6.1.2.1.184.1.4.2.2.1.5
DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The time at which the last Binding Update was rejected by the home agent for this mobile router. If there have been no rejections, then this object will be inaccessible. An implementation MUST return all 11 bytes of the DateAndTime textual-convention so that a manager may retrieve the offset from GMT time.
1.3.6.1.2.1.184.1.4.2.2.1.6
NemoBURequestRejectionCode140 = mobileRouterOperationNotPermitted141 = invalidPrefix142 = notAuthorizedForPrefix143 = forwardingSetupFailedThe value of the status field in the Binding Acknowledgment message when the Binding Update was rejected for NEMO-specific reasons.Reference: RFC 3963: Section 4.2 · Integer32
The Status code (>= 128) in the latest Binding Acknowledgment indicating a rejection, sent to this mobile router. If a Binding Update request is rejected and a Binding Acknowledgment is not sent to this mobile router, then this will be the value of the Status code that corresponds to the reason of the rejection. If there have been no Binding Update request rejections, then this object will be inaccessible.
1.3.6.1.2.1.184.1.4.2.2.1.7
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime on the most recent occasion at which any one or more of the counters in this row, viz., instances of 'nemoHaBURequestsAccepted' and 'nemoHaBURequestsDenied', suffered a discontinuity. If no such discontinuity has occurred since the last re-initialization of the local management subsystem, then this object will have a zero value.
1.3.6.1.2.1.184.1.4.3.1
Index: mip6BindingHomeAddressType · mip6BindingHomeAddress · nemoHaMobileNetworkPrefixSeqNo
This table contains the mobile network prefixes that the home agent maintains for the mobile router. The mobile network prefixes in this table are registered by Binding Updates or are manually pre-configured. Reference: RFC 3963: Section 6.1.2
from MOBILEIPV6-MIB
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mip6BindingHomeAddress that follows.
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
The home address of the mobile node corresponding to the Binding Cache entry. This field is used as the key for searching the mobile node's current care-of address in the Binding Cache. The type of the address represented by this object is specified by the corresponding mip6BindingHomeAddressType object. Reference: RFC 3775 : Section 9.1
1.3.6.1.2.1.184.1.4.3.1.1.1
Unsigned32 (1..1024)
A Binding Update may have multiple mobile network prefixes. This object, along with mip6BindingHomeAddressType and mip6BindingHomeAddress, uniquely identifies a row containing a single mobile network prefix for a mobile router in this table. Reference: RFC 3963: Sections 2, 6.1, 6.2
1.3.6.1.2.1.184.1.4.3.1.1.2
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The address type for the mobile network prefix that follows.
1.3.6.1.2.1.184.1.4.3.1.1.3
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
A mobile network prefix related to the corresponding Binding Update. The type of the address represented by this object is specified by the corresponding nemoHaMobileNetworkPrefixType object. Reference: RFC 3963: Sections 2, 6.1, 6.2
1.3.6.1.2.1.184.1.4.3.1.1.4
Unsigned32 (0..128)
The length of the prefix specified by the corresponding nemoHaMobileNetworkPrefix object. Reference: RFC 3963: Sections 4.3, 6.1, 6.2
1.3.6.1.2.1.184.1.4.3.1.1.5
INTEGER1 = configured2 = bindingUpdate · Integer32
The information source of the mobile network prefix configured with the Binding Update. configured(1): indicates that the mobile network prefix has been manually pre-configured. bindingUpdate(2): indicates that the information is introduced to the home agent by the Mobile Network Prefix Option in the Binding Updates received by the home agent. Reference: RFC 3963: Sections 4.3, 6.1, 6.2
1.3.6.1.2.1.184.0.1
This notification is sent by the mobile router every time the tunnel is established between the home agent and the mobile router. Reference: RFC 3963: Section 5.5
1.3.6.1.2.1.184.1.2.3.1.1.5
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index of the currently active egress interface. Reference: RFC 3963: Section 5.5
1.3.6.1.2.1.184.1.2.3.1.1.6
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index of the tunnel established between the mobile router and the home agent for NEMO traffic. Reference: RFC 3963: Section 5.5
1.3.6.1.2.1.133.1.2.3.1.1.3
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mip6MnBLCOA that follows.
1.3.6.1.2.1.133.1.2.3.1.1.4
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
Care-of address that the mobile node intends to register in the Binding Update request. The type of the address represented by this object is specified by the corresponding mip6MnBLCOAType object. Reference: RFC 3775 : Section 11.1
1.3.6.1.2.1.184.1.2.3.1.1.3
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The prefix length of the mobile router's home network. Reference: RFC 3963: Section 3
1.3.6.1.2.1.184.1.2.3.1.1.4
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The prefix length of the care-of address of the mobile router. Reference: RFC 3963: Section 3
1.3.6.1.2.1.184.0.2
This notification is sent by the mobile router every time the tunnel is deleted between the home agent and the mobile router. Reference: RFC 3963: Section 5.5
1.3.6.1.2.1.184.1.2.3.1.1.5
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index of the currently active egress interface. Reference: RFC 3963: Section 5.5
1.3.6.1.2.1.184.1.2.3.1.1.6
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
The interface index of the tunnel established between the mobile router and the home agent for NEMO traffic. Reference: RFC 3963: Section 5.5
1.3.6.1.2.1.133.1.2.3.1.1.3
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
The InetAddressType of the mip6MnBLCOA that follows.
1.3.6.1.2.1.133.1.2.3.1.1.4
InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
Care-of address that the mobile node intends to register in the Binding Update request. The type of the address represented by this object is specified by the corresponding mip6MnBLCOAType object. Reference: RFC 3775 : Section 11.1
1.3.6.1.2.1.184.1.2.3.1.1.3
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The prefix length of the mobile router's home network. Reference: RFC 3963: Section 3
1.3.6.1.2.1.184.1.2.3.1.1.4
InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d
The prefix length of the care-of address of the mobile router. Reference: RFC 3963: Section 3