EZ5 MIB Catalog

NETWORK-SERVICES-MIB

2000-03-03

Download NETWORK-SERVICES-MIB.txt Open NETWORK-SERVICES-MIB.txt in a new tab

The MIB module describing network service applications

TABLES (2)

Tables (2)

NameOID
applTable1.3.6.1.2.1.27.1
assocTable1.3.6.1.2.1.27.2

END OF TOC

Table details

applTable

1.3.6.1.2.1.27.1

Index: applIndex

The table holding objects which apply to all different kinds of applications providing network services. Each network service application capable of being monitored should have a single entry in this table.

applIndex

1.3.6.1.2.1.27.1.1.1

INTEGER (1..2147483647) · Integer32

An index to uniquely identify the network service application. This attribute is the index used for lexicographic ordering of the table.

applName

1.3.6.1.2.1.27.1.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The name the network service application chooses to be known by.

applDirectoryName

1.3.6.1.2.1.27.1.1.3

DistinguishedNameA Distinguished Name represented in accordance with RFC 2253, presented in the UTF-8 charset defined in RFC 2279. SIZE (0..255) · OCTET STRING · hint 255a

The Distinguished Name of the directory entry where static information about this application is stored. An empty string indicates that no information about the application is available in the directory.

applVersion

1.3.6.1.2.1.27.1.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The version of network service application software. This field is usually defined by the vendor of the network service application software.

applUptime

1.3.6.1.2.1.27.1.1.5

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of sysUpTime at the time the network service application was last initialized. If the application was last initialized prior to the last initialization of the network management subsystem, then this object contains a zero value.

applOperStatus

1.3.6.1.2.1.27.1.1.6

INTEGER1 = up2 = down3 = halted4 = congested5 = restarting6 = quiescing · Integer32

Indicates the operational status of the network service application. 'down' indicates that the network service is not available. 'up' indicates that the network service is operational and available. 'halted' indicates that the service is operational but not available. 'congested' indicates that the service is operational but no additional inbound associations can be accommodated. 'restarting' indicates that the service is currently unavailable but is in the process of restarting and will be available soon. 'quiescing' indicates that service is currently operational but is in the process of shutting down. Additional inbound associations may be rejected by applications in the 'quiescing' state.

applLastChange

1.3.6.1.2.1.27.1.1.7

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of sysUpTime at the time the network service application entered its current operational state. If the current state was entered prior to the last initialization of the local network management subsystem, then this object contains a zero value.

applInboundAssociations

1.3.6.1.2.1.27.1.1.8

Gauge32

The number of current associations to the network service application, where it is the responder. An inbound association occurs when another application successfully connects to this one.

applOutboundAssociations

1.3.6.1.2.1.27.1.1.9

Gauge32

The number of current associations to the network service application, where it is the initiator. An outbound association occurs when this application successfully connects to another one.

applAccumulatedInboundAssociations

1.3.6.1.2.1.27.1.1.10

Counter32

The total number of associations to the application entity since application initialization, where it was the responder.

applAccumulatedOutboundAssociations

1.3.6.1.2.1.27.1.1.11

Counter32

The total number of associations to the application entity since application initialization, where it was the initiator.

applLastInboundActivity

1.3.6.1.2.1.27.1.1.12

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of sysUpTime at the time this application last had an inbound association. If the last association occurred prior to the last initialization of the network subsystem, then this object contains a zero value.

applLastOutboundActivity

1.3.6.1.2.1.27.1.1.13

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of sysUpTime at the time this application last had an outbound association. If the last association occurred prior to the last initialization of the network subsystem, then this object contains a zero value.

applRejectedInboundAssociations

1.3.6.1.2.1.27.1.1.14

Counter32

The total number of inbound associations the application entity has rejected, since application initialization. Rejected associations are not counted in the accumulated association totals. Note that this only counts associations the application entity has rejected itself; it does not count rejections that occur at lower layers of the network. Thus, this counter may not reflect the true number of failed inbound associations.

applFailedOutboundAssociations

1.3.6.1.2.1.27.1.1.15

Counter32

The total number associations where the application entity is initiator and association establishment has failed, since application initialization. Failed associations are not counted in the accumulated association totals.

applDescription

1.3.6.1.2.1.27.1.1.16

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

A text description of the application. This information is intended to identify and briefly describe the application in a status display.

applURL

1.3.6.1.2.1.27.1.1.17

URLStringA Uniform Resource Locator represented in accordance with RFCs 1738 and 2368, presented in the NVT ASCII charset defined in RFC 854. SIZE (0..255) · OCTET STRING · hint 255a

A URL pointing to a description of the application. This information is intended to identify and describe the application in a status display.

assocTable

1.3.6.1.2.1.27.2

Index: applIndex · assocIndex

The table holding a set of all active application associations.

assocIndex

1.3.6.1.2.1.27.2.1.1

INTEGER (1..2147483647) · Integer32

An index to uniquely identify each association for a network service application. This attribute is the index that is used for lexicographic ordering of the table. Note that the table is also indexed by the applIndex.

assocRemoteApplication

1.3.6.1.2.1.27.2.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The name of the system running remote network service application. For an IP-based application this should be either a domain name or IP address. For an OSI application it should be the string encoded distinguished name of the managed object. For X.400(1984) MTAs which do not have a Distinguished Name, the RFC 2156 syntax 'mta in globalid' used in X400-Received: fields can be used. Note, however, that not all connections an MTA makes are necessarily to another MTA.

assocApplicationProtocol

1.3.6.1.2.1.27.2.1.3

OBJECT IDENTIFIER

An identification of the protocol being used for the application. For an OSI Application, this will be the Application Context. For Internet applications, OID values of the form {applTCPProtoID port} or {applUDPProtoID port} are used for TCP-based and UDP-based protocols, respectively. In either case 'port' corresponds to the primary port number being used by the protocol. The usual IANA procedures may be used to register ports for new protocols.

assocApplicationType

1.3.6.1.2.1.27.2.1.4

INTEGER1 = uainitiator2 = uaresponder3 = peerinitiator4 = peerresponder · Integer32

This indicates whether the remote application is some type of client making use of this network service (e.g., a Mail User Agent) or a server acting as a peer. Also indicated is whether the remote end initiated an incoming connection to the network service or responded to an outgoing connection made by the local application. MTAs and messaging gateways are considered to be peers for the purposes of this variable.

assocDuration

1.3.6.1.2.1.27.2.1.5

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of sysUpTime at the time this association was started. If this association started prior to the last initialization of the network subsystem, then this object contains a zero value.

↑ To TOC