EZ5 MIB Catalog

NTPv4-MIB

2010-05-17

Download NTPv4-MIB.txt Open NTPv4-MIB.txt in a new tab

The Management Information Base for NTP time entities. Copyright (c) 2010 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).

SCALARS (26) · TABLES (3) · TRAPS (8)

Scalars (26)

NameOID
ntpEntSoftwareName1.3.6.1.2.1.197.1.1.1
ntpEntSoftwareVersion1.3.6.1.2.1.197.1.1.2
ntpEntSoftwareVendor1.3.6.1.2.1.197.1.1.3
ntpEntSystemType1.3.6.1.2.1.197.1.1.4
ntpEntTimeResolution1.3.6.1.2.1.197.1.1.5
ntpEntTimePrecision1.3.6.1.2.1.197.1.1.6
ntpEntTimeDistance1.3.6.1.2.1.197.1.1.7
ntpEntStatusCurrentMode1.3.6.1.2.1.197.1.2.1
ntpEntStatusStratum1.3.6.1.2.1.197.1.2.2
ntpEntStatusActiveRefSourceId1.3.6.1.2.1.197.1.2.3
ntpEntStatusActiveRefSourceName1.3.6.1.2.1.197.1.2.4
ntpEntStatusActiveOffset1.3.6.1.2.1.197.1.2.5
ntpEntStatusNumberOfRefSources1.3.6.1.2.1.197.1.2.6
ntpEntStatusDispersion1.3.6.1.2.1.197.1.2.7
ntpEntStatusEntityUptime1.3.6.1.2.1.197.1.2.8
ntpEntStatusDateTime1.3.6.1.2.1.197.1.2.9
ntpEntStatusLeapSecond1.3.6.1.2.1.197.1.2.10
ntpEntStatusLeapSecDirection1.3.6.1.2.1.197.1.2.11
ntpEntStatusInPkts1.3.6.1.2.1.197.1.2.12
ntpEntStatusOutPkts1.3.6.1.2.1.197.1.2.13
ntpEntStatusBadVersion1.3.6.1.2.1.197.1.2.14
ntpEntStatusProtocolError1.3.6.1.2.1.197.1.2.15
ntpEntStatusNotifications1.3.6.1.2.1.197.1.2.16
ntpEntHeartbeatInterval1.3.6.1.2.1.197.1.4.1
ntpEntNotifBits1.3.6.1.2.1.197.1.4.2
ntpEntNotifMessage1.3.6.1.2.1.197.1.5.1

Tables (3)

NameOID
ntpEntStatPktModeTable1.3.6.1.2.1.197.1.2.17
ntpAssociationTable1.3.6.1.2.1.197.1.3.1
ntpAssociationStatisticsTable1.3.6.1.2.1.197.1.3.2

Traps (8)

NameOID
ntpEntNotifModeChange1.3.6.1.2.1.197.0.1
ntpEntNotifStratumChange1.3.6.1.2.1.197.0.2
ntpEntNotifSyspeerChanged1.3.6.1.2.1.197.0.3
ntpEntNotifAddAssociation1.3.6.1.2.1.197.0.4
ntpEntNotifRemoveAssociation1.3.6.1.2.1.197.0.5
ntpEntNotifConfigChanged1.3.6.1.2.1.197.0.6
ntpEntNotifLeapSecondAnnounced1.3.6.1.2.1.197.0.7
ntpEntNotifHeartbeat1.3.6.1.2.1.197.0.8

END OF TOC

Scalar details

ntpEntSoftwareName

1.3.6.1.2.1.197.1.1.1

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

The product name of the running NTP version, e.g., 'ntpd'.

ntpEntSoftwareVersion

1.3.6.1.2.1.197.1.1.2

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

The software version of the installed NTP implementation as a full version string, e.g., 'ntpd-4.2.0b@1.1433 ...'

ntpEntSoftwareVendor

1.3.6.1.2.1.197.1.1.3

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

The vendor/author of the installed NTP version.

ntpEntSystemType

1.3.6.1.2.1.197.1.1.4

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

General hardware/os platform information, e.g., 'Linux 2.6.12 / x86'.

ntpEntTimeResolution

1.3.6.1.2.1.197.1.1.5

Unsigned32

The time resolution in integer format, where the resolution is represented as divisions of a second, e.g., a value of 1000 translates to 1.0 ms.

ntpEntTimePrecision

1.3.6.1.2.1.197.1.1.6

Integer32

The entity's precision in integer format, shows the precision. A value of -5 would mean 2^-5 = 31.25 ms.

ntpEntTimeDistance

1.3.6.1.2.1.197.1.1.7

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The distance from this NTP entity to the root time reference (stratum 0) source including the unit, e.g., '13.243 ms'.

ntpEntStatusCurrentMode

1.3.6.1.2.1.197.1.2.1

INTEGER1 = notRunning2 = notSynchronized3 = noneConfigured4 = syncToLocal5 = syncToRefclock6 = syncToRemoteServer99 = unknown · Integer32

The current mode of the NTP. The definition of each possible value is: notRunning(1) - NTP is not running. notSynchronized(2) - NTP is not synchronized to any time source (stratum = 16). noneConfigured(3) - NTP is not synchronized and does not have a reference configured (stratum = 16). syncToLocal(4) - NTP is distributing time based on its local clock (degraded accuracy and/or reliability). syncToRefclock(5) - NTP is synchronized to a local hardware refclock (e.g., GPS). syncToRemoteServer(6) - NTP is synchronized to a remote NTP server ('upstream' server). unknown(99) - The state of NTP is unknown.

ntpEntStatusStratum

1.3.6.1.2.1.197.1.2.2

NtpStratumThe NTP stratum, with 16 representing no stratum. (1..16) · Unsigned32 · hint d

The NTP entity's own stratum value. Should be a stratum of syspeer + 1 (or 16 if no syspeer).

ntpEntStatusActiveRefSourceId

1.3.6.1.2.1.197.1.2.3

Unsigned32 (0..99999)

The association ID of the current syspeer.

ntpEntStatusActiveRefSourceName

1.3.6.1.2.1.197.1.2.4

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

The hostname/descriptive name of the current reference source selected as syspeer, e.g., 'ntp1.ptb.de' or 'GPS' or 'DCFi', ...

ntpEntStatusActiveOffset

1.3.6.1.2.1.197.1.2.5

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The time offset to the current selected reference time source as a string including unit, e.g., '0.032 ms' or '1.232 s'.

ntpEntStatusNumberOfRefSources

1.3.6.1.2.1.197.1.2.6

Unsigned32 (0..99)

The number of reference sources configured for NTP.

ntpEntStatusDispersion

1.3.6.1.2.1.197.1.2.7

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The root dispersion of the running NTP entity, e.g., '6.927'.

ntpEntStatusEntityUptime

1.3.6.1.2.1.197.1.2.8

TimeTicks

The uptime of the NTP entity, (i.e., the time since ntpd was (re-)initialized not sysUptime!). The time is represented in hundreds of seconds since Jan 1, 1970 (00:00:00.000) UTC.

ntpEntStatusDateTime

1.3.6.1.2.1.197.1.2.9

NtpDateTimeNTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This trusted certificate (TC) is not to be used for objects that are used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.Reference: RFC 5905, section 6 SIZE (0 | 16) · OCTET STRING · hint 4d:4d:4d.4d

The current NTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This object can be used to timestamp events on this node and allow a management station to correlate different time objects. For example, a management station could query this object and sysUpTime in the same operation to be able to relate sysUpTime to NTP time. This object is not to be used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.

ntpEntStatusLeapSecond

1.3.6.1.2.1.197.1.2.10

NtpDateTimeNTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This trusted certificate (TC) is not to be used for objects that are used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.Reference: RFC 5905, section 6 SIZE (0 | 16) · OCTET STRING · hint 4d:4d:4d.4d

Date the next known leap second will occur. If there is no leap second announced, then this object should be 0.

ntpEntStatusLeapSecDirection

1.3.6.1.2.1.197.1.2.11

Integer32 (-1..1)

Direction of next known leap second. If there is no leap second announced, then this object should be 0.

ntpEntStatusInPkts

1.3.6.1.2.1.197.1.2.12

Counter32 · packets

The total number of NTP messages delivered to the NTP entity from the transport service. Discountinuities in the value of this counter can occur upon cold start or reinitialization of the NTP entity, the management system and at other times as indicated by discontinuities in the value of sysUpTime.

ntpEntStatusOutPkts

1.3.6.1.2.1.197.1.2.13

Counter32 · packets

The total number of NTP messages delivered to the transport service by this NTP entity. Discountinuities in the value of this counter can occur upon cold start or reinitialization of the NTP entity, the management system and at other times as indicated by discontinuities in the value of sysUpTime.

ntpEntStatusBadVersion

1.3.6.1.2.1.197.1.2.14

Counter32 · packets

The total number of NTP messages that were delivered to this NTP entity and were for an unsupported NTP version. Discountinuities in the value of this counter can occur upon cold start or reinitialization of the NTP entity, the management system and at other times as indicated by discontinuities in the value of sysUpTime.

ntpEntStatusProtocolError

1.3.6.1.2.1.197.1.2.15

Counter32 · packets

The total number of NTP messages that were delivered to this NTP entity and this entity was not able to process due to an NTP protocol error. Discountinuities in the value of this counter can occur upon cold start or reinitialization of the NTP entity, the management system and at other times as indicated by discontinuities in the value of sysUpTime.

ntpEntStatusNotifications

1.3.6.1.2.1.197.1.2.16

Counter32 · notifications

The total number of SNMP notifications that this NTP entity has generated. Discountinuities in the value of this counter can occur upon cold start or reinitialization of the NTP entity, the management system and at other times as indicated by discontinuities in the value of sysUpTime.

ntpEntHeartbeatInterval

1.3.6.1.2.1.197.1.4.1

Unsigned32 · seconds

The interval at which the ntpEntNotifHeartbeat notification should be sent, in seconds. If set to 0 and the entNotifHeartbeat bit in ntpEntNotifBits is 1, then ntpEntNotifHeartbeat is sent once. This value is stored persistently and will be restored to its last set value upon cold start or restart.

ntpEntNotifBits

1.3.6.1.2.1.197.1.4.2

BITS

A bit for each notification. A 1 for a particular bit enables that particular notification, a 0 disables it. This value is stored persistently and will be restored to its last set value upon cold start or restart.

ntpEntNotifMessage

1.3.6.1.2.1.197.1.5.1

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

Used as a payload object for all notifications. Holds a cleartext event message.

Table details

ntpEntStatPktModeTable

1.3.6.1.2.1.197.1.2.17

Index: ntpEntStatPktMode

The number of packets sent and received by packet mode. One entry per packet mode.

ntpEntStatPktMode

1.3.6.1.2.1.197.1.2.17.1.1

INTEGER1 = symetricactive2 = symetricpassive3 = client4 = server5 = broadcastserver6 = broadcastclient · Integer32

The NTP packet mode.

ntpEntStatPktSent

1.3.6.1.2.1.197.1.2.17.1.2

Counter32 · packets

The number of NTP packets sent with this packet mode. Discountinuities in the value of this counter can occur upon cold start or reinitialization of the NTP entity, the management system and at other times as indicated by discontinuities in the value of sysUpTime.

ntpEntStatPktReceived

1.3.6.1.2.1.197.1.2.17.1.3

Counter32 · packets

The number of NTP packets received with this packet mode. Discountinuities in the value of this counter can occur upon cold start or reinitialization of the NTP entity, the management system and at other times as indicated by discontinuities in the value of sysUpTime.

ntpAssociationTable

1.3.6.1.2.1.197.1.3.1

Index: ntpAssocId

The table of currently mobilized associations.

ntpAssocId

1.3.6.1.2.1.197.1.3.1.1.1

Unsigned32 (1..99999)

The association ID. This is an internal, unique ID.

ntpAssocName

1.3.6.1.2.1.197.1.3.1.1.2

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

The hostname or other descriptive name for the association.

ntpAssocRefId

1.3.6.1.2.1.197.1.3.1.1.3

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The refclock driver ID, if available.

ntpAssocAddressType

1.3.6.1.2.1.197.1.3.1.1.4

InetAddressType1 = ipv42 = ipv63 = ipv4z4 = ipv6zA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The type of address of the association. Can be either IPv4 or IPv6 (both with or without zone index) and contains the type of address for unicast, multicast, and broadcast associations.

ntpAssocAddress

1.3.6.1.2.1.197.1.3.1.1.5

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 8 | 16 | 20) · OCTET STRING

The IP address (IPv4 or IPv6, with or without zone index) of the association. The type and size depends on the ntpAssocAddressType object. Represents the IP address of a uni/multi/broadcast association.

ntpAssocOffset

1.3.6.1.2.1.197.1.3.1.1.6

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The time offset to the association as a string.

ntpAssocStratum

1.3.6.1.2.1.197.1.3.1.1.7

NtpStratumThe NTP stratum, with 16 representing no stratum. (1..16) · Unsigned32 · hint d

The association stratum value.

ntpAssocStatusJitter

1.3.6.1.2.1.197.1.3.1.1.8

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The jitter in milliseconds as a string.

ntpAssocStatusDelay

1.3.6.1.2.1.197.1.3.1.1.9

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The network delay in milliseconds as a string.

ntpAssocStatusDispersion

1.3.6.1.2.1.197.1.3.1.1.10

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The root dispersion of the association.

ntpAssociationStatisticsTable

1.3.6.1.2.1.197.1.3.2

Index: ntpAssocId

The table of statistics for current associations.

ntpAssocStatInPkts

1.3.6.1.2.1.197.1.3.2.1.1

Counter32 · packets

The total number of NTP messages delivered to the NTP entity from this association. Discountinuities in the value of this counter can occur upon cold start or reinitialization of the NTP entity, the management system and at other times as indicated by discontinuities in the value of sysUpTime.

ntpAssocStatOutPkts

1.3.6.1.2.1.197.1.3.2.1.2

Counter32 · packets

The total number of NTP messages delivered to the transport service by this NTP entity for this association. Discountinuities in the value of this counter can occur upon cold start or reinitialization of the NTP entity, the management system and at other times as indicated by discontinuities in the value of sysUpTime.

ntpAssocStatProtocolError

1.3.6.1.2.1.197.1.3.2.1.3

Counter32 · packets

The total number of NTP messages that were delivered to this NTP entity from this association and this entity was not able to process due to an NTP protocol error. Discountinuities in the value of this counter can occur upon cold start or reinitialization of the NTP entity, the management system and at other times as indicated by discontinuities in the value of sysUpTime.

Trap details

ntpEntNotifModeChange

1.3.6.1.2.1.197.0.1

The notification to be sent when the NTP entity changes mode, including starting and stopping (if possible).

ntpEntStatusCurrentMode

1.3.6.1.2.1.197.1.2.1

INTEGER1 = notRunning2 = notSynchronized3 = noneConfigured4 = syncToLocal5 = syncToRefclock6 = syncToRemoteServer99 = unknown · Integer32

The current mode of the NTP. The definition of each possible value is: notRunning(1) - NTP is not running. notSynchronized(2) - NTP is not synchronized to any time source (stratum = 16). noneConfigured(3) - NTP is not synchronized and does not have a reference configured (stratum = 16). syncToLocal(4) - NTP is distributing time based on its local clock (degraded accuracy and/or reliability). syncToRefclock(5) - NTP is synchronized to a local hardware refclock (e.g., GPS). syncToRemoteServer(6) - NTP is synchronized to a remote NTP server ('upstream' server). unknown(99) - The state of NTP is unknown.

ntpEntNotifStratumChange

1.3.6.1.2.1.197.0.2

The notification to be sent when stratum level of NTP changes.

ntpEntStatusDateTime

1.3.6.1.2.1.197.1.2.9

NtpDateTimeNTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This trusted certificate (TC) is not to be used for objects that are used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.Reference: RFC 5905, section 6 SIZE (0 | 16) · OCTET STRING · hint 4d:4d:4d.4d

The current NTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This object can be used to timestamp events on this node and allow a management station to correlate different time objects. For example, a management station could query this object and sysUpTime in the same operation to be able to relate sysUpTime to NTP time. This object is not to be used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.

ntpEntStatusStratum

1.3.6.1.2.1.197.1.2.2

NtpStratumThe NTP stratum, with 16 representing no stratum. (1..16) · Unsigned32 · hint d

The NTP entity's own stratum value. Should be a stratum of syspeer + 1 (or 16 if no syspeer).

ntpEntNotifMessage

1.3.6.1.2.1.197.1.5.1

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

Used as a payload object for all notifications. Holds a cleartext event message.

ntpEntNotifSyspeerChanged

1.3.6.1.2.1.197.0.3

The notification to be sent when a (new) syspeer has been selected.

ntpEntStatusDateTime

1.3.6.1.2.1.197.1.2.9

NtpDateTimeNTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This trusted certificate (TC) is not to be used for objects that are used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.Reference: RFC 5905, section 6 SIZE (0 | 16) · OCTET STRING · hint 4d:4d:4d.4d

The current NTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This object can be used to timestamp events on this node and allow a management station to correlate different time objects. For example, a management station could query this object and sysUpTime in the same operation to be able to relate sysUpTime to NTP time. This object is not to be used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.

ntpEntStatusActiveRefSourceId

1.3.6.1.2.1.197.1.2.3

Unsigned32 (0..99999)

The association ID of the current syspeer.

ntpEntNotifMessage

1.3.6.1.2.1.197.1.5.1

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

Used as a payload object for all notifications. Holds a cleartext event message.

ntpEntNotifAddAssociation

1.3.6.1.2.1.197.0.4

The notification to be sent when a new association is mobilized.

ntpEntStatusDateTime

1.3.6.1.2.1.197.1.2.9

NtpDateTimeNTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This trusted certificate (TC) is not to be used for objects that are used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.Reference: RFC 5905, section 6 SIZE (0 | 16) · OCTET STRING · hint 4d:4d:4d.4d

The current NTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This object can be used to timestamp events on this node and allow a management station to correlate different time objects. For example, a management station could query this object and sysUpTime in the same operation to be able to relate sysUpTime to NTP time. This object is not to be used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.

ntpAssocName

1.3.6.1.2.1.197.1.3.1.1.2

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

The hostname or other descriptive name for the association.

ntpEntNotifMessage

1.3.6.1.2.1.197.1.5.1

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

Used as a payload object for all notifications. Holds a cleartext event message.

ntpEntNotifRemoveAssociation

1.3.6.1.2.1.197.0.5

The notification to be sent when an association is demobilized.

ntpEntStatusDateTime

1.3.6.1.2.1.197.1.2.9

NtpDateTimeNTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This trusted certificate (TC) is not to be used for objects that are used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.Reference: RFC 5905, section 6 SIZE (0 | 16) · OCTET STRING · hint 4d:4d:4d.4d

The current NTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This object can be used to timestamp events on this node and allow a management station to correlate different time objects. For example, a management station could query this object and sysUpTime in the same operation to be able to relate sysUpTime to NTP time. This object is not to be used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.

ntpAssocName

1.3.6.1.2.1.197.1.3.1.1.2

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

The hostname or other descriptive name for the association.

ntpEntNotifMessage

1.3.6.1.2.1.197.1.5.1

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

Used as a payload object for all notifications. Holds a cleartext event message.

ntpEntNotifConfigChanged

1.3.6.1.2.1.197.0.6

The notification to be sent when the NTP configuration has changed, e.g., when the system connected to the Internet and was assigned a new IP address by the ISPs DHCP server.

ntpEntStatusDateTime

1.3.6.1.2.1.197.1.2.9

NtpDateTimeNTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This trusted certificate (TC) is not to be used for objects that are used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.Reference: RFC 5905, section 6 SIZE (0 | 16) · OCTET STRING · hint 4d:4d:4d.4d

The current NTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This object can be used to timestamp events on this node and allow a management station to correlate different time objects. For example, a management station could query this object and sysUpTime in the same operation to be able to relate sysUpTime to NTP time. This object is not to be used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.

ntpEntNotifMessage

1.3.6.1.2.1.197.1.5.1

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

Used as a payload object for all notifications. Holds a cleartext event message.

ntpEntNotifLeapSecondAnnounced

1.3.6.1.2.1.197.0.7

The notification to be sent when a leap second has been announced.

ntpEntStatusDateTime

1.3.6.1.2.1.197.1.2.9

NtpDateTimeNTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This trusted certificate (TC) is not to be used for objects that are used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.Reference: RFC 5905, section 6 SIZE (0 | 16) · OCTET STRING · hint 4d:4d:4d.4d

The current NTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This object can be used to timestamp events on this node and allow a management station to correlate different time objects. For example, a management station could query this object and sysUpTime in the same operation to be able to relate sysUpTime to NTP time. This object is not to be used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.

ntpEntNotifMessage

1.3.6.1.2.1.197.1.5.1

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

Used as a payload object for all notifications. Holds a cleartext event message.

ntpEntNotifHeartbeat

1.3.6.1.2.1.197.0.8

The notification to be sent periodically (as defined by ntpEntHeartbeatInterval) to indicate that the NTP entity is still alive.

ntpEntStatusDateTime

1.3.6.1.2.1.197.1.2.9

NtpDateTimeNTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This trusted certificate (TC) is not to be used for objects that are used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.Reference: RFC 5905, section 6 SIZE (0 | 16) · OCTET STRING · hint 4d:4d:4d.4d

The current NTP date/time on the device, in 128-bit NTP date format. If time is not syncronized, this field shall be a zero-length string. This object can be used to timestamp events on this node and allow a management station to correlate different time objects. For example, a management station could query this object and sysUpTime in the same operation to be able to relate sysUpTime to NTP time. This object is not to be used to set the time of the node querying this object. NTP should be used for this -- or at least SNTP.

ntpEntStatusCurrentMode

1.3.6.1.2.1.197.1.2.1

INTEGER1 = notRunning2 = notSynchronized3 = noneConfigured4 = syncToLocal5 = syncToRefclock6 = syncToRemoteServer99 = unknown · Integer32

The current mode of the NTP. The definition of each possible value is: notRunning(1) - NTP is not running. notSynchronized(2) - NTP is not synchronized to any time source (stratum = 16). noneConfigured(3) - NTP is not synchronized and does not have a reference configured (stratum = 16). syncToLocal(4) - NTP is distributing time based on its local clock (degraded accuracy and/or reliability). syncToRefclock(5) - NTP is synchronized to a local hardware refclock (e.g., GPS). syncToRemoteServer(6) - NTP is synchronized to a remote NTP server ('upstream' server). unknown(99) - The state of NTP is unknown.

ntpEntHeartbeatInterval

1.3.6.1.2.1.197.1.4.1

Unsigned32 · seconds

The interval at which the ntpEntNotifHeartbeat notification should be sent, in seconds. If set to 0 and the entNotifHeartbeat bit in ntpEntNotifBits is 1, then ntpEntNotifHeartbeat is sent once. This value is stored persistently and will be restored to its last set value upon cold start or restart.

ntpEntNotifMessage

1.3.6.1.2.1.197.1.5.1

Utf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..255) · OCTET STRING · hint 255a

Used as a payload object for all notifications. Holds a cleartext event message.

↑ To TOC