This MIB module specifies the basic management objects for managing events generated by the Multimedia Terminal Adapter devices compliant with the PacketCable and IPCablecom requirements.
Copyright (c) 2009 IETF Trust and the persons identified as authors of the code. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:
- Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
- Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
- Neither the name of Internet Society, IETF or IETF Trust, nor the names of specific contributors, may be used to endorse or promote products derived from this software without specific prior written permission.
THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 'AS IS' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
This version of this MIB module is part of RFC 5428; see the RFC itself for full legal notices.
This MIB object allows a management station to clear the local log of generated events, reset the management event descriptions, or both.
MTAs generate management events. These events are stored in the MIB table pktcEventLogTable. If a management station needs to clear all the current entries (e.g., after a troubleshooting operation is complete), it can do so by setting the resetEventLogTable(0) bit to a value of '1'.
The MTA is pre-configured with the events that it can generate. This is stored in the MIB table pktcEventTable. This table also contains the descriptions associated with these events. These descriptions can be modified by a management station. However, if the management station wishes to reset the descriptions to factory defaults, it can do so by setting the resetEventTable(1) bit to a value of '1'.
The MTA actions are summarized below:
Bit resetEventLogTable(0) set to a value of '1' - delete all entries in pktcEventLogTable; - reset the value of pktcEventLogIndex to '0'.
Bit resetEventTable(1) set to a value of '1' - reset the pktcEventTable to the factory default values.
Bits resetEventLogTable(0) and resetEventTable(1) set to a value of '1' - perform the above actions as though they were performed individually (in any order).
Setting a reset bit to a value of '0' MUST NOT result in any action.
The MTA MUST perform the above actions regardless of persistence (i.e., storage in non-volatile memory).
The MTA MUST always return a value of '00' when this MIB object is read.
A management station that resets tables using this MIB object needs to be careful about the impact to other management stations that may be reliant on the information contained in the table(s) being reset. For example, say management station A creates a specific set of event descriptions in the event table (pktcEventTable) for debugging purposes and expects any generated events to report the modified descriptions. In such a case, if another management station resets the event table to factory defaults, any subsequent events will not contain the modified descriptions expected by management station A. Such multi-manager contentions are not addressed within this MIB module. Thus, management stations are RECOMMENDED to use this MIB object with care and caution, and only when absolutely required.
pktcEventSyslogCapabilities
1.3.6.1.2.1.182.1.1.2.1
BITS
This MIB object contains the MTA capabilities for supporting the syslog protocol, specifically the message formats and the transport protocols.
The BSD syslog message format is specified in [RFC3164] (formatBSDSyslog), and the IETF syslog protocol is specified in [RFC5424] (formatSyslogProtocol).
The MTA MUST set the appropriate protocol and transport bits, based on implementation. Reference: The BSD syslog Protocol, [RFC3164]; The Syslog Protocol, [RFC5424]; Transmission of Syslog Messages over UDP, [RFC5426]; TLS Transport Mapping for Syslog, [RFC5425]; Reliable Delivery for syslog, [RFC3195].
pktcEventSyslogAddressType
1.3.6.1.2.1.182.1.1.2.2
InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address.
unknown(0) An unknown address type. This value MUST
be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below.
ipv4(1) An IPv4 address as defined by the
InetAddressIPv4 textual convention.
ipv6(2) An IPv6 address as defined by the
InetAddressIPv6 textual convention.
ipv4z(3) A non-global IPv4 address including a zone
index as defined by the InetAddressIPv4z textual convention.
ipv6z(4) A non-global IPv6 address including a zone
index as defined by the InetAddressIPv6z textual convention.
dns(16) A DNS domain name as defined by the
InetAddressDNS textual convention.
Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType.
To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation.
Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32
This MIB object defines the Internet address type of the syslog server specified by the MIB object pktcEventSyslogAddress. A value of dns(16) is disallowed since a non-resolvable DNS domain name will leave the device without a syslog server to which it can report events. Reference: PacketCable MTA Device Provisioning Specification, [PKT-SP-PROV].
pktcEventSyslogAddress
1.3.6.1.2.1.182.1.1.2.3
InetAddressDenotes a generic Internet address.
An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row.
The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error.
When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING
This MIB object contains the IP address of the syslog server to which the MTA can transmit a syslog message upon the generation of a management event. The type of address this object represents is defined by the MIB object pktDevEventSyslogAddressType.
The format of the syslog message is specified by the MIB object pktcEventSyslogMessageFormat. Reference: PacketCable MTA Device Provisioning Specification, [PKT-SP-PROV]; PacketCable Management Event Mechanism Specification, [PKT-SP-MEM1.5];
This MIB object contains the syslog message format to be used for transmitting syslog messages to the server contained in the MIB object pktcEventSyslogServer. Reference: The BSD syslog Protocol, [RFC3164]; The Syslog Protocol, [RFC5424].
pktcEventSyslogTransport
1.3.6.1.2.1.182.1.1.2.5
INTEGER1 = udp2 = tls3 = beep · Integer32
This MIB object specifies the transport to be used to transmit syslog messages to the syslog server contained in the MIB object pktcEventSyslogAddress.
If the MTA does not support the transport specified in a SET operation, then the MTA MUST return an appropriate error response, such as 'inconsistentValue'. Reference: Transmission of Syslog messages over UDP, [RFC5426]; TLS Transport Mapping for Syslog, [RFC5425].
pktcEventSyslogPort
1.3.6.1.2.1.182.1.1.2.6
InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>.
The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d
This MIB object contains the port number of the syslog server to which the syslog messages are to be transmitted. Reference: Transmission of Syslog Messages over UDP, [RFC5426]; TLS Transport Mapping for Syslog, [RFC5425].
This MIB object controls the throttling of the transmitted messages upon generation of an event (SNMP/syslog). It does not affect local logging of events.
A value of unconstrained(1) causes event messages to be transmitted without regard to the threshold settings.
A value of maintainBelowThreshold(2) causes event messages to be suppressed if the number of transmissions would otherwise exceed the threshold specified by pktcEventThrottleThreshold over the interval specified by pktcEventThrottleInterval.
A value of stopAtThreshold(3) causes event message transmission to cease once the threshold specified by pktcEventThrottleThreshold (over the interval specified by pktcEventThrottleInterval) is reached. Event generation is resumed when the value of this MIB object is modified by a management station or when the device resets or reboots.
A value of inhibited(4) causes all event message transmissions to be suppressed.
An event causing both an SNMP and a syslog message is still treated as a single event.
Refer to MIB objects pktcEventThrottleThreshold and pktcEventThrottleInterval for information on throttling.
pktcEventThrottleThreshold
1.3.6.1.2.1.182.1.2.2
Unsigned32 (0..1024)
This MIB object contains the number of events per pktcEventThrottleInterval to be transmitted before throttling.
An event resulting in multiple actions (e.g., SNMP and syslog) is still treated as a single event.
pktcEventThrottleInterval
1.3.6.1.2.1.182.1.2.3
Unsigned32 (0..604800) · seconds
This MIB object contains the interval over which the throttle threshold applies.
pktcEventTransmissionStatus
1.3.6.1.2.1.182.1.3.1
BITS
This MIB object reflects the status of the event transmissions using syslog, SNMP, or both.
If a bit corresponding to a state is set to a value of: '1', it indicates that the state is true '0', it indicates that the state is false
If the MTA is not configured with a syslog server or an SNMP Manager, the corresponding 'throttling' and 'transmit error' bits MUST be set to a value of '0'. For example, if an SNMP Manager is not configured on the MTA, the bit corresponding to validSnmpManagerAbsent(3) is set to a value of '1', and the values of the bits corresponding to snmpThrottled(1) and snmpTransmitError(5) are set to a value of '0'.
'Event throttling' is based on thresholds and the current setting of the MIB object pktcEventThrottleAdminStatus.
'Server/Manager' indicators are based on the availability of valid syslog server/SNMP Managers. Transmit errors are reported when detected. If an MTA cannot detect an error situation, the value of the BIT will be set '0'.
It is to be noted that not all the conditions that are indicated by this MIB object are detectable by all devices, and when detected may not be accurate. It is meant to provide a report of the status as determined by the device during event transmissions.
Table details
pktcEventClassTable
1.3.6.1.2.1.182.1.1.3
Index: pktcEventClassIndex
This MIB table allows for management events that can be generated by an MTA to be classified into categories, or 'event classes'. For example, all the configuration- related events can be associated with an event class titled 'configuration'. Such a classification allows for a management station to affect changes on a common group of events at once. Two operations are specified on an event class: enabling or disabling of all the events in an event class, and selective enabling or disabling based on the severity level.
pktcEventClassIndex
1.3.6.1.2.1.182.1.1.3.1.1
Unsigned32 (1..100)
This MIB object is an index into the event class table. It is a locally meaningful value.
pktcEventClassName
1.3.6.1.2.1.182.1.1.3.1.2
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (1..100) · OCTET STRING · hint 255t
This MIB object contains the name of the event class.
Vendors MAY define different event classes (e.g., DHCP, SNMP, DEBUG) to group together management events of a particular category.
Event class names need to take into consideration the SnmpAdminString definition requirements, such as the use of control code sequence CR LF to represent a newline.
pktcEventClassStatus
1.3.6.1.2.1.182.1.1.3.1.3
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This MIB object indicates if events belonging to the corresponding event class are enabled or disabled, for event reporting.
Setting this object to a value of 'true' enables reporting of all the events in the event class.
When enabled, the means of reporting events is specified by the MIB object pktcEventReporting.
Setting this object to a value of 'false' disables any event reporting, irrespective of the value of the MIB object pktcEventReporting for a specific event.
The default value of this MIB object is vendor- specific. However, the vendor SHOULD enable all event categories defined by PacketCable or IPCablecom by default.
pktcEventClassSeverity
1.3.6.1.2.1.182.1.1.3.1.4
SyslogSeverityMaskThis textual convention represents a bit mask representing the severity of the syslog events that can be generated. It corresponds to the various severity levels associated with syslog messages, as specified in 'The Syslog Protocol', [RFC5424].
emerg (0), - emergency; system is unusable
alert (1), - action must be taken immediately
crit (2), - critical condition
err (3), - error condition
warning (4), - warning condition
notice (5), - normal but significant condition
info (6), - informational message
debug (7) - debug-level messages · BITS
This MIB object defines the severity level of events belonging to a specific event class that are enabled for event reporting.
This MIB object has no effect on the event reporting unless the MIB object pktcEventClassStatus is set to a value of 'true' (enabled), for the corresponding event class.
Setting a bit within the mask to a value of '1' implies that events corresponding to that severity level MUST be reported as defined by the corresponding value of 'pktcEventReporting' for events in the event class.
Setting a bit to a value of '0' implies that events corresponding to that level MUST NOT be reported, irrespective of the corresponding value of 'pktcEventReporting' for events in the event class.
It is recommended that the bits corresponding to emerg(0), alert(1), crit(2), and err(3) be set to a value of '1' to ensure reporting of events requiring immediate attention. Reference: The Syslog Protocol, [RFC5424].
This MIB table contains all possible management events that can be generated by the device. This includes PacketCable- and IPCablecom-defined events and vendor-specific events.
pktcEventOrganization
1.3.6.1.2.1.182.1.4.1.1.1
Unsigned32 (1..4294967295)
This MIB object provides the IANA enterprise number of the organization defining the event. Thus, all PacketCable- or IPCablecom-defined events will contain the PacketCable or IPCablecom IANA enterprise number, and all vendor-specific events will contain the IANA enterprise number of the defining organization. Reference: IANA Private Enterprise Number assignment, [IANA-ENTERPRISE].
pktcEventIdentifier
1.3.6.1.2.1.182.1.4.1.1.2
Unsigned32 (1..4294967295)
This MIB object contains the event identifier for the corresponding event. Reference: PacketCable Management Event Mechanism Specification, [PKT-SP-MEM1.5]; PacketCable MTA Device Provisioning Specification, [PKT-SP-PROV].
pktcEventFacility
1.3.6.1.2.1.182.1.4.1.1.3
SyslogFacility0 = kern1 = user2 = mail3 = daemon4 = auth5 = syslog6 = lpr7 = news8 = uucp9 = cron10 = authpriv11 = ftp12 = ntp13 = audit14 = console15 = cron216 = local017 = local118 = local219 = local320 = local421 = local522 = local623 = local7This textual convention enumerates the Facilities that originate syslog messages.
The Facilities of syslog messages are numerically coded with decimal values. For interoperability and backwards- compatibility reasons, this document specifies a normative mapping between a label, which represents a Facility, and the corresponding numeric value. This label could be used in, for example, SNMP Manager user interfaces. The label itself is often semantically meaningless because it is impractical to attempt to enumerate all possible Facilities, and many daemons and processes do not have an explicitly assigned Facility code or label. For example, there is no Facility label corresponding to an HTTP service. An HTTP service implementation might log messages as coming from, for example, 'local7' or 'uucp'. This is typical current practice, and originators, relays, and collectors can be configured to properly handle this situation. For improved accuracy, an application can also include an APP-NAME structured data element.
Note that operating system mechanisms for configuring syslog, such as syslog.conf, have not yet been standardized and might use different sets of Facility labels and/or mapping between Facility labels and Facility codes than the MIB.
In particular, the labels corresponding to Facility codes 4, 10, 13, and 14, and the code corresponding to the Facility label 'cron' are known to vary across different operating systems. To distinguish between the labels corresponding to Facility codes 9 and 15, a label of 'cron2' is assigned to the Facility code 15. This list is not intended to be exhaustive; other differences might exist, and new differences might be introduced in the future.
The mapping specified here MUST be used in a MIB network management interface, even though a particular syslog implementation might use a different mapping in a different network management interface.Reference: The Syslog Protocol (RFC5424): Table 1 · Integer32
This MIB object contains the facility for the event. For PacketCable, IPCablecom, or ETSI events, this MUST be set to a value of local0(16). Reference: The Syslog Protocol, [RFC5424]; Textual Conventions for Syslog Management, [RFC5427].
pktcEventSeverityLevel
1.3.6.1.2.1.182.1.4.1.1.4
SyslogSeverity0 = emerg1 = alert2 = crit3 = err4 = warning5 = notice6 = info7 = debugThis textual convention enumerates the Severity levels of syslog messages.
The Severity levels of syslog messages are numerically coded with decimal values. For interoperability and backwards-compatibility reasons, this document specifies a normative mapping between a label, which represents a Severity level, and the corresponding numeric value. This label could be used in, for example, SNMP Manager user interfaces.
The label itself is often semantically meaningless because it is impractical to attempt to strictly define the criteria for each Severity level, and the criteria that is used by syslog originators is, and has historically been, implementation-dependent.
Note that operating system mechanisms for configuring syslog, such as syslog.conf, have not yet been standardized and might use different sets of Severity labels and/or mapping between Severity labels and Severity codes than the MIB.
For example, the foobar application might log messages as 'crit' based on some subjective criteria. Yet the operator can configure syslog to forward these messages, even though the criteria for 'crit' may differ from one originator to another. This is typical current practice, and originators, relays, and collectors can be configured to properly handle this situation.Reference: The Syslog Protocol (RFC5424): Table 2 · Integer32
This MIB object contains the severity level that is applicable to the specified event. Reference: The Syslog Protocol, [RFC5424]; Textual Conventions for Syslog Management, [RFC5427].
pktcEventReporting
1.3.6.1.2.1.182.1.4.1.1.5
BITS
This MIB object defines the action to be taken on occurrence of this event. Bit local(0) refers to local logging of events; bit sylog(1) refers to the transmission of events using syslog; bit snmpTrap(2) refers to the transmission of events using SNMP Traps (SNMPv2-Trap-PDU); and bit snmpInform(3) refers to the transmission of events using SNMP INFORMs.
Setting a bit to a value of '1' indicates that the corresponding action will be taken upon occurrence of this event. If none of the bits are set, then no action is taken upon occurrence of the event. The success of transmission using syslog and SNMP depends on the MTA configuration. For example, a valid syslog server address is required for syslog message transmission.
Specification of a management event does not necessarily include the actions to be taken upon its generation, i.e., it does not need to specify if a generated event needs to be transmitted via SNMP or syslog, or stored locally. Thus, certain default values are specified, based on the event's severity level specified by the MIB object pktcEventSeverityLevel, as follows: - If the severity level of an event is emerg(0), alert(1), crit(2), or err(3), set the bits for local(0), syslog(1), and snmpInform(3) to a value of '1' and set the remaining bits to a value of '0'. - For an event with any other severity level, set the bits for local(0) and syslog(1) to a value of '1' and set the rest of the bits to a value of '0'.
pktcEventText
1.3.6.1.2.1.182.1.4.1.1.6
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..127) · OCTET STRING · hint 255t
This MIB object provides a human-readable description of the event. Descriptions need to take into consideration the SnmpAdminString definition requirements such as the use of control code sequence CR LF to represent a newline.
pktcEventClass
1.3.6.1.2.1.182.1.4.1.1.7
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..100) · OCTET STRING · hint 255t
This MIB object represents the event class that affects the event. If an event is associated with only one event class, then its name (pktcEventClassName) is reported. If an event is associated with more than one event class, then the name of the event class with the lowest index in the event class table (pktcEventClassTable) is reported.
See the MIB table pktcEventClassTable for a description of event classes and usage.
Descriptions need to take into consideration the SnmpAdminString definition requirements, such as the use of control code sequence CR LF to represent a newline.
pktcEventLogTable
1.3.6.1.2.1.182.1.5.1
Index: pktcEventLogIndex
This MIB table contains a log of the events generated by the MTA.
A description of all the events that can be generated by the device can be obtained from the MIB table pktcEventTable.
An MTA is not required to persist the contents of this table across resets.
pktcEventLogIndex
1.3.6.1.2.1.182.1.5.1.1.1
Unsigned32 (1..4294967295)
This MIB object provides relative ordering of the objects in the event log.
If the MTA implements non-volatile storage, then this object will always increase except when the MIB object reaches a value of 2^32-1.
If the MTA does not implement non-volatile storage, then this object will always increase except when the MIB object reaches a value of 2^32-1 or the MTA is reset.
When the value reaches 2^32-1, or an MTA that does not implement non-volatile storage is reset, newer events will be stored starting with an index value of '1' (cyclic rotation).
pktcEventLogTime
1.3.6.1.2.1.182.1.5.1.1.2
DateAndTimeA date-time specification.
field octets contents range
----- ------ -------- -----
1 1-2 year* 0..65536
2 3 month 1..12
3 4 day 1..31
4 5 hour 0..23
5 6 minutes 0..59
6 7 seconds 0..60
(use 60 for leap-second)
7 8 deci-seconds 0..9
8 9 direction from UTC '+' / '-'
9 10 hours from UTC* 0..13
10 11 minutes from UTC 0..59
* Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13
For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as:
1992-5-26,13:30:15.0,-4:0
Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
This MIB object provides a human-readable description of the date and time at which the event occurred. The value of the date and time contained in this MIB object SHOULD reflect the date and time used in the syslog message resulting from the associated event, if such a syslog message was transmitted.
pktcEventLogOrganization
1.3.6.1.2.1.182.1.5.1.1.3
Unsigned32 (1..4294967295)
This MIB object provides the IANA enterprise number of the organization defining the event. Thus, all PacketCable- or IPCablecom-defined events will contain the CableLabs or IPCablecom IANA enterprise number, and all vendor-specific events will contain the IANA enterprise number of the defining organization.
pktcEventLogIdentifier
1.3.6.1.2.1.182.1.5.1.1.4
Unsigned32
This MIB object contains the event identifier for the corresponding event.
pktcEventLogText
1.3.6.1.2.1.182.1.5.1.1.5
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..127) · OCTET STRING · hint 255t
This MIB object contains the contents of the MIB object pktcEventText, corresponding to the event, at the moment of generation.
pktcEventLogEndpointName
1.3.6.1.2.1.182.1.5.1.1.6
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This MIB object contains the unique identifier of the MTA endpoint that generated the corresponding event. If the generated event was not associated with any specific endpoint on the MTA, then this MIB object contains the MTA identifier.
An MTA endpoint can be uniquely identified using a combination of the MTA identifier and the endpoint number. The MTA is identified via its Fully-Qualified Domain Name (FQDN) and the associated IP address at the given point in time.
The format of the value contained by this MIB object is as follows:
aaln/n:<FQDN>/<IP>, when it identifies an endpoint, 'n' being the endpoint number; or, <FQDN>/<IP>, when it identifies an MTA.
The value contained by this MIB object needs to observe the SnmpAdminString definition requirements.
pktcEventLogType
1.3.6.1.2.1.182.1.5.1.1.7
BITS
This MIB object contains the type of actions taken by the MTA when the event indicated by the MIB object pktcEventLogIdentifier occurred.
A bit with a value of '1' indicates the corresponding action was taken. Setting it to a value of '0' indicates that the corresponding action was not taken.
An event may trigger one or more actions (e.g., syslog and SNMP) or result only in a local log. An action may also be prevented due to throttling, in which case it is not reported by this MIB object.
pktcEventLogTargetInfo
1.3.6.1.2.1.182.1.5.1.1.8
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This MIB object contains a comma-separated list of the actions taken for external notifications, along with the target IP address for the generated events. Locally stored events MUST NOT be recorded in this MIB object.
The syntax is as: <action-1/IP>,<action-2/IP>,<action-3/IP>
Where <action-n/IP> is to be denoted as follows: For syslog events: syslog/<IP address of the syslog server> For SNMP traps: snmpTrap/<IP address of the SNMP server> For SNMP INFORMS: snmpInform/<IP address of the SNMP server>
If there are multiple targets for the same type (SNMP traps sent to multiple IP addresses) or if there are multiple message types sent to the same IP (syslog and SNMP sent to the same IP address), they need to be reported individually. It is to be noted that this MIB object may not be able to store all the data in some cases (e.g., multiple IPv6 addresses), in which case some actions may not be reported. In such cases, the MTA MUST present a value of '...' at the end of the value.
Values contained by this MIB object need to observe the SnmpAdminString definition requirements.
pktcEventLogCorrelationId
1.3.6.1.2.1.182.1.5.1.1.9
Unsigned32
This MIB object contains the correlation ID generated by the MTA during the initiation of the last provisioning flow, within or following which the event occurred.
Although a correlation ID once generated after MTA reset does not change until next MTA reset, the value of this object will differ for the events preserved across MTA resets in case of a persistent pktcEventLogTable.
For more information on the generation of correlation IDs, refer to the corresponding PacketCable/IPCablecom Device Provisioning specifications. Reference: PacketCable MTA Device Provisioning Specification, [PKT-SP-PROV].
pktcEventLogAdditionalInfo
1.3.6.1.2.1.182.1.5.1.1.10
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This MIB object contains additional information in relation to the corresponding event that an MTA might wish to report, such as parameterized data or debugging information. The format is vendor-specific.
If the MTA cannot provide any additional information for the particular event generated, it MUST populate this MIB object with a zero-length OCTET-STRING. Vendors providing this information need to observe the SnmpAdminString definition requirements, such as the use of control code sequence CR LF for newline.
Trap details
pktcEventNotification
1.3.6.1.2.1.182.0.1
This Notification MIB object contains the contents for event reporting.
It contains the event log time, the organization ID, the event identifier, the endpoint identifier, the correlation ID, and the MTA's MAC address.
pktcEventLogTime
1.3.6.1.2.1.182.1.5.1.1.2
DateAndTimeA date-time specification.
field octets contents range
----- ------ -------- -----
1 1-2 year* 0..65536
2 3 month 1..12
3 4 day 1..31
4 5 hour 0..23
5 6 minutes 0..59
6 7 seconds 0..60
(use 60 for leap-second)
7 8 deci-seconds 0..9
8 9 direction from UTC '+' / '-'
9 10 hours from UTC* 0..13
10 11 minutes from UTC 0..59
* Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13
For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as:
1992-5-26,13:30:15.0,-4:0
Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
This MIB object provides a human-readable description of the date and time at which the event occurred. The value of the date and time contained in this MIB object SHOULD reflect the date and time used in the syslog message resulting from the associated event, if such a syslog message was transmitted.
pktcEventLogOrganization
1.3.6.1.2.1.182.1.5.1.1.3
Unsigned32 (1..4294967295)
This MIB object provides the IANA enterprise number of the organization defining the event. Thus, all PacketCable- or IPCablecom-defined events will contain the CableLabs or IPCablecom IANA enterprise number, and all vendor-specific events will contain the IANA enterprise number of the defining organization.
pktcEventLogIdentifier
1.3.6.1.2.1.182.1.5.1.1.4
Unsigned32
This MIB object contains the event identifier for the corresponding event.
pktcEventLogEndpointName
1.3.6.1.2.1.182.1.5.1.1.6
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
This MIB object contains the unique identifier of the MTA endpoint that generated the corresponding event. If the generated event was not associated with any specific endpoint on the MTA, then this MIB object contains the MTA identifier.
An MTA endpoint can be uniquely identified using a combination of the MTA identifier and the endpoint number. The MTA is identified via its Fully-Qualified Domain Name (FQDN) and the associated IP address at the given point in time.
The format of the value contained by this MIB object is as follows:
aaln/n:<FQDN>/<IP>, when it identifies an endpoint, 'n' being the endpoint number; or, <FQDN>/<IP>, when it identifies an MTA.
The value contained by this MIB object needs to observe the SnmpAdminString definition requirements.
pktcEventLogCorrelationId
1.3.6.1.2.1.182.1.5.1.1.9
Unsigned32
This MIB object contains the correlation ID generated by the MTA during the initiation of the last provisioning flow, within or following which the event occurred.
Although a correlation ID once generated after MTA reset does not change until next MTA reset, the value of this object will differ for the events preserved across MTA resets in case of a persistent pktcEventLogTable.
For more information on the generation of correlation IDs, refer to the corresponding PacketCable/IPCablecom Device Provisioning specifications. Reference: PacketCable MTA Device Provisioning Specification, [PKT-SP-PROV].
ifPhysAddress
1.3.6.1.2.1.2.2.1.6
PhysAddressRepresents media- or physical-level addresses. · OCTET STRING · hint 1x:
The interface's address at its protocol sub-layer. For example, for an 802.x interface, this object normally contains a MAC address. The interface's media-specific MIB must define the bit and byte ordering and the format of the value of this object. For interfaces which do not have such an address (e.g., a serial line), this object should contain an octet string of zero length.