The PSAMP MIB defines managed objects for packet sampling and filtering.
These objects provide information about managed nodes supporting packet sampling, including packet sampling capabilities, configuration, and statistics. The PSAMP MIB module registers additional top-level OIDs for the parameter subtrees of its Selector functions in the IPFIX-SELECTOR-MIB Function sub-registry according to the procedures defined in RFC 6615.
Copyright (c) 2012 IETF Trust and the persons identified as authors of the code. All rights reserved.
Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).
This version of this MIB module is part of RFC 6727; see the RFC itself for full legal notices.
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates the availability of systematic count-based sampling at the managed node.
A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar.
psampSampTimeBasedAvail
1.3.6.1.2.1.194.1.1.3.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates the availability of systematic time-based sampling at the managed node.
A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar.
psampSampRandOutOfNAvail
1.3.6.1.2.1.194.1.1.4.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates the availability of random n-out-of-N sampling at the managed node.
A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar.
psampSampUniProbAvail
1.3.6.1.2.1.194.1.1.5.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates the availability of random uniform probabilistic sampling at the managed node. A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar.
psampFiltPropMatchAvail
1.3.6.1.2.1.194.1.1.6.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates the availability of property match filtering at the managed node.
A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar.
psampFiltHashAvail
1.3.6.1.2.1.194.1.1.7.1
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object indicates the availability of hash filtering at the managed node.
A Selector may be unavailable if it is implemented but currently disabled due to, e.g., administrative reasons, lack of resources, or similar.
Table details
psampSampCountBasedParamSetTable
1.3.6.1.2.1.194.1.1.2.2
Index: psampSampCountBasedIndex
This table lists configurations of systematic count-based packet sampling. A parameter set describing a configuration contains two parameters: the sampling interval length and space.
psampSampCountBasedIndex
1.3.6.1.2.1.194.1.1.2.2.1.1
Integer32 (1..2147483647)
The index of this parameter set in the psampSampCountBasedParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelectionProcessTable in the IPFIX-MIB as reference to this parameter set.
psampSampCountBasedInterval
1.3.6.1.2.1.194.1.1.2.2.1.2
Unsigned32 · packets
This object specifies the number of packets that are consecutively sampled. A value of 100 means that 100 consecutive packets are sampled. Reference: RFC 5475 (Section 5.1) and RFC 5477 (Section 8.2)
psampSampCountBasedSpace
1.3.6.1.2.1.194.1.1.2.2.1.3
Unsigned32 · packets
This object specifies the number of packets between two intervals specified by the object psampSampCountBasedInterval. A value of 100 means that the next interval starts 100 packets (which are not sampled) after the current psampSampCountBasedInterval is over. Reference: RFC 5475 (Section 5.1) and RFC 5477 (Section 8.2)
psampSampTimeBasedParamSetTable
1.3.6.1.2.1.194.1.1.3.2
Index: psampSampTimeBasedIndex
This table lists configurations of systematic time-based packet sampling. A parameter set describing a configuration contains two parameters: the sampling interval length and the space.
psampSampTimeBasedIndex
1.3.6.1.2.1.194.1.1.3.2.1.1
Integer32 (1..2147483647)
The index of this parameter set in the psampSampTimeBasedParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelectionProcessTable in the IPFIX-MIB as reference to this parameter set.
psampSampTimeBasedInterval
1.3.6.1.2.1.194.1.1.3.2.1.2
Unsigned32 · microseconds
This object specifies the time interval in microseconds during which all arriving packets are sampled. Reference: RFC 5475 (Section 5.1) and RFC 5477 (Section 8.2)
psampSampTimeBasedSpace
1.3.6.1.2.1.194.1.1.3.2.1.3
Unsigned32 · microseconds
This object specifies the time interval in microseconds between two intervals specified by the object psampSampTimeBasedInterval. A value of 100 means that the next interval starts 100 microseconds (during which no packets are sampled) after the current psampSampTimeBasedInterval is over. Reference: RFC 5475 (Section 5.1) and RFC 5477 (Section 8.2)
psampSampRandOutOfNParamSetTable
1.3.6.1.2.1.194.1.1.4.2
Index: psampSampRandOutOfNIndex
This table lists configurations of random n-out-of-N sampling. A parameter set describing a configuration contains two parameters: the sampling size and the parent population.
psampSampRandOutOfNIndex
1.3.6.1.2.1.194.1.1.4.2.1.1
Integer32 (1..2147483647)
The index of this parameter set in the psampSampRandOutOfNParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelectionProcessTable in the IPFIX-MIB as reference to this parameter set.
psampSampRandOutOfNSize
1.3.6.1.2.1.194.1.1.4.2.1.2
Unsigned32 · packets
This object specifies the number of elements taken from the parent Population specified in psampSampRandOutOfNPopulation. Reference: RFC 5475 (Section 5.2.1) and RFC 5477 (Section 8.2)
psampSampRandOutOfNPopulation
1.3.6.1.2.1.194.1.1.4.2.1.3
Unsigned32 · packets
This object specifies the number of elements in the parent Population. Reference: RFC 5475 (Section 5.2.1) and RFC 5477 (Section 8.2)
psampSampUniProbParamSetTable
1.3.6.1.2.1.194.1.1.5.2
Index: psampSampUniProbIndex
This table lists configurations of random probabilistic sampling. A parameter set describing a configuration contains a single parameter only: the sampling probability.
psampSampUniProbIndex
1.3.6.1.2.1.194.1.1.5.2.1.1
Integer32 (1..2147483647)
The index of this parameter set in the psampSampUniProbParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelectionProcessTable in the IPFIX-MIB as reference to this parameter set.
psampSampUniProbProbability
1.3.6.1.2.1.194.1.1.5.2.1.2
Float64TCThis type represents a 64-bit (8-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (8) · OCTET STRING
This object specifies the probability that a packet is sampled, expressed as a value between 0 and 1. The probability is equal for every packet. A value of 0 means no packet is sampled since the probability is 0. A value of 1 means all packets are sampled since the probability is 1. NaN (not a number) and infinity MUST NOT be used. Reference: RFC 5475 (Section 5.2.2.1) and RFC 5477 (Section 8.2)
psampFiltHashParamSetTable
1.3.6.1.2.1.194.1.1.7.3
Index: psampFiltHashIndex
This table lists configurations of hash filtering. A parameter set describing a configuration contains eight parameters describing the hash function.
psampFiltHashIndex
1.3.6.1.2.1.194.1.1.7.3.1.1
Integer32 (1..2147483647)
The index of this parameter set in the psampFiltHashParamSetTable. It is used in the object ipfixSelectionProcessSelectorFunction entries of the ipfixSelectionProcessTable in the IPFIX-MIB as reference to this parameter set.
psampFiltHashFunction
1.3.6.1.2.1.194.1.1.7.3.1.2
INTEGER1 = crc322 = ipsx3 = bob · Integer32
The hash function used by this filter. The PSAMP-MIB defines the following hash functions:
crc32(1): The CRC-32 Hash Function as defined in RFC 1141.
ipsx(2): The IPSX Hash Function as described in RFC 5475, Appendix A.1.
bob(3): The BOB Hash Function as described in RFC 5475, Appendix A.2. Reference: RFC 5475 (Section 6.2 and Appendixes A.1 and A.2) and RFC 1141
psampFiltHashInitializerValue
1.3.6.1.2.1.194.1.1.7.3.1.3
Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64
This object specifies the initializer value to the hash function. Reference: RFC 5475, Sections 6.2, 3.8, and 7.1
psampFiltHashIpPayloadOffset
1.3.6.1.2.1.194.1.1.7.3.1.4
Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64
This object specifies the IP payload offset used by a Hash-based Selection Selector. Reference: RFC 5475, Sections 6.2, 3.8, and 7.1
psampFiltHashIpPayloadSize
1.3.6.1.2.1.194.1.1.7.3.1.5
Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64
This object specifies the IP payload size used by a Hash-based Selection Selector. Reference: RFC 5475, Sections 6.2, 3.8, and 7.1
psampFiltHashSelectedRangeMin
1.3.6.1.2.1.194.1.1.7.3.1.6
Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64
This object specifies the value for the beginning of a hash function's selected range. Reference: RFC 5475, Sections 6.2, 3.8, and 7.1
psampFiltHashSelectedRangeMax
1.3.6.1.2.1.194.1.1.7.3.1.7
Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64
This object specifies the value for the end of a hash function's selected range. Reference: RFC 5475, Sections 6.2, 3.8, and 7.1
psampFiltHashOutputRangeMin
1.3.6.1.2.1.194.1.1.7.3.1.8
Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64
This object specifies the value for the beginning of a hash function's potential output range. Reference: RFC 5475, Sections 6.2, 3.8, and 7.1
psampFiltHashOutputRangeMax
1.3.6.1.2.1.194.1.1.7.3.1.9
Unsigned64TCA non-negative 64-bit bit integer, without counter semantics. (0..18446744073709551615) · Counter64
This object specifies the value for the end of a hash function's potential output range. Reference: RFC 5475, Sections 6.2, 3.8, and 7.1