EZ5 MIB Catalog

RADIUS-ACC-SERVER-MIB

2006-08-21

Download RADIUS-ACC-SERVER-MIB.txt Open RADIUS-ACC-SERVER-MIB.txt in a new tab

The MIB module for entities implementing the server side of the Remote Authentication Dial-In User Service (RADIUS) accounting protocol. Copyright (C) The Internet Society (2006). This version of this MIB module is part of RFC 4671; see the RFC itself for full legal notices.

SCALARS (13) · TABLES (2)

Scalars (13)

NameOID
radiusAccServIdent1.3.6.1.2.1.67.2.1.1.1.1
radiusAccServUpTime1.3.6.1.2.1.67.2.1.1.1.2
radiusAccServResetTime1.3.6.1.2.1.67.2.1.1.1.3
radiusAccServConfigReset1.3.6.1.2.1.67.2.1.1.1.4
radiusAccServTotalRequests1.3.6.1.2.1.67.2.1.1.1.5
radiusAccServTotalInvalidRequests1.3.6.1.2.1.67.2.1.1.1.6
radiusAccServTotalDupRequests1.3.6.1.2.1.67.2.1.1.1.7
radiusAccServTotalResponses1.3.6.1.2.1.67.2.1.1.1.8
radiusAccServTotalMalformedRequests1.3.6.1.2.1.67.2.1.1.1.9
radiusAccServTotalBadAuthenticators1.3.6.1.2.1.67.2.1.1.1.10
radiusAccServTotalPacketsDropped1.3.6.1.2.1.67.2.1.1.1.11
radiusAccServTotalNoRecords1.3.6.1.2.1.67.2.1.1.1.12
radiusAccServTotalUnknownTypes1.3.6.1.2.1.67.2.1.1.1.13

Tables (2)

NameOID
radiusAccClientTable1.3.6.1.2.1.67.2.1.1.1.14
radiusAccClientExtTable1.3.6.1.2.1.67.2.1.1.1.15

END OF TOC

Scalar details

radiusAccServIdent

1.3.6.1.2.1.67.2.1.1.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The implementation identification string for the RADIUS accounting server software in use on the system, for example, 'FNS-2.1'.

radiusAccServUpTime

1.3.6.1.2.1.67.2.1.1.1.2

TimeTicks

If the server has a persistent state (e.g., a process), this value will be the time elapsed (in hundredths of a second) since the server process was started. For software without persistent state, this value will be zero.

radiusAccServResetTime

1.3.6.1.2.1.67.2.1.1.1.3

TimeTicks

If the server has a persistent state (e.g., a process) and supports a 'reset' operation (e.g., can be told to re-read configuration files), this value will be the time elapsed (in hundredths of a second) since the server was 'reset.' For software that does not have persistence or does not support a 'reset' operation, this value will be zero.

radiusAccServConfigReset

1.3.6.1.2.1.67.2.1.1.1.4

INTEGER1 = other2 = reset3 = initializing4 = running · Integer32

Status/action object to reinitialize any persistent server state. When set to reset(2), any persistent server state (such as a process) is reinitialized as if the server had just been started. This value will never be returned by a read operation. When read, one of the following values will be returned: other(1) - server in some unknown state; initializing(3) - server (re)initializing; running(4) - server currently running.

radiusAccServTotalRequests

1.3.6.1.2.1.67.2.1.1.1.5

Counter32 · packets

The number of packets received on the accounting port.

radiusAccServTotalInvalidRequests

1.3.6.1.2.1.67.2.1.1.1.6

Counter32 · packets

The number of RADIUS Accounting-Request packets received from unknown addresses.

radiusAccServTotalDupRequests

1.3.6.1.2.1.67.2.1.1.1.7

Counter32 · packets

The number of duplicate RADIUS Accounting-Request packets received.

radiusAccServTotalResponses

1.3.6.1.2.1.67.2.1.1.1.8

Counter32 · packets

The number of RADIUS Accounting-Response packets sent.

radiusAccServTotalMalformedRequests

1.3.6.1.2.1.67.2.1.1.1.9

Counter32 · packets

The number of malformed RADIUS Accounting-Request packets received. Bad authenticators or unknown types are not included as malformed Access-Requests.

radiusAccServTotalBadAuthenticators

1.3.6.1.2.1.67.2.1.1.1.10

Counter32 · packets

The number of RADIUS Accounting-Request packets that contained an invalid authenticator.

radiusAccServTotalPacketsDropped

1.3.6.1.2.1.67.2.1.1.1.11

Counter32 · packets

The number of incoming packets silently discarded for a reason other than malformed, bad authenticators, or unknown types.

radiusAccServTotalNoRecords

1.3.6.1.2.1.67.2.1.1.1.12

Counter32 · packets

The number of RADIUS Accounting-Request packets that were received and responded to but not recorded.

radiusAccServTotalUnknownTypes

1.3.6.1.2.1.67.2.1.1.1.13

Counter32 · packets

The number of RADIUS packets of unknown type that were received.

Table details

radiusAccClientTable

1.3.6.1.2.1.67.2.1.1.1.14

Index: radiusAccClientIndex

The (conceptual) table listing the RADIUS accounting clients with which the server shares a secret.

radiusAccClientIndex

1.3.6.1.2.1.67.2.1.1.1.14.1.1

Integer32 (1..2147483647)

A number uniquely identifying each RADIUS accounting client with which this server communicates.

radiusAccClientAddress

1.3.6.1.2.1.67.2.1.1.1.14.1.2

IpAddress SIZE (4)

The NAS-IP-Address of the RADIUS accounting client referred to in this table entry.

radiusAccClientID

1.3.6.1.2.1.67.2.1.1.1.14.1.3

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The NAS-Identifier of the RADIUS accounting client referred to in this table entry. This is not necessarily the same as sysName in MIB II.

radiusAccServPacketsDropped

1.3.6.1.2.1.67.2.1.1.1.14.1.4

Counter32 · packets

The number of incoming packets received from this client and silently discarded for a reason other than malformed, bad authenticators, or unknown types.

radiusAccServRequests

1.3.6.1.2.1.67.2.1.1.1.14.1.5

Counter32 · packets

The number of packets received from this client on the accounting port.

radiusAccServDupRequests

1.3.6.1.2.1.67.2.1.1.1.14.1.6

Counter32 · packets

The number of duplicate RADIUS Accounting-Request packets received from this client.

radiusAccServResponses

1.3.6.1.2.1.67.2.1.1.1.14.1.7

Counter32 · packets

The number of RADIUS Accounting-Response packets sent to this client.

radiusAccServBadAuthenticators

1.3.6.1.2.1.67.2.1.1.1.14.1.8

Counter32 · packets

The number of RADIUS Accounting-Request packets that contained invalid authenticators received from this client.

radiusAccServMalformedRequests

1.3.6.1.2.1.67.2.1.1.1.14.1.9

Counter32 · packets

The number of malformed RADIUS Accounting-Request packets that were received from this client. Bad authenticators and unknown types are not included as malformed Accounting-Requests.

radiusAccServNoRecords

1.3.6.1.2.1.67.2.1.1.1.14.1.10

Counter32 · packets

The number of RADIUS Accounting-Request packets that were received and responded to but not recorded.

radiusAccServUnknownTypes

1.3.6.1.2.1.67.2.1.1.1.14.1.11

Counter32 · packets

The number of RADIUS packets of unknown type that were received from this client.

radiusAccClientExtTable

1.3.6.1.2.1.67.2.1.1.1.15

Index: radiusAccClientExtIndex

The (conceptual) table listing the RADIUS accounting clients with which the server shares a secret.

radiusAccClientExtIndex

1.3.6.1.2.1.67.2.1.1.1.15.1.1

Integer32 (1..2147483647)

A number uniquely identifying each RADIUS accounting client with which this server communicates.

radiusAccClientInetAddressType

1.3.6.1.2.1.67.2.1.1.1.15.1.2

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The type of address format used for the radiusAccClientInetAddress object.

radiusAccClientInetAddress

1.3.6.1.2.1.67.2.1.1.1.15.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The IP address of the RADIUS accounting client referred to in this table entry, using the IPv6 address format.

radiusAccClientExtID

1.3.6.1.2.1.67.2.1.1.1.15.1.4

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The NAS-Identifier of the RADIUS accounting client referred to in this table entry. This is not necessarily the same as sysName in MIB II.

radiusAccServExtPacketsDropped

1.3.6.1.2.1.67.2.1.1.1.15.1.5

Counter32 · packets

The number of incoming packets received from this client and silently discarded for a reason other than malformed, bad authenticators, or unknown types. This counter may experience a discontinuity when the RADIUS Accounting Server module within the managed entity is reinitialized, as indicated by the current value of radiusAccServerCounterDiscontinuity.

radiusAccServExtRequests

1.3.6.1.2.1.67.2.1.1.1.15.1.6

Counter32 · packets

The number of packets received from this client on the accounting port. This counter may experience a discontinuity when the RADIUS Accounting Server module within the managed entity is reinitialized, as indicated by the current value of radiusAccServerCounterDiscontinuity.

radiusAccServExtDupRequests

1.3.6.1.2.1.67.2.1.1.1.15.1.7

Counter32 · packets

The number of duplicate RADIUS Accounting-Request packets received from this client. This counter may experience a discontinuity when the RADIUS Accounting Server module within the managed entity is reinitialized, as indicated by the current value of radiusAccServerCounterDiscontinuity.

radiusAccServExtResponses

1.3.6.1.2.1.67.2.1.1.1.15.1.8

Counter32 · packets

The number of RADIUS Accounting-Response packets sent to this client. This counter may experience a discontinuity when the RADIUS Accounting Server module within the managed entity is reinitialized, as indicated by the current value of radiusAccServerCounterDiscontinuity.

radiusAccServExtBadAuthenticators

1.3.6.1.2.1.67.2.1.1.1.15.1.9

Counter32 · packets

The number of RADIUS Accounting-Request packets that contained invalid authenticators received from this client. This counter may experience a discontinuity when the RADIUS Accounting Server module within the managed entity is reinitialized, as indicated by the current value of radiusAccServerCounterDiscontinuity.

radiusAccServExtMalformedRequests

1.3.6.1.2.1.67.2.1.1.1.15.1.10

Counter32 · packets

The number of malformed RADIUS Accounting-Request packets that were received from this client. Bad authenticators and unknown types are not included as malformed Accounting-Requests. This counter may experience a discontinuity when the RADIUS Accounting Server module within the managed entity is reinitialized, as indicated by the current value of radiusAccServerCounterDiscontinuity.

radiusAccServExtNoRecords

1.3.6.1.2.1.67.2.1.1.1.15.1.11

Counter32 · packets

The number of RADIUS Accounting-Request packets that were received and responded to but not recorded. This counter may experience a discontinuity when the RADIUS Accounting Server module within the managed entity is reinitialized, as indicated by the current value of radiusAccServerCounterDiscontinuity.

radiusAccServExtUnknownTypes

1.3.6.1.2.1.67.2.1.1.1.15.1.12

Counter32 · packets

The number of RADIUS packets of unknown type that were received from this client. This counter may experience a discontinuity when the RADIUS Accounting Server module within the managed entity is reinitialized, as indicated by the current value of radiusAccServerCounterDiscontinuity.

radiusAccServerCounterDiscontinuity

1.3.6.1.2.1.67.2.1.1.1.15.1.13

TimeTicks · centiseconds

The number of centiseconds since the last discontinuity in the RADIUS Accounting Server counters. A discontinuity may be the result of a reinitialization of the RADIUS Accounting Server module within the managed entity.

↑ To TOC