EZ5 MIB Catalog

RADIUS-DYNAUTH-CLIENT-MIB

2006-08-29

Download RADIUS-DYNAUTH-CLIENT-MIB.txt Open RADIUS-DYNAUTH-CLIENT-MIB.txt in a new tab

The MIB module for entities implementing the client side of the Dynamic Authorization Extensions to the Remote Authentication Dial-In User Service (RADIUS) protocol. Copyright (C) The Internet Society (2006). Initial version as published in RFC 4672; for full legal notices see the RFC itself.

SCALARS (2) · TABLES (1)

Scalars (2)

NameOID
radiusDynAuthClientDisconInvalidServerAddresses1.3.6.1.2.1.145.1.1.1
radiusDynAuthClientCoAInvalidServerAddresses1.3.6.1.2.1.145.1.1.2

Tables (1)

NameOID
radiusDynAuthServerTable1.3.6.1.2.1.145.1.2

END OF TOC

Scalar details

radiusDynAuthClientDisconInvalidServerAddresses

1.3.6.1.2.1.145.1.1.1

Counter32

The number of Disconnect-Ack and Disconnect-NAK packets received from unknown addresses. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCoAInvalidServerAddresses

1.3.6.1.2.1.145.1.1.2

Counter32

The number of CoA-Ack and CoA-NAK packets received from unknown addresses. Disconnect-NAK packets received from unknown addresses. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

Table details

radiusDynAuthServerTable

1.3.6.1.2.1.145.1.2

Index: radiusDynAuthServerIndex

The (conceptual) table listing the RADIUS Dynamic Authorization Servers with which the client shares a secret.

radiusDynAuthServerIndex

1.3.6.1.2.1.145.1.2.1.1

Integer32 (1..2147483647)

A number uniquely identifying each RADIUS Dynamic Authorization Server with which this Dynamic Authorization Client communicates. This number is allocated by the agent implementing this MIB module and is unique in this context.

radiusDynAuthServerAddressType

1.3.6.1.2.1.145.1.2.1.2

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The type of IP address of the RADIUS Dynamic Authorization Server referred to in this table entry.

radiusDynAuthServerAddress

1.3.6.1.2.1.145.1.2.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The IP address value of the RADIUS Dynamic Authorization Server referred to in this table entry using the version neutral IP address format. The type of this address is determined by the value of the radiusDynAuthServerAddressType object.

radiusDynAuthServerClientPortNumber

1.3.6.1.2.1.145.1.2.1.4

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (1..65535) · Unsigned32 · hint d

The UDP destination port that the RADIUS Dynamic Authorization Client is using to send requests to this server. The value zero is invalid.

radiusDynAuthServerID

1.3.6.1.2.1.145.1.2.1.5

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

The NAS-Identifier of the RADIUS Dynamic Authorization Server referred to in this table entry. This is not necessarily the same as sysName in MIB II.

radiusDynAuthClientRoundTripTime

1.3.6.1.2.1.145.1.2.1.6

TimeTicks · hundredths of a second

The time interval (in hundredths of a second) between the most recent Disconnect or CoA request and the receipt of the corresponding Disconnect or CoA reply. A value of zero is returned if no reply has been received yet from this server.

radiusDynAuthClientDisconRequests

1.3.6.1.2.1.145.1.2.1.7

Counter32 · requests

The number of RADIUS Disconnect-Requests sent to this Dynamic Authorization Server. This also includes the RADIUS Disconnect-Requests that have a Service-Type attribute with value 'Authorize Only'. Disconnect-NAK packets received from unknown addresses. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientDisconAuthOnlyRequests

1.3.6.1.2.1.145.1.2.1.8

Counter32 · requests

The number of RADIUS Disconnect-Requests that include a Service-Type attribute with value 'Authorize Only' sent to this Dynamic Authorization Server. Disconnect-NAK packets received from unknown addresses. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientDisconRetransmissions

1.3.6.1.2.1.145.1.2.1.9

Counter32 · retransmissions

The number of RADIUS Disconnect-request packets retransmitted to this RADIUS Dynamic Authorization Server. Disconnect-NAK packets received from unknown addresses. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientDisconAcks

1.3.6.1.2.1.145.1.2.1.10

Counter32 · replies

The number of RADIUS Disconnect-ACK packets received from this Dynamic Authorization Server. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientDisconNaks

1.3.6.1.2.1.145.1.2.1.11

Counter32 · replies

The number of RADIUS Disconnect-NAK packets received from this Dynamic Authorization Server. This includes the RADIUS Disconnect-NAK packets received with a Service-Type attribute with value 'Authorize Only' and the RADIUS Disconnect-NAK packets received if no session context was found. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientDisconNakAuthOnlyRequest

1.3.6.1.2.1.145.1.2.1.12

Counter32 · replies

The number of RADIUS Disconnect-NAK packets that include a Service-Type attribute with value 'Authorize Only' received from this Dynamic Authorization Server. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientDisconNakSessNoContext

1.3.6.1.2.1.145.1.2.1.13

Counter32 · replies

The number of RADIUS Disconnect-NAK packets received from this Dynamic Authorization Server because no session context was found; i.e., it includes an Error-Cause attribute with value 503 ('Session Context Not Found'). This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientMalformedDisconResponses

1.3.6.1.2.1.145.1.2.1.14

Counter32 · replies

The number of malformed RADIUS Disconnect-Ack and Disconnect-NAK packets received from this Dynamic Authorization Server. Bad authenticators and unknown types are not included as malformed Disconnect-Ack and Disconnect-NAK packets. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientDisconBadAuthenticators

1.3.6.1.2.1.145.1.2.1.15

Counter32 · replies

The number of RADIUS Disconnect-Ack and Disconnect-NAK packets that contained invalid Authenticator field received from this Dynamic Authorization Server. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientDisconPendingRequests

1.3.6.1.2.1.145.1.2.1.16

Gauge32 · requests

The number of RADIUS Disconnect-request packets destined for this server that have not yet timed out or received a response. This variable is incremented when an Disconnect-Request is sent and decremented due to receipt of a Disconnect-Ack, a Disconnect-NAK, a timeout, or a retransmission.

radiusDynAuthClientDisconTimeouts

1.3.6.1.2.1.145.1.2.1.17

Counter32 · timeouts

The number of Disconnect request timeouts to this server. After a timeout, the client may retry to the same server or give up. A retry to the same server is counted as a retransmit and as a timeout. A send to a different server is counted as a Disconnect-Request and as a timeout. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientDisconPacketsDropped

1.3.6.1.2.1.145.1.2.1.18

Counter32 · replies

The number of incoming Disconnect-Ack and Disconnect-NAK packets from this Dynamic Authorization Server silently discarded by the client application for some reason other than malformed, bad authenticators, or unknown types. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCoARequests

1.3.6.1.2.1.145.1.2.1.19

Counter32 · requests

The number of RADIUS CoA-Requests sent to this Dynamic Authorization Server. This also includes CoA requests that have a Service-Type attribute with value 'Authorize Only'. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCoAAuthOnlyRequest

1.3.6.1.2.1.145.1.2.1.20

Counter32 · requests

The number of RADIUS CoA-requests that include a Service-Type attribute with value 'Authorize Only' sent to this Dynamic Authorization Client. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCoARetransmissions

1.3.6.1.2.1.145.1.2.1.21

Counter32 · retransmissions

The number of RADIUS CoA-request packets retransmitted to this RADIUS Dynamic Authorization Server. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCoAAcks

1.3.6.1.2.1.145.1.2.1.22

Counter32 · replies

The number of RADIUS CoA-ACK packets received from this Dynamic Authorization Server. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCoANaks

1.3.6.1.2.1.145.1.2.1.23

Counter32 · replies

The number of RADIUS CoA-NAK packets received from this Dynamic Authorization Server. This includes the RADIUS CoA-NAK packets received with a Service-Type attribute with value 'Authorize Only' and the RADIUS CoA-NAK packets received because no session context was found. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCoANakAuthOnlyRequest

1.3.6.1.2.1.145.1.2.1.24

Counter32 · replies

The number of RADIUS CoA-NAK packets that include a Service-Type attribute with value 'Authorize Only' received from this Dynamic Authorization Server. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCoANakSessNoContext

1.3.6.1.2.1.145.1.2.1.25

Counter32 · replies

The number of RADIUS CoA-NAK packets received from this Dynamic Authorization Server because no session context was found; i.e., it includes an Error-Cause attribute with value 503 ('Session Context Not Found'). This counter may experience a discontinuity when the DAC module (re)starts as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientMalformedCoAResponses

1.3.6.1.2.1.145.1.2.1.26

Counter32 · replies

The number of malformed RADIUS CoA-Ack and CoA-NAK packets received from this Dynamic Authorization Server. Bad authenticators and unknown types are not included as malformed CoA-Ack and CoA-NAK packets. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCoABadAuthenticators

1.3.6.1.2.1.145.1.2.1.27

Counter32 · replies

The number of RADIUS CoA-Ack and CoA-NAK packets that contained invalid Authenticator field received from this Dynamic Authorization Server. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCoAPendingRequests

1.3.6.1.2.1.145.1.2.1.28

Gauge32 · requests

The number of RADIUS CoA-request packets destined for this server that have not yet timed out or received a response. This variable is incremented when an CoA-Request is sent and decremented due to receipt of a CoA-Ack, a CoA-NAK, or a timeout, or a retransmission.

radiusDynAuthClientCoATimeouts

1.3.6.1.2.1.145.1.2.1.29

Counter32 · timeouts

The number of CoA request timeouts to this server. After a timeout, the client may retry to the same server or give up. A retry to the same server is counted as a retransmit and as a timeout. A send to a different server is counted as a CoA-Request and as a timeout. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCoAPacketsDropped

1.3.6.1.2.1.145.1.2.1.30

Counter32 · replies

The number of incoming CoA-Ack and CoA-NAK from this Dynamic Authorization Server silently discarded by the client application for some reason other than malformed, bad authenticators, or unknown types. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientUnknownTypes

1.3.6.1.2.1.145.1.2.1.31

Counter32 · replies

The number of incoming packets of unknown types that were received on the Dynamic Authorization port. This counter may experience a discontinuity when the DAC module (re)starts, as indicated by the value of radiusDynAuthClientCounterDiscontinuity.

radiusDynAuthClientCounterDiscontinuity

1.3.6.1.2.1.145.1.2.1.32

TimeTicks · hundredths of a second

The time (in hundredths of a second) since the last counter discontinuity. A discontinuity may be the result of a reinitialization of the DAC module within the managed entity.

↑ To TOC