DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
A textual description of the entity. This value should include the full name and version identification of the system's hardware type, software operating-system, and networking software. It is mandatory that this only contain printable ASCII characters.
sysObjectID
1.3.6.1.2.1.1.2
OBJECT IDENTIFIER
The vendor's authoritative identification of the network management subsystem contained in the entity. This value is allocated within the SMI enterprises subtree (1.3.6.1.4.1) and provides an easy and unambiguous means for determining `what kind of box' is being managed. For example, if vendor `Flintstones, Inc.' was assigned the subtree 1.3.6.1.4.1.4242, it could assign the identifier 1.3.6.1.4.1.4242.1.1 to its `Fred Router'.
sysUpTime
1.3.6.1.2.1.1.3
TimeTicks
The time (in hundredths of a second) since the network management portion of the system was last re-initialized.
sysContact
1.3.6.1.2.1.1.4
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The textual identification of the contact person for this managed node, together with information on how to contact this person.
sysName
1.3.6.1.2.1.1.5
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
An administratively-assigned name for this managed node. By convention, this is the node's fully-qualified domain name.
sysLocation
1.3.6.1.2.1.1.6
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The physical location of this node (e.g., `telephone closet, 3rd floor').
sysServices
1.3.6.1.2.1.1.7
INTEGER (0..127) · Integer32
A value which indicates the set of services that this entity primarily offers.
The value is a sum. This sum initially takes the value zero, Then, for each layer, L, in the range 1 through 7, that this node performs transactions for, 2 raised to (L - 1) is added to the sum. For example, a node which performs primarily routing functions would have a value of 4 (2^(3-1)). In contrast, a node which is a host offering application services would have a value of 72 (2^(4-1) + 2^(7-1)). Note that in the context of the Internet suite of protocols, values should be calculated accordingly:
layer functionality
1 physical (e.g., repeaters)
2 datalink/subnetwork (e.g., bridges)
3 internet (e.g., IP gateways)
4 end-to-end (e.g., IP hosts)
7 applications (e.g., mail relays)
For systems including OSI protocols, layers 5 and 6 may also be counted.
ifNumber
1.3.6.1.2.1.2.1
INTEGER · Integer32
The number of network interfaces (regardless of their current state) present on this system.
The indication of whether this entity is acting as an IP gateway in respect to the forwarding of datagrams received by, but not addressed to, this entity. IP gateways forward datagrams. IP hosts do not (except those source-routed via the host).
Note that for some managed nodes, this object may take on only a subset of the values possible. Accordingly, it is appropriate for an agent to return a `badValue' response if a management station attempts to change this object to an inappropriate value.
ipDefaultTTL
1.3.6.1.2.1.4.2
INTEGER · Integer32
The default value inserted into the Time-To-Live field of the IP header of datagrams originated at this entity, whenever a TTL value is not supplied by the transport layer protocol.
ipInReceives
1.3.6.1.2.1.4.3
Counter · Counter32
The total number of input datagrams received from interfaces, including those received in error.
ipInHdrErrors
1.3.6.1.2.1.4.4
Counter · Counter32
The number of input datagrams discarded due to errors in their IP headers, including bad checksums, version number mismatch, other format errors, time-to-live exceeded, errors discovered in processing their IP options, etc.
ipInAddrErrors
1.3.6.1.2.1.4.5
Counter · Counter32
The number of input datagrams discarded because the IP address in their IP header's destination field was not a valid address to be received at this entity. This count includes invalid addresses (e.g., 0.0.0.0) and addresses of unsupported Classes (e.g., Class E). For entities which are not IP Gateways and therefore do not forward datagrams, this counter includes datagrams discarded because the destination address was not a local address.
ipForwDatagrams
1.3.6.1.2.1.4.6
Counter · Counter32
The number of input datagrams for which this entity was not their final IP destination, as a result of which an attempt was made to find a route to forward them to that final destination. In entities which do not act as IP Gateways, this counter will include only those packets which were Source-Routed via this entity, and the Source- Route option processing was successful.
ipInUnknownProtos
1.3.6.1.2.1.4.7
Counter · Counter32
The number of locally-addressed datagrams received successfully but discarded because of an unknown or unsupported protocol.
ipInDiscards
1.3.6.1.2.1.4.8
Counter · Counter32
The number of input IP datagrams for which no problems were encountered to prevent their continued processing, but which were discarded (e.g., for lack of buffer space). Note that this counter does not include any datagrams discarded while awaiting re-assembly.
ipInDelivers
1.3.6.1.2.1.4.9
Counter · Counter32
The total number of input datagrams successfully delivered to IP user-protocols (including ICMP).
ipOutRequests
1.3.6.1.2.1.4.10
Counter · Counter32
The total number of IP datagrams which local IP user-protocols (including ICMP) supplied to IP in requests for transmission. Note that this counter does not include any datagrams counted in ipForwDatagrams.
ipOutDiscards
1.3.6.1.2.1.4.11
Counter · Counter32
The number of output IP datagrams for which no problem was encountered to prevent their transmission to their destination, but which were discarded (e.g., for lack of buffer space). Note that this counter would include datagrams counted in ipForwDatagrams if any such packets met this (discretionary) discard criterion.
ipOutNoRoutes
1.3.6.1.2.1.4.12
Counter · Counter32
The number of IP datagrams discarded because no route could be found to transmit them to their destination. Note that this counter includes any packets counted in ipForwDatagrams which meet this `no-route' criterion. Note that this includes any datagarms which a host cannot route because all of its default gateways are down.
ipReasmTimeout
1.3.6.1.2.1.4.13
INTEGER · Integer32
The maximum number of seconds which received fragments are held while they are awaiting reassembly at this entity.
ipReasmReqds
1.3.6.1.2.1.4.14
Counter · Counter32
The number of IP fragments received which needed to be reassembled at this entity.
ipReasmOKs
1.3.6.1.2.1.4.15
Counter · Counter32
The number of IP datagrams successfully re- assembled.
ipReasmFails
1.3.6.1.2.1.4.16
Counter · Counter32
The number of failures detected by the IP re- assembly algorithm (for whatever reason: timed out, errors, etc). Note that this is not necessarily a count of discarded IP fragments since some algorithms (notably the algorithm in RFC 815) can lose track of the number of fragments by combining them as they are received.
ipFragOKs
1.3.6.1.2.1.4.17
Counter · Counter32
The number of IP datagrams that have been successfully fragmented at this entity.
ipFragFails
1.3.6.1.2.1.4.18
Counter · Counter32
The number of IP datagrams that have been discarded because they needed to be fragmented at this entity but could not be, e.g., because their Don't Fragment flag was set.
ipFragCreates
1.3.6.1.2.1.4.19
Counter · Counter32
The number of IP datagram fragments that have been generated as a result of fragmentation at this entity.
ipRoutingDiscards
1.3.6.1.2.1.4.23
Counter · Counter32
The number of routing entries which were chosen to be discarded even though they are valid. One possible reason for discarding such an entry could be to free-up buffer space for other routing entries.
icmpInMsgs
1.3.6.1.2.1.5.1
Counter · Counter32
The total number of ICMP messages which the entity received. Note that this counter includes all those counted by icmpInErrors.
icmpInErrors
1.3.6.1.2.1.5.2
Counter · Counter32
The number of ICMP messages which the entity received but determined as having ICMP-specific errors (bad ICMP checksums, bad length, etc.).
icmpInDestUnreachs
1.3.6.1.2.1.5.3
Counter · Counter32
The number of ICMP Destination Unreachable messages received.
icmpInTimeExcds
1.3.6.1.2.1.5.4
Counter · Counter32
The number of ICMP Time Exceeded messages received.
icmpInParmProbs
1.3.6.1.2.1.5.5
Counter · Counter32
The number of ICMP Parameter Problem messages received.
icmpInSrcQuenchs
1.3.6.1.2.1.5.6
Counter · Counter32
The number of ICMP Source Quench messages received.
icmpInRedirects
1.3.6.1.2.1.5.7
Counter · Counter32
The number of ICMP Redirect messages received.
icmpInEchos
1.3.6.1.2.1.5.8
Counter · Counter32
The number of ICMP Echo (request) messages received.
icmpInEchoReps
1.3.6.1.2.1.5.9
Counter · Counter32
The number of ICMP Echo Reply messages received.
icmpInTimestamps
1.3.6.1.2.1.5.10
Counter · Counter32
The number of ICMP Timestamp (request) messages received.
icmpInTimestampReps
1.3.6.1.2.1.5.11
Counter · Counter32
The number of ICMP Timestamp Reply messages received.
icmpInAddrMasks
1.3.6.1.2.1.5.12
Counter · Counter32
The number of ICMP Address Mask Request messages received.
icmpInAddrMaskReps
1.3.6.1.2.1.5.13
Counter · Counter32
The number of ICMP Address Mask Reply messages received.
icmpOutMsgs
1.3.6.1.2.1.5.14
Counter · Counter32
The total number of ICMP messages which this entity attempted to send. Note that this counter includes all those counted by icmpOutErrors.
icmpOutErrors
1.3.6.1.2.1.5.15
Counter · Counter32
The number of ICMP messages which this entity did not send due to problems discovered within ICMP such as a lack of buffers. This value should not include errors discovered outside the ICMP layer such as the inability of IP to route the resultant datagram. In some implementations there may be no types of error which contribute to this counter's value.
icmpOutDestUnreachs
1.3.6.1.2.1.5.16
Counter · Counter32
The number of ICMP Destination Unreachable messages sent.
icmpOutTimeExcds
1.3.6.1.2.1.5.17
Counter · Counter32
The number of ICMP Time Exceeded messages sent.
icmpOutParmProbs
1.3.6.1.2.1.5.18
Counter · Counter32
The number of ICMP Parameter Problem messages sent.
icmpOutSrcQuenchs
1.3.6.1.2.1.5.19
Counter · Counter32
The number of ICMP Source Quench messages sent.
icmpOutRedirects
1.3.6.1.2.1.5.20
Counter · Counter32
The number of ICMP Redirect messages sent. For a host, this object will always be zero, since hosts do not send redirects.
icmpOutEchos
1.3.6.1.2.1.5.21
Counter · Counter32
The number of ICMP Echo (request) messages sent.
icmpOutEchoReps
1.3.6.1.2.1.5.22
Counter · Counter32
The number of ICMP Echo Reply messages sent.
icmpOutTimestamps
1.3.6.1.2.1.5.23
Counter · Counter32
The number of ICMP Timestamp (request) messages sent.
icmpOutTimestampReps
1.3.6.1.2.1.5.24
Counter · Counter32
The number of ICMP Timestamp Reply messages sent.
icmpOutAddrMasks
1.3.6.1.2.1.5.25
Counter · Counter32
The number of ICMP Address Mask Request messages sent.
icmpOutAddrMaskReps
1.3.6.1.2.1.5.26
Counter · Counter32
The number of ICMP Address Mask Reply messages sent.
The algorithm used to determine the timeout value used for retransmitting unacknowledged octets.
tcpRtoMin
1.3.6.1.2.1.6.2
INTEGER · Integer32
The minimum value permitted by a TCP implementation for the retransmission timeout, measured in milliseconds. More refined semantics for objects of this type depend upon the algorithm used to determine the retransmission timeout. In particular, when the timeout algorithm is rsre(3), an object of this type has the semantics of the LBOUND quantity described in RFC 793.
tcpRtoMax
1.3.6.1.2.1.6.3
INTEGER · Integer32
The maximum value permitted by a TCP implementation for the retransmission timeout, measured in milliseconds. More refined semantics for objects of this type depend upon the algorithm used to determine the retransmission timeout. In particular, when the timeout algorithm is rsre(3), an object of this type has the semantics of the UBOUND quantity described in RFC 793.
tcpMaxConn
1.3.6.1.2.1.6.4
INTEGER · Integer32
The limit on the total number of TCP connections the entity can support. In entities where the maximum number of connections is dynamic, this object should contain the value -1.
tcpActiveOpens
1.3.6.1.2.1.6.5
Counter · Counter32
The number of times TCP connections have made a direct transition to the SYN-SENT state from the CLOSED state.
tcpPassiveOpens
1.3.6.1.2.1.6.6
Counter · Counter32
The number of times TCP connections have made a direct transition to the SYN-RCVD state from the LISTEN state.
tcpAttemptFails
1.3.6.1.2.1.6.7
Counter · Counter32
The number of times TCP connections have made a direct transition to the CLOSED state from either the SYN-SENT state or the SYN-RCVD state, plus the number of times TCP connections have made a direct transition to the LISTEN state from the SYN-RCVD state.
tcpEstabResets
1.3.6.1.2.1.6.8
Counter · Counter32
The number of times TCP connections have made a direct transition to the CLOSED state from either the ESTABLISHED state or the CLOSE-WAIT state.
tcpCurrEstab
1.3.6.1.2.1.6.9
Gauge · Gauge32
The number of TCP connections for which the current state is either ESTABLISHED or CLOSE- WAIT.
tcpInSegs
1.3.6.1.2.1.6.10
Counter · Counter32
The total number of segments received, including those received in error. This count includes segments received on currently established connections.
tcpOutSegs
1.3.6.1.2.1.6.11
Counter · Counter32
The total number of segments sent, including those on current connections but excluding those containing only retransmitted octets.
tcpRetransSegs
1.3.6.1.2.1.6.12
Counter · Counter32
The total number of segments retransmitted - that is, the number of TCP segments transmitted containing one or more previously transmitted octets.
tcpInErrs
1.3.6.1.2.1.6.14
Counter · Counter32
The total number of segments received in error (e.g., bad TCP checksums).
tcpOutRsts
1.3.6.1.2.1.6.15
Counter · Counter32
The number of TCP segments sent containing the RST flag.
udpInDatagrams
1.3.6.1.2.1.7.1
Counter · Counter32
The total number of UDP datagrams delivered to UDP users.
udpNoPorts
1.3.6.1.2.1.7.2
Counter · Counter32
The total number of received UDP datagrams for which there was no application at the destination port.
udpInErrors
1.3.6.1.2.1.7.3
Counter · Counter32
The number of received UDP datagrams that could not be delivered for reasons other than the lack of an application at the destination port.
udpOutDatagrams
1.3.6.1.2.1.7.4
Counter · Counter32
The total number of UDP datagrams sent from this entity.
egpInMsgs
1.3.6.1.2.1.8.1
Counter · Counter32
The number of EGP messages received without error.
egpInErrors
1.3.6.1.2.1.8.2
Counter · Counter32
The number of EGP messages received that proved to be in error.
egpOutMsgs
1.3.6.1.2.1.8.3
Counter · Counter32
The total number of locally generated EGP messages.
egpOutErrors
1.3.6.1.2.1.8.4
Counter · Counter32
The number of locally generated EGP messages not sent due to resource limitations within an EGP entity.
egpAs
1.3.6.1.2.1.8.6
INTEGER · Integer32
The autonomous system number of this EGP entity.
snmpInPkts
1.3.6.1.2.1.11.1
Counter · Counter32
The total number of Messages delivered to the SNMP entity from the transport service.
snmpOutPkts
1.3.6.1.2.1.11.2
Counter · Counter32
The total number of SNMP Messages which were passed from the SNMP protocol entity to the transport service.
snmpInBadVersions
1.3.6.1.2.1.11.3
Counter · Counter32
The total number of SNMP Messages which were delivered to the SNMP protocol entity and were for an unsupported SNMP version.
snmpInBadCommunityNames
1.3.6.1.2.1.11.4
Counter · Counter32
The total number of SNMP Messages delivered to the SNMP protocol entity which used a SNMP community name not known to said entity.
snmpInBadCommunityUses
1.3.6.1.2.1.11.5
Counter · Counter32
The total number of SNMP Messages delivered to the SNMP protocol entity which represented an SNMP operation which was not allowed by the SNMP community named in the Message.
snmpInASNParseErrs
1.3.6.1.2.1.11.6
Counter · Counter32
The total number of ASN.1 or BER errors encountered by the SNMP protocol entity when decoding received SNMP Messages.
snmpInTooBigs
1.3.6.1.2.1.11.8
Counter · Counter32
The total number of SNMP PDUs which were delivered to the SNMP protocol entity and for which the value of the error-status field is `tooBig'.
snmpInNoSuchNames
1.3.6.1.2.1.11.9
Counter · Counter32
The total number of SNMP PDUs which were delivered to the SNMP protocol entity and for which the value of the error-status field is `noSuchName'.
snmpInBadValues
1.3.6.1.2.1.11.10
Counter · Counter32
The total number of SNMP PDUs which were delivered to the SNMP protocol entity and for which the value of the error-status field is `badValue'.
snmpInReadOnlys
1.3.6.1.2.1.11.11
Counter · Counter32
The total number valid SNMP PDUs which were delivered to the SNMP protocol entity and for which the value of the error-status field is `readOnly'. It should be noted that it is a protocol error to generate an SNMP PDU which contains the value `readOnly' in the error-status field, as such this object is provided as a means of detecting incorrect implementations of the SNMP.
snmpInGenErrs
1.3.6.1.2.1.11.12
Counter · Counter32
The total number of SNMP PDUs which were delivered to the SNMP protocol entity and for which the value of the error-status field is `genErr'.
snmpInTotalReqVars
1.3.6.1.2.1.11.13
Counter · Counter32
The total number of MIB objects which have been retrieved successfully by the SNMP protocol entity as the result of receiving valid SNMP Get-Request and Get-Next PDUs.
snmpInTotalSetVars
1.3.6.1.2.1.11.14
Counter · Counter32
The total number of MIB objects which have been altered successfully by the SNMP protocol entity as the result of receiving valid SNMP Set-Request PDUs.
snmpInGetRequests
1.3.6.1.2.1.11.15
Counter · Counter32
The total number of SNMP Get-Request PDUs which have been accepted and processed by the SNMP protocol entity.
snmpInGetNexts
1.3.6.1.2.1.11.16
Counter · Counter32
The total number of SNMP Get-Next PDUs which have been accepted and processed by the SNMP protocol entity.
snmpInSetRequests
1.3.6.1.2.1.11.17
Counter · Counter32
The total number of SNMP Set-Request PDUs which have been accepted and processed by the SNMP protocol entity.
snmpInGetResponses
1.3.6.1.2.1.11.18
Counter · Counter32
The total number of SNMP Get-Response PDUs which have been accepted and processed by the SNMP protocol entity.
snmpInTraps
1.3.6.1.2.1.11.19
Counter · Counter32
The total number of SNMP Trap PDUs which have been accepted and processed by the SNMP protocol entity.
snmpOutTooBigs
1.3.6.1.2.1.11.20
Counter · Counter32
The total number of SNMP PDUs which were generated by the SNMP protocol entity and for which the value of the error-status field is `tooBig.'
snmpOutNoSuchNames
1.3.6.1.2.1.11.21
Counter · Counter32
The total number of SNMP PDUs which were generated by the SNMP protocol entity and for which the value of the error-status is `noSuchName'.
snmpOutBadValues
1.3.6.1.2.1.11.22
Counter · Counter32
The total number of SNMP PDUs which were generated by the SNMP protocol entity and for which the value of the error-status field is `badValue'.
snmpOutGenErrs
1.3.6.1.2.1.11.24
Counter · Counter32
The total number of SNMP PDUs which were generated by the SNMP protocol entity and for which the value of the error-status field is `genErr'.
snmpOutGetRequests
1.3.6.1.2.1.11.25
Counter · Counter32
The total number of SNMP Get-Request PDUs which have been generated by the SNMP protocol entity.
snmpOutGetNexts
1.3.6.1.2.1.11.26
Counter · Counter32
The total number of SNMP Get-Next PDUs which have been generated by the SNMP protocol entity.
snmpOutSetRequests
1.3.6.1.2.1.11.27
Counter · Counter32
The total number of SNMP Set-Request PDUs which have been generated by the SNMP protocol entity.
snmpOutGetResponses
1.3.6.1.2.1.11.28
Counter · Counter32
The total number of SNMP Get-Response PDUs which have been generated by the SNMP protocol entity.
snmpOutTraps
1.3.6.1.2.1.11.29
Counter · Counter32
The total number of SNMP Trap PDUs which have been generated by the SNMP protocol entity.
snmpEnableAuthenTraps
1.3.6.1.2.1.11.30
INTEGER1 = enabled2 = disabled · Integer32
Indicates whether the SNMP agent process is permitted to generate authentication-failure traps. The value of this object overrides any configuration information; as such, it provides a means whereby all authentication-failure traps may be disabled.
Note that it is strongly recommended that this object be stored in non-volatile memory so that it remains constant between re-initializations of the network management system.
Table details
ifTable
1.3.6.1.2.1.2.2
Index: ifIndex
A list of interface entries. The number of entries is given by the value of ifNumber.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.
ifIndex
1.3.6.1.2.1.2.2.1.1
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.
ifDescr
1.3.6.1.2.1.2.2.1.2
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
A textual string containing information about the interface. This string should include the name of the manufacturer, the product name and the version of the interface hardware/software.
ifType
1.3.6.1.2.1.2.2.1.3
IANAifType1 = other2 = regular18223 = hdh18224 = ddnX255 = rfc877x256 = ethernetCsmacd7 = iso88023Csmacd8 = iso88024TokenBus9 = iso88025TokenRing10 = iso88026Man11 = starLan12 = proteon10Mbit13 = proteon80Mbit14 = hyperchannel15 = fddi16 = lapb17 = sdlc18 = ds119 = e120 = basicISDN21 = primaryISDN22 = propPointToPointSerial23 = ppp24 = softwareLoopback25 = eon26 = ethernet3Mbit27 = nsip28 = slip29 = ultra30 = ds331 = sip32 = frameRelay33 = rs23234 = para35 = arcnet36 = arcnetPlus37 = atm38 = miox2539 = sonet40 = x25ple41 = iso88022llc42 = localTalk43 = smdsDxi44 = frameRelayService45 = v3546 = hssi47 = hippi48 = modem49 = aal550 = sonetPath51 = sonetVT52 = smdsIcip53 = propVirtual54 = propMultiplexor55 = ieee8021256 = fibreChannel57 = hippiInterface58 = frameRelayInterconnect59 = aflane802360 = aflane802561 = cctEmul62 = fastEther63 = isdn64 = v1165 = v3666 = g703at64k67 = g703at2mb68 = qllc69 = fastEtherFX70 = channel71 = ieee8021172 = ibm370parChan73 = escon74 = dlsw75 = isdns76 = isdnu77 = lapd78 = ipSwitch79 = rsrb80 = atmLogical81 = ds082 = ds0Bundle83 = bsc84 = async85 = cnr86 = iso88025Dtr87 = eplrs88 = arap89 = propCnls90 = hostPad91 = termPad92 = frameRelayMPI93 = x21394 = adsl95 = radsl96 = sdsl97 = vdsl98 = iso88025CRFPInt99 = myrinet100 = voiceEM101 = voiceFXO102 = voiceFXS103 = voiceEncap104 = voiceOverIp105 = atmDxi106 = atmFuni107 = atmIma108 = pppMultilinkBundle109 = ipOverCdlc110 = ipOverClaw111 = stackToStack112 = virtualIpAddress113 = mpc114 = ipOverAtm115 = iso88025Fiber116 = tdlc117 = gigabitEthernet118 = hdlc119 = lapf120 = v37121 = x25mlp122 = x25huntGroup123 = transpHdlc124 = interleave125 = fast126 = ip127 = docsCableMaclayer128 = docsCableDownstream129 = docsCableUpstream130 = a12MppSwitch131 = tunnel132 = coffee133 = ces134 = atmSubInterface135 = l2vlan136 = l3ipvlan137 = l3ipxvlan138 = digitalPowerline139 = mediaMailOverIp140 = dtm141 = dcn142 = ipForward143 = msdsl144 = ieee1394145 = if-gsn146 = dvbRccMacLayer147 = dvbRccDownstream148 = dvbRccUpstream149 = atmVirtual150 = mplsTunnel151 = srp152 = voiceOverAtm153 = voiceOverFrameRelay154 = idsl155 = compositeLink156 = ss7SigLink157 = propWirelessP2P158 = frForward159 = rfc1483160 = usb161 = ieee8023adLag162 = bgppolicyaccounting163 = frf16MfrBundle164 = h323Gatekeeper165 = h323Proxy166 = mpls167 = mfSigLink168 = hdsl2169 = shdsl170 = ds1FDL171 = pos172 = dvbAsiIn173 = dvbAsiOut174 = plc175 = nfas176 = tr008177 = gr303RDT178 = gr303IDT179 = isup180 = propDocsWirelessMaclayer181 = propDocsWirelessDownstream182 = propDocsWirelessUpstream183 = hiperlan2184 = propBWAp2Mp185 = sonetOverheadChannel186 = digitalWrapperOverheadChannel187 = aal2188 = radioMAC189 = atmRadio190 = imt191 = mvl192 = reachDSL193 = frDlciEndPt194 = atmVciEndPt195 = opticalChannel196 = opticalTransport197 = propAtm198 = voiceOverCable199 = infiniband200 = teLink201 = q2931202 = virtualTg203 = sipTg204 = sipSig205 = docsCableUpstreamChannel206 = econet207 = pon155208 = pon622209 = bridge210 = linegroup211 = voiceEMFGD212 = voiceFGDEANA213 = voiceDID214 = mpegTransport215 = sixToFour216 = gtp217 = pdnEtherLoop1218 = pdnEtherLoop2219 = opticalChannelGroup220 = homepna221 = gfp222 = ciscoISLvlan223 = actelisMetaLOOP224 = fcipLink225 = rpr226 = qam227 = lmp228 = cblVectaStar229 = docsCableMCmtsDownstream230 = adsl2231 = macSecControlledIF232 = macSecUncontrolledIF233 = aviciOpticalEther234 = atmbond235 = voiceFGDOS236 = mocaVersion1237 = ieee80216WMAN238 = adsl2plus239 = dvbRcsMacLayer240 = dvbTdm241 = dvbRcsTdma242 = x86Laps243 = wwanPP244 = wwanPP2245 = voiceEBS246 = ifPwType247 = ilan248 = pip249 = aluELP250 = gpon251 = vdsl2252 = capwapDot11Profile253 = capwapDot11Bss254 = capwapWtpVirtualRadio255 = bits256 = docsCableUpstreamRfPort257 = cableDownstreamRfPort258 = vmwareVirtualNic259 = ieee802154260 = otnOdu261 = otnOtu262 = ifVfiType263 = g9981264 = g9982265 = g9983266 = aluEpon267 = aluEponOnu268 = aluEponPhysicalUni269 = aluEponLogicalLink270 = aluGponOnu271 = aluGponPhysicalUni272 = vmwareNicTeam277 = docsOfdmDownstream278 = docsOfdmaUpstream279 = gfast280 = sdci281 = xboxWireless282 = fastdsl283 = docsCableScte55d1FwdOob284 = docsCableScte55d1RetOob285 = docsCableScte55d2DsOob286 = docsCableScte55d2UsOob287 = docsCableNdf288 = docsCableNdr289 = ptm290 = ghn291 = otnOtsi292 = otnOtuc293 = otnOduc294 = otnOtsig295 = microwaveCarrierTermination296 = microwaveRadioLinkTerminal297 = ieee8021axDrni298 = ax25299 = ieee19061nanocomThis data type is used as the syntax of the ifType object in the (updated) definition of MIB-II's ifTable.
The definition of this textual convention with the addition of newly assigned values is published periodically by the IANA, in either the Assigned Numbers RFC, or some derivative of it specific to Internet Network Management number assignments. (The latest arrangements can be obtained by contacting the IANA.)
Interface types must not be directly added to the IANAifType-MIB MIB module. They must instead be added to the 'ifType definitions' registry at https://www.iana.org/assignments/smi-numbers.
The relationship between the assignment of ifType values and of OIDs to particular media-specific MIBs is solely the purview of IANA and is subject to change without notice. Quite often, a media-specific MIB's OID-subtree assignment within MIB-II's 'transmission' subtree will be the same as its ifType value. However, in some circumstances this will not be the case, and implementors must not pre-assume any specific relationship between ifType values and transmission subtree OIDs. · Integer32
The type of interface. Additional values for ifType are assigned by the Internet Assigned Numbers Authority (IANA), through updating the syntax of the IANAifType textual convention.
ifMtu
1.3.6.1.2.1.2.2.1.4
Integer32
The size of the largest packet which can be sent/received on the interface, specified in octets. For interfaces that are used for transmitting network datagrams, this is the size of the largest network datagram that can be sent on the interface.
ifSpeed
1.3.6.1.2.1.2.2.1.5
Gauge32
An estimate of the interface's current bandwidth in bits per second. For interfaces which do not vary in bandwidth or for those where no accurate estimation can be made, this object should contain the nominal bandwidth. If the bandwidth of the interface is greater than the maximum value reportable by this object then this object should report its maximum value (4,294,967,295) and ifHighSpeed must be used to report the interace's speed. For a sub-layer which has no concept of bandwidth, this object should be zero.
ifPhysAddress
1.3.6.1.2.1.2.2.1.6
PhysAddressRepresents media- or physical-level addresses. · OCTET STRING · hint 1x:
The interface's address at its protocol sub-layer. For example, for an 802.x interface, this object normally contains a MAC address. The interface's media-specific MIB must define the bit and byte ordering and the format of the value of this object. For interfaces which do not have such an address (e.g., a serial line), this object should contain an octet string of zero length.
ifAdminStatus
1.3.6.1.2.1.2.2.1.7
INTEGER1 = up2 = down3 = testing · Integer32
The desired state of the interface. The testing(3) state indicates that no operational packets can be passed. When a managed system initializes, all interfaces start with ifAdminStatus in the down(2) state. As a result of either explicit management action or per configuration information retained by the managed system, ifAdminStatus is then changed to either the up(1) or testing(3) states (or remains in the down(2) state).
The current operational state of the interface. The testing(3) state indicates that no operational packets can be passed. If ifAdminStatus is down(2) then ifOperStatus should be down(2). If ifAdminStatus is changed to up(1) then ifOperStatus should change to up(1) if the interface is ready to transmit and receive network traffic; it should change to dormant(5) if the interface is waiting for external actions (such as a serial line waiting for an incoming connection); it should remain in the down(2) state if and only if there is a fault that prevents it from going to the up(1) state; it should remain in the notPresent(6) state if the interface has missing (typically, hardware) components.
ifLastChange
1.3.6.1.2.1.2.2.1.9
TimeTicks
The value of sysUpTime at the time the interface entered its current operational state. If the current state was entered prior to the last re-initialization of the local network management subsystem, then this object contains a zero value.
ifInOctets
1.3.6.1.2.1.2.2.1.10
Counter32
The total number of octets received on the interface, including framing characters.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
ifInUcastPkts
1.3.6.1.2.1.2.2.1.11
Counter32
The number of packets, delivered by this sub-layer to a higher (sub-)layer, which were not addressed to a multicast or broadcast address at this sub-layer.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
ifInNUcastPkts
1.3.6.1.2.1.2.2.1.12
Counter32
The number of packets, delivered by this sub-layer to a higher (sub-)layer, which were addressed to a multicast or broadcast address at this sub-layer.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
This object is deprecated in favour of ifInMulticastPkts and ifInBroadcastPkts.
ifInDiscards
1.3.6.1.2.1.2.2.1.13
Counter32
The number of inbound packets which were chosen to be discarded even though no errors had been detected to prevent their being deliverable to a higher-layer protocol. One possible reason for discarding such a packet could be to free up buffer space.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
ifInErrors
1.3.6.1.2.1.2.2.1.14
Counter32
For packet-oriented interfaces, the number of inbound packets that contained errors preventing them from being deliverable to a higher-layer protocol. For character- oriented or fixed-length interfaces, the number of inbound transmission units that contained errors preventing them from being deliverable to a higher-layer protocol.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
ifInUnknownProtos
1.3.6.1.2.1.2.2.1.15
Counter32
For packet-oriented interfaces, the number of packets received via the interface which were discarded because of an unknown or unsupported protocol. For character-oriented or fixed-length interfaces that support protocol multiplexing the number of transmission units received via the interface which were discarded because of an unknown or unsupported protocol. For any interface that does not support protocol multiplexing, this counter will always be 0.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
ifOutOctets
1.3.6.1.2.1.2.2.1.16
Counter32
The total number of octets transmitted out of the interface, including framing characters.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
ifOutUcastPkts
1.3.6.1.2.1.2.2.1.17
Counter32
The total number of packets that higher-level protocols requested be transmitted, and which were not addressed to a multicast or broadcast address at this sub-layer, including those that were discarded or not sent.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
ifOutNUcastPkts
1.3.6.1.2.1.2.2.1.18
Counter32
The total number of packets that higher-level protocols requested be transmitted, and which were addressed to a multicast or broadcast address at this sub-layer, including those that were discarded or not sent.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
This object is deprecated in favour of ifOutMulticastPkts and ifOutBroadcastPkts.
ifOutDiscards
1.3.6.1.2.1.2.2.1.19
Counter32
The number of outbound packets which were chosen to be discarded even though no errors had been detected to prevent their being transmitted. One possible reason for discarding such a packet could be to free up buffer space.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
ifOutErrors
1.3.6.1.2.1.2.2.1.20
Counter32
For packet-oriented interfaces, the number of outbound packets that could not be transmitted because of errors. For character-oriented or fixed-length interfaces, the number of outbound transmission units that could not be transmitted because of errors.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
ifOutQLen
1.3.6.1.2.1.2.2.1.21
Gauge32
The length of the output packet queue (in packets).
ifSpecific
1.3.6.1.2.1.2.2.1.22
OBJECT IDENTIFIER
A reference to MIB definitions specific to the particular media being used to realize the interface. It is recommended that this value point to an instance of a MIB object in the media-specific MIB, i.e., that this object have the semantics associated with the InstancePointer textual convention defined in RFC 2579. In fact, it is recommended that the media-specific MIB specify what value ifSpecific should/can take for values of ifType. If no MIB definitions specific to the particular media are available, the value should be set to the OBJECT IDENTIFIER { 0 0 }.
atTable
1.3.6.1.2.1.3.1
Index: atIfIndex · atNetAddress
The Address Translation tables contain the NetworkAddress to `physical' address equivalences. Some interfaces do not use translation tables for determining address equivalences (e.g., DDN-X.25 has an algorithmic method); if all interfaces are of this type, then the Address Translation table is empty, i.e., has zero entries.
atIfIndex
1.3.6.1.2.1.3.1.1.1
INTEGER · Integer32
The interface on which this entry's equivalence is effective. The interface identified by a particular value of this index is the same interface as identified by the same value of ifIndex.
atPhysAddress
1.3.6.1.2.1.3.1.1.2
PhysAddressRepresents media- or physical-level addresses. · OCTET STRING · hint 1x:
The media-dependent `physical' address.
Setting this object to a null string (one of zero length) has the effect of invaliding the corresponding entry in the atTable object. That is, it effectively dissasociates the interface identified with said entry from the mapping identified with said entry. It is an implementation-specific matter as to whether the agent removes an invalidated entry from the table. Accordingly, management stations must be prepared to receive tabular information from agents that corresponds to entries not currently in use. Proper interpretation of such entries requires examination of the relevant atPhysAddress object.
atNetAddress
1.3.6.1.2.1.3.1.1.3
NetworkAddress SIZE (4) · IpAddress
The NetworkAddress (e.g., the IP address) corresponding to the media-dependent `physical' address.
ipAddrTable
1.3.6.1.2.1.4.20
Index: ipAdEntAddr
The table of addressing information relevant to this entity's IP addresses.
The IPv4 address to which this entry's addressing information pertains.
ipAdEntAddr
1.3.6.1.2.1.4.20.1.1
IpAddress SIZE (4)
The IPv4 address to which this entry's addressing information pertains.
ipAdEntIfIndex
1.3.6.1.2.1.4.20.1.2
INTEGER (1..2147483647) · Integer32
The index value which uniquely identifies the interface to which this entry is applicable. The interface identified by a particular value of this index is the same interface as identified by the same value of the IF-MIB's ifIndex.
ipAdEntNetMask
1.3.6.1.2.1.4.20.1.3
IpAddress SIZE (4)
The subnet mask associated with the IPv4 address of this entry. The value of the mask is an IPv4 address with all the network bits set to 1 and all the hosts bits set to 0.
ipAdEntBcastAddr
1.3.6.1.2.1.4.20.1.4
INTEGER (0..1) · Integer32
The value of the least-significant bit in the IPv4 broadcast address used for sending datagrams on the (logical) interface associated with the IPv4 address of this entry. For example, when the Internet standard all-ones broadcast address is used, the value will be 1. This value applies to both the subnet and network broadcast addresses used by the entity on this (logical) interface.
ipAdEntReasmMaxSize
1.3.6.1.2.1.4.20.1.5
INTEGER (0..65535) · Integer32
The size of the largest IPv4 datagram which this entity can re-assemble from incoming IPv4 fragmented datagrams received on this interface.
ipRouteTable
1.3.6.1.2.1.4.21
Index: ipRouteDest
This entity's IP Routing table.
ipRouteDest
1.3.6.1.2.1.4.21.1.1
IpAddress SIZE (4)
The destination IP address of this route. An entry with a value of 0.0.0.0 is considered a default route. Multiple routes to a single destination can appear in the table, but access to such multiple entries is dependent on the table- access mechanisms defined by the network management protocol in use.
ipRouteIfIndex
1.3.6.1.2.1.4.21.1.2
INTEGER · Integer32
The index value which uniquely identifies the local interface through which the next hop of this route should be reached. The interface identified by a particular value of this index is the same interface as identified by the same value of ifIndex.
ipRouteMetric1
1.3.6.1.2.1.4.21.1.3
INTEGER · Integer32
The primary routing metric for this route. The semantics of this metric are determined by the routing-protocol specified in the route's ipRouteProto value. If this metric is not used, its value should be set to -1.
ipRouteMetric2
1.3.6.1.2.1.4.21.1.4
INTEGER · Integer32
An alternate routing metric for this route. The semantics of this metric are determined by the routing-protocol specified in the route's ipRouteProto value. If this metric is not used, its value should be set to -1.
ipRouteMetric3
1.3.6.1.2.1.4.21.1.5
INTEGER · Integer32
An alternate routing metric for this route. The semantics of this metric are determined by the routing-protocol specified in the route's ipRouteProto value. If this metric is not used, its value should be set to -1.
ipRouteMetric4
1.3.6.1.2.1.4.21.1.6
INTEGER · Integer32
An alternate routing metric for this route. The semantics of this metric are determined by the routing-protocol specified in the route's ipRouteProto value. If this metric is not used, its value should be set to -1.
ipRouteNextHop
1.3.6.1.2.1.4.21.1.7
IpAddress SIZE (4)
The IP address of the next hop of this route. (In the case of a route bound to an interface which is realized via a broadcast media, the value of this field is the agent's IP address on that interface.)
The type of route. Note that the values direct(3) and indirect(4) refer to the notion of direct and indirect routing in the IP architecture.
Setting this object to the value invalid(2) has the effect of invalidating the corresponding entry in the ipRouteTable object. That is, it effectively dissasociates the destination identified with said entry from the route identified with said entry. It is an implementation-specific matter as to whether the agent removes an invalidated entry from the table. Accordingly, management stations must be prepared to receive tabular information from agents that corresponds to entries not currently in use. Proper interpretation of such entries requires examination of the relevant ipRouteType object.
The routing mechanism via which this route was learned. Inclusion of values for gateway routing protocols is not intended to imply that hosts should support those protocols.
ipRouteAge
1.3.6.1.2.1.4.21.1.10
INTEGER · Integer32
The number of seconds since this route was last updated or otherwise determined to be correct. Note that no semantics of `too old' can be implied except through knowledge of the routing protocol by which the route was learned.
ipRouteMask
1.3.6.1.2.1.4.21.1.11
IpAddress SIZE (4)
Indicate the mask to be logical-ANDed with the destination address before being compared to the value in the ipRouteDest field. For those systems that do not support arbitrary subnet masks, an agent constructs the value of the ipRouteMask by determining whether the value of the correspondent ipRouteDest field belong to a class-A, B, or C network, and then using one of:
mask network
255.0.0.0 class-A
255.255.0.0 class-B
255.255.255.0 class-C
If the value of the ipRouteDest is 0.0.0.0 (a default route), then the mask value is also 0.0.0.0. It should be noted that all IP routing subsystems implicitly use this mechanism.
ipRouteMetric5
1.3.6.1.2.1.4.21.1.12
INTEGER · Integer32
An alternate routing metric for this route. The semantics of this metric are determined by the routing-protocol specified in the route's ipRouteProto value. If this metric is not used, its value should be set to -1.
ipRouteInfo
1.3.6.1.2.1.4.21.1.13
OBJECT IDENTIFIER
A reference to MIB definitions specific to the particular routing protocol which is responsible for this route, as determined by the value specified in the route's ipRouteProto value. If this information is not present, its value should be set to the OBJECT IDENTIFIER { 0 0 }, which is a syntatically valid object identifier, and any conformant implementation of ASN.1 and BER must be able to generate and recognize this value.
The interface on which this entry's equivalence is effective. The interface identified by a particular value of this index is the same interface as identified by the same value of the IF-MIB's ifIndex.
This object predates the rule limiting index objects to a max access value of 'not-accessible' and so continues to use a value of 'read-create'.
ipNetToMediaNetAddress
IpAddress SIZE (4)
The IpAddress corresponding to the media-dependent `physical' address.
This object predates the rule limiting index objects to a max access value of 'not-accessible' and so continues to use a value of 'read-create'.
ipNetToMediaIfIndex
1.3.6.1.2.1.4.22.1.1
INTEGER (1..2147483647) · Integer32
The interface on which this entry's equivalence is effective. The interface identified by a particular value of this index is the same interface as identified by the same value of the IF-MIB's ifIndex.
This object predates the rule limiting index objects to a max access value of 'not-accessible' and so continues to use a value of 'read-create'.
ipNetToMediaPhysAddress
1.3.6.1.2.1.4.22.1.2
PhysAddressRepresents media- or physical-level addresses. SIZE (0..65535) · OCTET STRING · hint 1x:
The media-dependent `physical' address. This object should return 0 when this entry is in the 'incomplete' state.
As the entries in this table are typically not persistent when this object is written the entity should not save the change to non-volatile storage. Note: a stronger requirement is not used because this object was previously defined.
ipNetToMediaNetAddress
1.3.6.1.2.1.4.22.1.3
IpAddress SIZE (4)
The IpAddress corresponding to the media-dependent `physical' address.
This object predates the rule limiting index objects to a max access value of 'not-accessible' and so continues to use a value of 'read-create'.
The type of mapping.
Setting this object to the value invalid(2) has the effect of invalidating the corresponding entry in the ipNetToMediaTable. That is, it effectively dis-associates the interface identified with said entry from the mapping identified with said entry. It is an implementation- specific matter as to whether the agent removes an invalidated entry from the table. Accordingly, management stations must be prepared to receive tabular information from agents that corresponds to entries not currently in use. Proper interpretation of such entries requires examination of the relevant ipNetToMediaType object.
As the entries in this table are typically not persistent when this object is written the entity should not save the change to non-volatile storage. Note: a stronger requirement is not used because this object was previously defined.
The local IP address for this TCP connection. In the case of a connection in the listen state which is willing to accept connections for any IP interface associated with the node, the value 0.0.0.0 is used.
The state of this TCP connection.
The only value which may be set by a management station is deleteTCB(12). Accordingly, it is appropriate for an agent to return a `badValue' response if a management station attempts to set this object to any other value.
If a management station sets this object to the value deleteTCB(12), then this has the effect of deleting the TCB (as defined in RFC 793) of the corresponding connection on the managed node, resulting in immediate termination of the connection.
As an implementation-specific option, a RST segment may be sent from the managed node to the other TCP endpoint (note however that RST segments are not sent reliably).
tcpConnLocalAddress
1.3.6.1.2.1.6.13.1.2
IpAddress SIZE (4)
The local IP address for this TCP connection. In the case of a connection in the listen state which is willing to accept connections for any IP interface associated with the node, the value 0.0.0.0 is used.
The local IP address for this UDP listener. In the case of a UDP listener which is willing to accept datagrams for any IP interface associated with the node, the value 0.0.0.0 is used.
udpLocalPort
INTEGER (0..65535) · Integer32
The local port number for this UDP listener.
udpLocalAddress
1.3.6.1.2.1.7.5.1.1
IpAddress SIZE (4)
The local IP address for this UDP listener. In the case of a UDP listener which is willing to accept datagrams for any IP interface associated with the node, the value 0.0.0.0 is used.
The EGP state of the local system with respect to this entry's EGP neighbor. Each EGP state is represented by a value that is one greater than the numerical value associated with said state in RFC 904.
egpNeighAddr
1.3.6.1.2.1.8.5.1.2
IpAddress SIZE (4)
The IP address of this entry's EGP neighbor.
egpNeighAs
1.3.6.1.2.1.8.5.1.3
INTEGER · Integer32
The autonomous system of this EGP peer. Zero should be specified if the autonomous system number of the neighbor is not yet known.
egpNeighInMsgs
1.3.6.1.2.1.8.5.1.4
Counter · Counter32
The number of EGP messages received without error from this EGP peer.
egpNeighInErrs
1.3.6.1.2.1.8.5.1.5
Counter · Counter32
The number of EGP messages received from this EGP peer that proved to be in error (e.g., bad EGP checksum).
egpNeighOutMsgs
1.3.6.1.2.1.8.5.1.6
Counter · Counter32
The number of locally generated EGP messages to this EGP peer.
egpNeighOutErrs
1.3.6.1.2.1.8.5.1.7
Counter · Counter32
The number of locally generated EGP messages not sent to this EGP peer due to resource limitations within an EGP entity.
egpNeighInErrMsgs
1.3.6.1.2.1.8.5.1.8
Counter · Counter32
The number of EGP-defined error messages received from this EGP peer.
egpNeighOutErrMsgs
1.3.6.1.2.1.8.5.1.9
Counter · Counter32
The number of EGP-defined error messages sent to this EGP peer.
egpNeighStateUps
1.3.6.1.2.1.8.5.1.10
Counter · Counter32
The number of EGP state transitions to the UP state with this EGP peer.
egpNeighStateDowns
1.3.6.1.2.1.8.5.1.11
Counter · Counter32
The number of EGP state transitions from the UP state to any other state with this EGP peer.
egpNeighIntervalHello
1.3.6.1.2.1.8.5.1.12
INTEGER · Integer32
The interval between EGP Hello command retransmissions (in hundredths of a second). This represents the t1 timer as defined in RFC 904.
egpNeighIntervalPoll
1.3.6.1.2.1.8.5.1.13
INTEGER · Integer32
The interval between EGP poll command retransmissions (in hundredths of a second). This represents the t3 timer as defined in RFC 904.
egpNeighMode
1.3.6.1.2.1.8.5.1.14
INTEGER1 = active2 = passive · Integer32
The polling mode of this EGP entity, either passive or active.
egpNeighEventTrigger
1.3.6.1.2.1.8.5.1.15
INTEGER1 = start2 = stop · Integer32
A control variable used to trigger operator- initiated Start and Stop events. When read, this variable always returns the most recent value that egpNeighEventTrigger was set to. If it has not been set since the last initialization of the network management subsystem on the node, it returns a value of `stop'.
When set, this variable causes a Start or Stop event on the specified neighbor, as specified on pages 8-10 of RFC 904. Briefly, a Start event causes an Idle peer to begin neighbor acquisition and a non-Idle peer to reinitiate neighbor acquisition. A stop event causes a non-Idle peer to return to the Idle state until a Start event occurs, either via egpNeighEventTrigger or otherwise.