This MIB module defines a set of basic objects for monitoring and configuring robust header compression. The module covers information about running instances of ROHC (compressors or decompressors) at IP interfaces.
Information about compressor contexts and decompressor contexts has different structure for different profiles. Therefore it is not provided by this MIB module, but by individual modules for different profiles.
Copyright (C) The Internet Society (2004). The initial version of this MIB module was published in RFC 3816. For full legal notices see the RFC itself or see: http://www.ietf.org/copyrights/ianamib.html
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.
rohcChannelID
1.3.6.1.2.1.112.1.1.1.1.2
RohcChannelIdentifierA number identifying a channel. The value of 0 must not be used as identifier of an existing channel. (1..4294967295) · Unsigned32 · hint d
The locally arbitrary, but unique identifier associated with this channel. The value is REQUIRED to be unique per ROHC MIB implementation independent of the associated interface.
The value is REQUIRED to remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. It is RECOMMENDED that the value persist across such re-initializations. Reference: RFC 3095, Section 5.1.1
Type of usage of the channel. A channel might be currently not in use for ROHC or feedback, it might be in use as a ROHC channel carrying packets and optional piggy-backed feedback, or it might be used as a dedicated feedback channel exclusively carrying feedback.
rohcChannelFeedbackFor
1.3.6.1.2.1.112.1.1.1.1.4
RohcChannelIdentifierOrZeroA number identifying a channel. The value of 0 is indicates that no channel is identified. · Unsigned32 · hint d
The index of another channel of this interface for which the channel serves as feedback channel.
If no feedback information is transferred on this channel, then the value of this ID is 0. If the channel type is set to notInUse(1), then the value of this object must be 0. If the channel type is rohc(2) and the value of this object is a valid channel ID, then feedback information is piggy-backed on the ROHC channel. If the channel type is dedicatedFeedback(3), then feedback is transferred on this channel and the value of this object MUST be different from 0 and MUST identify an existing ROHC channel. Reference: RFC 3095, Section 5.1.1
rohcChannelDescr
1.3.6.1.2.1.112.1.1.1.1.5
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
A textual description of the channel.
rohcChannelStatus
1.3.6.1.2.1.112.1.1.1.1.6
INTEGER1 = enabled2 = disabled · Integer32
Status of the channel.
rohcInstanceTable
1.3.6.1.2.1.112.1.1.2
Index: ifIndex · rohcInstanceType · rohcChannelID
This table lists properties of running instances of robust header compressors and decompressors at IP interfaces. It is indexed by interface number, the type of instance (compressor or decompressor), and the ID of the channel used by the instance as ROHC channel.
Note that the rohcChannelID uniquely identifies an instance. The ifIndex and rohcInstanceType are part of the index, because it simplifies accessing instances per interface and for addressing either compressors or decompressors only.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.
rohcInstanceType
1.3.6.1.2.1.112.1.1.2.1.2
INTEGER1 = compressor2 = decompressor · Integer32
Type of the instance of ROHC. It is either a compressor instance or a decompressor instance.
rohcInstanceFBChannelID
1.3.6.1.2.1.112.1.1.2.1.4
RohcChannelIdentifierOrZeroA number identifying a channel. The value of 0 is indicates that no channel is identified. · Unsigned32 · hint d
Identifier of the channel used for feedback. If no feedback channel is used, the value of this object is 0 . Reference: RFC 3095, Section 5.1.1
rohcInstanceVendor
1.3.6.1.2.1.112.1.1.2.1.5
OBJECT IDENTIFIER
An object identifier that identifies the vendor who provides the implementation of robust header description. This object identifier SHALL point to the object identifier directly below the enterprise object identifier {1 3 6 1 4 1} allocated for the vendor. The value must be the object identifier {0 0} if the vendor is not known.
rohcInstanceVersion
1.3.6.1.2.1.112.1.1.2.1.6
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t
The version number of the implementation of robust header compression. The zero-length string shall be used if the implementation does not have a version number. It is suggested that the version number consist of one or more decimal numbers separated by dots, where the first number is called the major version number.
rohcInstanceDescr
1.3.6.1.2.1.112.1.1.2.1.7
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
A textual description of the implementation.
rohcInstanceClockRes
1.3.6.1.2.1.112.1.1.2.1.8
Unsigned32 · milliseconds
This object indicates the system clock resolution in units of milliseconds. A zero (0) value means that there is no clock available.
rohcInstanceMaxCID
1.3.6.1.2.1.112.1.1.2.1.9
Unsigned32 (1..16383)
The highest context ID number to be used by the compressor. Note that this parameter is not coupled to, but in effect further constrained by, rohcChannelLargeCIDs. Reference: RFC 3095, Section 5.1.1
rohcInstanceLargeCIDs
1.3.6.1.2.1.112.1.1.2.1.10
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
When retrieved, this boolean object returns false if the short CID representation (0 bytes or 1 prefix byte, covering CID 0 to 15) is used; it returns true, if the embedded CID representation (1 or 2 embedded CID bytes covering CID 0 to 16383) is used. Reference: RFC 3095, Section 5.1.1
rohcInstanceMRRU
1.3.6.1.2.1.112.1.1.2.1.11
Unsigned32
Maximum reconstructed reception unit. This is the size of the largest reconstructed unit in octets that the decompressor is expected to reassemble from segments (see RFC 3095, Section 5.2.5). Note that this size includes the CRC. If MRRU is negotiated to be 0, no segment headers are allowed on the channel. Reference: RFC 3095, Section 5.1.1
rohcInstanceContextStorageTime
1.3.6.1.2.1.112.1.1.2.1.12
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · centi-seconds
This object indicates the default maximum amount of time information on a context belonging to this instance is kept as entry in the rohcContextTable after the context is expired or terminated. The value of this object is used to initialize rohcContexStorageTime object when a new context is created. Changing the value of an rohcInstanceContextStorageTime instance does not affect any entry of the rohcContextTable created previously. ROHC-MIB implementations SHOULD store the set value of this object persistently.
rohcInstanceStatus
1.3.6.1.2.1.112.1.1.2.1.13
INTEGER1 = enabled2 = disabled · Integer32
Status of the instance of ROHC.
rohcInstanceContextsTotal
1.3.6.1.2.1.112.1.1.2.1.14
Counter32
Counter of all contexts created by this instance.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
rohcInstanceContextsCurrent
1.3.6.1.2.1.112.1.1.2.1.15
Unsigned32
Number of currently active contexts created by this instance.
rohcInstancePackets
1.3.6.1.2.1.112.1.1.2.1.16
Counter32
Counter of all packets passing this instance.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
rohcInstanceIRs
1.3.6.1.2.1.112.1.1.2.1.17
Counter32
The number of all IR packets that are either sent or received by this instance.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. Reference: RFC 3095, Section 5.7.7.1
rohcInstanceIRDYNs
1.3.6.1.2.1.112.1.1.2.1.18
Counter32
The number of all IR-DYN packets that are either sent or received by this instance.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. Reference: RFC 3095, Section 5.7.7.2
rohcInstanceFeedbacks
1.3.6.1.2.1.112.1.1.2.1.19
Counter32
The number of all feedbacks that are either sent or received by this instance.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime.
rohcInstanceCompressionRatio
1.3.6.1.2.1.112.1.1.2.1.20
RohcCompressionRatioA number indicating a compression ratio over a set of bytes. The value is defined as 1000 * bytes(compressed) / bytes(original) rounded to the next integer value.
Note that compressed sets of bytes can be larger than the corresponding uncompressed ones. Therefore, the number can be greater than 1000. · Unsigned32 · hint d
This object indicates the compression ratio so far over all packets on the channel served by this instance. The compression is computed over all bytes of the IP packets including the IP header but excluding all lower layer headers.
rohcProfileTable
1.3.6.1.2.1.112.1.1.3
Index: rohcChannelID · rohcProfile
This table lists a set of profiles supported by the instance. Reference: RFC 3095, Section 5.1.1
rohcProfile
1.3.6.1.2.1.112.1.1.3.1.2
Unsigned32 (0..65535)
Identifier of a profile supported. For a listing of possible profile values, see the IANA registry for 'RObust Header Compression (ROHC) Profile Identifiers' at http://www.iana.org/assignments/rohc-pro-ids
rohcProfileVendor
1.3.6.1.2.1.112.1.1.3.1.3
OBJECT IDENTIFIER
An object identifier that identifies the vendor who provides the implementation of robust header description. This object identifier SHALL point to the object identifier directly below the enterprise object identifier {1 3 6 1 4 1} allocated for the vendor. The value must be the object identifier {0 0} if the vendor is not known.
rohcProfileVersion
1.3.6.1.2.1.112.1.1.3.1.4
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t
The version number of the implementation of robust header compression. The zero-length string shall be used if the implementation does not have a version number.
It is suggested that the version number consist of one or more decimal numbers separated by dots, where the first number is called the major version number.
rohcProfileDescr
1.3.6.1.2.1.112.1.1.3.1.5
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form.
To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279].
Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited.
The use of control codes should be avoided.
When it is necessary to represent a newline, the control code sequence CR LF should be used.
The use of leading or trailing white space should be avoided.
For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided.
For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding.
UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding.
Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416].
Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
A textual description of the implementation.
rohcProfileNegotiated
1.3.6.1.2.1.112.1.1.3.1.6
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
When retrieved, this boolean object returns true if the profile has been negotiated to be used at the instance, i.e., is supported also be the corresponding compressor/decompressor.
rohcContextTable
1.3.6.1.2.1.112.1.2
Index: rohcChannelID · rohcContextCID
This table lists and describes all compressor contexts per instance.
rohcContextCID
1.3.6.1.2.1.112.1.2.1.2
Unsigned32 (0..16383)
The context identifier (CID) of this context. Reference: RFC 3095, Sections 5.1.1 and 5.1.3
State of the CID. When a CID is assigned to a context, its state changes from `unused' to `active'. The active context may stop operation due to some explicit signalling or after observing no packet for some specified time. In the first case then the CID state changes to `terminated', in the latter case it changes to `expired'. If the CID is re-used again for another context, the state changes back to `active'.
rohcContextProfile
1.3.6.1.2.1.112.1.2.1.4
Unsigned32 (0..65535)
Identifier of the profile for this context. The profile is identified by its index in the rohcProfileTable for this instance. There MUST exist a corresponding entry in the rohcProfileTable using the value of rohcContextProfile as second part of the index (and using the same rohcChannelID as first part of the index).
rohcContextDecompressorDepth
1.3.6.1.2.1.112.1.2.1.5
Unsigned32
This object indicates whether reverse decompression, for example as described in RFC 3095, Section 6.1, is used on this channel or not, and if used, to what extent. Its value is only valid for decompressor contexts, i.e., if rohcInstanceType has the value decompressor(2). For compressor contexts where rohcInstanceType has the value compressor(1), the value of this object is irrelevant and MUST be set to zero (0).
The value of the reverse decompression depth indicates the maximum number of packets that are buffered, and thus possibly be reverse decompressed by the decompressor. A zero (0) value means that reverse decompression is not used.
rohcContextStorageTime
1.3.6.1.2.1.112.1.2.1.6
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · centi-seconds
The value of this object specifies how long this row can exist in the rohcContextTable after the rohcContextCIDState switched to expired(3) or
terminated(4). This object returns the remaining time
that the row may exist before it is aged out. The object
is initialized with the value of the associated
rohcContextStorageTime object. After expiration or termination of the context, the value of this object ticks backwards. The entry in the rohcContextTable is destroyed when the value reaches 0.
The value of this object may be set in order to increase or reduce the remaining time that the row may exist. Setting the value to 0 will destroy this entry as soon as the rochContextCIDState has the value expired(3) or terminated(4).
Note that there is no guarantee that the row is stored as long as this object indicates. In case of limited CID space, the instance may re-use a CID before the storage time of the corresponding row in rohcContextTable reaches the value of 0. In this case the information stored in this row is not anymore available.
rohcContextActivationTime
1.3.6.1.2.1.112.1.2.1.7
DateAndTimeA date-time specification.
field octets contents range
----- ------ -------- -----
1 1-2 year* 0..65536
2 3 month 1..12
3 4 day 1..31
4 5 hour 0..23
5 6 minutes 0..59
6 7 seconds 0..60
(use 60 for leap-second)
7 8 deci-seconds 0..9
8 9 direction from UTC '+' / '-'
9 10 hours from UTC* 0..13
10 11 minutes from UTC 0..59
* Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13
For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as:
1992-5-26,13:30:15.0,-4:0
Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The date and time when the context started to be able to compress packets or decompress packets, respectively. The value '0000000000000000'H is returned if the context has not been activated yet.
rohcContextDeactivationTime
1.3.6.1.2.1.112.1.2.1.8
DateAndTimeA date-time specification.
field octets contents range
----- ------ -------- -----
1 1-2 year* 0..65536
2 3 month 1..12
3 4 day 1..31
4 5 hour 0..23
5 6 minutes 0..59
6 7 seconds 0..60
(use 60 for leap-second)
7 8 deci-seconds 0..9
8 9 direction from UTC '+' / '-'
9 10 hours from UTC* 0..13
10 11 minutes from UTC 0..59
* Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13
For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as:
1992-5-26,13:30:15.0,-4:0
Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d
The date and time when the context stopped being able to compress packets or decompress packets, respectively, because it expired or was terminated for other reasons. The value '0000000000000000'H is returned if the context has not been deactivated yet.
rohcContextPackets
1.3.6.1.2.1.112.1.2.1.9
Counter32
The number of all packets passing this context.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable.
rohcContextIRs
1.3.6.1.2.1.112.1.2.1.10
Counter32
The number of all IR packets sent or received, respectively, by this context.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable. Reference: RFC 3095, Section 5.7.7.1
rohcContextIRDYNs
1.3.6.1.2.1.112.1.2.1.11
Counter32
The number of all IR-DYN packets sent or received, respectively, by this context.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable. Reference: RFC 3095, Section 5.7.7.2
rohcContextFeedbacks
1.3.6.1.2.1.112.1.2.1.12
Counter32
The number of all feedbacks sent or received, respectively, by this context.
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable.
rohcContextDecompressorFailures
1.3.6.1.2.1.112.1.2.1.13
Counter32
The number of all decompressor failures so far in this context. The number is only valid for decompressor contexts, i.e., if rohcInstanceType has the value decompressor(2).
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable.
rohcContextDecompressorRepairs
1.3.6.1.2.1.112.1.2.1.14
Counter32
The number of all context repairs so far in this context. The number is only valid for decompressor contexts, i.e., if rohcInstanceType has the value decompressor(2).
Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable.
rohcContextAllPacketsRatio
1.3.6.1.2.1.112.1.2.1.15
RohcCompressionRatioA number indicating a compression ratio over a set of bytes. The value is defined as 1000 * bytes(compressed) / bytes(original) rounded to the next integer value.
Note that compressed sets of bytes can be larger than the corresponding uncompressed ones. Therefore, the number can be greater than 1000. · Unsigned32 · hint d
This object indicates the compression ratio so far over all packets passing this context. The compression is computed over all bytes of the IP packets including the IP header but excluding all lower layer headers.
rohcContextAllHeadersRatio
1.3.6.1.2.1.112.1.2.1.16
RohcCompressionRatioA number indicating a compression ratio over a set of bytes. The value is defined as 1000 * bytes(compressed) / bytes(original) rounded to the next integer value.
Note that compressed sets of bytes can be larger than the corresponding uncompressed ones. Therefore, the number can be greater than 1000. · Unsigned32 · hint d
This object indicates the compression ratio so far over all packet headers passing this context. The compression is computed over all bytes of all headers that are subject to compression for the used profile.
rohcContextAllPacketsMeanSize
1.3.6.1.2.1.112.1.2.1.17
Unsigned32
This object indicates the mean compressed packet size of all packets passing this context. The packet size includes the IP header and payload but excludes all lower layer headers. The mean value is given in byte rounded to the next integer value.
rohcContextAllHeadersMeanSize
1.3.6.1.2.1.112.1.2.1.18
Unsigned32
This object indicates the mean compressed packet header size of all packets passing this context. The packet header size is the sum of the size of all headers of a packet that are subject to compression for the used profile. The mean value is given in byte rounded to the next integer value.
rohcContextLastPacketsRatio
1.3.6.1.2.1.112.1.2.1.19
RohcCompressionRatioA number indicating a compression ratio over a set of bytes. The value is defined as 1000 * bytes(compressed) / bytes(original) rounded to the next integer value.
Note that compressed sets of bytes can be larger than the corresponding uncompressed ones. Therefore, the number can be greater than 1000. · Unsigned32 · hint d
This object indicates the compression ratio concerning the last 16 packets passing this context or concerning all packets passing this context if they are less than 16, so far. The compression is computed over all bytes of the IP packets including the IP header but excluding all lower layer headers.
rohcContextLastHeadersRatio
1.3.6.1.2.1.112.1.2.1.20
RohcCompressionRatioA number indicating a compression ratio over a set of bytes. The value is defined as 1000 * bytes(compressed) / bytes(original) rounded to the next integer value.
Note that compressed sets of bytes can be larger than the corresponding uncompressed ones. Therefore, the number can be greater than 1000. · Unsigned32 · hint d
This object indicates the compression ratio concerning the headers of the last 16 packets passing this context or concerning the headers of all packets passing this context if they are less than 16, so far. The compression is computed over all bytes of all headers that are subject to compression for the used profile.
rohcContextLastPacketsMeanSize
1.3.6.1.2.1.112.1.2.1.21
Unsigned32
This object indicates the mean compressed packet size concerning the last 16 packets passing this context or concerning all packets passing this context if they are less than 16, so far. The packet size includes the IP header and payload but excludes all lower layer headers. The mean value is given in byte rounded to the next integer value.
rohcContextLastHeadersMeanSize
1.3.6.1.2.1.112.1.2.1.22
Unsigned32
This object indicates the mean compressed packet header size concerning the last 16 packets passing this context or concerning all packets passing this context if they are less than 16, so far. The packet header size is the sum of the size of all headers of a packet that are subject to compression for the used profile. The mean value is given in byte rounded to the next integer value.