EZ5 MIB Catalog

RPKI-ROUTER-MIB

2013-05-01

Download RPKI-ROUTER-MIB.txt Open RPKI-ROUTER-MIB.txt in a new tab

This MIB module contains management objects to support monitoring of the Resource Public Key Infrastructure (RPKI) protocol on routers. Copyright (c) 2013 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). This version of this MIB module is part of RFC 6945; see the RFC itself for full legal notices.

SCALARS (1) · TABLES (3) · TRAPS (2)

Scalars (1)

NameOID
rpkiRtrDiscontinuityTimer1.3.6.1.2.1.218.1.1

Tables (3)

NameOID
rpkiRtrCacheServerTable1.3.6.1.2.1.218.1.2
rpkiRtrCacheServerErrorsTableaugments rpkiRtrCacheServerTable1.3.6.1.2.1.218.1.3
rpkiRtrPrefixOriginTable1.3.6.1.2.1.218.1.4

Traps (2)

NameOID
rpkiRtrCacheServerConnectionStateChange1.3.6.1.2.1.218.0.1
rpkiRtrCacheServerConnectionToGoStale1.3.6.1.2.1.218.0.2

END OF TOC

Scalar details

rpkiRtrDiscontinuityTimer

1.3.6.1.2.1.218.1.1

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

This timer represents the timestamp (value of sysUpTime) at which time any of the Counter32 objects in this MIB module encountered a discontinuity. For objects that use rpkiRtrDiscontinuityTimer to indicate discontinuity, only values received since the time indicated by rpkiRtrDiscontinuityTimer are comparable to each other. A manager should take the possibility of rollover into account when calculating difference values. In principle, that should only happen if the SNMP agent or the instrumentation for this MIB module starts or restarts.

Table details

rpkiRtrCacheServerTable

1.3.6.1.2.1.218.1.2

Index: rpkiRtrCacheServerRemoteAddressType · rpkiRtrCacheServerRemoteAddress · rpkiRtrCacheServerRemotePort

This table lists the RPKI cache servers known to this router/system.

rpkiRtrCacheServerRemoteAddressType

1.3.6.1.2.1.218.1.2.1.1

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The network address type of the connection to this RPKI cache server. Note: Only IPv4, IPv6, and DNS support are required for read-only compliance with RFC 6945.

rpkiRtrCacheServerRemoteAddress

1.3.6.1.2.1.218.1.2.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The remote network address for this connection to this RPKI cache server. The format of the address is defined by the value of the corresponding instance of rpkiRtrCacheServerRemoteAddressType. This object matches the address type used within the local router configuration. If the address is of type dns (fqdn), then the router will resolve it at the time it connects to the cache server.

rpkiRtrCacheServerRemotePort

1.3.6.1.2.1.218.1.2.1.3

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (1..65535) · Unsigned32 · hint d

The remote port number for this connection to this RPKI cache server.

rpkiRtrCacheServerLocalAddressType

1.3.6.1.2.1.218.1.2.1.4

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The network address type of the connection to this RPKI cache server. Note: Only IPv4, IPv6, and DNS support are required for read-only compliance with RFC 6945.

rpkiRtrCacheServerLocalAddress

1.3.6.1.2.1.218.1.2.1.5

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The local network address for this connection to this RPKI cache server. The format of the address is defined by the value of the corresponding instance of rpkiRtrCacheServerLocalAddressType. This object matches the address type used within the local router configuration. If the address is of type dns (fqdn), then the router will resolve it at the time it connects to the cache server.

rpkiRtrCacheServerLocalPort

1.3.6.1.2.1.218.1.2.1.6

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (1..65535) · Unsigned32 · hint d

The local port number for this connection to this RPKI cache server.

rpkiRtrCacheServerPreference

1.3.6.1.2.1.218.1.2.1.7

Unsigned32

The routers' preference for this RPKI cache server. A lower value means more preferred. If two entries have the same preference, then the order is arbitrary. In two cases, the maximum value for an Unsigned32 object should be returned for this object: - If no order is specified in the RPKI-Router configuration. - If a preference value is configured that is larger than the max value for an Unsigned32 object.

rpkiRtrCacheServerConnectionType

1.3.6.1.2.1.218.1.2.1.8

RpkiRtrConnectionType1 = ssh2 = tls3 = tcpMD54 = tcpAO5 = tcp6 = ipsec7 = otherThe connection type used between a router (as a client) and a cache server. The following types have been defined in RFC 6810: ssh(1) - Section 7.1; see also RFC 4252. tls(2) - Section 7.2; see also RFC 5246. tcpMD5(3) - Section 7.3; see also RFC 2385. tcpAO(4) - Section 7.4; see also RFC 5925. tcp(5) - Section 7. ipsec(6) - Section 7; see also RFC 4301. other(7) - none of the above.Reference: The RPKI-Router Protocol, RFC 6810, Section 7 · Integer32

The connection type or transport security suite in use for this RPKI cache server.

rpkiRtrCacheServerConnectionStatus

1.3.6.1.2.1.218.1.2.1.9

INTEGER1 = up2 = down · Integer32

The connection status for this entry (connection to this RPKI cache server).

rpkiRtrCacheServerDescription

1.3.6.1.2.1.218.1.2.1.10

LongUtf8StringTo facilitate internationalization, this TC represents information taken from the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 character encoding scheme described in RFC 2044 [10]. For strings in 7-bit US-ASCII, there is no impact since the UTF-8 representation is identical to the US-ASCII encoding. SIZE (0..1024) · OCTET STRING · hint 1024a

Free form description/information for this connection to this RPKI cache server.

rpkiRtrCacheServerMsgsReceived

1.3.6.1.2.1.218.1.2.1.11

Counter32

Number of messages received from this RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerMsgsSent

1.3.6.1.2.1.218.1.2.1.12

Counter32

Number of messages sent to this RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerV4ActiveRecords

1.3.6.1.2.1.218.1.2.1.13

Gauge32

Number of active IPv4 records received from this RPKI cache server via this connection.

rpkiRtrCacheServerV4Announcements

1.3.6.1.2.1.218.1.2.1.14

Counter32

The number of IPv4 records announced by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerV4Withdrawals

1.3.6.1.2.1.218.1.2.1.15

Counter32

The number of IPv4 records withdrawn by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerV6ActiveRecords

1.3.6.1.2.1.218.1.2.1.16

Gauge32

Number of active IPv6 records received from this RPKI cache server via this connection.

rpkiRtrCacheServerV6Announcements

1.3.6.1.2.1.218.1.2.1.17

Counter32

The number of IPv6 records announced by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerV6Withdrawals

1.3.6.1.2.1.218.1.2.1.18

Counter32

The number of IPv6 records withdrawn by the RPKI cache server via this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerLatestSerial

1.3.6.1.2.1.218.1.2.1.19

Unsigned32

The latest serial number of data received from this RPKI server on this connection. Note: this value wraps back to zero when it reaches its maximum value.

rpkiRtrCacheServerSessionID

1.3.6.1.2.1.218.1.2.1.20

Unsigned32 (0..65535)

The Session ID associated with the RPKI cache server at the other end of this connection.

rpkiRtrCacheServerRefreshTimer

1.3.6.1.2.1.218.1.2.1.21

Unsigned32 (60..7200) · seconds

The number of seconds configured for the refresh timer for this connection to this RPKI cache server.

rpkiRtrCacheServerTimeToRefresh

1.3.6.1.2.1.218.1.2.1.22

Integer32 · seconds

The number of seconds remaining before a new refresh is performed via a Serial Query to this cache server over this connection. A negative value means that the refresh time has passed this many seconds and the refresh has not yet been completed. It will stop decrementing at the maximum negative value. Upon a completed refresh (i.e., a successful and complete response to a Serial Query) the value of this attribute will be reinitialized with the value of the corresponding rpkiRtrCacheServerRefreshTimer attribute.

rpkiRtrCacheServerId

1.3.6.1.2.1.218.1.2.1.23

Unsigned32 (1..4294967295)

The unique ID for this connection. An implementation must make sure this ID is unique within this table. It is this ID that can be used to find entries in the rpkiRtrPrefixOriginTable that were created by announcements received on this connection from this cache server.

rpkiRtrCacheServerErrorsTable

1.3.6.1.2.1.218.1.3

augments rpkiRtrCacheServerTable

Index: rpkiRtrCacheServerRemoteAddressType · rpkiRtrCacheServerRemoteAddress · rpkiRtrCacheServerRemotePort

This table provides statistics on errors per RPKI peer connection. These can be used for debugging.

rpkiRtrCacheServerErrorsCorruptData

1.3.6.1.2.1.218.1.3.1.1

Counter32

The number of 'Corrupt Data' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerErrorsInternalError

1.3.6.1.2.1.218.1.3.1.2

Counter32

The number of 'Internal Error' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerErrorsNoData

1.3.6.1.2.1.218.1.3.1.3

Counter32

The number of 'No Data Available' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerErrorsInvalidRequest

1.3.6.1.2.1.218.1.3.1.4

Counter32

The number of 'Invalid Request' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerErrorsUnsupportedVersion

1.3.6.1.2.1.218.1.3.1.5

Counter32

The number of 'Unsupported Protocol Version' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerErrorsUnsupportedPdu

1.3.6.1.2.1.218.1.3.1.6

Counter32

The number of 'Unsupported PDU Type' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerErrorsWithdrawalUnknown

1.3.6.1.2.1.218.1.3.1.7

Counter32

The number of 'Withdrawal of Unknown Record' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrCacheServerErrorsDuplicateAnnounce

1.3.6.1.2.1.218.1.3.1.8

Counter32

The number of 'Duplicate Announcement Received' errors received from the RPKI cache server at the other end of this connection. Discontinuities are indicated by the value of rpkiRtrDiscontinuityTimer.

rpkiRtrPrefixOriginTable

1.3.6.1.2.1.218.1.4

Index: rpkiRtrPrefixOriginAddressType · rpkiRtrPrefixOriginAddress · rpkiRtrPrefixOriginMinLength · rpkiRtrPrefixOriginMaxLength · rpkiRtrPrefixOriginASN · rpkiRtrPrefixOriginCacheServerId

This table lists the prefixes that were announced by RPKI cache servers to this system. That is the prefixes and their Origin Autonomous System Number (ASN) as received by announcements via the RPKI-Router Protocol.

rpkiRtrPrefixOriginAddressType

1.3.6.1.2.1.218.1.4.1.1

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The network address type for this prefix. Note: Only IPv4 and IPv6 support are required for read-only compliance with RFC 6945.

rpkiRtrPrefixOriginAddress

1.3.6.1.2.1.218.1.4.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

The network address for this prefix. The format of the address is defined by the value of the corresponding instance of rpkiRtrPrefixOriginAddressType.

rpkiRtrPrefixOriginMinLength

1.3.6.1.2.1.218.1.4.1.3

InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d

The minimum prefix length allowed for this prefix.

rpkiRtrPrefixOriginMaxLength

1.3.6.1.2.1.218.1.4.1.4

InetAddressPrefixLengthDenotes the length of a generic Internet network address prefix. A value of n corresponds to an IP address mask that has n contiguous 1-bits from the most significant bit (MSB), with all other bits set to 0. An InetAddressPrefixLength value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddressPrefixLength textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddressPrefixLength textual convention, if they appear in the same logical row. InetAddressPrefixLength values larger than the maximum length of an IP address for a specific InetAddressType are treated as the maximum significant value applicable for the InetAddressType. The maximum significant value is 32 for the InetAddressType 'ipv4(1)' and 'ipv4z(3)' and 128 for the InetAddressType 'ipv6(2)' and 'ipv6z(4)'. The maximum significant value for the InetAddressType 'dns(16)' is 0. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where the Internet network address prefix is unknown or does not apply. The upper bound of the prefix length has been chosen to be consistent with the maximum size of an InetAddress. (0..2040) · Unsigned32 · hint d

The maximum prefix length allowed for this prefix. Note, this value must be greater or equal to the value of rpkiRtrPrefixOriginMinLength.

rpkiRtrPrefixOriginASN

1.3.6.1.2.1.218.1.4.1.5

InetAutonomousSystemNumberRepresents an autonomous system number that identifies an Autonomous System (AS). An AS is a set of routers under a single technical administration, using an interior gateway protocol and common metrics to route packets within the AS, and using an exterior gateway protocol to route packets to other ASes'. IANA maintains the AS number space and has delegated large parts to the regional registries. Autonomous system numbers are currently limited to 16 bits (0..65535). There is, however, work in progress to enlarge the autonomous system number space to 32 bits. Therefore, this textual convention uses an Unsigned32 value without a range restriction in order to support a larger autonomous system number space.Reference: RFC 1771, RFC 1930 · Unsigned32 · hint d

The ASN that is authorized to announce the prefix or sub-prefixes covered by this entry.

rpkiRtrPrefixOriginCacheServerId

1.3.6.1.2.1.218.1.4.1.6

Unsigned32 (1..4294967295)

The unique ID of the connection to the cache server from which this announcement was received. That connection is identified/found by a matching value in attribute rpkiRtrCacheServerId.

Trap details

rpkiRtrCacheServerConnectionStateChange

1.3.6.1.2.1.218.0.1

This notification signals a change in the status of an rpkiRtrCacheServerConnection. The management agent MUST throttle the generation of consecutive rpkiRtrCacheServerConnectionStateChange notifications such that there is at least a 5 second gap between them. If more than one notification has occurred locally during that time, the most recent notification is sent at the end of the 5 second gap and the others are discarded.

rpkiRtrCacheServerConnectionStatus

1.3.6.1.2.1.218.1.2.1.9

INTEGER1 = up2 = down · Integer32

The connection status for this entry (connection to this RPKI cache server).

rpkiRtrCacheServerLatestSerial

1.3.6.1.2.1.218.1.2.1.19

Unsigned32

The latest serial number of data received from this RPKI server on this connection. Note: this value wraps back to zero when it reaches its maximum value.

rpkiRtrCacheServerSessionID

1.3.6.1.2.1.218.1.2.1.20

Unsigned32 (0..65535)

The Session ID associated with the RPKI cache server at the other end of this connection.

rpkiRtrCacheServerConnectionToGoStale

1.3.6.1.2.1.218.0.2

This notification signals that an RPKI cache server connection is about to go stale. It is suggested that this notification is generated when the value of the rpkiRtrCacheServerTimeToRefresh attribute goes below 60 seconds. The SNMP agent MUST throttle the generation of consecutive rpkiRtrCacheServerConnectionToGoStale notifications such that there is at least a 5 second gap between them.

rpkiRtrCacheServerV4ActiveRecords

1.3.6.1.2.1.218.1.2.1.13

Gauge32

Number of active IPv4 records received from this RPKI cache server via this connection.

rpkiRtrCacheServerV6ActiveRecords

1.3.6.1.2.1.218.1.2.1.16

Gauge32

Number of active IPv6 records received from this RPKI cache server via this connection.

rpkiRtrCacheServerLatestSerial

1.3.6.1.2.1.218.1.2.1.19

Unsigned32

The latest serial number of data received from this RPKI server on this connection. Note: this value wraps back to zero when it reaches its maximum value.

rpkiRtrCacheServerSessionID

1.3.6.1.2.1.218.1.2.1.20

Unsigned32 (0..65535)

The Session ID associated with the RPKI cache server at the other end of this connection.

rpkiRtrCacheServerRefreshTimer

1.3.6.1.2.1.218.1.2.1.21

Unsigned32 (60..7200) · seconds

The number of seconds configured for the refresh timer for this connection to this RPKI cache server.

rpkiRtrCacheServerTimeToRefresh

1.3.6.1.2.1.218.1.2.1.22

Integer32 · seconds

The number of seconds remaining before a new refresh is performed via a Serial Query to this cache server over this connection. A negative value means that the refresh time has passed this many seconds and the refresh has not yet been completed. It will stop decrementing at the maximum negative value. Upon a completed refresh (i.e., a successful and complete response to a Serial Query) the value of this attribute will be reinitialized with the value of the corresponding rpkiRtrCacheServerRefreshTimer attribute.

↑ To TOC