EZ5 MIB Catalog

RSERPOOL-MIB

2009-04-07

Download RSERPOOL-MIB.txt Open RSERPOOL-MIB.txt in a new tab

The MIB module for managing an RSerPool implementation. Copyright (c) 2009 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met: - Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer. - Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution. - Neither the name of Internet Society, IETF or IETF Trust, nor the names of specific contributors, may be used to endorse or promote products derived from this software without specific prior written permission. THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS 'AS IS' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. This version of this MIB module is part of RFC 5525; see the RFC itself for full legal notices.

TABLES (12)

Tables (12)

NameOID
rserpoolENRPTable1.3.6.1.3.125.1.1.1
rserpoolENRPPoolTable1.3.6.1.3.125.1.1.3
rserpoolENRPPoolElementTable1.3.6.1.3.125.1.1.4
rserpoolENRPASAPAddrTable1.3.6.1.3.125.1.1.5
rserpoolENRPUserAddrTable1.3.6.1.3.125.1.1.6
rserpoolENRPENRPAddrTable1.3.6.1.3.125.1.1.7
rserpoolENRPPeerTable1.3.6.1.3.125.1.1.8
rserpoolENRPPeerAddrTable1.3.6.1.3.125.1.1.9
rserpoolPETable1.3.6.1.3.125.1.2.1
rserpoolPEASAPAddrTable1.3.6.1.3.125.1.2.2
rserpoolPEUserAddrTable1.3.6.1.3.125.1.2.6
rserpoolPUTable1.3.6.1.3.125.1.3.1

END OF TOC

Table details

rserpoolENRPTable

1.3.6.1.3.125.1.1.1

Index: rserpoolENRPIndex

The table listing of ENRP servers.

rserpoolENRPIndex

1.3.6.1.3.125.1.1.1.1.1

Unsigned32 (1..4294967295)

An integer to uniquely identify an ENRP server.

rserpoolENRPOperationScope

1.3.6.1.3.125.1.1.1.1.2

RSerPoolOperationScopeTCThe ID of an operation scope SIZE (0..65535) · OCTET STRING · hint 1024t

The definition of the operation scope of this ENRP server.

rserpoolENRPIdentifier

1.3.6.1.3.125.1.1.1.1.3

RSerPoolENRPServerIdentifierTCThe ID of an ENRP server (1..4294967295) · Unsigned32 · hint x

The ENRP server identifier of this ENRP server.

rserpoolENRPDescription

1.3.6.1.3.125.1.1.1.1.4

OCTET STRING SIZE (0..255)

A textual description of this ENRP server, e.g., its location and a contact address of its administrator. This object SHOULD be maintained in a persistent manner.

rserpoolENRPUptime

1.3.6.1.3.125.1.1.1.1.5

TimeTicks

The ENRP service uptime of this ENRP server.

rserpoolENRPPort

1.3.6.1.3.125.1.1.1.1.6

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

The Stream Control Transmission Protocol (SCTP) port number of the ENRP protocol endpoint of this ENRP server.

rserpoolENRPASAPAnnouncePort

1.3.6.1.3.125.1.1.1.1.7

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

The destination UDP port number to which ASAP multicast announce messages are sent.

rserpoolENRPASAPAnnounceAddrType

1.3.6.1.3.125.1.1.1.1.8

InetAddressType1 = ipv42 = ipv6A value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The network-layer protocol over which ASAP multicast announce messages are sent.

rserpoolENRPASAPAnnounceAddr

1.3.6.1.3.125.1.1.1.1.9

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 16) · OCTET STRING

The destination IP multicast address to which ASAP multicast announce messages are sent. The type of this address is given in rserpoolENRPASAPAnnounceAddrType.

rserpoolENRPENRPAnnouncePort

1.3.6.1.3.125.1.1.1.1.10

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

The destination UDP port number to which ENRP multicast announce messages are sent.

rserpoolENRPENRPAnnounceAddrType

1.3.6.1.3.125.1.1.1.1.11

InetAddressType1 = ipv42 = ipv6A value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The network-layer protocol over which ENRP multicast announce messages are sent.

rserpoolENRPENRPAnnounceAddr

1.3.6.1.3.125.1.1.1.1.12

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 16) · OCTET STRING

The destination multicast IP address to which ENRP multicast announce messages are sent. The type of this address is given in rserpoolENRPENRPAnnounceAddrType.

rserpoolENRPPoolTable

1.3.6.1.3.125.1.1.3

Index: rserpoolENRPIndex · rserpoolENRPPoolIndex

The table listing of pools.

rserpoolENRPPoolIndex

1.3.6.1.3.125.1.1.3.1.1

Unsigned32 (1..4294967295)

An integer to uniquely identify a pool.

rserpoolENRPPoolHandle

1.3.6.1.3.125.1.1.3.1.2

RSerPoolPoolHandleTCThe pool handle SIZE (0..65535) · OCTET STRING · hint 1024t

The pool handle of this pool.

rserpoolENRPPoolElementTable

1.3.6.1.3.125.1.1.4

Index: rserpoolENRPIndex · rserpoolENRPPoolIndex · rserpoolENRPPoolElementIndex

The table listing of pool elements.

rserpoolENRPPoolElementIndex

1.3.6.1.3.125.1.1.4.1.1

Unsigned32 (1..4294967295)

An integer to uniquely identify a pool element. Note, that uniqueness of a pool element identifier in the pool is not enforced; therefore, this index is required here!

rserpoolENRPPoolElementID

1.3.6.1.3.125.1.1.4.1.2

RserpoolPoolElementIdentifierTCThe pool element ID (1..4294967295) · Unsigned32 · hint x

The pool element identifier of this pool element.

rserpoolENRPASAPTransportPort

1.3.6.1.3.125.1.1.4.1.3

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

The SCTP port number of the ASAP endpoint of this pool element.

rserpoolENRPUserTransportProto

1.3.6.1.3.125.1.1.4.1.4

Unsigned32 (0..255)

The transport protocol number of the service endpoint of this pool element.

rserpoolENRPUserTransportPort

1.3.6.1.3.125.1.1.4.1.5

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

The transport protocol's port number of the service endpoint of this pool element.

rserpoolENRPUserTransportUse

1.3.6.1.3.125.1.1.4.1.6

RSerPoolTransportUseTypeTC0 = dataOnly1 = dataPlusControlThe transport use of a pool element · Integer32

The transport use of the service endpoint of this pool element.

rserpoolENRPPolicyID

1.3.6.1.3.125.1.1.4.1.7

RSerPoolPolicyIdentifierTCThe ID of the pool policy (1..4294967295) · Unsigned32 · hint x

The pool policy of this pool element.

rserpoolENRPPolicyDescription

1.3.6.1.3.125.1.1.4.1.8

OCTET STRING SIZE (0..255)

The textual description of the pool policy of this pool element.

rserpoolENRPPolicyWeight

1.3.6.1.3.125.1.1.4.1.9

RSerPoolPolicyWeightTCThe weight of a pool element · Unsigned32 · hint d

The pool policy's weight parameter for this pool element.

rserpoolENRPPolicyLoad

1.3.6.1.3.125.1.1.4.1.10

RSerPoolPolicyLoadTCThe load status of a pool element · Unsigned32 · hint d

The pool policy's load status for this pool element.

rserpoolENRPPolicyLoadDeg

1.3.6.1.3.125.1.1.4.1.11

RSerPoolPolicyLoadTCThe load status of a pool element · Unsigned32 · hint d

The pool policy's load degradation parameter for this pool element.

rserpoolENRPRegistrationLife

1.3.6.1.3.125.1.1.4.1.12

TimeTicks

The registration life of this pool element.

rserpoolENRPHomeENRPServer

1.3.6.1.3.125.1.1.4.1.13

RSerPoolENRPServerIdentifierTCThe ID of an ENRP server (1..4294967295) · Unsigned32 · hint x

The ID of the Home ENRP server of this pool element.

rserpoolENRPASAPAddrTable

1.3.6.1.3.125.1.1.5

Index: rserpoolENRPIndex · rserpoolENRPPoolIndex · rserpoolENRPPoolElementIndex · rserpoolENRPASAPAddrTableIndex

A table listing of all IP addresses of the ASAP transport endpoint.

rserpoolENRPASAPAddrTableIndex

1.3.6.1.3.125.1.1.5.1.1

Unsigned32 (1..4294967295)

A unique identifier for the IP address of an ASAP transport endpoint.

rserpoolENRPASAPL3Type

1.3.6.1.3.125.1.1.5.1.2

InetAddressType1 = ipv42 = ipv6A value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The network-layer protocol (IPv4 or IPv6) of an IP address of an ASAP transport endpoint.

rserpoolENRPASAPL3Addr

1.3.6.1.3.125.1.1.5.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 16) · OCTET STRING

The IP address of an ASAP transport endpoint. The type of this address is given in rserpoolENRPASAPL3Type.

rserpoolENRPUserAddrTable

1.3.6.1.3.125.1.1.6

Index: rserpoolENRPIndex · rserpoolENRPPoolIndex · rserpoolENRPPoolElementIndex · rserpoolENRPUserAddrTableIndex

A table listing of all IP addresses of the user transport endpoint.

rserpoolENRPUserAddrTableIndex

1.3.6.1.3.125.1.1.6.1.1

Unsigned32 (1..4294967295)

A unique identifier for the IP address of a user transport endpoint.

rserpoolENRPUserL3Type

1.3.6.1.3.125.1.1.6.1.2

InetAddressType0 = unknown1 = ipv42 = ipv6A value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The network-layer protocol (IPv4 or IPv6) of an IP address of a user transport endpoint. Set to unknown for an opaque address.

rserpoolENRPUserL3Addr

1.3.6.1.3.125.1.1.6.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0 | 4 | 16) · OCTET STRING

The IP address of a user transport endpoint. The type of this address is given in rserpoolENRPUserL3Type.

rserpoolENRPUserL3Opaque

1.3.6.1.3.125.1.1.6.1.4

RSerPoolOpaqueAddressTCOpaque address SIZE (0..65535) · OCTET STRING · hint 1024t

The opaque address of a user transport endpoint.

rserpoolENRPENRPAddrTable

1.3.6.1.3.125.1.1.7

Index: rserpoolENRPIndex · rserpoolENRPENRPAddrTableIndex

A table listing of all IP addresses of the ENRP transport endpoint.

rserpoolENRPENRPAddrTableIndex

1.3.6.1.3.125.1.1.7.1.1

Unsigned32 (1..4294967295)

A unique identifier for the IP address of an ENRP transport endpoint.

rserpoolENRPENRPL3Type

1.3.6.1.3.125.1.1.7.1.2

InetAddressType1 = ipv42 = ipv6A value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The network-layer protocol (IPv4 or IPv6) of an IP address of an ENRP transport endpoint.

rserpoolENRPENRPL3Addr

1.3.6.1.3.125.1.1.7.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 16) · OCTET STRING

The IP address of an ENRP transport endpoint. The type of this address is given in rserpoolENRPENRPL3Type.

rserpoolENRPPeerTable

1.3.6.1.3.125.1.1.8

Index: rserpoolENRPPeerIndex

The table listing of a peer table.

rserpoolENRPPeerIndex

1.3.6.1.3.125.1.1.8.1.1

Unsigned32 (1..4294967295)

A unique identifier for a peer entry in the table listing of a peer table.

rserpoolENRPPeerIdentifier

1.3.6.1.3.125.1.1.8.1.2

RSerPoolENRPServerIdentifierTCThe ID of an ENRP server (1..4294967295) · Unsigned32 · hint x

The ENRP identifier of this peer.

rserpoolENRPPeerPort

1.3.6.1.3.125.1.1.8.1.3

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

The SCTP port number of the ENRP transport endpoint of this peer.

rserpoolENRPPeerLastHeard

1.3.6.1.3.125.1.1.8.1.4

TimeTicks

The time since the reception of the last ENRP Presence message of this peer.

rserpoolENRPPeerAddrTable

1.3.6.1.3.125.1.1.9

Index: rserpoolENRPPeerIndex · rserpoolENRPPeerAddrTableIndex

A table listing of the peer endpoint addresses.

rserpoolENRPPeerAddrTableIndex

1.3.6.1.3.125.1.1.9.1.1

Unsigned32 (1..4294967295)

A unique identifier for the IP address of a peer ENRP transport endpoint.

rserpoolENRPPeerL3Type

1.3.6.1.3.125.1.1.9.1.2

InetAddressType1 = ipv42 = ipv6A value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The network-layer protocol (IPv4 or IPv6) of an IP address of a peer ENRP transport endpoint.

rserpoolENRPPeerL3Addr

1.3.6.1.3.125.1.1.9.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 16) · OCTET STRING

The IP address of a peer ENRP transport endpoint. The type of this address is given in rserpoolENRPPeerL3Type.

rserpoolPETable

1.3.6.1.3.125.1.2.1

Index: rserpoolPEIndex

The table listing of pool elements.

rserpoolPEIndex

1.3.6.1.3.125.1.2.1.1.1

Unsigned32 (1..4294967295)

An integer to uniquely identify a pool element. Note, that uniqueness of a pool element identifier in the pool is not enforced; therefore, this index is required here!

rserpoolPEOperationScope

1.3.6.1.3.125.1.2.1.1.2

RSerPoolOperationScopeTCThe ID of an operation scope SIZE (0..65535) · OCTET STRING · hint 1024t

The operation scope of this pool element.

rserpoolPEPoolHandle

1.3.6.1.3.125.1.2.1.1.3

RSerPoolPoolHandleTCThe pool handle SIZE (0..65535) · OCTET STRING · hint 1024t

The pool handle of this pool element. Changing this object will update the pool element's pool handle and result in a re-registration. This object SHOULD be maintained in a persistent manner.

rserpoolPEIdentifier

1.3.6.1.3.125.1.2.1.1.4

RserpoolPoolElementIdentifierTCThe pool element ID (1..4294967295) · Unsigned32 · hint x

The pool element identifier of this pool element.

rserpoolPEDescription

1.3.6.1.3.125.1.2.1.1.5

OCTET STRING SIZE (0..255)

A textual description of this pool element, e.g., its location and a contact address of its administrator. This object SHOULD be maintained in a persistent manner.

rserpoolPEUptime

1.3.6.1.3.125.1.2.1.1.6

TimeTicks

The ENRP service uptime of this pool element.

rserpoolPEASAPTransportPort

1.3.6.1.3.125.1.2.1.1.7

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

The SCTP port number of the ASAP endpoint of this pool element.

rserpoolPEUserTransportProto

1.3.6.1.3.125.1.2.1.1.8

Unsigned32 (0..255)

The transport protocol number of the service endpoint of this pool element.

rserpoolPEUserTransportPort

1.3.6.1.3.125.1.2.1.1.9

InetPortNumberRepresents a 16 bit port number of an Internet transport layer protocol. Port numbers are assigned by IANA. A current list of all assignments is available from <http://www.iana.org/>. The value zero is object-specific and must be defined as part of the description of any object that uses this syntax. Examples of the usage of zero might include situations where a port number is unknown, or when the value zero is used as a wildcard in a filter.Reference: STD 6 (RFC 768), STD 7 (RFC 793) and RFC 2960 (0..65535) · Unsigned32 · hint d

The transport protocol's port number of the service endpoint of this pool element.

rserpoolPEUserTransportUse

1.3.6.1.3.125.1.2.1.1.10

RSerPoolTransportUseTypeTC0 = dataOnly1 = dataPlusControlThe transport use of a pool element · Integer32

The transport use of the service endpoint of this pool element.

rserpoolPEPolicyID

1.3.6.1.3.125.1.2.1.1.11

RSerPoolPolicyIdentifierTCThe ID of the pool policy (1..4294967295) · Unsigned32 · hint x

The pool policy of this pool element. Changing this object will update the pool element's policy and result in a re-registration. This object SHOULD be maintained in a persistent manner.

rserpoolPEPolicyDescription

1.3.6.1.3.125.1.2.1.1.12

OCTET STRING SIZE (0..255)

The textual description of the pool policy of this pool element. This object SHOULD be maintained in a persistent manner.

rserpoolPEPolicyWeight

1.3.6.1.3.125.1.2.1.1.13

RSerPoolPolicyWeightTCThe weight of a pool element · Unsigned32 · hint d

The pool policy's weight parameter for this pool element. Changing this object will update the pool element's policy weight setting and result in a re-registration. This object SHOULD be maintained in a persistent manner.

rserpoolPEPolicyLoad

1.3.6.1.3.125.1.2.1.1.14

RSerPoolPolicyLoadTCThe load status of a pool element · Unsigned32 · hint d

The pool policy's load status for this pool element.

rserpoolPEPolicyLoadDeg

1.3.6.1.3.125.1.2.1.1.15

RSerPoolPolicyLoadTCThe load status of a pool element · Unsigned32 · hint d

The pool policy's load degradation parameter for this pool element. Changing this object will update the pool element's load degradation setting and result in a re-registration. This object SHOULD be maintained in a persistent manner.

rserpoolPERegistrationLife

1.3.6.1.3.125.1.2.1.1.16

TimeTicks

The registration life of this pool element. Changing this object will update the pool element's lifetime setting and result in a re-registration. This object SHOULD be maintained in a persistent manner.

rserpoolPEHomeENRPServer

1.3.6.1.3.125.1.2.1.1.17

RSerPoolENRPServerIdentifierTCThe ID of an ENRP server (1..4294967295) · Unsigned32 · hint x

The ID of the Home ENRP server of this pool element.

rserpoolPEASAPAddrTable

1.3.6.1.3.125.1.2.2

Index: rserpoolPEIndex · rserpoolPEASAPAddrTableIndex

A table listing of all IP addresses of the ASAP transport endpoint.

rserpoolPEASAPAddrTableIndex

1.3.6.1.3.125.1.2.2.1.1

Unsigned32 (1..4294967295)

A unique identifier for the IP address of an ASAP transport endpoint.

rserpoolPEASAPL3Type

1.3.6.1.3.125.1.2.2.1.2

InetAddressType1 = ipv42 = ipv6A value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The network-layer protocol (IPv4 or IPv6) of an IP address of an ASAP transport endpoint.

rserpoolPEASAPL3Addr

1.3.6.1.3.125.1.2.2.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (4 | 16) · OCTET STRING

The IP address of an ASAP transport endpoint. The type of this address is given in rserpoolPEASAPL3Type.

rserpoolPEUserAddrTable

1.3.6.1.3.125.1.2.6

Index: rserpoolPEIndex · rserpoolPEUserAddrTableIndex

A table listing of all IP addresses of the user transport endpoint.

rserpoolPEUserAddrTableIndex

1.3.6.1.3.125.1.2.6.1.1

Unsigned32 (1..4294967295)

A unique identifier for the IP address of a user transport endpoint.

rserpoolPEUserL3Type

1.3.6.1.3.125.1.2.6.1.2

InetAddressType0 = unknown1 = ipv42 = ipv6A value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

The network-layer protocol of an IP address of a user transport endpoint. Set to unknown for opaque address.

rserpoolPEUserL3Addr

1.3.6.1.3.125.1.2.6.1.3

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0 | 4 | 16) · OCTET STRING

The IP address of a user transport endpoint. The type of this address is given in rserpoolPEUserL3Addr.

rserpoolPEUserL3Opaque

1.3.6.1.3.125.1.2.6.1.4

RSerPoolOpaqueAddressTCOpaque address SIZE (0..65535) · OCTET STRING · hint 1024t

The opaque address of a user transport endpoint.

rserpoolPUTable

1.3.6.1.3.125.1.3.1

Index: rserpoolPUIndex

The table listing of pool users.

rserpoolPUIndex

1.3.6.1.3.125.1.3.1.1.1

Unsigned32 (1..4294967295)

An integer to uniquely identify a pool user.

rserpoolPUOperationScope

1.3.6.1.3.125.1.3.1.1.2

RSerPoolOperationScopeTCThe ID of an operation scope SIZE (0..65535) · OCTET STRING · hint 1024t

The operation scope of this pool user.

rserpoolPUPoolHandle

1.3.6.1.3.125.1.3.1.1.3

RSerPoolPoolHandleTCThe pool handle SIZE (0..65535) · OCTET STRING · hint 1024t

The pool handle of this pool user. Changing this object will update the pool user's pool handle for all future sessions. This object SHOULD be maintained in a persistent manner.

rserpoolPUDescription

1.3.6.1.3.125.1.3.1.1.4

OCTET STRING SIZE (0..255)

A textual description of this pool user, e.g., its location and a contact address of its administrator. This object SHOULD be maintained in a persistent manner.

rserpoolPUUptime

1.3.6.1.3.125.1.3.1.1.5

TimeTicks

The ENRP service uptime of this pool user.

↑ To TOC