EZ5 MIB Catalog

TED-MIB

2012-12-21

Download TED-MIB.txt Open TED-MIB.txt in a new tab

This MIB module contains managed object definitions for TED in support of MPLS/GMPLS TE Database. Copyright (c) 2013 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info).

SCALARS (2) · TABLES (5) · TRAPS (3)

Scalars (2)

NameOID
tedStatusChangeNotificationMaxRate1.3.6.1.2.1.10.273.1.6
tedCreatedDeletedNotificationMaxRate1.3.6.1.2.1.10.273.1.7

Tables (5)

NameOID
tedTable1.3.6.1.2.1.10.273.1.1
tedLocalIfAddrTable1.3.6.1.2.1.10.273.1.2
tedRemoteIfAddrTable1.3.6.1.2.1.10.273.1.3
tedSwCapTable1.3.6.1.2.1.10.273.1.4
tedSrlgTable1.3.6.1.2.1.10.273.1.5

Traps (3)

NameOID
tedStatusChange1.3.6.1.2.1.10.273.0.1
tedEntryCreated1.3.6.1.2.1.10.273.0.2
tedEntryDeleted1.3.6.1.2.1.10.273.0.3

END OF TOC

Scalar details

tedStatusChangeNotificationMaxRate

1.3.6.1.2.1.10.273.1.6

Unsigned32

A lot of notifications relating to the status change are expected to generate in a node, especially when a network failure occurs and might cause a performance degradation of the node itself. To avoid such a defect, this object provides the maximum number of notifications generated per minute. If events occur more rapidly, the implementation may simply fail to emit these notifications during that period, or may queue them until an appropriate time. A value of 0 means no throttling is applied and events may be notified at the rate at which they occur.

tedCreatedDeletedNotificationMaxRate

1.3.6.1.2.1.10.273.1.7

Unsigned32

A lot of notifications relating to new registration in the TED table by receiving new TE link information or deletion of existing entries in the TED table are expected to generate in a node. This object provides the maximum number of notifications generated per minute.

Table details

tedTable

1.3.6.1.2.1.10.273.1.1

Index: tedLocalRouterId · tedRemoteRouterId · tedLinkInformationSource · tedLinkIndex

This table indicates multiple TED information, which has been supported by RFC 3630 and RFC 5305.

tedLinkInformationSource

1.3.6.1.2.1.10.273.1.1.1.1

INTEGER0 = unknown1 = locallyConfigured2 = ospfv23 = ospfv34 = isis5 = other · Integer32

This object indicates the source of the information about the TE link.

tedLocalRouterId

1.3.6.1.2.1.10.273.1.1.1.2

TedRouterIdTCThe router identifier. If OSPF is used to advertise LSA, this represents a Router ID. If IS-IS is used, this represents a System ID. SIZE (0..6) · OCTET STRING

This object represents the Router ID of the router originating the LSA. If OSPF is used to advertise LSA, this represents a Router ID. If IS-IS is used, this represents a System ID. Otherwise, this represents zero.

tedRemoteRouterId

1.3.6.1.2.1.10.273.1.1.1.3

TedRouterIdTCThe router identifier. If OSPF is used to advertise LSA, this represents a Router ID. If IS-IS is used, this represents a System ID. SIZE (0..6) · OCTET STRING

This object indicates the router at the remote end of the link from the originating router. If OSPF is used to advertise LSA, this represents a Link ID in the Link TLV. If IS-IS is used, this represents a neighbor System ID defined in RFC 5305. Otherwise, this represents zero.

tedLinkIndex

1.3.6.1.2.1.10.273.1.1.1.4

TedLinkIndexTCThe link identifier. If OSPF is used, this represents an ospfLsdbID. If IS-IS is used, this represents an isisLSPID. If a locally configured link is used, this object represents an arbitrary value, which is locally defined in a router. SIZE (0..8) · OCTET STRING

This object indicates the link state identifier. If OSPF is used, this represents an ospfLsdbID. If IS-IS is used, this represents an isisLSPID. Otherwise, this represents a unique identifier within a node.

tedLinkInformationData

1.3.6.1.2.1.10.273.1.1.1.5

RowPointerRepresents a pointer to a conceptual row. The value is the name of the instance of the first accessible columnar object in the conceptual row. For example, ifIndex.3 would point to the 3rd row in the ifTable (note that if ifIndex were not-accessible, then ifDescr.3 would be used instead). · OBJECT IDENTIFIER

If tedLinkInformationSource has the value unknown(0), this object MUST contain a value of zeroDotZero. If tedLinkInformationSource has the value locallyConfigured(1), an implementation can use this object to supply the identifier of the corresponding row entry in the teLinkTable of TE-LINK- STD-MIB (RFC 4220), the identifier of the corresponding row in a local proprietary TE link MIB module, or the value of zeroDotZero. If tedLinkInformationSource has the value ospfv2(2) and ospfv3(3), an implementation can use this object to supply the identifier of the corresponding row entry in the ospfLocalLsdbTable (OSPFv2-MIB) and the ospfv3AreaLsdbTable (OSPFv3-MIB), or the value of zeroDotZero. If tedLinkInformationSource has the value isis(4), an implementation can use this object to supply the identifier of the corresponding row entry in the isisAreaAddr of ISIS-MIB (RFC 4444), or the value of zeroDotZero. If tedLinkInformationSource has the value other(5), an implementation can use this object to supply the identifier of the corresponding row entry in the local proprietary MIB module, or the value of zeroDotZero.

tedLinkState

1.3.6.1.2.1.10.273.1.1.1.6

INTEGER0 = unknown1 = up2 = down · Integer32

This object represents the actual operational state of this TE link. For instance, if a row is created in the TED table, but the actual TE link is not available for some reason (e.g., when there is not yet a physical link or the link has been manually disabled), then the object would be down(2) state. In contrast, if a row is added and the TE link is available, this would be operationally up(1).

tedAreaId

1.3.6.1.2.1.10.273.1.1.1.7

TedAreaIdTCThe area identifier of the IGP. If OSPF is used to advertise LSA, this represents an ospfArea. If IS-IS is used, this represents an area address. SIZE (0..20) · OCTET STRING

This object indicates the area identifier of the IGP. If OSPF is used to advertise LSA, this represents an ospfArea. If IS-IS is used, this represents an area address. Otherwise, this represents zero.

tedLinkType

1.3.6.1.2.1.10.273.1.1.1.8

INTEGER1 = pointToPoint2 = multiAccess · Integer32

This indicates the type of the link, such as point to point or multi-access.

tedTeRouterIdAddrType

1.3.6.1.2.1.10.273.1.1.1.9

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the TE-Router ID address type. Only values unknown(0), ipv4(1), or ipv6(2) are supported.

tedTeRouterIdAddr

1.3.6.1.2.1.10.273.1.1.1.10

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This object indicates the TE-Router ID.

tedLinkIdAddrType

1.3.6.1.2.1.10.273.1.1.1.11

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the address type of the TE Link ID. Only values unknown(0), ipv4(1), or ipv6(2) are supported.

tedLinkIdAddr

1.3.6.1.2.1.10.273.1.1.1.12

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (0..255) · OCTET STRING

This indicates the Router ID of the neighbor in the case of point-to-point links. This also indicates the interface address of the designated router in the case of multi-access links.

tedMetric

1.3.6.1.2.1.10.273.1.1.1.13

Integer32

This indicates the traffic engineering metric value of the TE link.

tedMaxBandwidth

1.3.6.1.2.1.10.273.1.1.1.14

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This indicates the maximum bandwidth that can be used on this link in this direction.

tedMaxReservableBandwidth

1.3.6.1.2.1.10.273.1.1.1.15

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This indicates the maximum bandwidth that may be reserved on this link in this direction.

tedUnreservedBandwidthPri0

1.3.6.1.2.1.10.273.1.1.1.16

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This indicates the amount of bandwidth not yet reserved at the priority 0.

tedUnreservedBandwidthPri1

1.3.6.1.2.1.10.273.1.1.1.17

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This indicates the amount of bandwidth not yet reserved at the priority 1.

tedUnreservedBandwidthPri2

1.3.6.1.2.1.10.273.1.1.1.18

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This indicates the amount of bandwidth not yet reserved at the priority 2.

tedUnreservedBandwidthPri3

1.3.6.1.2.1.10.273.1.1.1.19

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This indicates the amount of bandwidth not yet reserved at the priority 3.

tedUnreservedBandwidthPri4

1.3.6.1.2.1.10.273.1.1.1.20

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This indicates the amount of bandwidth not yet reserved at the priority 4.

tedUnreservedBandwidthPri5

1.3.6.1.2.1.10.273.1.1.1.21

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This indicates the amount of bandwidth not yet reserved at the priority 5.

tedUnreservedBandwidthPri6

1.3.6.1.2.1.10.273.1.1.1.22

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This indicates the amount of bandwidth not yet reserved at the priority 6.

tedUnreservedBandwidthPri7

1.3.6.1.2.1.10.273.1.1.1.23

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This indicates the amount of bandwidth not yet reserved at the priority 7.

tedAdministrativeGroup

1.3.6.1.2.1.10.273.1.1.1.24

Integer32

This indicates the Administrative Group to which the link belongs. Since the value is a bit mask, the link can belong to multiple groups. This is also called Resource Class/Color.

tedLocalId

1.3.6.1.2.1.10.273.1.1.1.25

Integer32

This indicates the Link Local Identifier of an unnumbered link.

tedRemoteId

1.3.6.1.2.1.10.273.1.1.1.26

Integer32

This indicates the Link Remote Identifier of an unnumbered link.

tedLinkProtectionType

1.3.6.1.2.1.10.273.1.1.1.27

BITS

This object indicates the protection type of the TE link.

tedLocalIfAddrTable

1.3.6.1.2.1.10.273.1.2

Index: tedLinkIndex · tedLocalIfAddr

This table contains the IP address information of a local TE link.

tedLocalIfAddrType

1.3.6.1.2.1.10.273.1.2.1.1

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the address type of the local TE link. Only values unknown(0), ipv4(1), or ipv6(2) have to be supported.

tedLocalIfAddr

1.3.6.1.2.1.10.273.1.2.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (1..20) · OCTET STRING

This object indicates the address of the local TE link.

tedRemoteIfAddrTable

1.3.6.1.2.1.10.273.1.3

Index: tedLinkIndex · tedRemoteIfAddr

This table contains the IP address information of a remote TE link.

tedRemoteIfAddrType

1.3.6.1.2.1.10.273.1.3.1.1

InetAddressType0 = unknown1 = ipv42 = ipv63 = ipv4z4 = ipv6z16 = dnsA value that represents a type of Internet address. unknown(0) An unknown address type. This value MUST be used if the value of the corresponding InetAddress object is a zero-length string. It may also be used to indicate an IP address that is not in one of the formats defined below. ipv4(1) An IPv4 address as defined by the InetAddressIPv4 textual convention. ipv6(2) An IPv6 address as defined by the InetAddressIPv6 textual convention. ipv4z(3) A non-global IPv4 address including a zone index as defined by the InetAddressIPv4z textual convention. ipv6z(4) A non-global IPv6 address including a zone index as defined by the InetAddressIPv6z textual convention. dns(16) A DNS domain name as defined by the InetAddressDNS textual convention. Each definition of a concrete InetAddressType value must be accompanied by a definition of a textual convention for use with that InetAddressType. To support future extensions, the InetAddressType textual convention SHOULD NOT be sub-typed in object type definitions. It MAY be sub-typed in compliance statements in order to require only a subset of these address types for a compliant implementation. Implementations must ensure that InetAddressType objects and any dependent objects (e.g., InetAddress objects) are consistent. An inconsistentValue error must be generated if an attempt to change an InetAddressType object would, for example, lead to an undefined InetAddress value. In particular, InetAddressType/InetAddress pairs must be changed together if the address type changes (e.g., from ipv6(2) to ipv4(1)). · Integer32

This object indicates the address type of the remote TE link.

tedRemoteIfAddr

1.3.6.1.2.1.10.273.1.3.1.2

InetAddressDenotes a generic Internet address. An InetAddress value is always interpreted within the context of an InetAddressType value. Every usage of the InetAddress textual convention is required to specify the InetAddressType object that provides the context. It is suggested that the InetAddressType object be logically registered before the object(s) that use the InetAddress textual convention, if they appear in the same logical row. The value of an InetAddress object must always be consistent with the value of the associated InetAddressType object. Attempts to set an InetAddress object to a value inconsistent with the associated InetAddressType must fail with an inconsistentValue error. When this textual convention is used as the syntax of an index object, there may be issues with the limit of 128 sub-identifiers specified in SMIv2, STD 58. In this case, the object definition MUST include a 'SIZE' clause to limit the number of potential instance sub-identifiers; otherwise the applicable constraints MUST be stated in the appropriate conceptual row DESCRIPTION clauses, or in the surrounding documentation if there is no single DESCRIPTION clause that is appropriate. SIZE (1..20) · OCTET STRING

This object indicates the address of the remote TE link.

tedSwCapTable

1.3.6.1.2.1.10.273.1.4

Index: tedLinkIndex · tedSwCapIndex

This table contains the GMPLS TED switching capability information.

tedSwCapIndex

1.3.6.1.2.1.10.273.1.4.1.1

Unsigned32 (1..255)

This index is utilized to identify multiple switching functions on a local or remote TE link according to definitions of textual conventions of GMPLS, RFC 4801.

tedSwCapType

1.3.6.1.2.1.10.273.1.4.1.2

IANAGmplsSwitchingTypeTC0 = unknown1 = psc12 = psc23 = psc34 = psc451 = l2sc100 = tdm150 = lsc200 = fscThis type is used to represent and control the LSP switching type of an LSP signaled by a GMPLS signaling protocol. This textual convention is strongly tied to the Switching Types sub-registry of the GMPLS Signaling Parameters registry managed by IANA. Values should be assigned by IANA in step with the Switching Types sub-registry and using the same registry management rules. However, the actual values used in this textual convention are solely within the purview of IANA and do not necessarily match the values in the Switching Types sub-registry. The definition of this textual convention with the addition of newly assigned values is published periodically by the IANA, in either the Assigned Numbers RFC, or some derivative of it specific to Internet Network Management number assignments. (The latest arrangements can be obtained by contacting the IANA.) Requests for new values should be made to IANA via email (iana@iana.org).Reference: 1. Routing Extensions in Support of Generalized Multi-Protocol Label Switching, RFC 4202, section 2.4. 2. Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description, RFC 3471, section 3.1.1. · Integer32

This object indicates the GMPLS switching capability assigned to the TE link according to definitions of textual conventions of GMPLS, RFC 4801.

tedSwCapEncoding

1.3.6.1.2.1.10.273.1.4.1.3

IANAGmplsLSPEncodingTypeTC0 = tunnelLspNotGmpls1 = tunnelLspPacket2 = tunnelLspEthernet3 = tunnelLspAnsiEtsiPdh5 = tunnelLspSdhSonet7 = tunnelLspDigitalWrapper8 = tunnelLspLambda9 = tunnelLspFiber11 = tunnelLspFiberChannel12 = tunnelDigitalPath13 = tunnelOpticalChannelThis type is used to represent and control the LSP encoding type of an LSP signaled by a GMPLS signaling protocol. This textual convention is strongly tied to the LSP Encoding Types sub-registry of the GMPLS Signaling Parameters registry managed by IANA. Values should be assigned by IANA in step with the LSP Encoding Types sub-registry and using the same registry management rules. However, the actual values used in this textual convention are solely within the purview of IANA and do not necessarily match the values in the LSP Encoding Types sub-registry. The definition of this textual convention with the addition of newly assigned values is published periodically by the IANA, in either the Assigned Numbers RFC, or some derivative of it specific to Internet Network Management number assignments. (The latest arrangements can be obtained by contacting the IANA.) Requests for new values should be made to IANA via email (iana@iana.org).Reference: 1. Generalized Multi-Protocol Label Switching (GMPLS) Signaling Functional Description, RFC 3471, section 3.1.1. 2. Generalized MPLS Signalling Extensions for G.709 Optical Transport Networks Control, RFC 4328, section 3.1.1. · Integer32

This object indicates the GMPLS encoding type assigned to the TE link.

tedSwCapMaxLspBandwidthPri0

1.3.6.1.2.1.10.273.1.4.1.4

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This object indicates the maximum bandwidth of the TE link at the priority 0 for GMPLS LSP creation.

tedSwCapMaxLspBandwidthPri1

1.3.6.1.2.1.10.273.1.4.1.5

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This object indicates the maximum bandwidth of the TE link at the priority 1 for GMPLS LSP creation.

tedSwCapMaxLspBandwidthPri2

1.3.6.1.2.1.10.273.1.4.1.6

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This object indicates the maximum bandwidth of the TE link at the priority 2 for GMPLS LSP creation.

tedSwCapMaxLspBandwidthPri3

1.3.6.1.2.1.10.273.1.4.1.7

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This object indicates the maximum bandwidth of the TE link at the priority 3 for GMPLS LSP creation.

tedSwCapMaxLspBandwidthPri4

1.3.6.1.2.1.10.273.1.4.1.8

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This object indicates the maximum bandwidth of the TE link at the priority 4 for GMPLS LSP creation.

tedSwCapMaxLspBandwidthPri5

1.3.6.1.2.1.10.273.1.4.1.9

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This object indicates the maximum bandwidth of the TE link at the priority 5 for GMPLS LSP creation.

tedSwCapMaxLspBandwidthPri6

1.3.6.1.2.1.10.273.1.4.1.10

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This object indicates the maximum bandwidth of the TE link at the priority 6 for GMPLS LSP creation.

tedSwCapMaxLspBandwidthPri7

1.3.6.1.2.1.10.273.1.4.1.11

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This object indicates the maximum bandwidth of the TE link at the priority 7 for GMPLS LSP creation.

tedSwCapMinLspBandwidth

1.3.6.1.2.1.10.273.1.4.1.12

Float32TCThis type represents a 32-bit (4-octet) IEEE floating-point number in binary interchange format.Reference: IEEE Standard for Floating-Point Arithmetic, Standard 754-2008 SIZE (4) · OCTET STRING · Byte per second

This object indicates the minimum bandwidth of the TE link for GMPLS LSP creation if the switching capability field is TDM, PSC-1, PSC-2, PSC-3, or PSC-4.

tedSwCapIfMtu

1.3.6.1.2.1.10.273.1.4.1.13

Integer32

This object indicates the MTU of the local or remote TE link.

tedSwCapIndication

1.3.6.1.2.1.10.273.1.4.1.14

INTEGER0 = standard1 = arbitrary · Integer32

This object indicates whether the interface supports Standard or Arbitrary SONET/SDH.

tedSrlgTable

1.3.6.1.2.1.10.273.1.5

Index: tedLinkIndex · tedSrlgIndex

This table contains the SRLG information of the TE link.

tedSrlgIndex

1.3.6.1.2.1.10.273.1.5.1.1

Unsigned32 (1..255)

This index is utilized to identify multiple SRLG values on a local or remote TE link. This object represents an arbitrary value, which is locally defined in a router.

tedSrlg

1.3.6.1.2.1.10.273.1.5.1.2

Integer32

This object indicates the SRLG value assigned to a local or remote TE link.

Trap details

tedStatusChange

1.3.6.1.2.1.10.273.0.1

This notification signifies that there has been change in the TE information of tedTable, tedLocalIfAddrTable, tedRemoteIfAddrTable, tedSwCapTable, and/or tedSrlgTable. For example, this should be generated when tedUnreservedBandwidth is changed to create or delete LSP using the registered TE link.

tedLinkState

1.3.6.1.2.1.10.273.1.1.1.6

INTEGER0 = unknown1 = up2 = down · Integer32

This object represents the actual operational state of this TE link. For instance, if a row is created in the TED table, but the actual TE link is not available for some reason (e.g., when there is not yet a physical link or the link has been manually disabled), then the object would be down(2) state. In contrast, if a row is added and the TE link is available, this would be operationally up(1).

tedEntryCreated

1.3.6.1.2.1.10.273.0.2

This notification signifies that there has been new registration in the TED table by receiving new TE link information. For example, this should be generated when a new index (tedLinkIndex) is registered in the TED table.

tedLinkState

1.3.6.1.2.1.10.273.1.1.1.6

INTEGER0 = unknown1 = up2 = down · Integer32

This object represents the actual operational state of this TE link. For instance, if a row is created in the TED table, but the actual TE link is not available for some reason (e.g., when there is not yet a physical link or the link has been manually disabled), then the object would be down(2) state. In contrast, if a row is added and the TE link is available, this would be operationally up(1).

tedEntryDeleted

1.3.6.1.2.1.10.273.0.3

This notification signifies that there has been deletion of an entry in the TED table. For example, this should be generated when one of the existing entries is deleted in the TED table.

tedLinkState

1.3.6.1.2.1.10.273.1.1.1.6

INTEGER0 = unknown1 = up2 = down · Integer32

This object represents the actual operational state of this TE link. For instance, if a row is created in the TED table, but the actual TE link is not available for some reason (e.g., when there is not yet a physical link or the link has been manually disabled), then the object would be down(2) state. In contrast, if a row is added and the TE link is available, this would be operationally up(1).

↑ To TOC