EZ5 MIB Catalog

TRILL-OAM-MIB

2016-01-14

Download TRILL-OAM-MIB.txt Open TRILL-OAM-MIB.txt in a new tab

This MIB module contains the management objects for the management of TRILL Services Operations, Administration and Maintenance. Initial version. Published as RFC 7784. Copyright (c) 2016 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). ------------------------------------------------------------- Abbreviations Used Term Definition CFM Connectivity Fault Management IEEE Institute of Electrical and Electronics Engineers IETF Internet Engineering Task Force ITU-T International Telecommunication Union - Telecommunication Standardization Bureau FCOI The Final, Cross-Connect Error, Out-of-band, and In-band flags from the TRILL OAM Application Identifier TLV. LBM Loopback Message MA Maintenance Association (equivalent to a MEG) MAC Media Access Control MD Maintenance Domain (equivalent to an OAM Domain in Metro Ethernet Forum (MEF) 17) MEG Maintenance Entity Group (equivalent to a MA) MEG Level Maintenance Entity Group Level (equivalent to MD Level) MEP Maintenance Association End Point MIB Management Information Base MIP Maintenance Domain Intermediate Point MTVM Multi-destination Tree Verification Message MTVR Multi-destination Tree Verification Reply OAM Operations, Administration, and Maintenance On-Demand OAM actions that are initiated via manual intervention for a limited time to carry out diagnostics. On-demand OAM can result in singular or periodic OAM actions during the diagnostic time interval. PTM Path Trace Message PTR Path Trace Reply RFC Request for Comments SNMP Simple Network Management Protocol TLV Type-Length-Value, a method of encoding Objects TRILL Transparent Interconnection of Lots of Links VLAN Virtual LAN

TABLES (5) · TRAPS (1)

Tables (5)

NameOID
trillOamMepTableaugments dot1agCfmMepTable (IEEE8021-CFM-MIB)1.3.6.1.2.1.238.1.1.1
trillOamMepFlowCfgTable1.3.6.1.2.1.238.1.1.2
trillOamPtrTable1.3.6.1.2.1.238.1.1.3
trillOamMtvrTable1.3.6.1.2.1.238.1.1.4
trillOamMepDbTableaugments dot1agCfmMepDbTable (IEEE8021-CFM-MIB)1.3.6.1.2.1.238.1.1.5

Traps (1)

NameOID
trillOamFaultAlarm1.3.6.1.2.1.238.0.1

END OF TOC

Table details

trillOamMepTable

1.3.6.1.2.1.238.1.1.1

augments dot1agCfmMepTable (IEEE8021-CFM-MIB)

Index: dot1agCfmMdIndex · dot1agCfmMaIndex · dot1agCfmMepIdentifier

This table is an extension of the dot1agCfmMepTable and rows are automatically added or deleted from this table based upon row creation and destruction of the dot1agCfmMepTable. This table represents the local MEP TRILL OAM configuration table. The primary purpose of this table is provide local parameters for the TRILL OAM function found in RFC 7455 and instantiated at a MEP.

from IEEE8021-CFM-MIB

dot1agCfmMdIndex

Unsigned32 (1..4294967295)

The index to the Maintenance Domain table. dot1agCfmMdTableNextIndex needs to be inspected to find an available index for row-creation. Referential integrity is required, i.e., the index needs to be persistent upon a reboot or restart of a device. The index can never be reused for other Maintenance Domain. The index value SHOULD keep increasing up to the time that they wrap around. This is to facilitate access control based on OID.

dot1agCfmMaIndex

Unsigned32 (1..4294967295)

Index of the MA table dot1agCfmMdMaNextIndex needs to be inspected to find an available index for row-creation.

dot1agCfmMepIdentifier

Dot1agCfmMepIdMaintenance association Endpoint Identifier (MEPID): A small integer, unique over a given Maintenance Association, identifying a specific MEP.Reference: 3.132, 19.2.1 (1..8191) · Unsigned32 · hint d

Integer that is unique among all the MEPs in the same MA. Other definition is: a small integer, unique over a given Maintenance Association, identifying a specific Maintenance association Endpoint (3.132). MEP Identifier is also known as the MEPID.

trillOamMepRName

1.3.6.1.2.1.238.1.1.1.1.1

Unsigned32 (0..65471)

This object contains the RBridge Nickname field of the TRILL RBridge as defined in RFC 6325, Section 3.7.

trillOamMepNextPtmTId

1.3.6.1.2.1.238.1.1.1.1.2

Counter32

Next Sequence Number / Transaction Identifier to be sent in a Multi-destination message. This Sequence Number can be zero because it wraps around. Implementation of this identifier should be should provide a unique code value in order to identify the Transaction Identifier for a MEP with multiple flows.

trillOamMepNextMtvmTId

1.3.6.1.2.1.238.1.1.1.1.3

Counter32

Next Sequence Number / Transaction Identifier to be sent in a Multi-destination message. This Sequence Number can be zero because it wraps around. An implementation should be unique to identify Transaction Identifier for a MEP with multiple flows.

trillOamMepPtrIn

1.3.6.1.2.1.238.1.1.1.1.4

Counter32

Total number of valid, in-order Path Trace Replies received.

trillOamMepPtrInOutofOrder

1.3.6.1.2.1.238.1.1.1.1.5

Counter32

Total number of valid, out-of-order Path Trace Replies received.

trillOamMepPtrOut

1.3.6.1.2.1.238.1.1.1.1.6

Counter32

Total number of valid, Path Trace Replies transmitted.

trillOamMepMtvrIn

1.3.6.1.2.1.238.1.1.1.1.7

Counter32

Total number of valid, in-order Multi-destination Replies received.

trillOamMepMtvrInOutofOrder

1.3.6.1.2.1.238.1.1.1.1.8

Counter32

Total number of valid, out-of-order Multi-destination Replies received.

trillOamMepMtvrOut

1.3.6.1.2.1.238.1.1.1.1.9

Counter32

Total number of valid, Multi-destination Replies transmitted.

trillOamMepTxLbmDestRName

1.3.6.1.2.1.238.1.1.1.1.10

Unsigned32 (0..65471)

The Target Destination RBridge Nickname field, as defined in RFC 6325, Section 3.7, to be transmitted.

trillOamMepTxLbmHC

1.3.6.1.2.1.238.1.1.1.1.11

Unsigned32 (1..63)

The Hop Count field to be transmitted.

trillOamMepTxLbmReplyModeOob

1.3.6.1.2.1.238.1.1.1.1.12

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

True indicates that the Reply to an LBM is out of band and the out-of-band IP Address TLV is to be transmitted. False indicates that in-band reply is transmitted.

trillOamMepTransmitLbmReplyIp

1.3.6.1.2.1.238.1.1.1.1.13

OCTET STRING SIZE (4..16)

The IP address for an out-of-band IP Address TLV that is to be transmitted. Maximum length for IPv6 is 16 octets and IPv4 is 4 octets.

trillOamMepTxLbmFlowEntropy

1.3.6.1.2.1.238.1.1.1.1.14

OCTET STRING SIZE (96)

96-byte Flow Entropy, as defined in RFC 7455, to be transmitted.

trillOamMepTxPtmDestRName

1.3.6.1.2.1.238.1.1.1.1.15

Unsigned32 (0..65471)

The Target Destination RBridge Nickname field, as defined in RFC 6325, Section 3.7, to be transmitted.

trillOamMepTxPtmHC

1.3.6.1.2.1.238.1.1.1.1.16

Unsigned32 (1..63)

The Hop Count field to be transmitted.

trillOamMepTxPtmReplyModeOob

1.3.6.1.2.1.238.1.1.1.1.17

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

True indicates that a Reply to a PTM will be out of band and the out-of-band IP Address TLV is to be transmitted. False indicates that an in-band reply is transmitted.

trillOamMepTransmitPtmReplyIp

1.3.6.1.2.1.238.1.1.1.1.18

OCTET STRING SIZE (4..16)

The IP address for an out-of-band IP Address TLV to be transmitted. The maximum length for an IPv6 address is 16 octets. The maximum length for an IPv4 address is 4 octets.

trillOamMepTxPtmFlowEntropy

1.3.6.1.2.1.238.1.1.1.1.19

OCTET STRING SIZE (96)

96-byte Flow Entropy, as defined in RFC 7455, to be transmitted.

trillOamMepTxPtmStatus

1.3.6.1.2.1.238.1.1.1.1.20

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

A Boolean flag set to TRUE by the MEP Path Trace Initiator State Machine or a MIB manager to indicate that another PTM is being transmitted. This is reset to FALSE by the MEP Initiator State Machine. The PTM managed objects in the MEP table are used in a manner similar to that described for LBM transmission in the dot1agCfmMepTable. As per RFC 7455, Section 10, operation of the Path Trace Message is identical to the Loopback message except that it is first transmitted with a TRILL Header Hop Count field value of 1 and then retransmitted with an incrementing Hop Count until a response is received from the destination RBridge, or the Hop Count reaches a configured maximum value. The trillOamMepTxPtmStatus status is reset to FALSE by the initiator when the last PTM is transmitted.

trillOamMepTxPtmResultOK

1.3.6.1.2.1.238.1.1.1.1.21

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicates the following results of the operation: - true indicates the Path Trace Message(s) will be (or has been) sent. - false indicates the Path Trace Message(s) will not be sent.

trillOamMepTxPtmSeqNumber

1.3.6.1.2.1.238.1.1.1.1.22

Unsigned32

The Path Trace Transaction Identifier of the first PTM (to be) sent. The value returned is undefined if trillOamMepTxPtmResultOK is false.

trillOamMepTxPtmMessages

1.3.6.1.2.1.238.1.1.1.1.23

Integer32 (1..1024)

The number of Path Trace messages to be transmitted. As per RFC 7455, Section 10, the first Path Trace Message is transmitted with a Hop Count of 1; an RBridge may continue to retransmit the request at periodic intervals with an incrementing Hop Count until a response is received from the destination RBridge or the Hop Count reaches a configured maximum value. The event of the Destination response being received or the Hop Count reaching its maximum is treated as a single Counter increment of this object.

trillOamMepTxMtvmTree

1.3.6.1.2.1.238.1.1.1.1.24

Unsigned32

The Multi-destination Tree identifier, as defined in RFC 6325, for an MTVM.

trillOamMepTxMtvmHC

1.3.6.1.2.1.238.1.1.1.1.25

Unsigned32 (1..63)

The Hop Count field to be transmitted.

trillOamMepTxMtvmReplyModeOob

1.3.6.1.2.1.238.1.1.1.1.26

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

True indicates that the reply to an MTVM is out of band and this out-of-band IP Address TLV is where the reply is to be transmitted. False indicates that an in-band reply is transmitted.

trillOamMepTransmitMtvmReplyIp

1.3.6.1.2.1.238.1.1.1.1.27

OCTET STRING SIZE (4..16)

IP address for an out-of-band IP Address TLV that is to be transmitted. The maximum length for IPv6 is 16 octets and IPv4 is 4 octets.

trillOamMepTxMtvmFlowEntropy

1.3.6.1.2.1.238.1.1.1.1.28

OCTET STRING SIZE (96)

96-byte Flow Entropy, as defined in RFC 7455, to be transmitted.

trillOamMepTxMtvmStatus

1.3.6.1.2.1.238.1.1.1.1.29

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

A Boolean flag set to TRUE by the MEP Multi-destination Initiator State Machine or a MIB manager to indicate that another MTVM is being transmitted. Reset to FALSE by the MEP Initiator State Machine. The MTVM-managed objects in the MEP table are used in a manner similar to that described for LBM transmission in the dot1agCfmMepTable. As per RFC 7455, Section 11, operation of the MTVM is identical to the Loopback message except that it is first transmitted with a TRILL Header Hop Count field value of 1 and it is retransmitted incrementing the Hop Count until a response is received from the destination RBridge or the Hop Count reaches a configured maximum value. The trillOamMepTxMtvmStatus Status is reset to FALSE by the initiator when the last MTVM is transmitted.

trillOamMepTxMtvmResultOK

1.3.6.1.2.1.238.1.1.1.1.30

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicates the result of the operation in the following way: - true indicates the Multi-destination Message(s) will be (or has been) sent. - false indicates the Multi-destination Message(s) will not be sent.

trillOamMepTxMtvmMessages

1.3.6.1.2.1.238.1.1.1.1.31

Integer32 (1..1024)

The number of Multi-destination messages to be transmitted. The RBridge transmit the Multi-destination message incrementing the session Identification Number at periodic interval until this count expires.

trillOamMepTxMtvmSeqNumber

1.3.6.1.2.1.238.1.1.1.1.32

Unsigned32

The Multi-destination Transaction Identifier of the first MTVM (to be) sent. The value returned is undefined if trillOamMepTxMtvmResultOK is false.

trillOamMepTxMtvmScopeList

1.3.6.1.2.1.238.1.1.1.1.33

OCTET STRING

The Multi-destination RBridge Scope list, which requires 2 octets per RBridge.

trillOamMepDiscontinuityTime

1.3.6.1.2.1.238.1.1.1.1.34

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

Snapshot of the value of the sysUpTime object at the beginning of the latest period of continuity of the statistical counters associated with this MEP.

trillOamMepFlowCfgTable

1.3.6.1.2.1.238.1.1.2

Index: dot1agCfmMdIndex · dot1agCfmMaIndex · dot1agCfmMepIdentifier · trillOamMepFlowCfgIndex

This table includes configuration objects and operations for the TRILL OAM facilities in RFC 7455. Each row in the table represents a Flow Configuration Entry for the defined MEP. This table uses four indices. The first three indices are the indices of the Maintenance Domain, MANET, and MEP tables. The fourth index is the specific Flow Configuration Entry on the selected MEP. Some writable objects in this table are only applicable in certain cases (as described under each object), and attempts to write values for them in other cases will be ignored.

from IEEE8021-CFM-MIB

dot1agCfmMdIndex

Unsigned32 (1..4294967295)

The index to the Maintenance Domain table. dot1agCfmMdTableNextIndex needs to be inspected to find an available index for row-creation. Referential integrity is required, i.e., the index needs to be persistent upon a reboot or restart of a device. The index can never be reused for other Maintenance Domain. The index value SHOULD keep increasing up to the time that they wrap around. This is to facilitate access control based on OID.

dot1agCfmMaIndex

Unsigned32 (1..4294967295)

Index of the MA table dot1agCfmMdMaNextIndex needs to be inspected to find an available index for row-creation.

dot1agCfmMepIdentifier

Dot1agCfmMepIdMaintenance association Endpoint Identifier (MEPID): A small integer, unique over a given Maintenance Association, identifying a specific MEP.Reference: 3.132, 19.2.1 (1..8191) · Unsigned32 · hint d

Integer that is unique among all the MEPs in the same MA. Other definition is: a small integer, unique over a given Maintenance Association, identifying a specific Maintenance association Endpoint (3.132). MEP Identifier is also known as the MEPID.

trillOamMepFlowCfgIndex

1.3.6.1.2.1.238.1.1.2.1.1

Unsigned32 (1..65535)

An index to the TRILL OAM MEP Flow Configuration table, which indicates the specific flow for the MEP. The index is never reused for other flow sessions on the same MEP while this session is active. The index value keeps increasing until it wraps to 0. This value can also be used in the flow-identifier TLV RFC 7455.

trillOamMepFlowCfgFlowEntropy

1.3.6.1.2.1.238.1.1.2.1.2

OCTET STRING SIZE (96)

This is 96 bytes of Flow Entropy as described in TRILL OAM, RFC 7455.

trillOamMepFlowCfgDestRName

1.3.6.1.2.1.238.1.1.2.1.3

Unsigned32 (0..65471)

The Target Destination RBridge Nickname field, as defined in RFC 6325, Section 3.7, to be transmitted.

trillOamMepFlowCfgFlowHC

1.3.6.1.2.1.238.1.1.2.1.4

Unsigned32 (1..63)

The Hop Count field to be transmitted.

trillOamMepFlowCfgRowStatus

1.3.6.1.2.1.238.1.1.2.1.5

RowStatus1 = active2 = notInService3 = notReady4 = createAndGo5 = createAndWait6 = destroyThe RowStatus textual convention is used to manage the creation and deletion of conceptual rows, and is used as the value of the SYNTAX clause for the status column of a conceptual row (as described in Section 7.7.1 of [2].) The status column has six defined values: - `active', which indicates that the conceptual row is available for use by the managed device; - `notInService', which indicates that the conceptual row exists in the agent, but is unavailable for use by the managed device (see NOTE below); 'notInService' has no implication regarding the internal consistency of the row, availability of resources, or consistency with the current state of the managed device; - `notReady', which indicates that the conceptual row exists in the agent, but is missing information necessary in order to be available for use by the managed device (i.e., one or more required columns in the conceptual row have not been instanciated); - `createAndGo', which is supplied by a management station wishing to create a new instance of a conceptual row and to have its status automatically set to active, making it available for use by the managed device; - `createAndWait', which is supplied by a management station wishing to create a new instance of a conceptual row (but not make it available for use by the managed device); and, - `destroy', which is supplied by a management station wishing to delete all of the instances associated with an existing conceptual row. Whereas five of the six values (all except `notReady') may be specified in a management protocol set operation, only three values will be returned in response to a management protocol retrieval operation: `notReady', `notInService' or `active'. That is, when queried, an existing conceptual row has only three states: it is either available for use by the managed device (the status column has value `active'); it is not available for use by the managed device, though the agent has sufficient information to attempt to make it so (the status column has value `notInService'); or, it is not available for use by the managed device, and an attempt to make it so would fail because the agent has insufficient information (the state column has value `notReady'). NOTE WELL This textual convention may be used for a MIB table, irrespective of whether the values of that table's conceptual rows are able to be modified while it is active, or whether its conceptual rows must be taken out of service in order to be modified. That is, it is the responsibility of the DESCRIPTION clause of the status column to specify whether the status column must not be `active' in order for the value of some other column of the same conceptual row to be modified. If such a specification is made, affected columns may be changed by an SNMP set PDU if the RowStatus would not be equal to `active' either immediately before or after processing the PDU. In other words, if the PDU also contained a varbind that would change the RowStatus value, the column in question may be changed if the RowStatus was not equal to `active' as the PDU was received, or if the varbind sets the status to a value other than 'active'. Also note that whenever any elements of a row exist, the RowStatus column must also exist. To summarize the effect of having a conceptual row with a status column having a SYNTAX clause value of RowStatus, consider the following state diagram: STATE +--------------+-----------+-------------+------------- | A | B | C | D | |status col.|status column| |status column | is | is |status column ACTION |does not exist| notReady | notInService| is active --------------+--------------+-----------+-------------+------------- set status |noError ->D|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndGo |inconsistent- | | | | Value| | | --------------+--------------+-----------+-------------+------------- set status |noError see 1|inconsist- |inconsistent-|inconsistent- column to | or | entValue| Value| Value createAndWait |wrongValue | | | --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError column to | Value| entValue| | active | | | | | | or | | | | | | | |see 2 ->D|see 8 ->D| ->D --------------+--------------+-----------+-------------+------------- set status |inconsistent- |inconsist- |noError |noError ->C column to | Value| entValue| | notInService | | | | | | or | | or | | | | | |see 3 ->C| ->C|see 6 --------------+--------------+-----------+-------------+------------- set status |noError |noError |noError |noError ->A column to | | | | or destroy | ->A| ->A| ->A|see 7 --------------+--------------+-----------+-------------+------------- set any other |see 4 |noError |noError |see 5 column to some| | | | value | | see 1| ->C| ->D --------------+--------------+-----------+-------------+------------- (1) goto B or C, depending on information available to the agent. (2) if other variable bindings included in the same PDU, provide values for all columns which are missing but required, and all columns have acceptable values, then return noError and goto D. (3) if other variable bindings included in the same PDU, provide legal values for all columns which are missing but required, then return noError and goto C. (4) at the discretion of the agent, the return value may be either: inconsistentName: because the agent does not choose to create such an instance when the corresponding RowStatus instance does not exist, or inconsistentValue: if the supplied value is inconsistent with the state of some other MIB object's value, or noError: because the agent chooses to create the instance. If noError is returned, then the instance of the status column must also be created, and the new state is B or C, depending on the information available to the agent. If inconsistentName or inconsistentValue is returned, the row remains in state A. (5) depending on the MIB definition for the column/table, either noError or inconsistentValue may be returned. (6) the return value can indicate one of the following errors: wrongValue: because the agent does not support notInService (e.g., an agent which does not support createAndWait), or inconsistentValue: because the agent is unable to take the row out of service at this time, perhaps because it is in use and cannot be de-activated. (7) the return value can indicate the following error: inconsistentValue: because the agent is unable to remove the row at this time, perhaps because it is in use and cannot be de-activated. (8) the transition to D can fail, e.g., if the values of the conceptual row are inconsistent, then the error code would be inconsistentValue. NOTE: Other processing of (this and other varbinds of) the set request may result in a response other than noError being returned, e.g., wrongValue, noCreation, etc. Conceptual Row Creation There are four potential interactions when creating a conceptual row: selecting an instance-identifier which is not in use; creating the conceptual row; initializing any objects for which the agent does not supply a default; and, making the conceptual row available for use by the managed device. Interaction 1: Selecting an Instance-Identifier The algorithm used to select an instance-identifier varies for each conceptual row. In some cases, the instance- identifier is semantically significant, e.g., the destination address of a route, and a management station selects the instance-identifier according to the semantics. In other cases, the instance-identifier is used solely to distinguish conceptual rows, and a management station without specific knowledge of the conceptual row might examine the instances present in order to determine an unused instance-identifier. (This approach may be used, but it is often highly sub-optimal; however, it is also a questionable practice for a naive management station to attempt conceptual row creation.) Alternately, the MIB module which defines the conceptual row might provide one or more objects which provide assistance in determining an unused instance-identifier. For example, if the conceptual row is indexed by an integer-value, then an object having an integer-valued SYNTAX clause might be defined for such a purpose, allowing a management station to issue a management protocol retrieval operation. In order to avoid unnecessary collisions between competing management stations, `adjacent' retrievals of this object should be different. Finally, the management station could select a pseudo-random number to use as the index. In the event that this index was already in use and an inconsistentValue was returned in response to the management protocol set operation, the management station should simply select a new pseudo-random number and retry the operation. A MIB designer should choose between the two latter algorithms based on the size of the table (and therefore the efficiency of each algorithm). For tables in which a large number of entries are expected, it is recommended that a MIB object be defined that returns an acceptable index for creation. For tables with small numbers of entries, it is recommended that the latter pseudo-random index mechanism be used. Interaction 2: Creating the Conceptual Row Once an unused instance-identifier has been selected, the management station determines if it wishes to create and activate the conceptual row in one transaction or in a negotiated set of interactions. Interaction 2a: Creating and Activating the Conceptual Row The management station must first determine the column requirements, i.e., it must determine those columns for which it must or must not provide values. Depending on the complexity of the table and the management station's knowledge of the agent's capabilities, this determination can be made locally by the management station. Alternately, the management station issues a management protocol get operation to examine all columns in the conceptual row that it wishes to create. In response, for each column, there are three possible outcomes: - a value is returned, indicating that some other management station has already created this conceptual row. We return to interaction 1. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it should supply a value for this column when the conceptual row is to be created. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. Once the column requirements have been determined, a management protocol set operation is accordingly issued. This operation also sets the new instance of the status column to `createAndGo'. When the agent processes the set operation, it verifies that it has sufficient information to make the conceptual row available for use by the managed device. The information available to the agent is provided by two sources: the management protocol set operation which creates the conceptual row, and, implementation-specific defaults supplied by the agent (note that an agent must provide implementation-specific defaults for at least those objects which it implements as read-only). If there is sufficient information available, then the conceptual row is created, a `noError' response is returned, the status column is set to `active', and no further interactions are necessary (i.e., interactions 3 and 4 are skipped). If there is insufficient information, then the conceptual row is not created, and the set operation fails with an error of `inconsistentValue'. On this error, the management station can issue a management protocol retrieval operation to determine if this was because it failed to specify a value for a required column, or, because the selected instance of the status column already existed. In the latter case, we return to interaction 1. In the former case, the management station can re-issue the set operation with the additional information, or begin interaction 2 again using `createAndWait' in order to negotiate creation of the conceptual row. NOTE WELL Regardless of the method used to determine the column requirements, it is possible that the management station might deem a column necessary when, in fact, the agent will not allow that particular columnar instance to be created or written. In this case, the management protocol set operation will fail with an error such as `noCreation' or `notWritable'. In this case, the management station decides whether it needs to be able to set a value for that particular columnar instance. If not, the management station re-issues the management protocol set operation, but without setting a value for that particular columnar instance; otherwise, the management station aborts the row creation algorithm. Interaction 2b: Negotiating the Creation of the Conceptual Row The management station issues a management protocol set operation which sets the desired instance of the status column to `createAndWait'. If the agent is unwilling to process a request of this sort, the set operation fails with an error of `wrongValue'. (As a consequence, such an agent must be prepared to accept a single management protocol set operation, i.e., interaction 2a above, containing all of the columns indicated by its column requirements.) Otherwise, the conceptual row is created, a `noError' response is returned, and the status column is immediately set to either `notInService' or `notReady', depending on whether it has sufficient information to (attempt to) make the conceptual row available for use by the managed device. If there is sufficient information available, then the status column is set to `notInService'; otherwise, if there is insufficient information, then the status column is set to `notReady'. Regardless, we proceed to interaction 3. Interaction 3: Initializing non-defaulted Objects The management station must now determine the column requirements. It issues a management protocol get operation to examine all columns in the created conceptual row. In the response, for each column, there are three possible outcomes: - a value is returned, indicating that the agent implements the object-type associated with this column and had sufficient information to provide a value. For those columns to which the agent provides read-create access (and for which the agent allows their values to be changed after their creation), a value return tells the management station that it may issue additional management protocol set operations, if it desires, in order to change the value associated with this column. - the exception `noSuchInstance' is returned, indicating that the agent implements the object-type associated with this column, and that this column in at least one conceptual row would be accessible in the MIB view used by the retrieval were it to exist. However, the agent does not have sufficient information to provide a value, and until a value is provided, the conceptual row may not be made available for use by the managed device. For those columns to which the agent provides read-create access, the `noSuchInstance' exception tells the management station that it must issue additional management protocol set operations, in order to provide a value associated with this column. - the exception `noSuchObject' is returned, indicating that the agent does not implement the object-type associated with this column or that there is no conceptual row for which this column would be accessible in the MIB view used by the retrieval. As such, the management station can not issue any management protocol set operations to create an instance of this column. If the value associated with the status column is `notReady', then the management station must first deal with all `noSuchInstance' columns, if any. Having done so, the value of the status column becomes `notInService', and we proceed to interaction 4. Interaction 4: Making the Conceptual Row Available Once the management station is satisfied with the values associated with the columns of the conceptual row, it issues a management protocol set operation to set the status column to `active'. If the agent has sufficient information to make the conceptual row available for use by the managed device, the management protocol set operation succeeds (a `noError' response is returned). Otherwise, the management protocol set operation fails with an error of `inconsistentValue'. NOTE WELL A conceptual row having a status column with value `notInService' or `notReady' is unavailable to the managed device. As such, it is possible for the managed device to create its own instances during the time between the management protocol set operation which sets the status column to `createAndWait' and the management protocol set operation which sets the status column to `active'. In this case, when the management protocol set operation is issued to set the status column to `active', the values held in the agent supersede those used by the managed device. If the management station is prevented from setting the status column to `active' (e.g., due to management station or network failure) the conceptual row will be left in the `notInService' or `notReady' state, consuming resources indefinitely. The agent must detect conceptual rows that have been in either state for an abnormally long period of time and remove them. It is the responsibility of the DESCRIPTION clause of the status column to indicate what an abnormally long period of time would be. This period of time should be long enough to allow for human response time (including `think time') between the creation of the conceptual row and the setting of the status to `active'. In the absence of such information in the DESCRIPTION clause, it is suggested that this period be approximately 5 minutes in length. This removal action applies not only to newly-created rows, but also to previously active rows which are set to, and left in, the notInService state for a prolonged period exceeding that which is considered normal for such a conceptual row. Conceptual Row Suspension When a conceptual row is `active', the management station may issue a management protocol set operation which sets the instance of the status column to `notInService'. If the agent is unwilling to do so, the set operation fails with an error of `wrongValue' or `inconsistentValue'. Otherwise, the conceptual row is taken out of service, and a `noError' response is returned. It is the responsibility of the DESCRIPTION clause of the status column to indicate under what circumstances the status column should be taken out of service (e.g., in order for the value of some other column of the same conceptual row to be modified). Conceptual Row Deletion For deletion of conceptual rows, a management protocol set operation is issued which sets the instance of the status column to `destroy'. This request may be made regardless of the current value of the status column (e.g., it is possible to delete conceptual rows which are either `notReady', `notInService' or `active'.) If the operation succeeds, then all instances associated with the conceptual row are immediately removed. · Integer32

The status of the row. The writable columns in a row cannot be changed if the row is active. All columns MUST have a valid value before a row can be activated.

trillOamPtrTable

1.3.6.1.2.1.238.1.1.3

Index: dot1agCfmMdIndex · dot1agCfmMaIndex · dot1agCfmMepIdentifier · trillOamMepPtrTransactionId

This table includes Path Trace Reply objects and operations for the TRILL OAM facilities as described in RFC 7455. Each row in the table represents a Path Trace Reply Entry for the defined MEP and Transaction. This table uses four indices. The first three indices are the indices of the Maintenance Domain, MANET, and MEP tables. The fourth index is the specific Transaction Identifier on the selected MEP. Some writable objects in this table are only applicable in certain cases (as described under each object), and attempts to write values for them in other cases will be ignored.

from IEEE8021-CFM-MIB

dot1agCfmMdIndex

Unsigned32 (1..4294967295)

The index to the Maintenance Domain table. dot1agCfmMdTableNextIndex needs to be inspected to find an available index for row-creation. Referential integrity is required, i.e., the index needs to be persistent upon a reboot or restart of a device. The index can never be reused for other Maintenance Domain. The index value SHOULD keep increasing up to the time that they wrap around. This is to facilitate access control based on OID.

dot1agCfmMaIndex

Unsigned32 (1..4294967295)

Index of the MA table dot1agCfmMdMaNextIndex needs to be inspected to find an available index for row-creation.

dot1agCfmMepIdentifier

Dot1agCfmMepIdMaintenance association Endpoint Identifier (MEPID): A small integer, unique over a given Maintenance Association, identifying a specific MEP.Reference: 3.132, 19.2.1 (1..8191) · Unsigned32 · hint d

Integer that is unique among all the MEPs in the same MA. Other definition is: a small integer, unique over a given Maintenance Association, identifying a specific Maintenance association Endpoint (3.132). MEP Identifier is also known as the MEPID.

trillOamMepPtrTransactionId

1.3.6.1.2.1.238.1.1.3.1.1

Unsigned32

Sequence Number / Transaction Identifier returned by a previous transmit path trace message command, indicating which PTM's response is going to be returned.

trillOamMepPtrHC

1.3.6.1.2.1.238.1.1.3.1.2

Unsigned32 (1..63)

Hop Count field value for a returned PTR.

trillOamMepPtrFlag

1.3.6.1.2.1.238.1.1.3.1.3

Unsigned32 (0..15)

FCOI (TRILL OAM Message TLV) field value for a returned PTR.

trillOamMepPtrErrorCode

1.3.6.1.2.1.238.1.1.3.1.4

Unsigned32 (0..65535)

Return Code and Return Sub-code value for a returned PTR.

trillOamMepPtrTerminalMep

1.3.6.1.2.1.238.1.1.3.1.5

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

A boolean value stating whether the forwarded PTM reached a MEP enclosing its MA, as returned in the Terminal MEP flag of the Flags field.

trillOamMepPtrLastEgressId

1.3.6.1.2.1.238.1.1.3.1.6

Unsigned32 (0..65535)

An Integer field holding the Last Egress Identifier returned in the PTR Upstream RBridge Nickname TLV of the PTR. The Last Egress Identifier identifies the Upstream Nickname.

trillOamMepPtrIngress

1.3.6.1.2.1.238.1.1.3.1.7

Dot1agCfmIngressActionFieldValue0 = ingNoTlv1 = ingOk2 = ingDown3 = ingBlocked4 = ingVidPossible values returned in the ingress action field.Reference: 12.14.7.5.3:g, 20.41.2.6, 21.9.8.1, Table 21-29 · Integer32

The value returned in the Ingress Action field of the PTR. The value ingNoTlv(0) indicates that no Reply Ingress TLV was returned in the PTM.

trillOamMepPtrIngressMac

1.3.6.1.2.1.238.1.1.3.1.8

MacAddressRepresents an 802 MAC address represented in the `canonical' order defined by IEEE 802.1a, i.e., as if it were transmitted least significant bit first, even though 802.5 (in contrast to other 802.x protocols) requires MAC addresses to be transmitted most significant bit first. SIZE (6) · OCTET STRING · hint 1x:

MAC address returned in the ingress MAC address field.

trillOamMepPtrIngressPortIdSubtype

1.3.6.1.2.1.238.1.1.3.1.9

LldpPortIdSubtype1 = interfaceAlias2 = portComponent3 = macAddress4 = networkAddress5 = interfaceName6 = agentCircuitId7 = localThis TC describes the source of a particular type of port identifier used in the LLDP MIB. The enumeration 'interfaceAlias(1)' represents a port identifier based on the ifAlias MIB object, defined in IETF RFC 2863. The enumeration 'portComponent(2)' represents a port identifier based on the value of entPhysicalAlias (defined in IETF RFC 2737) for a port component (i.e., entPhysicalClass value of 'port(10)'), within the containing chassis. The enumeration 'macAddress(3)' represents a port identifier based on a unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order), which has been detected by the agent and associated with a particular port (IEEE Std 802-2001). The enumeration 'networkAddress(4)' represents a port identifier based on a network address, detected by the agent and associated with a particular port. The enumeration 'interfaceName(5)' represents a port identifier based on the ifName MIB object, defined in IETF RFC 2863. The enumeration 'agentCircuitId(6)' represents a port identifier based on the agent-local identifier of the circuit (defined in RFC 3046), detected by the agent and associated with a particular port. The enumeration 'local(7)' represents a port identifier based on a value locally assigned. · Integer32

Ingress Port ID. The format of this object is determined by the value of the trillOamMepPtrIngressPortIdSubtype object.

trillOamMepPtrIngressPortId

1.3.6.1.2.1.238.1.1.3.1.10

LldpPortIdThis TC describes the format of a port identifier string. Objects of this type are always used with an associated LldpPortIdSubtype object, which identifies the format of the particular LldpPortId object instance. If the associated LldpPortIdSubtype object has a value of 'interfaceAlias(1)', then the octet string identifies a particular instance of the ifAlias object (defined in IETF RFC 2863). If the particular ifAlias object does not contain any values, another port identifier type should be used. If the associated LldpPortIdSubtype object has a value of 'portComponent(2)', then the octet string identifies a particular instance of the entPhysicalAlias object (defined in IETF RFC 2737) for a port or backplane component. If the associated LldpPortIdSubtype object has a value of 'macAddress(3)', then this string identifies a particular unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order) associated with the port (IEEE Std 802-2001). If the associated LldpPortIdSubtype object has a value of 'networkAddress(4)', then this string identifies a network address associated with the port. The first octet contains the IANA AddressFamilyNumbers enumeration value for the specific address type, and octets 2 through N contain the networkAddress address value in network byte order. If the associated LldpPortIdSubtype object has a value of 'interfaceName(5)', then the octet string identifies a particular instance of the ifName object (defined in IETF RFC 2863). If the particular ifName object does not contain any values, another port identifier type should be used. If the associated LldpPortIdSubtype object has a value of 'agentCircuitId(6)', then this string identifies a agent-local identifier of the circuit (defined in RFC 3046). If the associated LldpPortIdSubtype object has a value of 'local(7)', then this string identifies a locally assigned port ID. SIZE (1..255) · OCTET STRING

Ingress Port ID. The format of this object is determined by the value of the trillOamMepPtrIngressPortId object.

trillOamMepPtrEgress

1.3.6.1.2.1.238.1.1.3.1.11

Dot1agCfmEgressActionFieldValue0 = egrNoTlv1 = egrOK2 = egrDown3 = egrBlocked4 = egrVidPossible values returned in the egress action fieldReference: 12.14.7.5.3:o, 20.41.2.10, 21.9.9.1, Table 21-31 · Integer32

The value returned in the Egress Action field of the PTR. The value ingNoTlv(0) indicates that no Reply Egress TLV was returned in the PTM.

trillOamMepPtrEgressMac

1.3.6.1.2.1.238.1.1.3.1.12

MacAddressRepresents an 802 MAC address represented in the `canonical' order defined by IEEE 802.1a, i.e., as if it were transmitted least significant bit first, even though 802.5 (in contrast to other 802.x protocols) requires MAC addresses to be transmitted most significant bit first. SIZE (6) · OCTET STRING · hint 1x:

MAC address returned in the egress MAC address field.

trillOamMepPtrEgressPortIdSubtype

1.3.6.1.2.1.238.1.1.3.1.13

LldpPortIdSubtype1 = interfaceAlias2 = portComponent3 = macAddress4 = networkAddress5 = interfaceName6 = agentCircuitId7 = localThis TC describes the source of a particular type of port identifier used in the LLDP MIB. The enumeration 'interfaceAlias(1)' represents a port identifier based on the ifAlias MIB object, defined in IETF RFC 2863. The enumeration 'portComponent(2)' represents a port identifier based on the value of entPhysicalAlias (defined in IETF RFC 2737) for a port component (i.e., entPhysicalClass value of 'port(10)'), within the containing chassis. The enumeration 'macAddress(3)' represents a port identifier based on a unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order), which has been detected by the agent and associated with a particular port (IEEE Std 802-2001). The enumeration 'networkAddress(4)' represents a port identifier based on a network address, detected by the agent and associated with a particular port. The enumeration 'interfaceName(5)' represents a port identifier based on the ifName MIB object, defined in IETF RFC 2863. The enumeration 'agentCircuitId(6)' represents a port identifier based on the agent-local identifier of the circuit (defined in RFC 3046), detected by the agent and associated with a particular port. The enumeration 'local(7)' represents a port identifier based on a value locally assigned. · Integer32

Egress Port ID. The format of this object is determined by the value of the trillOamMepPtrEgressPortIdSubtype object.

trillOamMepPtrEgressPortId

1.3.6.1.2.1.238.1.1.3.1.14

LldpPortIdThis TC describes the format of a port identifier string. Objects of this type are always used with an associated LldpPortIdSubtype object, which identifies the format of the particular LldpPortId object instance. If the associated LldpPortIdSubtype object has a value of 'interfaceAlias(1)', then the octet string identifies a particular instance of the ifAlias object (defined in IETF RFC 2863). If the particular ifAlias object does not contain any values, another port identifier type should be used. If the associated LldpPortIdSubtype object has a value of 'portComponent(2)', then the octet string identifies a particular instance of the entPhysicalAlias object (defined in IETF RFC 2737) for a port or backplane component. If the associated LldpPortIdSubtype object has a value of 'macAddress(3)', then this string identifies a particular unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order) associated with the port (IEEE Std 802-2001). If the associated LldpPortIdSubtype object has a value of 'networkAddress(4)', then this string identifies a network address associated with the port. The first octet contains the IANA AddressFamilyNumbers enumeration value for the specific address type, and octets 2 through N contain the networkAddress address value in network byte order. If the associated LldpPortIdSubtype object has a value of 'interfaceName(5)', then the octet string identifies a particular instance of the ifName object (defined in IETF RFC 2863). If the particular ifName object does not contain any values, another port identifier type should be used. If the associated LldpPortIdSubtype object has a value of 'agentCircuitId(6)', then this string identifies a agent-local identifier of the circuit (defined in RFC 3046). If the associated LldpPortIdSubtype object has a value of 'local(7)', then this string identifies a locally assigned port ID. SIZE (1..255) · OCTET STRING

Egress Port ID. The format of this object is determined by the value of the trillOamMepPtrEgressPortId object.

trillOamMepPtrChassisIdSubtype

1.3.6.1.2.1.238.1.1.3.1.15

LldpChassisIdSubtype1 = chassisComponent2 = interfaceAlias3 = portComponent4 = macAddress5 = networkAddress6 = interfaceName7 = localThis TC describes the source of a chassis identifier. The enumeration 'chassisComponent(1)' represents a chassis identifier based on the value of entPhysicalAlias object (defined in IETF RFC 2737) for a chassis component (i.e., an entPhysicalClass value of 'chassis(3)'). The enumeration 'interfaceAlias(2)' represents a chassis identifier based on the value of ifAlias object (defined in IETF RFC 2863) for an interface on the containing chassis. The enumeration 'portComponent(3)' represents a chassis identifier based on the value of entPhysicalAlias object (defined in IETF RFC 2737) for a port or backplane component (i.e., entPhysicalClass value of 'port(10)' or 'backplane(4)'), within the containing chassis. The enumeration 'macAddress(4)' represents a chassis identifier based on the value of a unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order), of a port on the containing chassis as defined in IEEE Std 802-2001. The enumeration 'networkAddress(5)' represents a chassis identifier based on a network address, associated with a particular chassis. The encoded address is actually composed of two fields. The first field is a single octet, representing the IANA AddressFamilyNumbers value for the specific address type, and the second field is the network address value. The enumeration 'interfaceName(6)' represents a chassis identifier based on the value of ifName object (defined in IETF RFC 2863) for an interface on the containing chassis. The enumeration 'local(7)' represents a chassis identifier based on a locally defined value. · Integer32

This object specifies the format of the Chassis ID returned in the Sender ID TLV of the PTR, if any. This value is meaningless if the trillOamMepPtrChassisId has a length of 0.

trillOamMepPtrChassisId

1.3.6.1.2.1.238.1.1.3.1.16

LldpChassisIdThis TC describes the format of a chassis identifier string. Objects of this type are always used with an associated LldpChassisIdSubtype object, which identifies the format of the particular LldpChassisId object instance. If the associated LldpChassisIdSubtype object has a value of 'chassisComponent(1)', then the octet string identifies a particular instance of the entPhysicalAlias object (defined in IETF RFC 2737) for a chassis component (i.e., an entPhysicalClass value of 'chassis(3)'). If the associated LldpChassisIdSubtype object has a value of 'interfaceAlias(2)', then the octet string identifies a particular instance of the ifAlias object (defined in IETF RFC 2863) for an interface on the containing chassis. If the particular ifAlias object does not contain any values, another chassis identifier type should be used. If the associated LldpChassisIdSubtype object has a value of 'portComponent(3)', then the octet string identifies a particular instance of the entPhysicalAlias object (defined in IETF RFC 2737) for a port or backplane component within the containing chassis. If the associated LldpChassisIdSubtype object has a value of 'macAddress(4)', then this string identifies a particular unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order), of a port on the containing chassis as defined in IEEE Std 802-2001. If the associated LldpChassisIdSubtype object has a value of 'networkAddress(5)', then this string identifies a particular network address, encoded in network byte order, associated with one or more ports on the containing chassis. The first octet contains the IANA Address Family Numbers enumeration value for the specific address type, and octets 2 through N contain the network address value in network byte order. If the associated LldpChassisIdSubtype object has a value of 'interfaceName(6)', then the octet string identifies a particular instance of the ifName object (defined in IETF RFC 2863) for an interface on the containing chassis. If the particular ifName object does not contain any values, another chassis identifier type should be used. If the associated LldpChassisIdSubtype object has a value of 'local(7)', then this string identifies a locally assigned Chassis ID. SIZE (1..255) · OCTET STRING

The Chassis ID returned in the Sender ID TLV of the PTR, if any. The format of this object is determined by the value of the trillOamMepPtrChassisIdSubtype object.

trillOamMepPtrOrganizationSpecificTlv

1.3.6.1.2.1.238.1.1.3.1.17

OCTET STRING SIZE (0 | 4..1500)

All organization-specific TLVs returned in the PTR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated together.

trillOamMepPtrNextHopNicknames

1.3.6.1.2.1.238.1.1.3.1.18

OCTET STRING SIZE (0 | 4..1500)

Next hop RBridge List TLV returned in the PTR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated together.

trillOamMtvrTable

1.3.6.1.2.1.238.1.1.4

Index: dot1agCfmMdIndex · dot1agCfmMaIndex · dot1agCfmMepIdentifier · trillOamMepPtrTransactionId · trillOamMepMtvrReceiveOrder

This table includes Multi-destination Reply objects and operations for the TRILL OAM facilities described in RFC 7455. Each row in the table represents a Multi-destination Reply Entry for the defined MEP and Transaction. This table uses five indices. The first three indices are the indices of the Maintenance Domain, MANET, and MEP tables. The fourth index is the specific Transaction Identifier on the selected MEP. The fifth index is the receive order of Multi-destination replies. Some writable objects in this table are only applicable in certain cases (as described under each object), and attempts to write values for them in other cases will be ignored.

from IEEE8021-CFM-MIB

dot1agCfmMdIndex

Unsigned32 (1..4294967295)

The index to the Maintenance Domain table. dot1agCfmMdTableNextIndex needs to be inspected to find an available index for row-creation. Referential integrity is required, i.e., the index needs to be persistent upon a reboot or restart of a device. The index can never be reused for other Maintenance Domain. The index value SHOULD keep increasing up to the time that they wrap around. This is to facilitate access control based on OID.

dot1agCfmMaIndex

Unsigned32 (1..4294967295)

Index of the MA table dot1agCfmMdMaNextIndex needs to be inspected to find an available index for row-creation.

dot1agCfmMepIdentifier

Dot1agCfmMepIdMaintenance association Endpoint Identifier (MEPID): A small integer, unique over a given Maintenance Association, identifying a specific MEP.Reference: 3.132, 19.2.1 (1..8191) · Unsigned32 · hint d

Integer that is unique among all the MEPs in the same MA. Other definition is: a small integer, unique over a given Maintenance Association, identifying a specific Maintenance association Endpoint (3.132). MEP Identifier is also known as the MEPID.

trillOamMepMtvrTransactionId

1.3.6.1.2.1.238.1.1.4.1.1

Unsigned32

Sequence Number / Transaction Identifier returned by a previously transmitted Multi-destination message command indicating which MTVM's response is going to be returned.

trillOamMepMtvrReceiveOrder

1.3.6.1.2.1.238.1.1.4.1.2

Unsigned32 (1..4294967295)

An index to distinguish among multiple MTVRs with same MTVR Transaction Identifier field value. trillOamMepMtvrReceiveOrder is assigned sequentially from 1, in the order that the Multi-destination Tree Initiator received the MTVRs.

trillOamMepMtvrFlag

1.3.6.1.2.1.238.1.1.4.1.3

Unsigned32 (0..15)

FCOI (TRILL OAM Message TLV) field value for a returned MTVR.

trillOamMepMtvrErrorCode

1.3.6.1.2.1.238.1.1.4.1.4

Unsigned32 (0..65535)

Return Code and Return Sub-code value for a returned MTVR.

trillOamMepMtvrLastEgressId

1.3.6.1.2.1.238.1.1.4.1.5

Unsigned32 (0..65535)

An Integer field holding the Last Egress Identifier returned in the MTVR Upstream RBridge Nickname TLV of the MTVR. The Last Egress Identifier identifies the Upstream Nickname.

trillOamMepMtvrIngress

1.3.6.1.2.1.238.1.1.4.1.6

Dot1agCfmIngressActionFieldValue0 = ingNoTlv1 = ingOk2 = ingDown3 = ingBlocked4 = ingVidPossible values returned in the ingress action field.Reference: 12.14.7.5.3:g, 20.41.2.6, 21.9.8.1, Table 21-29 · Integer32

The value returned in the Ingress Action field of the MTVR. The value ingNoTlv(0) indicates that no Reply Ingress TLV was returned in the MTVM.

trillOamMepMtvrIngressMac

1.3.6.1.2.1.238.1.1.4.1.7

MacAddressRepresents an 802 MAC address represented in the `canonical' order defined by IEEE 802.1a, i.e., as if it were transmitted least significant bit first, even though 802.5 (in contrast to other 802.x protocols) requires MAC addresses to be transmitted most significant bit first. SIZE (6) · OCTET STRING · hint 1x:

MAC address returned in the ingress MAC address field.

trillOamMepMtvrIngressPortIdSubtype

1.3.6.1.2.1.238.1.1.4.1.8

LldpPortIdSubtype1 = interfaceAlias2 = portComponent3 = macAddress4 = networkAddress5 = interfaceName6 = agentCircuitId7 = localThis TC describes the source of a particular type of port identifier used in the LLDP MIB. The enumeration 'interfaceAlias(1)' represents a port identifier based on the ifAlias MIB object, defined in IETF RFC 2863. The enumeration 'portComponent(2)' represents a port identifier based on the value of entPhysicalAlias (defined in IETF RFC 2737) for a port component (i.e., entPhysicalClass value of 'port(10)'), within the containing chassis. The enumeration 'macAddress(3)' represents a port identifier based on a unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order), which has been detected by the agent and associated with a particular port (IEEE Std 802-2001). The enumeration 'networkAddress(4)' represents a port identifier based on a network address, detected by the agent and associated with a particular port. The enumeration 'interfaceName(5)' represents a port identifier based on the ifName MIB object, defined in IETF RFC 2863. The enumeration 'agentCircuitId(6)' represents a port identifier based on the agent-local identifier of the circuit (defined in RFC 3046), detected by the agent and associated with a particular port. The enumeration 'local(7)' represents a port identifier based on a value locally assigned. · Integer32

Ingress Port ID. The format of this object is determined by the value of the trillOamMepMtvrIngressPortIdSubtype object.

trillOamMepMtvrIngressPortId

1.3.6.1.2.1.238.1.1.4.1.9

LldpPortIdThis TC describes the format of a port identifier string. Objects of this type are always used with an associated LldpPortIdSubtype object, which identifies the format of the particular LldpPortId object instance. If the associated LldpPortIdSubtype object has a value of 'interfaceAlias(1)', then the octet string identifies a particular instance of the ifAlias object (defined in IETF RFC 2863). If the particular ifAlias object does not contain any values, another port identifier type should be used. If the associated LldpPortIdSubtype object has a value of 'portComponent(2)', then the octet string identifies a particular instance of the entPhysicalAlias object (defined in IETF RFC 2737) for a port or backplane component. If the associated LldpPortIdSubtype object has a value of 'macAddress(3)', then this string identifies a particular unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order) associated with the port (IEEE Std 802-2001). If the associated LldpPortIdSubtype object has a value of 'networkAddress(4)', then this string identifies a network address associated with the port. The first octet contains the IANA AddressFamilyNumbers enumeration value for the specific address type, and octets 2 through N contain the networkAddress address value in network byte order. If the associated LldpPortIdSubtype object has a value of 'interfaceName(5)', then the octet string identifies a particular instance of the ifName object (defined in IETF RFC 2863). If the particular ifName object does not contain any values, another port identifier type should be used. If the associated LldpPortIdSubtype object has a value of 'agentCircuitId(6)', then this string identifies a agent-local identifier of the circuit (defined in RFC 3046). If the associated LldpPortIdSubtype object has a value of 'local(7)', then this string identifies a locally assigned port ID. SIZE (1..255) · OCTET STRING

Ingress Port ID. The format of this object is determined by the value of the trillOamMepMtvrIngressPortId object.

trillOamMepMtvrEgress

1.3.6.1.2.1.238.1.1.4.1.10

Dot1agCfmEgressActionFieldValue0 = egrNoTlv1 = egrOK2 = egrDown3 = egrBlocked4 = egrVidPossible values returned in the egress action fieldReference: 12.14.7.5.3:o, 20.41.2.10, 21.9.9.1, Table 21-31 · Integer32

The value returned in the Egress Action field of the MTVR. The value ingNoTlv(0) indicates that no Reply Egress TLV was returned in the MTVR.

trillOamMepMtvrEgressMac

1.3.6.1.2.1.238.1.1.4.1.11

MacAddressRepresents an 802 MAC address represented in the `canonical' order defined by IEEE 802.1a, i.e., as if it were transmitted least significant bit first, even though 802.5 (in contrast to other 802.x protocols) requires MAC addresses to be transmitted most significant bit first. SIZE (6) · OCTET STRING · hint 1x:

MAC address returned in the egress MAC address field.

trillOamMepMtvrEgressPortIdSubtype

1.3.6.1.2.1.238.1.1.4.1.12

LldpPortIdSubtype1 = interfaceAlias2 = portComponent3 = macAddress4 = networkAddress5 = interfaceName6 = agentCircuitId7 = localThis TC describes the source of a particular type of port identifier used in the LLDP MIB. The enumeration 'interfaceAlias(1)' represents a port identifier based on the ifAlias MIB object, defined in IETF RFC 2863. The enumeration 'portComponent(2)' represents a port identifier based on the value of entPhysicalAlias (defined in IETF RFC 2737) for a port component (i.e., entPhysicalClass value of 'port(10)'), within the containing chassis. The enumeration 'macAddress(3)' represents a port identifier based on a unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order), which has been detected by the agent and associated with a particular port (IEEE Std 802-2001). The enumeration 'networkAddress(4)' represents a port identifier based on a network address, detected by the agent and associated with a particular port. The enumeration 'interfaceName(5)' represents a port identifier based on the ifName MIB object, defined in IETF RFC 2863. The enumeration 'agentCircuitId(6)' represents a port identifier based on the agent-local identifier of the circuit (defined in RFC 3046), detected by the agent and associated with a particular port. The enumeration 'local(7)' represents a port identifier based on a value locally assigned. · Integer32

Egress Port ID. The format of this object is determined by the value of the trillOamMepMtvrEgressPortIdSubtype object.

trillOamMepMtvrEgressPortId

1.3.6.1.2.1.238.1.1.4.1.13

LldpPortIdThis TC describes the format of a port identifier string. Objects of this type are always used with an associated LldpPortIdSubtype object, which identifies the format of the particular LldpPortId object instance. If the associated LldpPortIdSubtype object has a value of 'interfaceAlias(1)', then the octet string identifies a particular instance of the ifAlias object (defined in IETF RFC 2863). If the particular ifAlias object does not contain any values, another port identifier type should be used. If the associated LldpPortIdSubtype object has a value of 'portComponent(2)', then the octet string identifies a particular instance of the entPhysicalAlias object (defined in IETF RFC 2737) for a port or backplane component. If the associated LldpPortIdSubtype object has a value of 'macAddress(3)', then this string identifies a particular unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order) associated with the port (IEEE Std 802-2001). If the associated LldpPortIdSubtype object has a value of 'networkAddress(4)', then this string identifies a network address associated with the port. The first octet contains the IANA AddressFamilyNumbers enumeration value for the specific address type, and octets 2 through N contain the networkAddress address value in network byte order. If the associated LldpPortIdSubtype object has a value of 'interfaceName(5)', then the octet string identifies a particular instance of the ifName object (defined in IETF RFC 2863). If the particular ifName object does not contain any values, another port identifier type should be used. If the associated LldpPortIdSubtype object has a value of 'agentCircuitId(6)', then this string identifies a agent-local identifier of the circuit (defined in RFC 3046). If the associated LldpPortIdSubtype object has a value of 'local(7)', then this string identifies a locally assigned port ID. SIZE (1..255) · OCTET STRING

Egress Port ID. The format of this object is determined by the value of the trillOamMepMtvrEgressPortId object.

trillOamMepMtvrChassisIdSubtype

1.3.6.1.2.1.238.1.1.4.1.14

LldpChassisIdSubtype1 = chassisComponent2 = interfaceAlias3 = portComponent4 = macAddress5 = networkAddress6 = interfaceName7 = localThis TC describes the source of a chassis identifier. The enumeration 'chassisComponent(1)' represents a chassis identifier based on the value of entPhysicalAlias object (defined in IETF RFC 2737) for a chassis component (i.e., an entPhysicalClass value of 'chassis(3)'). The enumeration 'interfaceAlias(2)' represents a chassis identifier based on the value of ifAlias object (defined in IETF RFC 2863) for an interface on the containing chassis. The enumeration 'portComponent(3)' represents a chassis identifier based on the value of entPhysicalAlias object (defined in IETF RFC 2737) for a port or backplane component (i.e., entPhysicalClass value of 'port(10)' or 'backplane(4)'), within the containing chassis. The enumeration 'macAddress(4)' represents a chassis identifier based on the value of a unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order), of a port on the containing chassis as defined in IEEE Std 802-2001. The enumeration 'networkAddress(5)' represents a chassis identifier based on a network address, associated with a particular chassis. The encoded address is actually composed of two fields. The first field is a single octet, representing the IANA AddressFamilyNumbers value for the specific address type, and the second field is the network address value. The enumeration 'interfaceName(6)' represents a chassis identifier based on the value of ifName object (defined in IETF RFC 2863) for an interface on the containing chassis. The enumeration 'local(7)' represents a chassis identifier based on a locally defined value. · Integer32

This object specifies the format of the Chassis ID returned in the Sender ID TLV of the MTVR, if any. This value is meaningless if the trillOamMepMtvrChassisId has a length of 0.

trillOamMepMtvrChassisId

1.3.6.1.2.1.238.1.1.4.1.15

LldpChassisIdThis TC describes the format of a chassis identifier string. Objects of this type are always used with an associated LldpChassisIdSubtype object, which identifies the format of the particular LldpChassisId object instance. If the associated LldpChassisIdSubtype object has a value of 'chassisComponent(1)', then the octet string identifies a particular instance of the entPhysicalAlias object (defined in IETF RFC 2737) for a chassis component (i.e., an entPhysicalClass value of 'chassis(3)'). If the associated LldpChassisIdSubtype object has a value of 'interfaceAlias(2)', then the octet string identifies a particular instance of the ifAlias object (defined in IETF RFC 2863) for an interface on the containing chassis. If the particular ifAlias object does not contain any values, another chassis identifier type should be used. If the associated LldpChassisIdSubtype object has a value of 'portComponent(3)', then the octet string identifies a particular instance of the entPhysicalAlias object (defined in IETF RFC 2737) for a port or backplane component within the containing chassis. If the associated LldpChassisIdSubtype object has a value of 'macAddress(4)', then this string identifies a particular unicast source address (encoded in network byte order and IEEE 802.3 canonical bit order), of a port on the containing chassis as defined in IEEE Std 802-2001. If the associated LldpChassisIdSubtype object has a value of 'networkAddress(5)', then this string identifies a particular network address, encoded in network byte order, associated with one or more ports on the containing chassis. The first octet contains the IANA Address Family Numbers enumeration value for the specific address type, and octets 2 through N contain the network address value in network byte order. If the associated LldpChassisIdSubtype object has a value of 'interfaceName(6)', then the octet string identifies a particular instance of the ifName object (defined in IETF RFC 2863) for an interface on the containing chassis. If the particular ifName object does not contain any values, another chassis identifier type should be used. If the associated LldpChassisIdSubtype object has a value of 'local(7)', then this string identifies a locally assigned Chassis ID. SIZE (1..255) · OCTET STRING

The Chassis ID returned in the Sender ID TLV of the MTVR, if any. The format of this object is determined by the value of the trillOamMepMtvrChassisIdSubtype object.

trillOamMepMtvrOrganizationSpecificTlv

1.3.6.1.2.1.238.1.1.4.1.16

OCTET STRING SIZE (0 | 4..1500)

All organization-specific TLVs returned in the MTVR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated together.

trillOamMepMtvrNextHopNicknames

1.3.6.1.2.1.238.1.1.4.1.17

OCTET STRING SIZE (0 | 4..1500)

Next hop RBridge List TLV returned in the PTR, if any. Includes all octets including and following the TLV Length field of each TLV, concatenated together.

trillOamMepMtvrReceiverAvailability

1.3.6.1.2.1.238.1.1.4.1.18

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

A value of true indicates that the MTVR response contained Multicast receiver availability TLV.

trillOamMepMtvrReceiverCount

1.3.6.1.2.1.238.1.1.4.1.19

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicates the number of multicast receivers available on the responding RBridge on the VLAN specified by the diagnostic VLAN.

trillOamMepDbTable

1.3.6.1.2.1.238.1.1.5

augments dot1agCfmMepDbTable (IEEE8021-CFM-MIB)

Index: dot1agCfmMdIndex · dot1agCfmMaIndex · dot1agCfmMepIdentifier · dot1agCfmMepDbRMepIdentifier

This table is an extension of the dot1agCfmMepDbTable and rows are automatically added to or deleted from this table based upon row creation and destruction of the dot1agCfmMepDbTable.

from IEEE8021-CFM-MIB

dot1agCfmMdIndex

Unsigned32 (1..4294967295)

The index to the Maintenance Domain table. dot1agCfmMdTableNextIndex needs to be inspected to find an available index for row-creation. Referential integrity is required, i.e., the index needs to be persistent upon a reboot or restart of a device. The index can never be reused for other Maintenance Domain. The index value SHOULD keep increasing up to the time that they wrap around. This is to facilitate access control based on OID.

dot1agCfmMaIndex

Unsigned32 (1..4294967295)

Index of the MA table dot1agCfmMdMaNextIndex needs to be inspected to find an available index for row-creation.

dot1agCfmMepIdentifier

Dot1agCfmMepIdMaintenance association Endpoint Identifier (MEPID): A small integer, unique over a given Maintenance Association, identifying a specific MEP.Reference: 3.132, 19.2.1 (1..8191) · Unsigned32 · hint d

Integer that is unique among all the MEPs in the same MA. Other definition is: a small integer, unique over a given Maintenance Association, identifying a specific Maintenance association Endpoint (3.132). MEP Identifier is also known as the MEPID.

dot1agCfmMepDbRMepIdentifier

Dot1agCfmMepIdMaintenance association Endpoint Identifier (MEPID): A small integer, unique over a given Maintenance Association, identifying a specific MEP.Reference: 3.132, 19.2.1 (1..8191) · Unsigned32 · hint d

Maintenance association Endpoint Identifier of a remote MEP whose information from the MEP Database is to be returned.

trillOamMepDbFlowIndex

1.3.6.1.2.1.238.1.1.5.1.1

Unsigned32 (1..65535)

This object identifies the flow. If the Flow Identifier TLV is received, then the index received can also be used.

trillOamMepDbFlowEntropy

1.3.6.1.2.1.238.1.1.5.1.2

OCTET STRING SIZE (96)

96 byte Flow Entropy.

trillOamMepDbFlowState

1.3.6.1.2.1.238.1.1.5.1.3

Dot1agCfmRemoteMepState1 = rMepIdle2 = rMepStart3 = rMepFailed4 = rMepOkOperational state of the remote MEP state machine. This state machine monitors the reception of valid CCMs from a remote MEP with a specific MEPID. It uses a timer that expires in 3.5 times the length of time indicated by the dot1agCfmMaNetCcmInterval object. rMepIdle(1) Momentary state during reset. rMepStart(2) The timer has not expired since the state machine was reset, and no valid CCM has yet been received. rMepFailed(3) The timer has expired, both since the state machine was reset, and since a valid CCM was received. rMepOk(4) The timer has not expired since a valid CCM was received.Reference: 12.14.7.6.3:b, 20.22 · Integer32

The operational state of the remote MEP (flow-based) IFF State machines. State Machine is running now per flow.

trillOamMepDbFlowFailedOkTime

1.3.6.1.2.1.238.1.1.5.1.4

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The Time (sysUpTime) at which the Remote MEP flow state machine last entered either the RMEP_FAILED or RMEP_OK state.

trillOamMepDbRBridgeName

1.3.6.1.2.1.238.1.1.5.1.5

Unsigned32 (0..65471)

Remote MEP RBridge Nickname.

trillOamMepDbLastGoodSeqNum

1.3.6.1.2.1.238.1.1.5.1.6

Counter32

Last Sequence Number received.

Trap details

trillOamFaultAlarm

1.3.6.1.2.1.238.0.1

A MEP flow has a persistent defect condition. A notification (fault alarm) is sent to the management entity with the OID of the flow that has detected the fault. The management entity receiving the notification can identify the system from the network source address of the notification and can identify the flow reporting the defect by the indices in the OID of the trillOamMepFlowIndex and trillOamFlowDefect variable in the notification: dot1agCfmMdIndex - Also the index of the MEP's Maintenance Domain table entry (dot1agCfmMdTable). dot1agCfmMaIndex - Also an index (with the MD table index) of the MEP's Maintenance Association network table entry (dot1agCfmMaNetTable) and (with the MD table index and component ID) of the MEP's MA component table entry (dot1agCfmMaCompTable). dot1agCfmMepIdentifier - MEP Identifier and final index into the MEP table (dot1agCfmMepTable). trillOamMepFlowCfgIndex - Index identifies indicates the specific flow for the MEP

trillOamMepDbFlowState

1.3.6.1.2.1.238.1.1.5.1.3

Dot1agCfmRemoteMepState1 = rMepIdle2 = rMepStart3 = rMepFailed4 = rMepOkOperational state of the remote MEP state machine. This state machine monitors the reception of valid CCMs from a remote MEP with a specific MEPID. It uses a timer that expires in 3.5 times the length of time indicated by the dot1agCfmMaNetCcmInterval object. rMepIdle(1) Momentary state during reset. rMepStart(2) The timer has not expired since the state machine was reset, and no valid CCM has yet been received. rMepFailed(3) The timer has expired, both since the state machine was reset, and since a valid CCM was received. rMepOk(4) The timer has not expired since a valid CCM was received.Reference: 12.14.7.6.3:b, 20.22 · Integer32

The operational state of the remote MEP (flow-based) IFF State machines. State Machine is running now per flow.

↑ To TOC