EZ5 MIB Catalog

VPLS-LDP-MIB

2014-05-19

Download VPLS-LDP-MIB.txt Open VPLS-LDP-MIB.txt in a new tab

Copyright (c) 2014 IETF Trust and the persons identified as authors of the code. All rights reserved. Redistribution and use in source and binary forms, with or without modification, is permitted pursuant to, and subject to the license terms contained in, the Simplified BSD License set forth in Section 4.c of the IETF Trust's Legal Provisions Relating to IETF Documents (http://trustee.ietf.org/license-info). The initial version of this MIB module was published in RFC 7257; for full legal notices see the RFC itself. This MIB module contains managed object definitions for LDP-signaled Virtual Private LAN Services as in RFC 4762. This MIB module enables the use of any underlying pseudowire network.

TABLES (2) · TRAPS (1)

Tables (2)

NameOID
vplsLdpConfigTable1.3.6.1.2.1.10.275.1.1
vplsLdpPwBindTable1.3.6.1.2.1.10.275.1.2

Traps (1)

NameOID
vplsLdpPwBindMacTableFull1.3.6.1.2.1.10.275.0.1

END OF TOC

Table details

vplsLdpConfigTable

1.3.6.1.2.1.10.275.1.1

Index: vplsConfigIndex

This table specifies information for configuring and monitoring LDP-specific parameters for Virtual Private LAN Service (VPLS).

from VPLS-GENERIC-MIB

vplsConfigIndex

Unsigned32 (1..2147483647)

Unique index for the conceptual row identifying a VPLS service.

vplsLdpConfigMacAddrWithdraw

1.3.6.1.2.1.10.275.1.1.1.1

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies if MAC address withdrawal is enabled in this service. If this object is 'true', then MAC address withdrawal is enabled. If 'false', then MAC address withdrawal is disabled.

vplsLdpPwBindTable

1.3.6.1.2.1.10.275.1.2

Index: vplsConfigIndex · pwIndex

This table provides LDP-specific information for an association between a VPLS service and the corresponding pseudowires. A service can have more than one pseudowire association. Pseudowires are defined in the pwTable.

from VPLS-GENERIC-MIB

vplsConfigIndex

Unsigned32 (1..2147483647)

Unique index for the conceptual row identifying a VPLS service.

from PW-STD-MIB

pwIndex

PwIndexTypePseudowire Index. A unique value, greater than zero, for each locally defined PW. Used for indexing several MIB tables associated with the particular PW. It is recommended that values are assigned contiguously starting from 1. The value for each PW MUST remain constant at least from one re-initialization to the next re-initialization. (1..4294967295) · Unsigned32 · hint d

A unique index for the conceptual row identifying a PW within this table.

vplsLdpPwBindMacAddressLimit

1.3.6.1.2.1.10.275.1.2.1.1

Unsigned32

The value of this object specifies the maximum number of learned and static entries allowed in the Forwarding database for this PW Binding. The value 0 means there is no limit for this PW Binding.

Trap details

vplsLdpPwBindMacTableFull

1.3.6.1.2.1.10.275.0.1

The vplsLdpPwBindMacTableFull notification is generated when the number of learned MAC addresses increases to the value specified in vplsLdpPwBindMacAddressLimit.

vplsConfigName

1.3.6.1.2.1.10.274.1.2.1.2

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t

A textual name of the VPLS. If there is no local name, or this object is otherwise not applicable, then this object MUST contain a zero-length octet string.

pwID

1.3.6.1.2.1.10.246.1.2.1.12

PwIDTypePseudowire Identifier. Used to identify the PW (together with some other fields) in the signaling session. · Unsigned32 · hint d

Pseudowire identifier. If the pwOwner object is 'pwIdFecSignaling' or 'l2tpControlProtocol', then this object is signaled in the outgoing PW ID field within the 'Virtual Circuit FEC Element'. For other values of pwOwner, this object is not signaled and it MAY be set to zero. For implementations that support the pwIndexMappingTable, a non-zero value is RECOMMENDED, even if this identifier is not signaled. This is so that reverse mappings can be provided by pwIndexMappingTable and pwPeerMappingTable. It is therefore RECOMMENDED that the value of this pwID be unique (or if pwPeerAddrType is not 'unknown', at least [pwType, pwID, pwPeerAddrType, pwPeerAddr] is unique.)

↑ To TOC