EZ5 MIB Catalog

CISCO-FRAME-RELAY-MIB

2000-10-13

Cisco Frame Relay MIB

Download CISCO-FRAME-RELAY-MIB.txt Open CISCO-FRAME-RELAY-MIB.txt in a new tab

SCALARS (1) · TABLES (9)

Scalars (1)

NameOID
cfrElmiIpAddr1.3.6.1.4.1.9.9.49.1.5.1

Tables (9)

NameOID
cfrLmiTableaugments frDlcmiTable (FRAME-RELAY-DTE-MIB)1.3.6.1.4.1.9.9.49.1.1.1
cfrCircuitTableaugments frCircuitTable (FRAME-RELAY-DTE-MIB)1.3.6.1.4.1.9.9.49.1.2.1
cfrExtCircuitTableaugments frCircuitTable (FRAME-RELAY-DTE-MIB)1.3.6.1.4.1.9.9.49.1.2.2
cfrMapTable1.3.6.1.4.1.9.9.49.1.3.1
cfrSvcTable1.3.6.1.4.1.9.9.49.1.4.1
cfrElmiTable1.3.6.1.4.1.9.9.49.1.5.2
cfrElmiNeighborTable1.3.6.1.4.1.9.9.49.1.5.3
cfrFragTable1.3.6.1.4.1.9.9.49.1.6.1
cfrConnectionTable1.3.6.1.4.1.9.9.49.1.7.1

END OF TOC

Scalar details

cfrElmiIpAddr

1.3.6.1.4.1.9.9.49.1.5.1

IpAddress SIZE (4)

This object represents the Management address of the device used for address registration. Network management station can send management messages to this IP address. This can be user configured address or the address of one of the interfaces on the device. If address registration is disabled then this will have a value of 0.0.0.0. This object is accessible only if the ELMI protocol is supported on the device

Table details

cfrLmiTable

1.3.6.1.4.1.9.9.49.1.1.1

augments frDlcmiTable (FRAME-RELAY-DTE-MIB)

Index: frDlcmiIfIndex

Reference: American National Standard T1.617-1991, Annex D

Table of Frame Relay LMI information that are either supplemental to the frDlcmiTable of RFC 1315 or specific to Cisco's implementation.

from FRAME-RELAY-DTE-MIB

frDlcmiIfIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

The ifIndex value of the corresponding ifEntry.

cfrLmiLinkstatus

1.3.6.1.4.1.9.9.49.1.1.1.1.1

INTEGER1 = up2 = down · Integer32

Data link status via LMI.

cfrLmiLinkType

1.3.6.1.4.1.9.9.49.1.1.1.1.2

INTEGER1 = dte2 = dce3 = nni · Integer32

Frame Relay link type.

cfrLmiEnquiryIns

1.3.6.1.4.1.9.9.49.1.1.1.1.3

Counter32 · messages

Number of Status Enquiry messages received.

cfrLmiEnquiryOuts

1.3.6.1.4.1.9.9.49.1.1.1.1.4

Counter32 · messages

Number of Status Enquiry messages sent.

cfrLmiStatusIns

1.3.6.1.4.1.9.9.49.1.1.1.1.5

Counter32 · messages

Number of Status messages received.

cfrLmiStatusOuts

1.3.6.1.4.1.9.9.49.1.1.1.1.6

Counter32 · messages

Number of Status messages sent.

cfrLmiUpdateStatusIns

1.3.6.1.4.1.9.9.49.1.1.1.1.7

Counter32 · messages

Number of Update Status messages received.

cfrLmiUpdateStatusOuts

1.3.6.1.4.1.9.9.49.1.1.1.1.8

Counter32 · messages

Number of Update Status messages sent

cfrLmiStatusTimeouts

1.3.6.1.4.1.9.9.49.1.1.1.1.9

Counter32 · times

Number of times when timeout occurred on waiting for Status message

cfrLmiStatusEnqTimeouts

1.3.6.1.4.1.9.9.49.1.1.1.1.10

Counter32 · times

Number of times when timeout occurred on waiting for Status Enquiry message

cfrLmiN392Dce

1.3.6.1.4.1.9.9.49.1.1.1.1.11

INTEGER (0..10) · Integer32

LMI error threshold for DCE interface. For DTE, value becomes 0.

cfrLmiN393Dce

1.3.6.1.4.1.9.9.49.1.1.1.1.12

INTEGER (0..10) · Integer32

LMI monitored event count for DCE interface. For DTE, value becomes zero (0).

cfrLmiT392Dce

1.3.6.1.4.1.9.9.49.1.1.1.1.13

INTEGER (0..30) · Integer32 · seconds

DCE polling verification timer for DCE interface For DTE, the value becomes zero (0).

cfrCircuitTable

1.3.6.1.4.1.9.9.49.1.2.1

augments frCircuitTable (FRAME-RELAY-DTE-MIB)

Index: frCircuitIfIndex · frCircuitDlci

Table of descriptive and statistics information that are generic to Frame Relay virtual circuits.

from FRAME-RELAY-DTE-MIB

frCircuitIfIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

The ifIndex Value of the ifEntry this virtual circuit is layered onto.

frCircuitDlci

DLCIThe range of DLCI values. Note that this varies by interface configuration; normally, interfaces may use 0..1023, but may be configured to use ranges as large as 0..2^23. (0..8388607) · Integer32

Reference: American National Standard T1.618-1991, Section 3.3.6

The Data Link Connection Identifier for this virtual circuit.

cfrCircuitDEins

1.3.6.1.4.1.9.9.49.1.2.1.1.1

Counter32 · packets

Number of packets received with the Discarded Eligibility indictor (the DE bit) set.

cfrCircuitDEouts

1.3.6.1.4.1.9.9.49.1.2.1.1.2

Counter32 · packets

Number of packets transmitted with DE bit set.

cfrCircuitDropPktsOuts

1.3.6.1.4.1.9.9.49.1.2.1.1.3

Counter32 · packets

Number of discarded packets that were to be sent.

cfrCircuitType

1.3.6.1.4.1.9.9.49.1.2.1.1.4

INTEGER1 = pvc2 = svc · Integer32

Basic circuit type

cfrExtCircuitTable

1.3.6.1.4.1.9.9.49.1.2.2

augments frCircuitTable (FRAME-RELAY-DTE-MIB)

Index: frCircuitIfIndex · frCircuitDlci

Table of Cisco implementation specific FR circuit information. This is a Cisco extension for the frCircuitTable of RFC 1315.

from FRAME-RELAY-DTE-MIB

frCircuitIfIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

The ifIndex Value of the ifEntry this virtual circuit is layered onto.

frCircuitDlci

DLCIThe range of DLCI values. Note that this varies by interface configuration; normally, interfaces may use 0..1023, but may be configured to use ranges as large as 0..2^23. (0..8388607) · Integer32

Reference: American National Standard T1.618-1991, Section 3.3.6

The Data Link Connection Identifier for this virtual circuit.

cfrExtCircuitIfName

1.3.6.1.4.1.9.9.49.1.2.2.1.1

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The textual name of the main interface or the subinterface that this DLCI is associated with. This is the same name string of an interface used in the configuration and all console displays, such as 'serial 0', 'serial 3/0.3', etc.

cfrExtCircuitIfType

1.3.6.1.4.1.9.9.49.1.2.2.1.2

INTEGER1 = mainInterface2 = pointToPoint3 = multipoint · Integer32

Type of the subinterface this DLCI is associated with, if configured.

cfrExtCircuitSubifIndex

1.3.6.1.4.1.9.9.49.1.2.2.1.3

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

For value greater than zero (0), it indicates the network management interface index for the subinterface associated with this DLCI. Value 0 means the DLCI is not associated with any subinterface.

cfrExtCircuitMapStatus

1.3.6.1.4.1.9.9.49.1.2.2.1.4

INTEGER (0..2047) · Integer32

The mapping protocols (internally considered as the 'link type') applied on this circuit. The value ranges from 0 to 2047. For point-to-point DLCI, the value stays zero. Otherwise, the value is a sum. It initially takes the value zero, then, for each type of Protocol, 2 raised to a power is added to the sum. The following table presents respective power and equivalent value for each applicable type: Protocol Power Value -------- ----- ----- IP 0 1 IPX 1 2 Appletalk 2 4 XNS 3 8 VINES 4 16 DECnet 5 32 CLNS 6 64 Bridging 7 128 RSRB 8 256 STUN 9 512 LLC2 10 1024 For example, value 3 means the circuit's mapping protocols include IP and IPX. (3 = 2**1 + 2**0, where 0 corresponds to IP and 1 to IPX.) Value 0 means there is currently no mapping protocol for the circuit. See cfrMapTable for more mapping information.

cfrExtCircuitCreateType

1.3.6.1.4.1.9.9.49.1.2.2.1.5

INTEGER1 = dynamic2 = static · Integer32

Identify the last source of the circuit's creation.

cfrExtCircuitMulticast

1.3.6.1.4.1.9.9.49.1.2.2.1.6

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicate if this DLCI is a multicast DLCI.

cfrExtCircuitRoutedDlci

1.3.6.1.4.1.9.9.49.1.2.2.1.7

DlciNumberNumerical format of Data Link Connection Identifier (DLCI) in decimal, identical to the 'DLCI' as INTEGER of 0..DLCINumber in RFC1315. The maximum value depends on Frame Relay implementation, which is currently set to be 1023 for 2-octet address format per UNI Implementation Agreement FRF.1. (0..1023) · Integer32

The routed DLCI to pair up with this DLCI for switching function. NOTE: Value zero (0) indicates that there is no such routed DLCI corresponding to this DLCI.

cfrExtCircuitRoutedIf

1.3.6.1.4.1.9.9.49.1.2.2.1.8

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

The interface for the routed DLCI that pairs up with this DLCI for switching. Value greater than 0 is the InterfaceIndex for that interface. Value zero (0) indicates that there is no such routed DLCI corresponding to this DLCI.

cfrExtCircuitUncompressIns

1.3.6.1.4.1.9.9.49.1.2.2.1.9

Counter32 · octets

Number of inbound octets of the data packets, accounted at Frame Relay level after FRF.9 payload decompression is applied. In the case of non-FRF.9, this value could be identical to frCircuitReceivedOctets, unless otherwise noted.

cfrExtCircuitUncompressOuts

1.3.6.1.4.1.9.9.49.1.2.2.1.10

Counter32 · octets

Number of outbound octets of the data packets, accounted at Frame Relay level before FRF.9 payload compression is applied. In the case of non-FRF.9, this value could be identical to frCircuitSentOctets, unless otherwise noted.

cfrExtCircuitFECNOuts

1.3.6.1.4.1.9.9.49.1.2.2.1.11

Counter32

Total number of frames sent out to the network indicating forward congestion.

cfrExtCircuitBECNOuts

1.3.6.1.4.1.9.9.49.1.2.2.1.12

Counter32

Total number of frames sent out to the network indicating backward congestion.

cfrExtCircuitMinThruputOut

1.3.6.1.4.1.9.9.49.1.2.2.1.13

Integer32 (9600..1544000) · bits per second

Circuit's outgoing minimal Throughput based on configuration.

cfrExtCircuitMinThruputIn

1.3.6.1.4.1.9.9.49.1.2.2.1.14

Integer32 (9600..1544000) · bits per second

Circuit's incoming minimal Throughput based on configuration.

cfrExtCircuitBcastPktOuts

1.3.6.1.4.1.9.9.49.1.2.2.1.15

Counter32

Total number of broadcast packets sent out to the network.

cfrExtCircuitBcastByteOuts

1.3.6.1.4.1.9.9.49.1.2.2.1.16

Counter32

Total number of bytes sent out to the network in broadcast packets.

cfrExtCircuitBandwidth

1.3.6.1.4.1.9.9.49.1.2.2.1.17

Integer32 (0..16777215) · bits per second

Bandwidth of the virtual circuit, acquired from Cisco typed LMI Full Status message.

cfrExtCircuitShapeByteLimit

1.3.6.1.4.1.9.9.49.1.2.2.1.18

Integer32 (125..2147483647) · octets

Maximum number of tokens a token bucket can hold in any time interval in case of traffic shaping.

cfrExtCircuitShapeInterval

1.3.6.1.4.1.9.9.49.1.2.2.1.19

Integer32 (10..125) · milliseconds

Committed rate measurement interval.

cfrExtCircuitShapeByteIncrement

1.3.6.1.4.1.9.9.49.1.2.2.1.20

Integer32 (125..2147483647) · octets

Number of tokens added into the token bucket per time interval in case of traffic shaping.

cfrExtCircuitShapePkts

1.3.6.1.4.1.9.9.49.1.2.2.1.21

Counter32

Total number of packets that went through traffic shaping.

cfrExtCircuitShapeBytes

1.3.6.1.4.1.9.9.49.1.2.2.1.22

Counter32 · octets

Total number of bytes that went through traffic shaping.

cfrExtCircuitShapePktsDelay

1.3.6.1.4.1.9.9.49.1.2.2.1.23

Counter32

Total number of packets that were delayed by the traffic shaper.

cfrExtCircuitShapeBytesDelay

1.3.6.1.4.1.9.9.49.1.2.2.1.24

Counter32 · octets

Total number of bytes that were delayed by the traffic shaper.

cfrExtCircuitShapeActive

1.3.6.1.4.1.9.9.49.1.2.2.1.25

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Shows whether shaping is active or not.

cfrExtCircuitShapeAdapting

1.3.6.1.4.1.9.9.49.1.2.2.1.26

INTEGER1 = none2 = becn3 = foreSight · Integer32

Type of Adaptive Shaping configured. none(1) - No adaptive shaping configured becn(2) - Backward Explicit Congestion Notification foreSight(3) - ForeSight is the network traffic control software used in Cisco WAN switches

cfrExtCircuitTxDataRate

1.3.6.1.4.1.9.9.49.1.2.2.1.27

INTEGER (1..45000000) · Integer32

The average rate (bytes/second) at which data is transmitted in this circuit.

cfrExtCircuitTxPktRate

1.3.6.1.4.1.9.9.49.1.2.2.1.28

INTEGER (1..45000000) · Integer32

The average number of packets sent in a second in this circuit.

cfrExtCircuitRcvDataRate

1.3.6.1.4.1.9.9.49.1.2.2.1.29

INTEGER (1..45000000) · Integer32

The average rate (bytes/second) at which data is received in this circuit.

cfrExtCircuitRcvPktRate

1.3.6.1.4.1.9.9.49.1.2.2.1.30

INTEGER (1..45000000) · Integer32

The average number of packets received in a second in this circuit.

cfrMapTable

1.3.6.1.4.1.9.9.49.1.3.1

Index: frCircuitIfIndex · frCircuitDlci · cfrMapIndex

Table of protocols and addresses mapping information of FR virtual circuit.

from FRAME-RELAY-DTE-MIB

frCircuitIfIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

The ifIndex Value of the ifEntry this virtual circuit is layered onto.

frCircuitDlci

DLCIThe range of DLCI values. Note that this varies by interface configuration; normally, interfaces may use 0..1023, but may be configured to use ranges as large as 0..2^23. (0..8388607) · Integer32

Reference: American National Standard T1.618-1991, Section 3.3.6

The Data Link Connection Identifier for this virtual circuit.

cfrMapIndex

1.3.6.1.4.1.9.9.49.1.3.1.1.1

INTEGER (1..999) · Integer32

An arbitrary Index to the mapping information associated with a certain circuit. The maximum value is arbitrarily picked which is considered sufficient for usual configuration.

cfrMapProtocol

1.3.6.1.4.1.9.9.49.1.3.1.1.2

CfrMapProtocols1 = arp6 = serialArp7 = ip10 = xns11 = novell12 = apollo13 = vines16 = appletalk18 = ieeeSpanning22 = decnet25 = clns37 = rsrb38 = bridge39 = stun40 = frArp47 = uncompressedTcp48 = compressedTcp49 = llc253 = frSwitch63 = dlsw74 = nhrp83 = compressedRtp999 = wildcardCisco link types (network protocols) that run over Frame Relay. Associated values, except for wildcard, match assigned values of internal software respectively. · Integer32

Mapping protocol for this circuit.

cfrMapAddress

1.3.6.1.4.1.9.9.49.1.3.1.1.3

OCTET STRING SIZE (0..64)

Mapping protocol address at remote end for this DLCI. NOTE: For point-to-point DLCI, the string is fixed to be point-to-point.

cfrMapType

1.3.6.1.4.1.9.9.49.1.3.1.1.4

INTEGER1 = static2 = dynamic3 = svc · Integer32

Type for the map creation.

cfrMapEncaps

1.3.6.1.4.1.9.9.49.1.3.1.1.5

INTEGER1 = ietf2 = cisco · Integer32

Indication of the encapsulation type for this mapping protocol.

cfrMapBroadcast

1.3.6.1.4.1.9.9.49.1.3.1.1.6

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Broadcast enabled or disabled.

cfrMapPayloadCompress

1.3.6.1.4.1.9.9.49.1.3.1.1.7

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicate if payload compression is enabled.

cfrMapTcpHdrCompress

1.3.6.1.4.1.9.9.49.1.3.1.1.8

INTEGER1 = inapplicable2 = passive3 = active · Integer32

TCP header compression type, if applicable.

cfrMapRtpHdrCompress

1.3.6.1.4.1.9.9.49.1.3.1.1.9

INTEGER1 = inapplicable2 = passive3 = active · Integer32

RTP header compression type, if applicable. The value 'passive' means that the header of an outgoing RTP/IP packet is compressed only if an incoming RTP/IP packet had a compressed header. The value 'active' means the header of every outgoing RTP/IP packet is compressed.

cfrMapPayloadCompressType

1.3.6.1.4.1.9.9.49.1.3.1.1.10

INTEGER1 = inapplicable2 = cisco3 = frf9Software4 = frf9Hardware · Integer32

Reference: Frame Relay Forum document number FRF.9

FR payload compression type, if applicable. FRF.9 is the Frame Relay Forum Implementation Agreement on FR payload compression. The compression can be done by either software or hardware (when equipped with the supporting hardware), depending on configuration.

cfrSvcTable

1.3.6.1.4.1.9.9.49.1.4.1

Index: frCircuitIfIndex · frCircuitDlci

Table of FR SVC specific, descriptive and statistics information.

from FRAME-RELAY-DTE-MIB

frCircuitIfIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

The ifIndex Value of the ifEntry this virtual circuit is layered onto.

frCircuitDlci

DLCIThe range of DLCI values. Note that this varies by interface configuration; normally, interfaces may use 0..1023, but may be configured to use ranges as large as 0..2^23. (0..8388607) · Integer32

Reference: American National Standard T1.618-1991, Section 3.3.6

The Data Link Connection Identifier for this virtual circuit.

cfrSvcAddrLocal

1.3.6.1.4.1.9.9.49.1.4.1.1.1

OCTET STRING SIZE (0..64)

Local E.164/X.125 address for the circuit.

cfrSvcAddrRemote

1.3.6.1.4.1.9.9.49.1.4.1.1.2

OCTET STRING SIZE (0..64)

Remote E.164/X.125 address for the circuit.

cfrSvcThroughputIn

1.3.6.1.4.1.9.9.49.1.4.1.1.3

Integer32 (9600..1544000) · bits per second

Circuit's incoming throughput. For outgoing throughput (commonly referred to as CIR) see frCircuitThroughput per RFC1315.

cfrSvcMinThruputOut

1.3.6.1.4.1.9.9.49.1.4.1.1.4

Integer32 (9600..1544000) · bits per second

Circuit's outgoing minimal Throughput.

cfrSvcMinThruputIn

1.3.6.1.4.1.9.9.49.1.4.1.1.5

Integer32 (9600..1544000) · bits per second

Circuit's incoming minimal Throughput.

cfrSvcCommitBurstIn

1.3.6.1.4.1.9.9.49.1.4.1.1.6

Integer32 (9600..1544000)

Circuit's incoming Committed Burst Rate. See ANSI and/or ITU specifications for definition and calculations. For outgoing CBR, see frCircuitCommittedBurst per RFC 1315.

cfrSvcExcessBurstIn

1.3.6.1.4.1.9.9.49.1.4.1.1.7

Integer32 (9600..2440000)

Circuit's incoming Excess Burst Rate. See ANSI and/or ITU specifications for definition and calculations. For outgoing EBR, see frCircuitExcessBurst per RFC 1315.

cfrSvcIdleTime

1.3.6.1.4.1.9.9.49.1.4.1.1.8

Integer32 · seconds

Circuit's idle time period. If expires, the circuit is cleared.

cfrElmiTable

1.3.6.1.4.1.9.9.49.1.5.2

Index: ifIndex

Table of CISCO Frame Relay ELMI information that is specific to CISCO implementation

from RFC1213-MIB

ifIndex

INTEGER · Integer32

A unique value for each interface. Its value ranges between 1 and the value of ifNumber. The value for each interface must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

cfrElmiLinkStatus

1.3.6.1.4.1.9.9.49.1.5.2.1.1

INTEGER1 = enabled2 = disabled · Integer32

This variable states whether Enhanced Link Management Interface(ELMI) protocol is enabled or not on a frame relay interface.

cfrElmiArStatus

1.3.6.1.4.1.9.9.49.1.5.2.1.2

INTEGER1 = enabled2 = disabled · Integer32

This variable states whether the Enhanced Link Management Interface(ELMI) address registration(AR) mechanism is enabled or not on a frame relay interface. A value of 1 indicates ELMI AR is supported on the interface. A value of 2 indicates ELMI AR is supported but the user disabled the exchange of IP address and ifIndex with the neighboring device. This object doesn't have any significance if cfrElmiLinkStatus is disabled on the interface.

cfrElmiRemoteStatus

1.3.6.1.4.1.9.9.49.1.5.2.1.3

INTEGER1 = enabled2 = disabled · Integer32

This variable states the Enhanced Link Management(ELMI) status on the other end of the interface. If cfrElmiLinkStatus is enabled on the other end a value of 1 will be returned, else 2 will be returned. This object doesn't have any significance if cfrElmiLinkStatus is disabled on the interface

cfrElmiNeighborTable

1.3.6.1.4.1.9.9.49.1.5.3

Index: ifIndex

Table of CISCO Frame Relay Neighbor ELMI information that is specific to CISCO implementation.

from RFC1213-MIB

ifIndex

INTEGER · Integer32

A unique value for each interface. Its value ranges between 1 and the value of ifNumber. The value for each interface must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

cfrElmiNeighborArStatus

1.3.6.1.4.1.9.9.49.1.5.3.1.1

INTEGER1 = notsupported2 = enabled3 = disabled · Integer32

This variable indicates the status of ELMI Address registration(AR) on the neighboring device. A value of 1 indicates ELMI AR is not supported on the neighboring device. A value of 2 indicates ELMI AR is enabled on the interface. A value of 3 indicates AR is supported, but user disabled the exchange of IP address and ifIndex with the neighbor.

cfrElmiNeighborIpAddress

1.3.6.1.4.1.9.9.49.1.5.3.1.2

IpAddress SIZE (4)

The Management IP address of the neighboring device to which the other end of this interface is connected. Network management system can use this address to send management messages to the device. If address registration is not supported on the remote end then the value will be 0.0.0.0. NMS uses this object in the topology discovery of the network.

cfrElmiNeighborIfIndex

1.3.6.1.4.1.9.9.49.1.5.3.1.3

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

The Interface index of the neighboring device to which this interface is connected. If the value of cfrElmiNeighborArStatus is 2 then this will have a valid value. If the value of cfrElmiNeighborArStatus is 3 or 1 then value of this object will be 0. NMS uses this object in the topology discovery of the network.

cfrElmiNeighborVendorName

1.3.6.1.4.1.9.9.49.1.5.3.1.4

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Vendor name of the neighboring device to which the other end of this interface is connected.

cfrElmiNeighborPlatformName

1.3.6.1.4.1.9.9.49.1.5.3.1.5

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Platform name of the neighboring device to which the other end of this interface is connected.

cfrElmiNeighborDeviceName

1.3.6.1.4.1.9.9.49.1.5.3.1.6

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Device name of the neighboring device to which the other end of this interface is connected.

cfrFragTable

1.3.6.1.4.1.9.9.49.1.6.1

Index: frCircuitIfIndex · frCircuitDlci

Table of Frame Relay Fragmentation information. These are specific to Cisco's implementation.

from FRAME-RELAY-DTE-MIB

frCircuitIfIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

The ifIndex Value of the ifEntry this virtual circuit is layered onto.

frCircuitDlci

DLCIThe range of DLCI values. Note that this varies by interface configuration; normally, interfaces may use 0..1023, but may be configured to use ranges as large as 0..2^23. (0..8388607) · Integer32

Reference: American National Standard T1.618-1991, Section 3.3.6

The Data Link Connection Identifier for this virtual circuit.

cfrFragSize

1.3.6.1.4.1.9.9.49.1.6.1.1.1

INTEGER (16..1600) · Integer32 · octets

cfrFragSize defines the payload size of a fragment and it excludes the FR headers and any FR fragmentation header.

cfrFragType

1.3.6.1.4.1.9.9.49.1.6.1.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Fragmentation type configured by the user. The types supported are end-to-end, VoFR-cisco and VoFR.

cfrFragInPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.3

Counter32 · packets

Total number of frames received that have a fragmentation header.

cfrFragOutPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.4

Counter32 · packets

Total number of fragments that are transmitted with a fragmenation header.

cfrFragInOctets

1.3.6.1.4.1.9.9.49.1.6.1.1.5

Counter32 · octets

Total number of bytes received in frames that have a fragmentation header. The number of bytes include the FR header.

cfrFragOutOctets

1.3.6.1.4.1.9.9.49.1.6.1.1.6

Counter32 · octets

Total number of bytes that are transmitted in frames with a fragmenation header. The number of bytes also includes the FR header.

cfrFragNotInPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.7

Counter32 · packets

Total number of frames received that do not require reassembly and therefore will not contain the fragmentation header. This counter is valid only when end-to-end fragmentation type is set.

cfrFragNotOutPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.8

Counter32 · packets

Total number of frames transmitted without fragmenting and therefore will not contain the fragmentation header. This counter is valid only when end-to-end fragmentation type is set.

cfrFragNotInOctets

1.3.6.1.4.1.9.9.49.1.6.1.1.9

Counter32 · octets

Total number of bytes received in frames that do not require reassembly and therefore will not contain the fragmentation header. This counter is valid only when end-to-end fragmentation type is set.

cfrFragNotOutOctets

1.3.6.1.4.1.9.9.49.1.6.1.1.10

Counter32 · octets

Total number of bytes transmitted in frames that are not fragmented and therefore will not contain the fragmentation header. This counter is valid only when end-to-end fragmentation type is set.

cfrFragAssembledInPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.11

Counter32 · packets

Total number of fully reassembled frames. It also counts the number of packets received without FR fragmentation header (i.e. in un-fragmentated pkts).

cfrFragAssembledInOctets

1.3.6.1.4.1.9.9.49.1.6.1.1.12

Counter32 · octets

Total number of bytes received in fully reassembled frames. It also counts the number of packets received without FR fragmentation header (i.e.in un-fragmentated pkts).

cfrFragPreOutPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.13

Counter32 · packets

Total number of frames fragmented and trasmitted. It also counts the number of packets trasmitted without FR fragmentation header (i.e. in un-fragmentated pkts).

cfrFragPreOutOctets

1.3.6.1.4.1.9.9.49.1.6.1.1.14

Counter32 · octets

Total number of bytes transmitted in fragmented frames. It also counts the number of bytes trasmitted in frames without FR fragmentation header (i.e. in un-fragmentated pkts).

cfrFragDroppedReAssembledInPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.15

Counter32 · packets

Number of received fragments dropped for reasons such as : running out of memory, receiving segments out of sequence, receiving an unexpected frame with a B bit set, timing out on a reassembling frame.

cfrFragDroppedFragmentedOutPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.16

Counter32 · packets

Number of fragments dropped because of running out of memory.

cfrFragTimeoutsIn

1.3.6.1.4.1.9.9.49.1.6.1.1.17

INTEGER (0..1000) · Integer32

Number of reassemble timer timeouts for this circuit. A frame requiring more than two minutes to fully reassemble is dropped and timeout will be incremented by one.

cfrFragOutOfSeqFragPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.18

Counter32 · packets

Indicates the total number of packets received with an unexpected sequence number. All fragments being reassembled are dropped. Start a new packet with the received segment only if the B bit is set on the segment. Otherwise the new segment is also dropped.

cfrFragUnexpectedBBitSetPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.19

Counter32 · packets

Number of fragments received in this circuit with a B bit set. All fragments being reassembled are dropped and a new packet is started with this segment.

cfrFragSeqMissedPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.20

Counter32 · packets

Number of fragments received in this circuit with skipped sequence number.

cfrFragInterleavedOutPkts

1.3.6.1.4.1.9.9.49.1.6.1.1.21

Counter32 · packets

Number of packets that have been interleaved between segments.

cfrConnectionTable

1.3.6.1.4.1.9.9.49.1.7.1

Index: frCircuitIfIndex · frCircuitDlci

Table of Frame Relay/Frame Relay and Frame Relay/ATM Network/Service Interworking connection information. These are specific to Cisco's implementation.

from FRAME-RELAY-DTE-MIB

frCircuitIfIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

The ifIndex Value of the ifEntry this virtual circuit is layered onto.

frCircuitDlci

DLCIThe range of DLCI values. Note that this varies by interface configuration; normally, interfaces may use 0..1023, but may be configured to use ranges as large as 0..2^23. (0..8388607) · Integer32

Reference: American National Standard T1.618-1991, Section 3.3.6

The Data Link Connection Identifier for this virtual circuit.

cfrConnName

1.3.6.1.4.1.9.9.49.1.7.1.1.1

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The textual name of a for FR/FR or FR/ATM Network/Service Interworking connection.

cfrConnID

1.3.6.1.4.1.9.9.49.1.7.1.1.2

INTEGER (1..2000) · Integer32

The numerical identifier of a FR/FR or FR/ATM Network/Service Interworking connection.

cfrConnState

1.3.6.1.4.1.9.9.49.1.7.1.1.3

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Status of a FR/FR or FR/ATM Network/Service Interworking connection.

cfrConnSegment1Name

1.3.6.1.4.1.9.9.49.1.7.1.1.4

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The textual name used to identify the first segment of a FR/FR or FR/ATM Network/Service Interworking connection.

cfrConnSegment1VCGroup

1.3.6.1.4.1.9.9.49.1.7.1.1.5

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The textual name used to identify the VC-Group in the first segment of a Frame Relay/ATM Network Interworking (FRF.5)connection. This field is not applicabe in case of, FRF.8 (Frame Relay/ATM Service Interworking) and FR-FR connectione.

cfrConnSegment1Dlci

1.3.6.1.4.1.9.9.49.1.7.1.1.6

DlciNumberNumerical format of Data Link Connection Identifier (DLCI) in decimal, identical to the 'DLCI' as INTEGER of 0..DLCINumber in RFC1315. The maximum value depends on Frame Relay implementation, which is currently set to be 1023 for 2-octet address format per UNI Implementation Agreement FRF.1. (0..1023) · Integer32

The DLCI used as the first segment of a FR-FR or FR-ATM Network/Service Interworking connection.

cfrConnSegment2Name

1.3.6.1.4.1.9.9.49.1.7.1.1.7

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The interface on which second segment of a FR-FR or FR-ATM Network/Service Interworking connection is configured.

cfrConnSegment2Vpi

1.3.6.1.4.1.9.9.49.1.7.1.1.8

INTEGER (0..4095) · Integer32

The value of VPI, in the ATM connection, used as the second segment of a FR-ATM Network/Service Interworking connection. In case of FR-FR connection, the same will be used to display the DLCI used as the second segment.

cfrConnSegment2Vci

1.3.6.1.4.1.9.9.49.1.7.1.1.9

INTEGER (0..4095) · Integer32

The value of VCI, in the ATM connection, used as the second segment of a FR-ATM Network/Service Interworking connection. In case of FR-FR connection, this is not supported.

cfrConnServiceTranslation

1.3.6.1.4.1.9.9.49.1.7.1.1.10

INTEGER1 = serviceTranslationEnabled2 = serviceTranslationNotEnabled · Integer32

Shows whether Service Translation Mode is supported or not. Translation Mode is the interworking of internetworking (routed and/or bridged) protocols used in FR-ATM Service PVC Interworking(FRF.8). This is not supported in case of FRF.5 (FR-ATM network Interworking) and FR-FR connections.

cfrConnFrSscsDlci

1.3.6.1.4.1.9.9.49.1.7.1.1.11

DlciNumberNumerical format of Data Link Connection Identifier (DLCI) in decimal, identical to the 'DLCI' as INTEGER of 0..DLCINumber in RFC1315. The maximum value depends on Frame Relay implementation, which is currently set to be 1023 for 2-octet address format per UNI Implementation Agreement FRF.1. (0..1023) · Integer32

The DLCI value used at the FR-SSCS layer. This is one of connection multiplexing methods used in Frame Relay/ATM Network Interworking. Not supported in case of FRF.8 (FR-ATM Service PVC Interworking) and FR-FR connections

cfrConnEfciBit

1.3.6.1.4.1.9.9.49.1.7.1.1.12

INTEGER1 = mapFecn2 = notMapFecn · Integer32

Shows whether the FECN field in the FR frame is mapped to the ATM EFCI field of every cell generated out of the FR frame. This is used to indicate congestion in FR to ATM direction in case of Frame Relay/ATM Service PVC Interworking. Not supported in FRF.5 (Frame Relay/ATM Network Interworking and FR-FR connections.

cfrConnDeBit

1.3.6.1.4.1.9.9.49.1.7.1.1.13

INTEGER1 = noMapClp2 = mapClp3 = setDe04 = setDe1 · Integer32

The method of operation for loss priority mapping in the B-ISDN to FR direction.. Not supported in case of FR-FR connection.

cfrConnClpBit

1.3.6.1.4.1.9.9.49.1.7.1.1.14

INTEGER1 = setClpTo0AndCopyDeToFrsscsDe2 = setClpTo1AndCopyDeToFrsscsDe3 = copyDeToFrsscsDeAndClp4 = copyDeToClp5 = setClp16 = setClp0 · Integer32

The method of operation used to map loss priority mapping in the FR to ATM direction. Not supported in case of FR-FR connection.

↑ To TOC