EZ5 MIB Catalog

CISCO-IETF-DHCP-SERVER-EXT-MIB

2007-03-15

The MIB module is an extension of the Cisco IETF Dynamic Host Configuration protocol (DHCP) MIB.

Download CISCO-IETF-DHCP-SERVER-EXT-MIB.txt Open CISCO-IETF-DHCP-SERVER-EXT-MIB.txt in a new tab

SCALARS (58) · TABLES (2) · TRAPS (3)

Scalars (58)

NameOID
cDhcpv4SrvStartTime1.3.6.1.4.1.9.10.122.1.1.1
cDhcpv4SrvResetTime1.3.6.1.4.1.9.10.122.1.1.2
cDhcpv4LeaseQueries1.3.6.1.4.1.9.10.122.1.2.1
cDhcpv4StatisticsResetTime1.3.6.1.4.1.9.10.122.1.2.2
cDhcpv4IntDiscovers1.3.6.1.4.1.9.10.122.1.3.1
cDhcpv4IntOffers1.3.6.1.4.1.9.10.122.1.3.2
cDhcpv4IntRequests1.3.6.1.4.1.9.10.122.1.3.3
cDhcpv4IntDeclines1.3.6.1.4.1.9.10.122.1.3.4
cDhcpv4IntAcks1.3.6.1.4.1.9.10.122.1.3.5
cDhcpv4IntNaks1.3.6.1.4.1.9.10.122.1.3.6
cDhcpv4IntReleases1.3.6.1.4.1.9.10.122.1.3.7
cDhcpv4IntInforms1.3.6.1.4.1.9.10.122.1.3.8
cDhcpv4IntLeaseQueries1.3.6.1.4.1.9.10.122.1.3.9
cDhcpv4IntReqBuffersInUse1.3.6.1.4.1.9.10.122.1.3.10
cDhcpv4IntRespBuffersInUse1.3.6.1.4.1.9.10.122.1.3.11
cDhcpv4IntEndTime1.3.6.1.4.1.9.10.122.1.3.12
cDhcpv4IntDeltaTime1.3.6.1.4.1.9.10.122.1.3.13
cDhcpv4FOPacketsRcvd1.3.6.1.4.1.9.10.122.1.4.1
cDhcpv4FOBindingUpdsRcvd1.3.6.1.4.1.9.10.122.1.4.2
cDhcpv4FOBindingAcksRcvd1.3.6.1.4.1.9.10.122.1.4.3
cDhcpv4FOBindingNaksRcvd1.3.6.1.4.1.9.10.122.1.4.4
cDhcpv4FOPoolRequestsRcvd1.3.6.1.4.1.9.10.122.1.4.5
cDhcpv4FOPollsRcvd1.3.6.1.4.1.9.10.122.1.4.6
cDhcpv4FOUpdateRequestsRcvd1.3.6.1.4.1.9.10.122.1.4.7
cDhcpv4FOUpdateDoneRcvd1.3.6.1.4.1.9.10.122.1.4.8
cDhcpv4FOPacketsSent1.3.6.1.4.1.9.10.122.1.4.9
cDhcpv4FOBindingUpdatesSent1.3.6.1.4.1.9.10.122.1.4.10
cDhcpv4FOBindingAcksSent1.3.6.1.4.1.9.10.122.1.4.11
cDhcpv4FOBindingNaksSent1.3.6.1.4.1.9.10.122.1.4.12
cDhcpv4FOPoolResponsesSent1.3.6.1.4.1.9.10.122.1.4.13
cDhcpv4FOPollsSent1.3.6.1.4.1.9.10.122.1.4.14
cDhcpv4FOUpdateRequestsSent1.3.6.1.4.1.9.10.122.1.4.15
cDhcpv4FOUpdateDoneSent1.3.6.1.4.1.9.10.122.1.4.16
cDhcpv4FOPacketsDropped1.3.6.1.4.1.9.10.122.1.4.17
cDhcpv4FOIntPacketsRcvd1.3.6.1.4.1.9.10.122.1.5.1
cDhcpv4FOIntBindingUpdsRcvd1.3.6.1.4.1.9.10.122.1.5.2
cDhcpv4FOIntBindingAcksRcvd1.3.6.1.4.1.9.10.122.1.5.3
cDhcpv4FOIntBindingNaksRcvd1.3.6.1.4.1.9.10.122.1.5.4
cDhcpv4FOIntPoolRequestsRcvd1.3.6.1.4.1.9.10.122.1.5.5
cDhcpv4FOIntPollsRcvd1.3.6.1.4.1.9.10.122.1.5.6
cDhcpv4FOIntUpdateReqsRcvd1.3.6.1.4.1.9.10.122.1.5.7
cDhcpv4FOIntUpdateDoneRcvd1.3.6.1.4.1.9.10.122.1.5.8
cDhcpv4FOIntPacketsSent1.3.6.1.4.1.9.10.122.1.5.9
cDhcpv4FOIntBindingUpdsSent1.3.6.1.4.1.9.10.122.1.5.10
cDhcpv4FOIntBindingAcksSent1.3.6.1.4.1.9.10.122.1.5.11
cDhcpv4FOIntBindingNaksSent1.3.6.1.4.1.9.10.122.1.5.12
cDhcpv4FOIntPoolResponsesSent1.3.6.1.4.1.9.10.122.1.5.13
cDhcpv4FOIntPollsSent1.3.6.1.4.1.9.10.122.1.5.14
cDhcpv4FOIntUpdateReqsSent1.3.6.1.4.1.9.10.122.1.5.15
cDhcpv4FOIntUpdateDoneSent1.3.6.1.4.1.9.10.122.1.5.16
cDhcpv4FOIntPacketsDropped1.3.6.1.4.1.9.10.122.1.5.17
cDhcpv4FOIntEndTime1.3.6.1.4.1.9.10.122.1.5.18
cDhcpv4FOIntDeltaTime1.3.6.1.4.1.9.10.122.1.5.19
cDhcpv4ConfigIntervalSample1.3.6.1.4.1.9.10.122.1.6.1
cDhcpv4ServerIfLeaseLimitEnable1.3.6.1.4.1.9.10.122.1.6.3
cDhcpv4ServerSubnetFreeAddressLowEnable1.3.6.1.4.1.9.10.122.1.6.4
cDhcpv4ServerSubnetFreeAddressHighEnable1.3.6.1.4.1.9.10.122.1.6.5
cDhcpv4ServerIfLeaseLimitDefault1.3.6.1.4.1.9.10.122.1.6.6

Tables (2)

NameOID
cDhcpv4SrvExtSubnetTableaugments cDhcpv4ServerSubnetTable (CISCO-IETF-DHCP-SERVER-MIB)1.3.6.1.4.1.9.10.122.1.6.2
cDhcpv4SrvIfCfgTable1.3.6.1.4.1.9.10.122.1.6.7

Traps (3)

NameOID
cDhcpv4ServerIfLeaseLimitExceeded1.3.6.1.4.1.9.10.122.0.2.0.1
cDhcpv4ServerSubnetFreeAddressLow1.3.6.1.4.1.9.10.122.0.2.0.2
cDhcpv4ServerSubnetFreeAddressHigh1.3.6.1.4.1.9.10.122.0.2.0.3

END OF TOC

Scalar details

cDhcpv4SrvStartTime

1.3.6.1.4.1.9.10.122.1.1.1

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The time when the process supporting this server was started.

cDhcpv4SrvResetTime

1.3.6.1.4.1.9.10.122.1.1.2

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The time when the process supporting this server was last reinitialized. This indicates the time when a server reload or start was executed. At server startup this time is the same as cDhcpv4SrvStartTime.

cDhcpv4LeaseQueries

1.3.6.1.4.1.9.10.122.1.2.1

Counter32 · packets

The total number of DHCPLEASEQUERY packets received.

cDhcpv4StatisticsResetTime

1.3.6.1.4.1.9.10.122.1.2.2

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The time the server statistics counters were last reinitialized; the statistics counters are reinitialized by a reset command, server reload, or server start; note also that any configuration change to reporting interval requires a server reload to take effect, which will reinitialize the statistics counters. If statistics are never reset, this time will equal cDhcpv4SrvResetTime, which may also equal cDhcpv4SrvStartTime, if the server was never reloaded.

cDhcpv4IntDiscovers

1.3.6.1.4.1.9.10.122.1.3.1

Unsigned32 · packets

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPDISCOVER (option 53 with value 1) packets received during the reporting interval.

cDhcpv4IntOffers

1.3.6.1.4.1.9.10.122.1.3.2

Unsigned32 · packets

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPOFFER (option 53 with value 2) packets sent during the reporting interval.

cDhcpv4IntRequests

1.3.6.1.4.1.9.10.122.1.3.3

Unsigned32 · packets

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPREQUEST (option 53 with value 3) packets received during the reporting interval.

cDhcpv4IntDeclines

1.3.6.1.4.1.9.10.122.1.3.4

Unsigned32 · packets

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPDECLINE (option 53 with value 4) packets received during the reporting interval.

cDhcpv4IntAcks

1.3.6.1.4.1.9.10.122.1.3.5

Unsigned32 · packets

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPACK (option 53 with value 5) packets sent during the reporting interval.

cDhcpv4IntNaks

1.3.6.1.4.1.9.10.122.1.3.6

Unsigned32 · packets

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPNACK (option 53 with value 6) packets sent during the reporting interval.

cDhcpv4IntReleases

1.3.6.1.4.1.9.10.122.1.3.7

Unsigned32 · packets

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPRELEASE (option 53 with value 7) packets received during the reporting interval.

cDhcpv4IntInforms

1.3.6.1.4.1.9.10.122.1.3.8

Unsigned32 · packets

Reference: RFC2131; RFC2132, section 9.6.

The number of DHCPINFORM (option 53 with value 8) packets received during the reporting interval.

cDhcpv4IntLeaseQueries

1.3.6.1.4.1.9.10.122.1.3.9

Unsigned32 · packets

The total number of DHCPLEASEQUERY packets received during the reporting interval.

cDhcpv4IntReqBuffersInUse

1.3.6.1.4.1.9.10.122.1.3.10

Gauge32 · buffers

The number of request buffers in use during the reporting interval.

cDhcpv4IntRespBuffersInUse

1.3.6.1.4.1.9.10.122.1.3.11

Gauge32 · buffers

The number of response buffers in use at the end of the reporting interval.

cDhcpv4IntEndTime

1.3.6.1.4.1.9.10.122.1.3.12

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The time when the server last calculated the sample statistics.

cDhcpv4IntDeltaTime

1.3.6.1.4.1.9.10.122.1.3.13

TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds

The interval in seconds over which the server last calculated the sample interval statistics. This is the configured reporting interval and the statistics are reset since the last cDhcpv4IntEndTime.

cDhcpv4FOPacketsRcvd

1.3.6.1.4.1.9.10.122.1.4.1

Counter32 · packets

The total total number of failover packets received.

cDhcpv4FOBindingUpdsRcvd

1.3.6.1.4.1.9.10.122.1.4.2

Counter32 · packets

The total total number of failover DHCPBNDUPD packets received.

cDhcpv4FOBindingAcksRcvd

1.3.6.1.4.1.9.10.122.1.4.3

Counter32 · packets

The total number of failover DHCPBNDACK packets received.

cDhcpv4FOBindingNaksRcvd

1.3.6.1.4.1.9.10.122.1.4.4

Counter32 · packets

The total number of failover DHCPBNDNAK packets received.

cDhcpv4FOPoolRequestsRcvd

1.3.6.1.4.1.9.10.122.1.4.5

Counter32 · packets

The total number of failover DHCPPOOLREQ packets received.

cDhcpv4FOPollsRcvd

1.3.6.1.4.1.9.10.122.1.4.6

Counter32 · packets

The total number of failover DHCPPOLL packets received.

cDhcpv4FOUpdateRequestsRcvd

1.3.6.1.4.1.9.10.122.1.4.7

Counter32 · packets

The total number of failover DHCPUPDATEREQ packets received.

cDhcpv4FOUpdateDoneRcvd

1.3.6.1.4.1.9.10.122.1.4.8

Counter32 · packets

The total number of failover DHCPUPDATEDONE packets received.

cDhcpv4FOPacketsSent

1.3.6.1.4.1.9.10.122.1.4.9

Counter32 · packets

The total number of failover packets sent.

cDhcpv4FOBindingUpdatesSent

1.3.6.1.4.1.9.10.122.1.4.10

Counter32 · packets

The total number of DHCPBNDUPD packets sent.

cDhcpv4FOBindingAcksSent

1.3.6.1.4.1.9.10.122.1.4.11

Counter32 · packets

The total number of DHCPBNDACKS packets sent.

cDhcpv4FOBindingNaksSent

1.3.6.1.4.1.9.10.122.1.4.12

Counter32 · packets

The total number of DHCPBNDNAK packets sent.

cDhcpv4FOPoolResponsesSent

1.3.6.1.4.1.9.10.122.1.4.13

Counter32 · packets

The total number of DHCPPOOLRESP packets sent.

cDhcpv4FOPollsSent

1.3.6.1.4.1.9.10.122.1.4.14

Counter32 · packets

The total number of DHCPPOLL packets sent during reporting interval.

cDhcpv4FOUpdateRequestsSent

1.3.6.1.4.1.9.10.122.1.4.15

Counter32 · packets

The total number of DHCPUPDATEREQ packets sent during reporting interval.

cDhcpv4FOUpdateDoneSent

1.3.6.1.4.1.9.10.122.1.4.16

Counter32 · packets

The total number of DHCPUPDATEDONE packets sent during reporting interval.

cDhcpv4FOPacketsDropped

1.3.6.1.4.1.9.10.122.1.4.17

Counter32 · packets

The total number of failover packets dropped during reporting interval.

cDhcpv4FOIntPacketsRcvd

1.3.6.1.4.1.9.10.122.1.5.1

Unsigned32 · packets

The number of failover packets received during the reporting interval.

cDhcpv4FOIntBindingUpdsRcvd

1.3.6.1.4.1.9.10.122.1.5.2

Unsigned32 · packets

The number of failover DHCPBNDUPD packets received during the reporting interval.

cDhcpv4FOIntBindingAcksRcvd

1.3.6.1.4.1.9.10.122.1.5.3

Unsigned32 · packets

The number of failover DHCPBNDACK packets received during the reporting interval.

cDhcpv4FOIntBindingNaksRcvd

1.3.6.1.4.1.9.10.122.1.5.4

Unsigned32 · packets

The number of failover DHCPBNDNAK packets received during reporting interval.

cDhcpv4FOIntPoolRequestsRcvd

1.3.6.1.4.1.9.10.122.1.5.5

Unsigned32 · packets

The number of failover DHCPPOOLREQ packets received during the reporting interval.

cDhcpv4FOIntPollsRcvd

1.3.6.1.4.1.9.10.122.1.5.6

Unsigned32 · packets

The number of failover DHCPPOLL packets received during the reporting interval.

cDhcpv4FOIntUpdateReqsRcvd

1.3.6.1.4.1.9.10.122.1.5.7

Unsigned32 · packets

The number of failover DHCPUPDATEREQ packets received during the reporting interval.

cDhcpv4FOIntUpdateDoneRcvd

1.3.6.1.4.1.9.10.122.1.5.8

Unsigned32 · packets

The number of failover DHCPUPDATEDONE packets received during the reporting interval.

cDhcpv4FOIntPacketsSent

1.3.6.1.4.1.9.10.122.1.5.9

Unsigned32 · packets

The number of failover packets sent during the reporting interval.

cDhcpv4FOIntBindingUpdsSent

1.3.6.1.4.1.9.10.122.1.5.10

Unsigned32 · packets

The number of DHCPBNDUPD packets sent during the reporting interval.

cDhcpv4FOIntBindingAcksSent

1.3.6.1.4.1.9.10.122.1.5.11

Unsigned32 · packets

The number of DHCPBNDACKS packets sent during the reporting interval.

cDhcpv4FOIntBindingNaksSent

1.3.6.1.4.1.9.10.122.1.5.12

Unsigned32 · packets

The number of DHCPBNDNAK packets sent during the reporting interval.

cDhcpv4FOIntPoolResponsesSent

1.3.6.1.4.1.9.10.122.1.5.13

Unsigned32 · packets

The number of DHCPPOOLRESP packets sent during the reporting interval.

cDhcpv4FOIntPollsSent

1.3.6.1.4.1.9.10.122.1.5.14

Unsigned32 · packets

The number of DHCPPOLL packets sent during the reporting interval.

cDhcpv4FOIntUpdateReqsSent

1.3.6.1.4.1.9.10.122.1.5.15

Unsigned32 · packets

The number of DHCPUPDATEREQ packets sent during the reporting interval.

cDhcpv4FOIntUpdateDoneSent

1.3.6.1.4.1.9.10.122.1.5.16

Unsigned32 · packets

The number of DHCPUPDATEDONE packets sent during the reporting interval.

cDhcpv4FOIntPacketsDropped

1.3.6.1.4.1.9.10.122.1.5.17

Unsigned32 · packets

The number of failover packets dropped during the reporting interval.

cDhcpv4FOIntEndTime

1.3.6.1.4.1.9.10.122.1.5.18

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The time when the server last calculated the interval statistics.

cDhcpv4FOIntDeltaTime

1.3.6.1.4.1.9.10.122.1.5.19

TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds

The interval in seconds over which the server last calculated the sample interval statistics. This is the configured reporting interval and the statistics are reset since the last cDhcpv4IntEndTime.

cDhcpv4ConfigIntervalSample

1.3.6.1.4.1.9.10.122.1.6.1

TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32 · milliseconds

Configures the sample time for the various interval counters.

cDhcpv4ServerIfLeaseLimitEnable

1.3.6.1.4.1.9.10.122.1.6.3

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies if the DHCP module should generate 'cDhcpv4ServerIfLeaseLimitExceeded' notifications. If value of this object is 'true', then the notification is generated when the number of leases offered to DHCP clients behind an interface is reached based on per limit lease configuration command. If it is 'false', the notification is not generated.

cDhcpv4ServerSubnetFreeAddressLowEnable

1.3.6.1.4.1.9.10.122.1.6.4

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies if the DHCP module should generate 'cDhcpv4ServerSubnetFreeAddressLow' notifications. If value of this object is 'true', then the notification is generated when the number of available IPv4 addresses for a particular subnet has fallen below the value of cDhcpv4ServerSubnetFreeAddrLowThreshold for that subnet. If it is 'false', the notification is not generated.

cDhcpv4ServerSubnetFreeAddressHighEnable

1.3.6.1.4.1.9.10.122.1.6.5

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies if the DHCP module should generate 'cDhcpv4ServerSubnetFreeAddressHigh' notifications. If value of this object is 'true', then the notification is generated when the number of available IPv4 addresses for a particular subnet has fallen below the value of cDhcpv4ServerSubnetFreeAddrHighThreshold for that subnet. If it is 'false', the notification is not generated.

cDhcpv4ServerIfLeaseLimitDefault

1.3.6.1.4.1.9.10.122.1.6.6

Unsigned32 (1..65535)

The default number of Dynamic Host Configuration Protocol (DHCP) clients allowed for an interface. Refer to 'cDhcpv4ServerIfLeaseLimit'.

Table details

cDhcpv4SrvExtSubnetTable

1.3.6.1.4.1.9.10.122.1.6.2

augments cDhcpv4ServerSubnetTable (CISCO-IETF-DHCP-SERVER-MIB)

Index: cDhcpv4ServerSubnetAddress

This table augments the cDhcpv4ServerSubnetTable.

from CISCO-IETF-DHCP-SERVER-MIB

cDhcpv4ServerSubnetAddress

InetAddressIPv4Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. SIZE (4) · OCTET STRING · hint 1d.1d.1d.1d

The IPv4 address of the subnet entry in the cDhcpv4ServerSubnetTable.

cDhcpv4ServerDefaultRouterAddress

1.3.6.1.4.1.9.10.122.1.6.2.1.1

InetAddressIPv4Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. SIZE (4) · OCTET STRING · hint 1d.1d.1d.1d

The default router IPv4 address in this subnet.

cDhcpv4ServerSubnetStartAddress

1.3.6.1.4.1.9.10.122.1.6.2.1.2

InetAddressIPv4Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. SIZE (4) · OCTET STRING · hint 1d.1d.1d.1d

The IPv4 address of the first address in the subnet. The value of cDhcpv4ServerSubnetStartAddress MUST be less than or equal to the value of cDhcpv4ServerSubnetEndAddress.

cDhcpv4ServerSubnetEndAddress

1.3.6.1.4.1.9.10.122.1.6.2.1.3

InetAddressIPv4Represents an IPv4 network address: Octets Contents Encoding 1-4 IPv4 address network-byte order The corresponding InetAddressType value is ipv4(1). This textual convention SHOULD NOT be used directly in object definitions, as it restricts addresses to a specific format. However, if it is used, it MAY be used either on its own or in conjunction with InetAddressType, as a pair. SIZE (4) · OCTET STRING · hint 1d.1d.1d.1d

The IPv4 address of the last address in the subnet. The value of cDhcpv4ServerSubnetEndAddress MUST be greater than or equal to the value of cDhcpv4ServerSubnetStartAddress.

cDhcpv4SrvIfCfgTable

1.3.6.1.4.1.9.10.122.1.6.7

Index: ifIndex

A table of the DHCP interface configuration data maintained by the server.

from IF-MIB

ifIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

cDhcpv4ServerIfLeaseLimit

1.3.6.1.4.1.9.10.122.1.6.7.1.1

Unsigned32 (1..65535)

The number of Dynamic Host Configuration Protocol (DHCP) clients allowed for an interface. The value of this object is equal to the value of the 'cDhcpv4ServerIfLeaseLimitDefault' for the interface that does not have the interface lease limit configuration. The value of the 'cDhcpv4ServerIfLeaseLimit' object reflects the lease limit on that interface (whether it's configured with a value specifically for that interface or if the value of 'cDhcpv4ServerIfLeaseLimitDefault' applies). When this lease limit is reached or exceeded, the cDhcpv4ServerIfLeaseLimitExceeded notification will be generated if cDhcpv4ServerIfLeaseLimitEnable is enabled.

Trap details

cDhcpv4ServerIfLeaseLimitExceeded

1.3.6.1.4.1.9.10.122.0.2.0.1

This notification indicates when a client has attempted to obtain a lease and the lease was not granted because the number of leases granted to clients on the receiving interface is equal to cDhcpv4ServerIfLeaseLimit.

ifName

1.3.6.1.2.1.31.1.1.1.1

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The textual name of the interface. The value of this object should be the name of the interface as assigned by the local device and should be suitable for use in commands entered at the device's `console'. This might be a text name, such as `le0' or a simple port number, such as `1', depending on the interface naming syntax of the device. If several entries in the ifTable together represent a single interface as named by the device, then each will have the same value of ifName. Note that for an agent which responds to SNMP queries concerning an interface on some other (proxied) device, then the value of ifName for such an interface is the proxied device's local name for it. If there is no local name, or this object is otherwise not applicable, then this object contains a zero-length string.

cDhcpv4ServerClientPhysicalAddress

1.3.6.1.4.1.9.10.102.1.4.4.1.8

CDhcpv4PhysicalAddressA DHCP-specific encoding of the physical address type and physical address, intended to mirror the representation of physical addresses in DHCP messages. The first octet of this object contains the hardware type from the 'htype' field of the DHCP message, the second octet of this object contains the hardware length from the 'hlen' field, and the remaining octets contain the hardware address from the 'chaddr' field.Reference: RFC 2131 SIZE (18) · OCTET STRING · hint 1d,1d,1x:1x:1x:1x:1x:1x

The hardware type and hardware address of the client that has been assigned this lease. The first octet of this object contains the hardware type from the 'htype' field of the BOOTP packet and the remaining octets contain the hardware address from the 'chaddr' field of the BOOTP packet. This object MAY be empty if the address has not been previously served.

cDhcpv4ServerIfLeaseLimit

1.3.6.1.4.1.9.10.122.1.6.7.1.1

Unsigned32 (1..65535)

The number of Dynamic Host Configuration Protocol (DHCP) clients allowed for an interface. The value of this object is equal to the value of the 'cDhcpv4ServerIfLeaseLimitDefault' for the interface that does not have the interface lease limit configuration. The value of the 'cDhcpv4ServerIfLeaseLimit' object reflects the lease limit on that interface (whether it's configured with a value specifically for that interface or if the value of 'cDhcpv4ServerIfLeaseLimitDefault' applies). When this lease limit is reached or exceeded, the cDhcpv4ServerIfLeaseLimitExceeded notification will be generated if cDhcpv4ServerIfLeaseLimitEnable is enabled.

cDhcpv4ServerSubnetFreeAddressLow

1.3.6.1.4.1.9.10.122.0.2.0.2

This notification indicates that the number of available IPv4 addresses for a particular subnet has fallen below the corresponding value of cDhcpv4ServerSubnetFreeAddrLowThreshold for that shared network.

cDhcpv4ServerSubnetFreeAddresses

1.3.6.1.4.1.9.10.102.1.4.2.1.6

Unsigned32

The number of free IPv4 addresses which are available in this subnet.

cDhcpv4ServerSubnetFreeAddrLowThreshold

1.3.6.1.4.1.9.10.102.1.4.2.1.4

Unsigned32

The low threshold for available free addresses in this subnet. If the value for available free addresses in this subnet becomes equal to or less than this value, a cDhcpv4ServerSubnetFreeAddrLowThreshold event will be generated for this shared network. No more cDhcpv4ServerSubnetFreeAddrLowThreshold events will be generated for this subnet during this execution of the DHCP server until the value for available free addresses has exceeded the value of cDhcpv4ServerSubnetFreeAddrHighThreshold.

cDhcpv4ServerSubnetFreeAddressHigh

1.3.6.1.4.1.9.10.122.0.2.0.3

This notification indicates that the number of available IPv4 addresses for a particular subnet has risen above the corresponding value of cDhcpv4ServerSubnetFreeAddrHighThreshold for that shared network.

cDhcpv4ServerSubnetFreeAddresses

1.3.6.1.4.1.9.10.102.1.4.2.1.6

Unsigned32

The number of free IPv4 addresses which are available in this subnet.

cDhcpv4ServerSubnetFreeAddrHighThreshold

1.3.6.1.4.1.9.10.102.1.4.2.1.5

Unsigned32

The high threshold for available free addresses in this subnet. If a cDhcpv4ServerSubnetFreeAddrLowThreshold event has been generated for this subnet, and the value for available free addresses has exceeded the value of cDhcpv4ServerSubnetFreeAddrHighThreshold, then a cDhcpv4ServerFreeAddressHigh event will be generated. No more cDhcpv4ServerFreeAddressHigh events will be generated for this subnet during this execution of the DHCP server until the value for available free addresses becomes equal to or less than the value of cDhcpv4ServerSubnetFreeAddrLowThreshold.

↑ To TOC