This MIB module enhances the IETF Dial Control MIB (RFC2128) for providing management of dial peers on both a circuit-switched telephony network, and a mail server on IP network.
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..20) · OCTET STRING · hint 255a
The regular expression for the FAX called subscriber identification (CSI) coding format. $d$ in the regular expression substitute CSI with the destination number of the call. Reference: ITU-T T30: Section 5.3.6.2.4 CSI coding format.
cmmFaxCfgXmitSubscriberId
1.3.6.1.4.1.9.9.102.1.4.2
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..20) · OCTET STRING · hint 255a
The regular expression for the FAX Transmitting subscriber identification (TSI) coding format. $s$ in the regular expression substitute TSI with the caller ID of the call. Reference: ITU-T T30: Section 5.3.6.2.6 TSI coding format.
cmmFaxCfgRightHeadingString
1.3.6.1.4.1.9.9.102.1.4.3
CmmFaxHeadingStringThe regular expression for the FAX heading at the top of cover page or text page. The regular expression syntax used in this object is the same as that used by the UNIX grep program. The embedded pattern substitutions are defined as follows: $p$ - translates to the page number as passed by FAX processing. $a$ - translates to human readable year-month-day that is defined in DateAndTime of SNMPv2-TC. $d$ - translates to the called party address. $s$ - translates to the calling party address. $t$ - translates to the time of transmission of the first FAX/image page. The human readable format is defined as year-month-day,hour:minutes:second in the DateAndTime of SNMPv2-TC.
Example, 'Date:$a$' means replacing the heading of a FAX page with the the string and date substitution.
'From $s$ Broadcast Service' means replacing the heading of FAX page with the the string and calling party address substitution.
'Page:$p$' means replacing the heading of a FAX page with the string and page number substitution. SIZE (0..80) · OCTET STRING · hint 255a
The regular expression for the FAX right heading at the top of cover page or text page.
The default value of this object is an empty string.
cmmFaxCfgCenterHeadingString
1.3.6.1.4.1.9.9.102.1.4.4
CmmFaxHeadingStringThe regular expression for the FAX heading at the top of cover page or text page. The regular expression syntax used in this object is the same as that used by the UNIX grep program. The embedded pattern substitutions are defined as follows: $p$ - translates to the page number as passed by FAX processing. $a$ - translates to human readable year-month-day that is defined in DateAndTime of SNMPv2-TC. $d$ - translates to the called party address. $s$ - translates to the calling party address. $t$ - translates to the time of transmission of the first FAX/image page. The human readable format is defined as year-month-day,hour:minutes:second in the DateAndTime of SNMPv2-TC.
Example, 'Date:$a$' means replacing the heading of a FAX page with the the string and date substitution.
'From $s$ Broadcast Service' means replacing the heading of FAX page with the the string and calling party address substitution.
'Page:$p$' means replacing the heading of a FAX page with the string and page number substitution. SIZE (0..80) · OCTET STRING · hint 255a
The regular expression for the FAX center heading at the top of cover page or text page.
The default value of this object is an empty string.
cmmFaxCfgLeftHeadingString
1.3.6.1.4.1.9.9.102.1.4.5
CmmFaxHeadingStringThe regular expression for the FAX heading at the top of cover page or text page. The regular expression syntax used in this object is the same as that used by the UNIX grep program. The embedded pattern substitutions are defined as follows: $p$ - translates to the page number as passed by FAX processing. $a$ - translates to human readable year-month-day that is defined in DateAndTime of SNMPv2-TC. $d$ - translates to the called party address. $s$ - translates to the calling party address. $t$ - translates to the time of transmission of the first FAX/image page. The human readable format is defined as year-month-day,hour:minutes:second in the DateAndTime of SNMPv2-TC.
Example, 'Date:$a$' means replacing the heading of a FAX page with the the string and date substitution.
'From $s$ Broadcast Service' means replacing the heading of FAX page with the the string and calling party address substitution.
'Page:$p$' means replacing the heading of a FAX page with the string and page number substitution. SIZE (0..80) · OCTET STRING · hint 255a
The regular expression for the FAX left heading at the top of cover page or text page.
The default value of this object is an empty string.
cmmFaxCfgCovergPageControl
1.3.6.1.4.1.9.9.102.1.4.6
BITS
The object controls the generation of cover page of FAX.
coverPageEnable - enable the managed system to generate
the FAX cover page. coverPageCtlByEmail - allow email to control the FAX cover page generation. coverPageDetailEnable- enable the detailed mail header on the cover page.
cmmFaxCfgCovergPageComment
1.3.6.1.4.1.9.9.102.1.4.7
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The object contains the comment on the FAX cover page.
cmmFaxCfgFaxProfile
1.3.6.1.4.1.9.9.102.1.4.8
BITS
The profile that applies to TIFF file for facsimile. The default value of this object is profileF. Reference: RFC 2301: Section 2.2.4 New TIFF fields recommended for fax modes.
Table details
cmmIpPeerCfgTable
1.3.6.1.4.1.9.9.102.1.1.1
Index: ifIndex
The table contains the Media mail peer specific information that is required to accept mail connection or to which it will connect them via IP network with the specified session protocol in cmmIpPeerCfgSessionProtocol.
InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d
A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.
cmmIpPeerCfgSessionProtocol
1.3.6.1.4.1.9.9.102.1.1.1.1.1
INTEGER1 = smtp · Integer32
The object specifies the session protocol to be used
for sending/receiving media mail between local and remote
mail sever via IP network. smtp - Simple Mail Transfer Protocol.
cmmIpPeerCfgSessionTarget
1.3.6.1.4.1.9.9.102.1.1.1.1.2
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The object specifies the session target of the peer. Session Targets definitions: The session target has the syntax used by the IETF service location protocol. The syntax is as follows:
mapping-type:type-specific-syntax
The mapping-type specifies a scheme for mapping the matching dial string to a session target. The type-specific-syntax is exactly that, something that the particular mapping scheme can understand. For example,
Session target mailto:+$d$@fax.cisco.com
The valid Mapping type definitions for the peer are as follows:
mailto - Syntax: mailto:w@x.y.z
This object specifies the image encoding conversion for outgoing mail connection to mail server. If the value of this object is transparent, it means 'pass through' without encoding conversion.
cmmIpPeerCfgImgResolution
1.3.6.1.4.1.9.9.102.1.1.1.1.4
CmmImgResolutionOrTransparent1 = transparent2 = standard3 = fine4 = superFineRepresents possible image resolution and transparent mode. transparent - pass through mode.
standard - standard resolution.
fine - fine resolution.
superFine - super fine resolution.Reference: RFC2301: Section 4.5.2 Encoding and Resolution. · Integer32
This object specifies the image resolution conversion for outgoing mail connection to mail server. If the value of this object is transparent, it means 'pass through' without resolution conversion.
cmmIpPeerCfgMsgDispoNotification
1.3.6.1.4.1.9.9.102.1.1.1.1.5
TruthValue1 = true2 = falseRepresents a boolean value. · Integer32
This object specifies the Request of Message Disposition Notification.
true - Request Message Disposition Notification.
false - No Message Disposition Notification.
cmmIpPeerCfgDeliStatNotification
1.3.6.1.4.1.9.9.102.1.1.1.1.6
BITS
This object specifies the Request of Delivery Status Notification. success - Request Notification if the media mail is successfully delivered to the recipient. failure - Request Notification if the media mail is failed to deliver to the recipient. delayed - Request Notification if the media mail is delayed to deliver to the recipient.
cmmIpCallActiveTable
1.3.6.1.4.1.9.9.102.1.2.1
Index: callActiveSetupTime · callActiveIndex
This table is the Media Mail over IP extension to the call active table of IETF Dial Control MIB. It contains Media Mail over IP call leg information.
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime when the call associated to this entry was started. This will be useful for an NMS to retrieve all calls after a specific time. Also, this object can be useful in finding large delays between the time the call was started and the time the call was connected. For ISDN media, this will be the time when the setup message was received from or sent to the network.
callActiveIndex
INTEGER (1..2147483647) · Integer32
Small index variable to distinguish calls that start in the same hundredth of a second.
cmmIpCallActiveConnectionId
1.3.6.1.4.1.9.9.102.1.2.1.1.1
CvcGUidRepresents a Global Call Identifier. The global call identifier is used as an unique identifier for an end-to-end call. A zero length CvcGUid indicates no value for the global call identifier. SIZE (0..16) · OCTET STRING
The global call identifier for the gateway call.
cmmIpCallActiveRemoteIPAddress
1.3.6.1.4.1.9.9.102.1.2.1.1.2
IpAddress SIZE (4)
Remote mail server IP address for the Media mail call.
cmmIpCallActiveSessionProtocol
1.3.6.1.4.1.9.9.102.1.2.1.1.3
INTEGER1 = smtp · Integer32
The object specifies the session protocol to be used for the media mail call between local and remote mail server via IP network.
cmmIpCallActiveSessionTarget
1.3.6.1.4.1.9.9.102.1.2.1.1.4
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The object specifies the session target of the peer that is used for the call. This object is set with the information in the call associated cmmIpPeerCfgSessionTarget object when the media mail call is connected.
cmmIpCallActiveMessageId
1.3.6.1.4.1.9.9.102.1.2.1.1.5
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The global unique message identification of the Media mail.
cmmIpCallActiveAccountId
1.3.6.1.4.1.9.9.102.1.2.1.1.6
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
CmmImgResolution2 = standard3 = fine4 = superFineRepresents possible image resolution in Media Mail.
standard - standard resolution.
fine - fine resolution.
superFine - super fine resolution.Reference: RFC2301: Section 4.5.2 Encoding and Resolution. · Integer32
The image resolution of Media mail.
cmmIpCallActiveAcceptMimeTypes
1.3.6.1.4.1.9.9.102.1.2.1.1.9
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32
The number of accepted MIME types for the Media mail call.
cmmIpCallActiveDiscdMimeTypes
1.3.6.1.4.1.9.9.102.1.2.1.1.10
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32
The number of discarded MIME types for the Media mail call.
The notification type of the Media mail call. none - No notification.
mdn - Message Disposition notification.
dsn - Delivery Status notification.
dsnMdn - Both Delivery Status and Message Disposition notification
cmmIpCallHistoryTable
1.3.6.1.4.1.9.9.102.1.3.1
Index: cCallHistoryIndex
This table is the Media Mail extension to the call history table of IETF Dial Control MIB. It contains Media Mail call leg information about specific Media mail gateway call.
A monotonically increasing integer for the sole purpose of indexing call disconnection events. When it reaches the maximum value, an extremely unlikely event, the agent wraps the value back to 1 and may flush existing entries.
cmmIpCallHistoryConnectionId
1.3.6.1.4.1.9.9.102.1.3.1.1.1
CvcGUidRepresents a Global Call Identifier. The global call identifier is used as an unique identifier for an end-to-end call. A zero length CvcGUid indicates no value for the global call identifier. SIZE (0..16) · OCTET STRING
The global call identifier for the gateway call.
cmmIpCallHistoryRemoteIPAddress
1.3.6.1.4.1.9.9.102.1.3.1.1.2
IpAddress SIZE (4)
Remote mail server IP address for the media mail call.
cmmIpCallHistorySessionProtocol
1.3.6.1.4.1.9.9.102.1.3.1.1.3
INTEGER1 = smtp · Integer32
The object specifies the session protocol to be used for the media mail call between local and remote mail server via IP network.
cmmIpCallHistorySessionTarget
1.3.6.1.4.1.9.9.102.1.3.1.1.4
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The object specifies the session target of the peer that is used for the call. This object is set with the information in the call associated cmmIpPeerCfgSessionTarget object when the media mail call is connected.
cmmIpCallHistoryMessageId
1.3.6.1.4.1.9.9.102.1.3.1.1.5
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
The global unique message identification of the Media mail.
cmmIpCallHistoryAccountId
1.3.6.1.4.1.9.9.102.1.3.1.1.6
DisplayStringRepresents textual information taken from the NVT ASCII
character set, as defined in pages 4, 10-11 of RFC 854.
To summarize RFC 854, the NVT ASCII repertoire specifies:
- the use of character codes 0-127 (decimal)
- the graphics characters (32-126) are interpreted as US ASCII
- NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854
- the other 25 codes have no standard interpretation
- the sequence 'CR LF' means newline
- the sequence 'CR NUL' means carriage-return
- an 'LF' not preceded by a 'CR' means moving to the same column on the next line.
- the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.)
Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a
CmmImgResolution2 = standard3 = fine4 = superFineRepresents possible image resolution in Media Mail.
standard - standard resolution.
fine - fine resolution.
superFine - super fine resolution.Reference: RFC2301: Section 4.5.2 Encoding and Resolution. · Integer32
The image resolution of Media mail.
cmmIpCallHistoryAcceptMimeTypes
1.3.6.1.4.1.9.9.102.1.3.1.1.9
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32
The number of accepted MIME types for the Media mail call.
cmmIpCallHistoryDiscdMimeTypes
1.3.6.1.4.1.9.9.102.1.3.1.1.10
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32
The number of discarded MIME types for the Media mail call.
The notification type of the Media mail call. none - No notification.
mdn - Message Disposition notification.
dsn - Delivery Status notification.
dsnMdn - Both Delivery Status and Message Disposition notification