This MIB module complements the CISCO-VOICE-DIAL-CONTROL-MIB, which provides voice telephony peer information, by providing management of video telephony peer information. This MIB module enhances the IETF Dial Control MIB (RFC2128) by providing video call information over an IP network.
A video call is different from an audio call in that a video call typically consists of 2 call legs - audio and video - and each call leg is represented by one call entry. Therefore, each video call creates 2 call entries. In order to associate the video and audio entries of the same video call, a call reference ID is used, i.e., the video and audio entries of the same video call have the same call reference ID.
There are 4 tables (Common, Common Statistics, Conferee and Call) in this MIB, where each table contains different information depending on the type of the video call: 1. 'common' and 'common statistics' table entries are created for all video calls; 2. A 'conferee' table entry is created for calls that belong to a video conference; conferee means a participant of a conference; and 3. A 'call' table entry is created for point-to-point video calls. I.e., for a video conference call, there are valid information in the 'common,' 'common statistics' and 'conferee' tables; for a video point-to-point call, there are valid information in the 'common,' 'common statistics' and 'call' tables.
Transmit(TX) and Receive(RX) Directions: The video stream direction is defined with respect to the video endpoint. I.e., transmit(TX) refers to the video stream sent by the endpoint and receive(RX) refers to the video stream received by the endpoint.
REFERENCE [1] RFC 2128 Dial Control Management Information Base using SMIv2.
This table provides the video extension to the call history table of Cisco Dial Control MIB. It contains common video call leg information and statistics for both a video conference call (video conferee) and a point-to-point video call.
A monotonically increasing integer for the sole purpose of indexing call disconnection events. When it reaches the maximum value, an extremely unlikely event, the agent wraps the value back to 1 and may flush existing entries.
cVideoCommonHistoryConnectionId
1.3.6.1.4.1.9.9.753.1.1.1.1.1
CvcGUidRepresents a Global Call Identifier. The global call identifier is used as an unique identifier for an end-to-end call. A zero length CvcGUid indicates no value for the global call identifier. SIZE (0..16) · OCTET STRING
The global call identifier for a video call session.
cVideoCommonHistoryCallReferenceId
1.3.6.1.4.1.9.9.753.1.1.1.1.2
CvcCallReferenceIdOrZeroA call reference ID correlates the video and audio call entries that belong to the same endpoint. In other words, if an audio call entry and a video call entry have the same call reference ID, these entries belong to the same endpoint. Because an audio-only endpoint creates only one call entry, call reference ID is not necessary and is set to zero. A call reference ID with value greater than zero signifies a video call, the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero include audio calls. · Unsigned32
The call reference ID associates the video call entry and voice call entry of the same endpoint. The call reference ID is assigned by the call manager and is non-zero for a video call session.
cVideoCommonHistoryCallType
1.3.6.1.4.1.9.9.753.1.1.1.1.3
CvcVoIPCallServiceType1 = conferenceCall2 = pointToPointCall3 = monitoredCall255 = otherThis object describes the call type of this call entry.
conferenceCall (1) - This call belongs to a video conference.
pointToPointCall (2) - This call belongs to a point-to-point video call.
monitoredCall (3) - This call is monitored for video quality. · Integer32
This object describes the call type of this call entry.
cVideoCommonHistoryTxCodec
1.3.6.1.4.1.9.9.753.1.1.1.1.4
CvcVideoCoderRate0 = none1 = h2612 = h2633 = h263plus4 = h264This object specifies the encoding type used to compress the video data of the voice call. · Integer32
The encoding type used to compress the video data in transmit direction for a video call session.
cVideoCommonHistoryTxPictureWidth
1.3.6.1.4.1.9.9.753.1.1.1.1.5
Unsigned32 · pixels
The picture width in transmit direction for a video call session.
cVideoCommonHistoryTxPictureHeight
1.3.6.1.4.1.9.9.753.1.1.1.1.6
Unsigned32 · pixels
The picture height in transmit direction for a video call session.
cVideoCommonHistoryTxConfigFrameRate
1.3.6.1.4.1.9.9.753.1.1.1.1.7
Unsigned32 · frames per second
The video stream frame rate in transmit direction for a video call session.
cVideoCommonHistoryTxConfigBitrate
1.3.6.1.4.1.9.9.753.1.1.1.1.8
Unsigned32 · kilobits per second
The video stream bitrate in transmit direction for a video call session.
cVideoCommonHistoryTxPayloadFormat
1.3.6.1.4.1.9.9.753.1.1.1.1.9
CvcVideoRtpPayloadFormat0 = unknown1 = rfc21902 = rfc24293 = rfc46294 = rfc3984A value that represents a type of the RTP payload format used for video stream.
RFC2190 (1) - RTP payload format for video codec H.263 RFC2429 (2) - RTP payload format for video codec H.263 RFC4629 (3) - RTP payload format for video codec H.263 RFC3984 (4) - RTP payload format for video codec H.264Reference: RFC 2190 - RTP Payload Format for H.263 Video Streams RFC 2429 - RTP Payload Format for the 1998 Version of ITU-T Rec. H.263 Video (H.263+) RFC 4629 - RTP Payload Format for ITU-T Rec. H.263 Video RFC 3984 - RTP Payload Format for H.264 Video · Integer32
The video stream RTP payload format in transmit direction for a video call session.
cVideoCommonHistoryTxAnnex
1.3.6.1.4.1.9.9.753.1.1.1.1.10
CvcVideoCodecAnnexMapThis is a bit map that describes the annex(es) present for the video codec. Multiple annexes can be present; bits that are set to 1 indicate the supported annex(es) correspondingly.
No annex - 0x000000 (no bit is on)
Annex D.1 - 0x000001 (bit 0) Annex D.2 - 0x000002 (bit 1)
Annex E - 0x000004 (bit 2)
Annex F - 0x000008 (bit 3)
Annex G - 0x000010 (bit 4)
Annex H - 0x000020 (bit 5)
Annex I - 0x000040 (bit 6)
Annex J - 0x000080 (bit 7)
Annex K - 0x000100 (bit 8)
Annex L - 0x000200 (bit 9)
Annex M - 0x000400 (bit 10)
Annex N - 0x000800 (bit 11)
Annex O - 0x001000 (bit 12)
Annex P - 0x002000 (bit 13)
Annex Q - 0x004000 (bit 14)
Annex R - 0x008000 (bit 15)
Annex S - 0x010000 (bit 16)
Annex T - 0x020000 (bit 17)
Annex U - 0x040000 (bit 18)
Annex V - 0x080000 (bit 19)
Annex W - 0x100000 (bit 20)
CvcVideoCodecAnnexMap object is superseded by CvcVideoCodecAnnexMap in CISCO-VIDEO-TC.Reference: ITU-T H.263 Annex A - Inverse transform accuracy specification Annex B - Hypothetical Reference Decoder Annex C - Considerations for multipoint Annex D - Unrestricted Motion Vector Mode Annex E - Syntax-based Arithmetic Coding mode Annex F - Advanced Prediction mode Annex G - PB-frames mode Annex H - Forward error correction for coded video signal Annex I - Advanced INTRA Coding mode Annex J - Deblocking Filter mode Annex K - Slice Structured mode Annex L - Supplemental enhancement information specification Annex M - Improved PB-frames mode Annex N - Reference Picture selection mode Annex O - Temporal, SNR, and Spatial Scalability mode Annex P - Reference picture resampling Annex Q - Reduced-Resolution Update mode Annex R - Independent Segment Decoding mode Annex S - Alternative INTER VLC mode Annex T - Modified Quantization mode Annex U - Enhanced reference picture selection mode Annex V - Data-partitioned slice mode Annex W - Additional supplemental enhancement information specification
ITU-T H.264 Annex C - Hypothetical reference decoder Annex D - Supplemental enhancement information Annex E - Video usability information Annex G - Scalable video coding Annex H - Multiview video coding · BITS
The video codec annex extension in transmit direction for a video call session. Reference: ITU-T H.263 Annex A - Inverse transform accuracy specification Annex B - Hypothetical Reference Decoder Annex C - Considerations for multipoint Annex D - Unrestricted Motion Vector Mode Annex E - Syntax-based Arithmetic Coding mode Annex F - Advanced Prediction mode Annex G - PB-frames mode Annex H - Forward error correction for coded video signal Annex I - Advanced INTRA Coding mode Annex J - Deblocking Filter mode Annex K - Slice Structured mode Annex L - Supplemental enhancement information specification Annex M - Improved PB-frames mode Annex N - Reference Picture selection mode Annex O - Temporal, SNR, and Spatial Scalability mode Annex P - Reference picture resampling Annex Q - Reduced-Resolution Update mode Annex R - Independent Segment Decoding mode Annex S - Alternative INTER VLC mode Annex T - Modified Quantization mode Annex U - Enhanced reference picture selection mode Annex V - Data-partitioned slice mode Annex W - Additional supplemental enhancement information specification
ITU-T H.264 Annex C - Hypothetical reference decoder Annex D - Supplemental enhancement information Annex E - Video usability information Annex G - Scalable video coding Annex H - Multiview video coding
cVideoCommonHistoryTxProfile
1.3.6.1.4.1.9.9.753.1.1.1.1.11
CvcVideoProfile10 = h263Profile011 = h263Profile112 = h263Profile213 = h263Profile314 = h263Profile415 = h263Profile516 = h263Profile617 = h263Profile718 = h263Profile8100 = h264ProfileBaseline101 = h264ProfileMain102 = h264ProfileExtended103 = h264ProfileHigh104 = h264ProfileHigh10105 = h264ProfileHigh422106 = h264ProfileHigh444Predictive107 = h264ProfileHigh10Intra108 = h264ProfileHigh422Intra109 = h264ProfileHigh444Intra110 = h264ProfileCavlc444Intra255 = otherThis object specifies the H.264 profile of the video stream.
H.263 Profiles: Profile 0 (10) Profile 1 (11) Profile 2 (12) Profile 3 (13) Profile 4 (14) Profile 5 (15) Profile 6 (16) Profile 7 (17) Profile 8 (18)
H.264 Profiles: Baseline Profile (100) Main Profile (101) Extended Profile (102) High Profile (103) High 10 Profile (104) High 4:2:2 Profile (105) High 4:4:4 Predictive Profile (106) High 10 Intra Profile (107) High 4:2:2 Intra Profile (108) High 4:4:4 Intra Profile (109) CAVLC 4:4:4 Intra Profile (110)
CvcVideoProfile object is superseded by CvcVideoProfile in CISCO-VIDEO-TC.Reference: ITU-T H.263: Annex X.2 Profiles of preferred mode support ITU-T H.264: Annex A.2 Profiles · Integer32
The video stream profile in transmit direction for a video call session. Reference: ITU-T H.263: Annex X.2 Profiles of preferred mode support ITU-T H.264: Annex A.2 Profiles
The video stream level in transmit direction for a video call session. Reference: ITU-T H.264: Annex A.3 Levels
cVideoCommonHistoryTxPackets
1.3.6.1.4.1.9.9.753.1.1.1.1.13
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The total number of video data packets transmitted for the video call session.
cVideoCommonHistoryTxBytes
1.3.6.1.4.1.9.9.753.1.1.1.1.14
Counter64 (0..18446744073709551615) · bytes
The total number of video data bytes transmitted for the video call session.
cVideoCommonHistoryTxDuration
1.3.6.1.4.1.9.9.753.1.1.1.1.15
Unsigned32 · seconds
Duration of video stream path, in transmit direction, opened for the call leg.
cVideoCommonHistoryRxCodec
1.3.6.1.4.1.9.9.753.1.1.1.1.16
CvcVideoCoderRate0 = none1 = h2612 = h2633 = h263plus4 = h264This object specifies the encoding type used to compress the video data of the voice call. · Integer32
The encoding type used to compress the video data in receive direction for a video call session.
cVideoCommonHistoryRxPictureWidth
1.3.6.1.4.1.9.9.753.1.1.1.1.17
Unsigned32 · pixels
The picture width in receive direction for a video call session.
cVideoCommonHistoryRxPictureHeight
1.3.6.1.4.1.9.9.753.1.1.1.1.18
Unsigned32 · pixels
The picture height in receive direction for a video call session.
cVideoCommonHistoryRxConfigFrameRate
1.3.6.1.4.1.9.9.753.1.1.1.1.19
Unsigned32 · frames per second
The video stream frame rate in receive direction for a video call session.
cVideoCommonHistoryRxConfigBitrate
1.3.6.1.4.1.9.9.753.1.1.1.1.20
Unsigned32 · kilobits per second
The video stream bitrate in receive direction for a video call session.
cVideoCommonHistoryRxPayloadFormat
1.3.6.1.4.1.9.9.753.1.1.1.1.21
CvcVideoRtpPayloadFormat0 = unknown1 = rfc21902 = rfc24293 = rfc46294 = rfc3984A value that represents a type of the RTP payload format used for video stream.
RFC2190 (1) - RTP payload format for video codec H.263 RFC2429 (2) - RTP payload format for video codec H.263 RFC4629 (3) - RTP payload format for video codec H.263 RFC3984 (4) - RTP payload format for video codec H.264Reference: RFC 2190 - RTP Payload Format for H.263 Video Streams RFC 2429 - RTP Payload Format for the 1998 Version of ITU-T Rec. H.263 Video (H.263+) RFC 4629 - RTP Payload Format for ITU-T Rec. H.263 Video RFC 3984 - RTP Payload Format for H.264 Video · Integer32
The video stream RTP payload format in receive direction for a video call session.
cVideoCommonHistoryRxAnnex
1.3.6.1.4.1.9.9.753.1.1.1.1.22
CvcVideoCodecAnnexMapThis is a bit map that describes the annex(es) present for the video codec. Multiple annexes can be present; bits that are set to 1 indicate the supported annex(es) correspondingly.
No annex - 0x000000 (no bit is on)
Annex D.1 - 0x000001 (bit 0) Annex D.2 - 0x000002 (bit 1)
Annex E - 0x000004 (bit 2)
Annex F - 0x000008 (bit 3)
Annex G - 0x000010 (bit 4)
Annex H - 0x000020 (bit 5)
Annex I - 0x000040 (bit 6)
Annex J - 0x000080 (bit 7)
Annex K - 0x000100 (bit 8)
Annex L - 0x000200 (bit 9)
Annex M - 0x000400 (bit 10)
Annex N - 0x000800 (bit 11)
Annex O - 0x001000 (bit 12)
Annex P - 0x002000 (bit 13)
Annex Q - 0x004000 (bit 14)
Annex R - 0x008000 (bit 15)
Annex S - 0x010000 (bit 16)
Annex T - 0x020000 (bit 17)
Annex U - 0x040000 (bit 18)
Annex V - 0x080000 (bit 19)
Annex W - 0x100000 (bit 20)
CvcVideoCodecAnnexMap object is superseded by CvcVideoCodecAnnexMap in CISCO-VIDEO-TC.Reference: ITU-T H.263 Annex A - Inverse transform accuracy specification Annex B - Hypothetical Reference Decoder Annex C - Considerations for multipoint Annex D - Unrestricted Motion Vector Mode Annex E - Syntax-based Arithmetic Coding mode Annex F - Advanced Prediction mode Annex G - PB-frames mode Annex H - Forward error correction for coded video signal Annex I - Advanced INTRA Coding mode Annex J - Deblocking Filter mode Annex K - Slice Structured mode Annex L - Supplemental enhancement information specification Annex M - Improved PB-frames mode Annex N - Reference Picture selection mode Annex O - Temporal, SNR, and Spatial Scalability mode Annex P - Reference picture resampling Annex Q - Reduced-Resolution Update mode Annex R - Independent Segment Decoding mode Annex S - Alternative INTER VLC mode Annex T - Modified Quantization mode Annex U - Enhanced reference picture selection mode Annex V - Data-partitioned slice mode Annex W - Additional supplemental enhancement information specification
ITU-T H.264 Annex C - Hypothetical reference decoder Annex D - Supplemental enhancement information Annex E - Video usability information Annex G - Scalable video coding Annex H - Multiview video coding · BITS
The video codec annex extension in receive direction for a video call session. Reference: ITU-T H.263 Annex A - Inverse transform accuracy specification Annex B - Hypothetical Reference Decoder Annex C - Considerations for multipoint Annex D - Unrestricted Motion Vector Mode Annex E - Syntax-based Arithmetic Coding mode Annex F - Advanced Prediction mode Annex G - PB-frames mode Annex H - Forward error correction for coded video signal Annex I - Advanced INTRA Coding mode Annex J - Deblocking Filter mode Annex K - Slice Structured mode Annex L - Supplemental enhancement information specification Annex M - Improved PB-frames mode Annex N - Reference Picture selection mode Annex O - Temporal, SNR, and Spatial Scalability mode Annex P - Reference picture resampling Annex Q - Reduced-Resolution Update mode Annex R - Independent Segment Decoding mode Annex S - Alternative INTER VLC mode Annex T - Modified Quantization mode Annex U - Enhanced reference picture selection mode Annex V - Data-partitioned slice mode Annex W - Additional supplemental enhancement information specification
ITU-T H.264 Annex C - Hypothetical reference decoder Annex D - Supplemental enhancement information Annex E - Video usability information Annex G - Scalable video coding Annex H - Multiview video coding
cVideoCommonHistoryRxProfile
1.3.6.1.4.1.9.9.753.1.1.1.1.23
CvcVideoProfile10 = h263Profile011 = h263Profile112 = h263Profile213 = h263Profile314 = h263Profile415 = h263Profile516 = h263Profile617 = h263Profile718 = h263Profile8100 = h264ProfileBaseline101 = h264ProfileMain102 = h264ProfileExtended103 = h264ProfileHigh104 = h264ProfileHigh10105 = h264ProfileHigh422106 = h264ProfileHigh444Predictive107 = h264ProfileHigh10Intra108 = h264ProfileHigh422Intra109 = h264ProfileHigh444Intra110 = h264ProfileCavlc444Intra255 = otherThis object specifies the H.264 profile of the video stream.
H.263 Profiles: Profile 0 (10) Profile 1 (11) Profile 2 (12) Profile 3 (13) Profile 4 (14) Profile 5 (15) Profile 6 (16) Profile 7 (17) Profile 8 (18)
H.264 Profiles: Baseline Profile (100) Main Profile (101) Extended Profile (102) High Profile (103) High 10 Profile (104) High 4:2:2 Profile (105) High 4:4:4 Predictive Profile (106) High 10 Intra Profile (107) High 4:2:2 Intra Profile (108) High 4:4:4 Intra Profile (109) CAVLC 4:4:4 Intra Profile (110)
CvcVideoProfile object is superseded by CvcVideoProfile in CISCO-VIDEO-TC.Reference: ITU-T H.263: Annex X.2 Profiles of preferred mode support ITU-T H.264: Annex A.2 Profiles · Integer32
The video stream profile in receive direction for a video call session. Reference: ITU-T H.263: Annex X.2 Profiles of preferred mode support ITU-T H.264: Annex A.2 Profiles
The video stream level in receive direction for a video call session. Reference: ITU-T H.264: Annex A.3 Levels
cVideoCommonHistoryRxPackets
1.3.6.1.4.1.9.9.753.1.1.1.1.25
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The total number of video data packets received for the video call session.
cVideoCommonHistoryRxBytes
1.3.6.1.4.1.9.9.753.1.1.1.1.26
Counter64 (0..18446744073709551615) · bytes
The total number of video data bytes received for the video call session.
cVideoCommonHistoryRxDuration
1.3.6.1.4.1.9.9.753.1.1.1.1.27
Unsigned32 · seconds
Duration of video stream path, in receive direction, opened for the call leg.
cVideoCommonHistorySessionId
1.3.6.1.4.1.9.9.753.1.1.1.1.28
Unsigned32
Session ID is assigned by the call manager to identify call legs that belong to the same call session.
cVideoConfereeHistoryTable
1.3.6.1.4.1.9.9.753.1.1.2
Index: cCallHistoryIndex
This table provides the video extension to the call history table of Cisco Dial Control MIB. It contains video call leg information and statistics for a video conference call (video conferee).
A monotonically increasing integer for the sole purpose of indexing call disconnection events. When it reaches the maximum value, an extremely unlikely event, the agent wraps the value back to 1 and may flush existing entries.
cVideoConfereeHistoryTotalDroppedPackets
1.3.6.1.4.1.9.9.753.1.1.2.1.1
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The total number of dropped video data packets for the video call session.
cVideoConfereeHistoryMaxJitter
1.3.6.1.4.1.9.9.753.1.1.2.1.2
Gauge32 · milliseconds
This object is superseded by cVideoCommonStatsHistoryTxMaxJitter in cVideoCommonStatsHistoryTable.
Maximum jitter measured since the beginning of the video call session.
cVideoConfereeHistoryMaxDelay
1.3.6.1.4.1.9.9.753.1.1.2.1.3
Gauge32 · milliseconds
This object is superseded by cVideoCommonStatsHistoryTxMaxDelay in cVideoCommonStatsHistoryTable.
Maximum delay measured since the beginning of the video call session.
cVideoConfereeHistoryTotalOutOfOrderPackets
1.3.6.1.4.1.9.9.753.1.1.2.1.4
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
This object is superseded by cVideoCommonStatsHistoryTxTotalOutOfOrderPackets in cVideoCommonStatsHistoryTable.
The total number of out-of-order video data packets for the video call session.
cVideoConfereeHistoryMaxOutOfSyncDelay
1.3.6.1.4.1.9.9.753.1.1.2.1.5
Gauge32 · milliseconds
Maximum out-of-sync delay measured since the beginning of the video call session.
cVideoConfereeHistoryTotalLostPackets
1.3.6.1.4.1.9.9.753.1.1.2.1.6
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
This object is superseded by cVideoCommonStatsHistoryTxTotalLostPackets in cVideoCommonStatsHistoryTable.
The total number of lost video data packets for the video call session.
cVideoCallHistoryTable
1.3.6.1.4.1.9.9.753.1.1.3
Index: cCallHistoryIndex
This table provides the video extension to the call history table of Cisco Dial Control MIB. It contains video call leg information and statistics for a point-to-point video call.
A monotonically increasing integer for the sole purpose of indexing call disconnection events. When it reaches the maximum value, an extremely unlikely event, the agent wraps the value back to 1 and may flush existing entries.
cVideoCallHistoryTxMacroblocksConcealed
1.3.6.1.4.1.9.9.753.1.1.3.1.1
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · macroblocks
Number of concealed macroblocks measured in transmit direction of the video call session. One macroblock is 16 pixels by 16 pixels.
cVideoCallHistoryTxFramesConcealed
1.3.6.1.4.1.9.9.753.1.1.3.1.2
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · frames
Number of concealed frames measured in transmit direction of the video call session.
cVideoCallHistoryTxBadHeaderPackets
1.3.6.1.4.1.9.9.753.1.1.3.1.3
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
Number of bad header packets measured in transmit direction of the video call session.
cVideoCallHistoryTxOverflowPackets
1.3.6.1.4.1.9.9.753.1.1.3.1.4
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
Number of overflow packets measured in transmit direction of the video call session.
cVideoCallHistoryTxOutOfOrderPackets
1.3.6.1.4.1.9.9.753.1.1.3.1.5
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
This object is superseded by cVideoCommonStatsHistoryTxTotalOutOfOrderPackets in cVideoCommonStatsHistoryTable.
Number of out-of-order packets measured in transmit direction of the video call session.
cVideoCallHistoryTxLostPackets
1.3.6.1.4.1.9.9.753.1.1.3.1.6
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
This object is superseded by cVideoCommonStatsHistoryTxTotalLostPackets in cVideoCommonStatsHistoryTable.
Number of lost packets measured in transmit direction of the video call session.
cVideoCommonStatsHistoryTable
1.3.6.1.4.1.9.9.753.1.1.4
Index: cCallHistoryIndex
This table provides the video extension to the call history table of Cisco Dial Control MIB. It contains common video call leg statistics for both a video call within a conference (video conferee) and a simple video call.
A monotonically increasing integer for the sole purpose of indexing call disconnection events. When it reaches the maximum value, an extremely unlikely event, the agent wraps the value back to 1 and may flush existing entries.
cVideoCommonStatsHistoryTxTotalLostPackets
1.3.6.1.4.1.9.9.753.1.1.4.1.1
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
Number of lost packets of the video call session measured in transmit direction.
cVideoCommonStatsHistoryTxPercentLostPackets
1.3.6.1.4.1.9.9.753.1.1.4.1.2
Unsigned32 (0..100) · percent
The percentage of lost video data packets for the entire duration of the video call session in transmit direction.
cVideoCommonStatsHistoryTxTotalOutOfOrderPackets
1.3.6.1.4.1.9.9.753.1.1.4.1.3
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
Number of out-of-order packets of the video call session measured in transmit direction.
cVideoCommonStatsHistoryTxMaxJitter
1.3.6.1.4.1.9.9.753.1.1.4.1.4
Gauge32 · milliseconds
Maximum jitter measured since the beginning of the video call session in transmit direction.
cVideoCommonStatsHistoryTxAvgJitter
1.3.6.1.4.1.9.9.753.1.1.4.1.5
Gauge32 · milliseconds
Average jitter measured since the beginning of the video call session in transmit direction.
cVideoCommonStatsHistoryTxMaxDelay
1.3.6.1.4.1.9.9.753.1.1.4.1.6
Gauge32 · milliseconds
Maximum delay measured since the beginning of the video call session in transmit direction.
cVideoCommonStatsHistoryTxAvgDelay
1.3.6.1.4.1.9.9.753.1.1.4.1.7
Gauge32 · milliseconds
Average delay since the beginning of the video call session measured in transmit direction.
cVideoCommonStatsHistoryRxTotalLostPackets
1.3.6.1.4.1.9.9.753.1.1.4.1.8
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The total number of lost video data packets for the video call session in receive direction.
cVideoCommonStatsHistoryRxPercentLostPackets
1.3.6.1.4.1.9.9.753.1.1.4.1.9
Unsigned32 (0..100) · percent
The percentage of lost video data packets for the entire duration of the video call session in receive direction.
cVideoCommonActiveTable
1.3.6.1.4.1.9.9.753.1.2.1
Index: callActiveSetupTime · callActiveIndex
This table provides the video extension to the call active table of IETF Dial Control MIB. It contains common video call leg information and statistics for both a video call within a conference (video conferee) and a simple video call.
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime when the call associated to this entry was started. This will be useful for an NMS to retrieve all calls after a specific time. Also, this object can be useful in finding large delays between the time the call was started and the time the call was connected. For ISDN media, this will be the time when the setup message was received from or sent to the network.
callActiveIndex
INTEGER (1..2147483647) · Integer32
Small index variable to distinguish calls that start in the same hundredth of a second.
cVideoCommonActiveConnectionId
1.3.6.1.4.1.9.9.753.1.2.1.1.1
CvcGUidRepresents a Global Call Identifier. The global call identifier is used as an unique identifier for an end-to-end call. A zero length CvcGUid indicates no value for the global call identifier. SIZE (0..16) · OCTET STRING
The global call identifier for a video call leg.
cVideoCommonActiveCallReferenceId
1.3.6.1.4.1.9.9.753.1.2.1.1.2
CvcCallReferenceIdOrZeroA call reference ID correlates the video and audio call entries that belong to the same endpoint. In other words, if an audio call entry and a video call entry have the same call reference ID, these entries belong to the same endpoint. Because an audio-only endpoint creates only one call entry, call reference ID is not necessary and is set to zero. A call reference ID with value greater than zero signifies a video call, the value zero is object-specific and must therefore be defined as part of the description of any object which uses this syntax. Examples of the usage of zero include audio calls. · Unsigned32
The call reference ID associates the video call entry and voice call entry of the same endpoint. The call reference ID is assigned by the call manager and is non-zero for a video call session.
cVideoCommonActiveCallType
1.3.6.1.4.1.9.9.753.1.2.1.1.3
CvcVoIPCallServiceType1 = conferenceCall2 = pointToPointCall3 = monitoredCall255 = otherThis object describes the call type of this call entry.
conferenceCall (1) - This call belongs to a video conference.
pointToPointCall (2) - This call belongs to a point-to-point video call.
monitoredCall (3) - This call is monitored for video quality. · Integer32
This object describes the call type of this call entry.
cVideoCommonActiveTxCodec
1.3.6.1.4.1.9.9.753.1.2.1.1.4
CvcVideoCoderRate0 = none1 = h2612 = h2633 = h263plus4 = h264This object specifies the encoding type used to compress the video data of the voice call. · Integer32
The encoding type used to compress the video data in transmit direction for a video call session.
cVideoCommonActiveTxPictureWidth
1.3.6.1.4.1.9.9.753.1.2.1.1.5
Unsigned32 · pixels
The picture width in transmit direction for a video call session.
cVideoCommonActiveTxPictureHeight
1.3.6.1.4.1.9.9.753.1.2.1.1.6
Unsigned32 · pixels
The picture height in transmit direction for a video call session.
cVideoCommonActiveTxConfigFrameRate
1.3.6.1.4.1.9.9.753.1.2.1.1.7
Unsigned32 · frames per second
The video stream frame rate in transmit direction for a video call session.
cVideoCommonActiveTxConfigBitrate
1.3.6.1.4.1.9.9.753.1.2.1.1.8
Unsigned32 · kilobits per second
The video stream bitrate in transmit direction for a video call session.
cVideoCommonActiveTxPayloadFormat
1.3.6.1.4.1.9.9.753.1.2.1.1.9
CvcVideoRtpPayloadFormat0 = unknown1 = rfc21902 = rfc24293 = rfc46294 = rfc3984A value that represents a type of the RTP payload format used for video stream.
RFC2190 (1) - RTP payload format for video codec H.263 RFC2429 (2) - RTP payload format for video codec H.263 RFC4629 (3) - RTP payload format for video codec H.263 RFC3984 (4) - RTP payload format for video codec H.264Reference: RFC 2190 - RTP Payload Format for H.263 Video Streams RFC 2429 - RTP Payload Format for the 1998 Version of ITU-T Rec. H.263 Video (H.263+) RFC 4629 - RTP Payload Format for ITU-T Rec. H.263 Video RFC 3984 - RTP Payload Format for H.264 Video · Integer32
The video stream RTP payload format in transmit direction for a video call session.
cVideoCommonActiveTxAnnex
1.3.6.1.4.1.9.9.753.1.2.1.1.10
CvcVideoCodecAnnexMapThis is a bit map that describes the annex(es) present for the video codec. Multiple annexes can be present; bits that are set to 1 indicate the supported annex(es) correspondingly.
No annex - 0x000000 (no bit is on)
Annex D.1 - 0x000001 (bit 0) Annex D.2 - 0x000002 (bit 1)
Annex E - 0x000004 (bit 2)
Annex F - 0x000008 (bit 3)
Annex G - 0x000010 (bit 4)
Annex H - 0x000020 (bit 5)
Annex I - 0x000040 (bit 6)
Annex J - 0x000080 (bit 7)
Annex K - 0x000100 (bit 8)
Annex L - 0x000200 (bit 9)
Annex M - 0x000400 (bit 10)
Annex N - 0x000800 (bit 11)
Annex O - 0x001000 (bit 12)
Annex P - 0x002000 (bit 13)
Annex Q - 0x004000 (bit 14)
Annex R - 0x008000 (bit 15)
Annex S - 0x010000 (bit 16)
Annex T - 0x020000 (bit 17)
Annex U - 0x040000 (bit 18)
Annex V - 0x080000 (bit 19)
Annex W - 0x100000 (bit 20)
CvcVideoCodecAnnexMap object is superseded by CvcVideoCodecAnnexMap in CISCO-VIDEO-TC.Reference: ITU-T H.263 Annex A - Inverse transform accuracy specification Annex B - Hypothetical Reference Decoder Annex C - Considerations for multipoint Annex D - Unrestricted Motion Vector Mode Annex E - Syntax-based Arithmetic Coding mode Annex F - Advanced Prediction mode Annex G - PB-frames mode Annex H - Forward error correction for coded video signal Annex I - Advanced INTRA Coding mode Annex J - Deblocking Filter mode Annex K - Slice Structured mode Annex L - Supplemental enhancement information specification Annex M - Improved PB-frames mode Annex N - Reference Picture selection mode Annex O - Temporal, SNR, and Spatial Scalability mode Annex P - Reference picture resampling Annex Q - Reduced-Resolution Update mode Annex R - Independent Segment Decoding mode Annex S - Alternative INTER VLC mode Annex T - Modified Quantization mode Annex U - Enhanced reference picture selection mode Annex V - Data-partitioned slice mode Annex W - Additional supplemental enhancement information specification
ITU-T H.264 Annex C - Hypothetical reference decoder Annex D - Supplemental enhancement information Annex E - Video usability information Annex G - Scalable video coding Annex H - Multiview video coding · BITS
The video codec annex extension in transmit direction for a video call session. Reference: ITU-T H.263 Annex A - Inverse transform accuracy specification Annex B - Hypothetical Reference Decoder Annex C - Considerations for multipoint Annex D - Unrestricted Motion Vector Mode Annex E - Syntax-based Arithmetic Coding mode Annex F - Advanced Prediction mode Annex G - PB-frames mode Annex H - Forward error correction for coded video signal Annex I - Advanced INTRA Coding mode Annex J - Deblocking Filter mode Annex K - Slice Structured mode Annex L - Supplemental enhancement information specification Annex M - Improved PB-frames mode Annex N - Reference Picture selection mode Annex O - Temporal, SNR, and Spatial Scalability mode Annex P - Reference picture resampling Annex Q - Reduced-Resolution Update mode Annex R - Independent Segment Decoding mode Annex S - Alternative INTER VLC mode Annex T - Modified Quantization mode Annex U - Enhanced reference picture selection mode Annex V - Data-partitioned slice mode Annex W - Additional supplemental enhancement information specification
ITU-T H.264 Annex C - Hypothetical reference decoder Annex D - Supplemental enhancement information Annex E - Video usability information Annex G - Scalable video coding Annex H - Multiview video coding
cVideoCommonActiveTxProfile
1.3.6.1.4.1.9.9.753.1.2.1.1.11
CvcVideoProfile10 = h263Profile011 = h263Profile112 = h263Profile213 = h263Profile314 = h263Profile415 = h263Profile516 = h263Profile617 = h263Profile718 = h263Profile8100 = h264ProfileBaseline101 = h264ProfileMain102 = h264ProfileExtended103 = h264ProfileHigh104 = h264ProfileHigh10105 = h264ProfileHigh422106 = h264ProfileHigh444Predictive107 = h264ProfileHigh10Intra108 = h264ProfileHigh422Intra109 = h264ProfileHigh444Intra110 = h264ProfileCavlc444Intra255 = otherThis object specifies the H.264 profile of the video stream.
H.263 Profiles: Profile 0 (10) Profile 1 (11) Profile 2 (12) Profile 3 (13) Profile 4 (14) Profile 5 (15) Profile 6 (16) Profile 7 (17) Profile 8 (18)
H.264 Profiles: Baseline Profile (100) Main Profile (101) Extended Profile (102) High Profile (103) High 10 Profile (104) High 4:2:2 Profile (105) High 4:4:4 Predictive Profile (106) High 10 Intra Profile (107) High 4:2:2 Intra Profile (108) High 4:4:4 Intra Profile (109) CAVLC 4:4:4 Intra Profile (110)
CvcVideoProfile object is superseded by CvcVideoProfile in CISCO-VIDEO-TC.Reference: ITU-T H.263: Annex X.2 Profiles of preferred mode support ITU-T H.264: Annex A.2 Profiles · Integer32
The video stream profile in transmit direction for a video call session. Reference: ITU-T H.263: Annex X.2 Profiles of preferred mode support ITU-T H.264: Annex A.2 Profiles
The video stream level in transmit direction for a video call session. Reference: ITU-T H.264: Annex A.3 Levels
cVideoCommonActiveTxPackets
1.3.6.1.4.1.9.9.753.1.2.1.1.13
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The total number of video data packets transmitted for the video call session.
cVideoCommonActiveTxBytes
1.3.6.1.4.1.9.9.753.1.2.1.1.14
Counter64 (0..18446744073709551615) · bytes
The total number of video data bytes transmitted for the video call session.
cVideoCommonActiveTxDuration
1.3.6.1.4.1.9.9.753.1.2.1.1.15
Unsigned32 · seconds
Duration of video stream path, in transmit direction, opened for the call leg.
cVideoCommonActiveRxCodec
1.3.6.1.4.1.9.9.753.1.2.1.1.16
CvcVideoCoderRate0 = none1 = h2612 = h2633 = h263plus4 = h264This object specifies the encoding type used to compress the video data of the voice call. · Integer32
The negotiated encoding type used to compress the video data in receive direction for a video call session.
cVideoCommonActiveRxPictureWidth
1.3.6.1.4.1.9.9.753.1.2.1.1.17
Unsigned32 · pixels
The negotiated picture width in receive direction for a video call session.
cVideoCommonActiveRxPictureHeight
1.3.6.1.4.1.9.9.753.1.2.1.1.18
Unsigned32 · pixels
The negotiated picture height in receive direction for a video call session.
cVideoCommonActiveRxConfigFrameRate
1.3.6.1.4.1.9.9.753.1.2.1.1.19
Unsigned32 · frames per second
The negotiated video stream frame rate in receive direction for a video call session.
cVideoCommonActiveRxConfigBitrate
1.3.6.1.4.1.9.9.753.1.2.1.1.20
Unsigned32 · kilobits per second
The negotiated video stream bitrate in receive direction for a video call session.
cVideoCommonActiveRxPayloadFormat
1.3.6.1.4.1.9.9.753.1.2.1.1.21
CvcVideoRtpPayloadFormat0 = unknown1 = rfc21902 = rfc24293 = rfc46294 = rfc3984A value that represents a type of the RTP payload format used for video stream.
RFC2190 (1) - RTP payload format for video codec H.263 RFC2429 (2) - RTP payload format for video codec H.263 RFC4629 (3) - RTP payload format for video codec H.263 RFC3984 (4) - RTP payload format for video codec H.264Reference: RFC 2190 - RTP Payload Format for H.263 Video Streams RFC 2429 - RTP Payload Format for the 1998 Version of ITU-T Rec. H.263 Video (H.263+) RFC 4629 - RTP Payload Format for ITU-T Rec. H.263 Video RFC 3984 - RTP Payload Format for H.264 Video · Integer32
The video stream RTP payload format in receive direction for a video call session.
cVideoCommonActiveRxAnnex
1.3.6.1.4.1.9.9.753.1.2.1.1.22
CvcVideoCodecAnnexMapThis is a bit map that describes the annex(es) present for the video codec. Multiple annexes can be present; bits that are set to 1 indicate the supported annex(es) correspondingly.
No annex - 0x000000 (no bit is on)
Annex D.1 - 0x000001 (bit 0) Annex D.2 - 0x000002 (bit 1)
Annex E - 0x000004 (bit 2)
Annex F - 0x000008 (bit 3)
Annex G - 0x000010 (bit 4)
Annex H - 0x000020 (bit 5)
Annex I - 0x000040 (bit 6)
Annex J - 0x000080 (bit 7)
Annex K - 0x000100 (bit 8)
Annex L - 0x000200 (bit 9)
Annex M - 0x000400 (bit 10)
Annex N - 0x000800 (bit 11)
Annex O - 0x001000 (bit 12)
Annex P - 0x002000 (bit 13)
Annex Q - 0x004000 (bit 14)
Annex R - 0x008000 (bit 15)
Annex S - 0x010000 (bit 16)
Annex T - 0x020000 (bit 17)
Annex U - 0x040000 (bit 18)
Annex V - 0x080000 (bit 19)
Annex W - 0x100000 (bit 20)
CvcVideoCodecAnnexMap object is superseded by CvcVideoCodecAnnexMap in CISCO-VIDEO-TC.Reference: ITU-T H.263 Annex A - Inverse transform accuracy specification Annex B - Hypothetical Reference Decoder Annex C - Considerations for multipoint Annex D - Unrestricted Motion Vector Mode Annex E - Syntax-based Arithmetic Coding mode Annex F - Advanced Prediction mode Annex G - PB-frames mode Annex H - Forward error correction for coded video signal Annex I - Advanced INTRA Coding mode Annex J - Deblocking Filter mode Annex K - Slice Structured mode Annex L - Supplemental enhancement information specification Annex M - Improved PB-frames mode Annex N - Reference Picture selection mode Annex O - Temporal, SNR, and Spatial Scalability mode Annex P - Reference picture resampling Annex Q - Reduced-Resolution Update mode Annex R - Independent Segment Decoding mode Annex S - Alternative INTER VLC mode Annex T - Modified Quantization mode Annex U - Enhanced reference picture selection mode Annex V - Data-partitioned slice mode Annex W - Additional supplemental enhancement information specification
ITU-T H.264 Annex C - Hypothetical reference decoder Annex D - Supplemental enhancement information Annex E - Video usability information Annex G - Scalable video coding Annex H - Multiview video coding · BITS
The video codec annex extension in receive direction for a video call session. Reference: ITU-T H.263 Annex A - Inverse transform accuracy specification Annex B - Hypothetical Reference Decoder Annex C - Considerations for multipoint Annex D - Unrestricted Motion Vector Mode Annex E - Syntax-based Arithmetic Coding mode Annex F - Advanced Prediction mode Annex G - PB-frames mode Annex H - Forward error correction for coded video signal Annex I - Advanced INTRA Coding mode Annex J - Deblocking Filter mode Annex K - Slice Structured mode Annex L - Supplemental enhancement information specification Annex M - Improved PB-frames mode Annex N - Reference Picture selection mode Annex O - Temporal, SNR, and Spatial Scalability mode Annex P - Reference picture resampling Annex Q - Reduced-Resolution Update mode Annex R - Independent Segment Decoding mode Annex S - Alternative INTER VLC mode Annex T - Modified Quantization mode Annex U - Enhanced reference picture selection mode Annex V - Data-partitioned slice mode Annex W - Additional supplemental enhancement information specification
ITU-T H.264 Annex C - Hypothetical reference decoder Annex D - Supplemental enhancement information Annex E - Video usability information Annex G - Scalable video coding Annex H - Multiview video coding
cVideoCommonActiveRxProfile
1.3.6.1.4.1.9.9.753.1.2.1.1.23
CvcVideoProfile10 = h263Profile011 = h263Profile112 = h263Profile213 = h263Profile314 = h263Profile415 = h263Profile516 = h263Profile617 = h263Profile718 = h263Profile8100 = h264ProfileBaseline101 = h264ProfileMain102 = h264ProfileExtended103 = h264ProfileHigh104 = h264ProfileHigh10105 = h264ProfileHigh422106 = h264ProfileHigh444Predictive107 = h264ProfileHigh10Intra108 = h264ProfileHigh422Intra109 = h264ProfileHigh444Intra110 = h264ProfileCavlc444Intra255 = otherThis object specifies the H.264 profile of the video stream.
H.263 Profiles: Profile 0 (10) Profile 1 (11) Profile 2 (12) Profile 3 (13) Profile 4 (14) Profile 5 (15) Profile 6 (16) Profile 7 (17) Profile 8 (18)
H.264 Profiles: Baseline Profile (100) Main Profile (101) Extended Profile (102) High Profile (103) High 10 Profile (104) High 4:2:2 Profile (105) High 4:4:4 Predictive Profile (106) High 10 Intra Profile (107) High 4:2:2 Intra Profile (108) High 4:4:4 Intra Profile (109) CAVLC 4:4:4 Intra Profile (110)
CvcVideoProfile object is superseded by CvcVideoProfile in CISCO-VIDEO-TC.Reference: ITU-T H.263: Annex X.2 Profiles of preferred mode support ITU-T H.264: Annex A.2 Profiles · Integer32
The negotiated video stream profile in receive direction for a video call session. Reference: ITU-T H.263: Annex X.2 Profiles of preferred mode support ITU-T H.264: Annex A.2 Profiles
The negotiated video stream level in receive direction for a video call session. Reference: ITU-T H.264: Annex A.3 Levels
cVideoCommonActiveRxPackets
1.3.6.1.4.1.9.9.753.1.2.1.1.25
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The total number of video data packets received for the video call session.
cVideoCommonActiveRxBytes
1.3.6.1.4.1.9.9.753.1.2.1.1.26
Counter64 (0..18446744073709551615) · bytes
The total number of video data bytes received for the video call session.
cVideoCommonActiveRxDuration
1.3.6.1.4.1.9.9.753.1.2.1.1.27
Unsigned32 · seconds
Duration of video stream path, in receive direction, opened for the call leg.
cVideoCommonActiveSessionId
1.3.6.1.4.1.9.9.753.1.2.1.1.28
Unsigned32
Session ID is assigned by the call manager to identify call legs that belong to the same call session.
cVideoConfereeActiveTable
1.3.6.1.4.1.9.9.753.1.2.2
Index: callActiveSetupTime · callActiveIndex
This table provides the video extension to the call active table of IETF Dial Control MIB. It contains video call leg information and statistics for a video call within a conference (video conferee).
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime when the call associated to this entry was started. This will be useful for an NMS to retrieve all calls after a specific time. Also, this object can be useful in finding large delays between the time the call was started and the time the call was connected. For ISDN media, this will be the time when the setup message was received from or sent to the network.
callActiveIndex
INTEGER (1..2147483647) · Integer32
Small index variable to distinguish calls that start in the same hundredth of a second.
cVideoConfereeActiveActualFrameRate
1.3.6.1.4.1.9.9.753.1.2.2.1.1
Unsigned32 · frames per second
The actual measured video stream frame rate for a video call session.
cVideoConfereeActiveActualBitrate
1.3.6.1.4.1.9.9.753.1.2.2.1.2
Unsigned32 · kilobits per second
This object is superseded by cVideoCommonStatsActiveTxActualBitrate in cVideoCommonStatsActiveTable.
The actual measured video stream bitrate for a video call session.
cVideoConfereeActiveTotalDroppedPackets
1.3.6.1.4.1.9.9.753.1.2.2.1.3
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The total number of dropped video data packets for the video call session.
cVideoConfereeActiveCurrentDroppedPackets
1.3.6.1.4.1.9.9.753.1.2.2.1.4
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The number of dropped video data packets within the last 5 seconds for the video call session.
cVideoConfereeActiveTotalOutOfOrderPackets
1.3.6.1.4.1.9.9.753.1.2.2.1.5
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
This object is superseded by cVideoCommonStatsActiveTxTotalOutOfOrderPackets in cVideoCommonStatsActiveTable.
The total number of out-of-order video data packets for the video call session.
cVideoConfereeActiveCurrentOutOfOrderPackets
1.3.6.1.4.1.9.9.753.1.2.2.1.6
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
This object is superseded by cVideoCommonStatsActiveTxCurrentOutOfOrderPackets in cVideoCommonStatsActiveTable.
The number of out-of-order video data packets within the last 5 seconds for the video call session.
cVideoConfereeActiveTotalLostPackets
1.3.6.1.4.1.9.9.753.1.2.2.1.7
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
This object is superseded by cVideoCommonStatsActiveTxTotalLostPackets in cVideoCommonStatsActiveTable.
The total number of lost video data packets for the video call session.
cVideoConfereeActiveCurrentLostPackets
1.3.6.1.4.1.9.9.753.1.2.2.1.8
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
This object is superseded by cVideoCommonStatsActiveTxCurrentLostPackets in cVideoCommonStatsActiveTable.
The number of lost video data packets within the last 5 seconds for the video call session.
cVideoConfereeActiveMaxJitter
1.3.6.1.4.1.9.9.753.1.2.2.1.9
Gauge32 · milliseconds
This object is superseded by cVideoCommonStatsActiveTxMaxJitter in cVideoCommonStatsActiveTable.
Maximum jitter measured since the beginning of the video call session.
cVideoConfereeActiveCurrentJitter
1.3.6.1.4.1.9.9.753.1.2.2.1.10
Gauge32 · milliseconds
This object is superseded by cVideoCommonStatsActiveTxAvgJitter in cVideoCommonStatsActiveTable.
Average jitter measured within the last 5 seconds of the video call session.
cVideoConfereeActiveMaxDelay
1.3.6.1.4.1.9.9.753.1.2.2.1.11
Gauge32 · milliseconds
This object is superseded by cVideoCommonStatsActiveTxMaxDelay in cVideoCommonStatsActiveTable.
Maximum delay measured since the beginning of the video call session.
cVideoConfereeActiveCurrentDelay
1.3.6.1.4.1.9.9.753.1.2.2.1.12
Gauge32 · milliseconds
This object is superseded by cVideoCommonStatsActiveTxCurrentDelay in cVideoCommonStatsActiveTable.
Average delay measured within the last 5 seconds of the video call session.
cVideoConfereeActiveMaxOutOfSyncDelay
1.3.6.1.4.1.9.9.753.1.2.2.1.13
Gauge32 · milliseconds
Maximum out-of-sync delay measured since the beginning of the video call session.
cVideoConfereeActiveCurrentOutOfSyncDelay
1.3.6.1.4.1.9.9.753.1.2.2.1.14
Gauge32 · milliseconds
Average out-of-sync delay measured within the last 5 seconds of the video call session.
cVideoConfereeActiveFastVideoUpdateRate
1.3.6.1.4.1.9.9.753.1.2.2.1.15
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32
Number of fast video update requests within the last 60 seconds.
cVideoCallActiveTable
1.3.6.1.4.1.9.9.753.1.2.3
Index: callActiveSetupTime · callActiveIndex
This table provides the video extension to the call active table of IETF Dial Control MIB. It contains video call leg information and statistics for a point-to-point video call.
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime when the call associated to this entry was started. This will be useful for an NMS to retrieve all calls after a specific time. Also, this object can be useful in finding large delays between the time the call was started and the time the call was connected. For ISDN media, this will be the time when the setup message was received from or sent to the network.
callActiveIndex
INTEGER (1..2147483647) · Integer32
Small index variable to distinguish calls that start in the same hundredth of a second.
cVideoCallActiveRxActualBitrate
1.3.6.1.4.1.9.9.753.1.2.3.1.1
Unsigned32 · kilobits per second
This object is superseded by cVideoCommonStatsActiveRxActualBitrate in cVideoCommonStatsActiveTable.
The actual measured video stream bitrate in receive direction for a video call session.
cVideoCallActiveTxMacroblocksConcealed
1.3.6.1.4.1.9.9.753.1.2.3.1.2
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · macroblocks
Number of concealed macroblocks measured in transmit direction of the video call session. One macroblock is 16 pixels by 16 pixels.
cVideoCallActiveTxFramesConcealed
1.3.6.1.4.1.9.9.753.1.2.3.1.3
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · frames
Number of concealed frames measured in transmit direction of the video call session.
cVideoCallActiveTxBadHeaderPackets
1.3.6.1.4.1.9.9.753.1.2.3.1.4
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
Number of bad header packets measured in transmit direction of the video call session.
cVideoCallActiveTxOverflowPackets
1.3.6.1.4.1.9.9.753.1.2.3.1.5
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
Number of overflow packets measured in transmit direction of the video call session.
cVideoCallActiveTxLostPackets
1.3.6.1.4.1.9.9.753.1.2.3.1.6
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
This object is superseded by cVideoCommonStatsActiveTxTotalLostPackets in cVideoCommonStatsActiveTable.
Number of lost packets measured in transmit direction of the video call session.
cVideoCommonStatsActiveTable
1.3.6.1.4.1.9.9.753.1.2.4
Index: callActiveSetupTime · callActiveIndex
This table provides the video extension to the call active table of IETF Dial Control MIB. It contains common video call leg statistics for both a video call within a conference (video conferee) and a simple video call.
TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be
defined in the description of any object defined using this type.
If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks
The value of sysUpTime when the call associated to this entry was started. This will be useful for an NMS to retrieve all calls after a specific time. Also, this object can be useful in finding large delays between the time the call was started and the time the call was connected. For ISDN media, this will be the time when the setup message was received from or sent to the network.
callActiveIndex
INTEGER (1..2147483647) · Integer32
Small index variable to distinguish calls that start in the same hundredth of a second.
cVideoCommonStatsActiveTxActualBitrate
1.3.6.1.4.1.9.9.753.1.2.4.1.1
Unsigned32 · kilobits per second
The actual measured video stream bitrate in transmit direction for a video call session.
cVideoCommonStatsActiveTxTotalLostPackets
1.3.6.1.4.1.9.9.753.1.2.4.1.2
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The total number of lost video data packets for the video call session in transmit direction.
cVideoCommonStatsActiveTxPercentLostPackets
1.3.6.1.4.1.9.9.753.1.2.4.1.3
Unsigned32 (0..100) · percent
The percentage of lost video data packets for the entire duration of the video call session in transmit direction.
cVideoCommonStatsActiveTxCurrentLostPackets
1.3.6.1.4.1.9.9.753.1.2.4.1.4
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
Number of lost packets within the last 5 seconds of the video call session in transmit direction.
cVideoCommonStatsActiveTxTotalOutOfOrderPackets
1.3.6.1.4.1.9.9.753.1.2.4.1.5
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The total number of out-of-order video data packets for the video call session.
cVideoCommonStatsActiveTxCurrentOutOfOrderPackets
1.3.6.1.4.1.9.9.753.1.2.4.1.6
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The number of out-of-order video data packets within the last 5 seconds for the video call session in transmit direction.
cVideoCommonStatsActiveTxMaxJitter
1.3.6.1.4.1.9.9.753.1.2.4.1.7
Gauge32 · milliseconds
Maximum jitter measured since the beginning of the video call session in transmit direction.
cVideoCommonStatsActiveTxAvgJitter
1.3.6.1.4.1.9.9.753.1.2.4.1.8
Gauge32 · milliseconds
Average jitter calculated over the entire duration of the video call session in transmit direction.
cVideoCommonStatsActiveTxCurrentJitter
1.3.6.1.4.1.9.9.753.1.2.4.1.9
Gauge32 · milliseconds
Average jitter measured within the last 5 seconds of the video call session in transmit direction.
cVideoCommonStatsActiveTxMaxDelay
1.3.6.1.4.1.9.9.753.1.2.4.1.10
Gauge32 · milliseconds
Maximum delay measured since the beginning of the video call session in transmit direction.
cVideoCommonStatsActiveTxAvgDelay
1.3.6.1.4.1.9.9.753.1.2.4.1.11
Gauge32 · milliseconds
Average delay calculated over the entire duration of the video call session in transmit direction.
cVideoCommonStatsActiveTxCurrentDelay
1.3.6.1.4.1.9.9.753.1.2.4.1.12
Gauge32 · milliseconds
Average delay measured within the last 5 seconds of the video call session in transmit direction.
cVideoCommonStatsActiveRxActualBitrate
1.3.6.1.4.1.9.9.753.1.2.4.1.13
Unsigned32 · kilobits per second
The actual measured video stream bitrate in receive direction for a video call session.
cVideoCommonStatsActiveRxTotalLostPackets
1.3.6.1.4.1.9.9.753.1.2.4.1.14
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
The total number of lost video data packets for the video call session in receive direction.
cVideoCommonStatsActiveRxPercentLostPackets
1.3.6.1.4.1.9.9.753.1.2.4.1.15
Unsigned32 (0..100) · percent
The percentage of lost video data packets for the entire duration of the video call session in receive direction.
cVideoCommonStatsActiveRxCurrentLostPackets
1.3.6.1.4.1.9.9.753.1.2.4.1.16
AbsoluteCounter32Represents a Counter32-like value that starts at zero, does not decrease, and does not wrap. This may be used only in situations where wrapping is not possible or extremely unlikely. Should such a counter overflow, it locks at the maxium value of 4,294,967,295.
The primary use of this type of counter is situations where a counter value is to be recorded as history and is thus no longer subject to reading for changing values. · Unsigned32 · packets
Number of lost packets within the last 5 seconds of the video call session in receive direction.