EZ5 MIB Catalog

CISCO-VOICE-ATM-DIAL-CONTROL-MIB

2002-11-17

Download CISCO-VOICE-ATM-DIAL-CONTROL-MIB.txt Open CISCO-VOICE-ATM-DIAL-CONTROL-MIB.txt in a new tab

This MIB module enhances the IETF Dial Control MIB (RFC2128) by providing ATM management information over a data network.

TABLES (3)

Tables (3)

NameOID
cvAtmCallHistoryTable1.3.6.1.4.1.9.10.35.1.1.1
cvAtmCallActiveTable1.3.6.1.4.1.9.10.35.1.2.1
cvAtmPeerCfgTable1.3.6.1.4.1.9.10.35.1.3.1

END OF TOC

Table details

cvAtmCallHistoryTable

1.3.6.1.4.1.9.10.35.1.1.1

Index: cCallHistoryIndex

This table is the ATM extension to the call history table of IETF Dial Control MIB. It contains ATM call leg information about specific voice over ATM call.

from CISCO-DIAL-CONTROL-MIB

cCallHistoryIndex

Unsigned32 (1..4294967295)

A monotonically increasing integer for the sole purpose of indexing call disconnection events. When it reaches the maximum value, an extremely unlikely event, the agent wraps the value back to 1 and may flush existing entries.

cvAtmCallHistoryConnectionId

1.3.6.1.4.1.9.10.35.1.1.1.1.1

CvcGUidRepresents a Global Call Identifier. The global call identifier is used as an unique identifier for an end-to-end call. A zero length CvcGUid indicates no value for the global call identifier. SIZE (0..16) · OCTET STRING

The global call identifier for the ATM call.

cvAtmCallHistoryVpi

1.3.6.1.4.1.9.10.35.1.1.1.1.2

INTEGER (0..4095) · Integer32

The VPI used for this ATM connection.

cvAtmCallHistoryVci

1.3.6.1.4.1.9.10.35.1.1.1.1.3

INTEGER (0..65535) · Integer32

The VCI used for this ATM connection.

cvAtmCallHistoryLowerIfName

1.3.6.1.4.1.9.10.35.1.1.1.1.4

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The ifName of the ATM interface associated with this call.

cvAtmCallHistorySessionTarget

1.3.6.1.4.1.9.10.35.1.1.1.1.5

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The object indicates the session target of the peer that was used for the voice over ATM call. A zero length string indicates that the value is unavailable.

cvAtmCallHistorySubchannelID

1.3.6.1.4.1.9.10.35.1.1.1.1.6

INTEGER (0..255) · Integer32

The subchannel used for this ATM connection.

cvAtmCallHistorySessionProtocol

1.3.6.1.4.1.9.10.35.1.1.1.1.7

CvAtmSessionProtocol1 = other2 = ciscoSwitched3 = aal2TrunkRepresents a Session Protocol used by Voice calls between a local and remote router via the ATM backbone. other - none of the following. ciscoSwitched - cisco proprietary ATM session protocol. · Integer32

Indicates the session protocol used on this call.

cvAtmCallHistoryCalledNumber

1.3.6.1.4.1.9.10.35.1.1.1.1.8

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Indicates the called party number for trunk connection calls. A zero length string indicates that this data is unavailable.

cvAtmCallHistoryDtmfRelay

1.3.6.1.4.1.9.10.35.1.1.1.1.9

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicates if Dtmf Relay was enabled for the call.

cvAtmCallHistoryUseSeqNumbers

1.3.6.1.4.1.9.10.35.1.1.1.1.10

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicates if Sequence Numbers were used on the voice data packets.

cvAtmCallActiveTable

1.3.6.1.4.1.9.10.35.1.2.1

Index: callActiveSetupTime · callActiveIndex

This table is the ATM extension to the active call table of IETF Dial Control MIB. It contains ATM call leg information about specific voice over ATM call.

from DIAL-CONTROL-MIB

callActiveSetupTime

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of sysUpTime when the call associated to this entry was started. This will be useful for an NMS to retrieve all calls after a specific time. Also, this object can be useful in finding large delays between the time the call was started and the time the call was connected. For ISDN media, this will be the time when the setup message was received from or sent to the network.

callActiveIndex

INTEGER (1..2147483647) · Integer32

Small index variable to distinguish calls that start in the same hundredth of a second.

cvAtmCallActiveConnectionId

1.3.6.1.4.1.9.10.35.1.2.1.1.1

CvcGUidRepresents a Global Call Identifier. The global call identifier is used as an unique identifier for an end-to-end call. A zero length CvcGUid indicates no value for the global call identifier. SIZE (0..16) · OCTET STRING

The global call identifier for the ATM call.

cvAtmCallActiveVpi

1.3.6.1.4.1.9.10.35.1.2.1.1.2

INTEGER (0..4095) · Integer32

The VPI used for this ATM connection.

cvAtmCallActiveVci

1.3.6.1.4.1.9.10.35.1.2.1.1.3

INTEGER (0..65535) · Integer32

The VCI used for this ATM connection.

cvAtmCallActiveLowerIfName

1.3.6.1.4.1.9.10.35.1.2.1.1.4

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The ifName of the ATM interface associated with this call.

cvAtmCallActiveSessionTarget

1.3.6.1.4.1.9.10.35.1.2.1.1.5

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The object indicates the session target of the peer that is used for the voice over ATM call. A null string indicates that the value is unavailable.

cvAtmCallActiveSubchannelID

1.3.6.1.4.1.9.10.35.1.2.1.1.6

INTEGER (0..255) · Integer32

The subchannel used for this ATM connection.

cvAtmCallActiveSessionProtocol

1.3.6.1.4.1.9.10.35.1.2.1.1.7

CvAtmSessionProtocol1 = other2 = ciscoSwitched3 = aal2TrunkRepresents a Session Protocol used by Voice calls between a local and remote router via the ATM backbone. other - none of the following. ciscoSwitched - cisco proprietary ATM session protocol. · Integer32

Indicates the session protocol being used on this call.

cvAtmCallActiveCalledNumber

1.3.6.1.4.1.9.10.35.1.2.1.1.8

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Indicates the called party number for trunk connection calls. A null string indicates that this data is unavailable.

cvAtmCallActiveDtmfRelay

1.3.6.1.4.1.9.10.35.1.2.1.1.9

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicates if Dtmf Relay is enabled for the call.

cvAtmCallActiveUseSeqNumbers

1.3.6.1.4.1.9.10.35.1.2.1.1.10

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Indicates if Sequence Numbers are used on the voice data packets.

cvAtmPeerCfgTable

1.3.6.1.4.1.9.10.35.1.3.1

Index: ifIndex

The table contains the Voice over ATM (ATM) peer specific information that is required to accept or place voice calls via the ATM backbone with the session protocol specified in cvAtmPeerCfgSessionProtocol.

from IF-MIB

ifIndex

InterfaceIndexA unique value, greater than zero, for each interface or interface sub-layer in the managed system. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. (1..2147483647) · Integer32 · hint d

A unique value, greater than zero, for each interface. It is recommended that values are assigned contiguously starting from 1. The value for each interface sub-layer must remain constant at least from one re-initialization of the entity's network management system to the next re- initialization.

cvAtmPeerCfgSessionProtocol

1.3.6.1.4.1.9.10.35.1.3.1.1.1

CvAtmSessionProtocol1 = other2 = ciscoSwitched3 = aal2TrunkRepresents a Session Protocol used by Voice calls between a local and remote router via the ATM backbone. other - none of the following. ciscoSwitched - cisco proprietary ATM session protocol. · Integer32

The object specifies the session protocol to be used for Internet call between local and remote router via ATM backbone.

cvAtmPeerCfgInterfaceName

1.3.6.1.4.1.9.10.35.1.3.1.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The object specifies the ifName on which the call will go out. A zero length string indicates that no interface has been assigned.

cvAtmPeerCfgVpi

1.3.6.1.4.1.9.10.35.1.3.1.1.3

INTEGER (0..4095) · Integer32

The VPI used for this ATM connection.

cvAtmPeerCfgVci

1.3.6.1.4.1.9.10.35.1.3.1.1.4

INTEGER (0..65535) · Integer32

The VCI used for this ATM connection.

cvAtmPeerCfgVcName

1.3.6.1.4.1.9.10.35.1.3.1.1.5

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

The VC Name used for this ATM connection.

cvAtmPeerCfgCoderRate

1.3.6.1.4.1.9.10.35.1.3.1.1.6

CvcSpeechCoderRate1 = g729r80002 = g729Ar80003 = g726r160004 = g726r240005 = g726r320006 = g711ulawr640007 = g711Alawr640008 = g728r160009 = g723r630010 = g723r530011 = gsmr1320012 = g729Br800013 = g729ABr800014 = g723Ar630015 = g723Ar530016 = g729IETFr800017 = gsmeEr1220018 = clearChannel19 = g726r4000020 = llcc21 = gsmAmrNb22 = iLBC23 = iLBCr1520024 = iLBCr1333025 = g722r480026 = g722r560027 = g722r640028 = iSAC29 = aaclc30 = aacldThis object specifies the most desirable codec of speech for the VoIP, VoATM or VoFR peer. g729r8000 - pre-IETF G.729 8000 bps g729Ar8000 - G.729 ANNEX-A 8000 bps g726r16000 - G.726 16000 bps g726r24000 - G.726 24000 bps g726r32000 - G.726 32000 bps g711ulawr64000 - G.711 u-Law 64000 bps g711Alawr64000 - G.711 A-Law 64000 bps g728r16000 - G.728 16000 bps g723r6300 - G.723.1 6300 bps g723r5300 - G.723.1 5300 bps gsmr13200 - GSM Full rate 13200 bps g729Br8000 - G.729 ANNEX-B 8000 bps g729ABr8000 - G.729 ANNEX-A & B 8000 bps g723Ar6300 - G723.1 Annex A 6300 bps g723Ar5300 - G723.1 Annex A 5300 bps g729IETFr8000 - IETF G.729 8000 bps gsmeEr12200 - GSM Enhanced Full Rate 12200 bps clearChannel - CLEAR Channel codec g726r40000 - G.726 40000 bps llcc - Lossless compression codec gsmAmrNb - GSM AMR-NB 4750 - 12200 bps iLBC - iILBC 13330 or 15200 bps iLBCr15200 - iLBC 15200 bps iLBCr13330 - iLBC 13330 bps g722r4800 - G.722 (modes 1, 2, 3) g722r5600 - G.722 (modes 1, 2) g722r6400 - G.722 (mode 1) iSAC - iSAC (10 to 32 kbps) aaclc - AAC-LC Advanced Audio Coding Low Complexity aacld - AAC-LD MPEG-4 Low Delay Audio CoderReference: [1] RFC 3267: For introduction about GSM AMR-NB codec, section 3.1 [2] RFC 3952: For introduction about iLBC codec, section 2 · Integer32

This object specifies the default voice coder rate of speech for the ATM peer.

cvAtmPeerCfgCodecBytes

1.3.6.1.4.1.9.10.35.1.3.1.1.7

INTEGER (0..240) · Integer32

This object specifies the payload size for the voice packets to be transmitted during the call.

cvAtmPeerCfgFaxRate

1.3.6.1.4.1.9.10.35.1.3.1.1.8

CvcFaxTransmitRate1 = none2 = voiceRate3 = fax24004 = fax48005 = fax72006 = fax96007 = fax144008 = fax12000This object specifies the default transmit rate of FAX for the VoIP, VoATM or VOFR peer. If the value of this object is 'none', then the Fax relay feature is disabled ; otherwise the Fax relay feature is enabled. none - Fax relay is disabled. voiceRate - the fastest possible fax rate not exceed the configured voice rate. fax2400 - 2400 bps FAX transmit rate. fax4800 - 4800 bps FAX transmit rate. fax7200 - 7200 bps FAX transmit rate. fax9600 - 9600 bps FAX transmit rate. fax14400 - 14400 bps FAX transmit rate. fax12000 - 12000 bps FAX transmit rate. · Integer32

This object specifies the default transmit rate of FAX for the ATM peer. If the value of this object is 'none', then the Fax relay feature is disabled; otherwise the Fax relay feature is enabled.

cvAtmPeerCfgFaxBytes

1.3.6.1.4.1.9.10.35.1.3.1.1.9

INTEGER (0..240) · Integer32

This object specifies the payload size for the fax packets to be transmitted during the call.

cvAtmPeerCfgInBandSignaling

1.3.6.1.4.1.9.10.35.1.3.1.1.10

CvcInBandSignaling1 = cas2 = none3 = cept4 = transparent5 = gr303Represents the type of in-band signaling used between the two end points of the call and is used to inform the router how interpret the ABCD signaling data bits passed as part of the voice payload data. cas - specifies interpret the signaling bits as North American Channel Associated signaling. none - specifies no in-band signaling or signaling is being done via an external method (e.g CCS). cept - specifies interpret the signaling bits as MELCAS transparent - specifies do not interpret or translate the signaling bits. gr303 - specifies interpret the signaling bits as GR303 · Integer32

This object specifies the type of in-band signaling used between the two end points of the call and is used by the router to determine how to interpret the ABCD signaling bits sent as part of the voice payload data.

cvAtmPeerCfgVADEnable

1.3.6.1.4.1.9.10.35.1.3.1.1.11

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies whether or not VAD (Voice Activity Detection) is enabled. If the object value is 'false', then the voice data is continuously transmitted to ATM backbone.

cvAtmPeerCfgUseSeqNumbers

1.3.6.1.4.1.9.10.35.1.3.1.1.12

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies whether or not Sequence Numbers are generated on voice packets.

cvAtmPeerCfgDtmfRelay

1.3.6.1.4.1.9.10.35.1.3.1.1.13

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object specifies whether or not Dtmf Relay is enabled. If it is then dtmf digits are transported as FRF11 Annex C packets, instead of being encoded as speech.

↑ To TOC