EZ5 MIB Catalog

CISCO-VOICE-COMMON-DIAL-CONTROL-MIB

2010-06-30

Download CISCO-VOICE-COMMON-DIAL-CONTROL-MIB.txt Open CISCO-VOICE-COMMON-DIAL-CONTROL-MIB.txt in a new tab

This MIB module contains voice related objects that are common across more than one network encapsulation i.e VoIP, VoATM and VoFR. *** ABBREVIATIONS, ACRONYMS AND SYMBOLS *** GSM - Global System for Mobile Communication AMR-NB - Adaptive Multi Rate - Narrow Band iLBC - internet Low Bitrate Codec iSAC - internet Speech Audio Codec

TABLES (2)

Tables (2)

NameOID
cvCommonDcCallActiveTable1.3.6.1.4.1.9.10.55.1.1.1
cvCommonDcCallHistoryTable1.3.6.1.4.1.9.10.55.1.2.1

END OF TOC

Table details

cvCommonDcCallActiveTable

1.3.6.1.4.1.9.10.55.1.1.1

Index: callActiveSetupTime · callActiveIndex

This table is a common extension to the call active table of IETF Dial Control MIB. It contains common call leg information about a network call leg.

from DIAL-CONTROL-MIB

callActiveSetupTime

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of sysUpTime when the call associated to this entry was started. This will be useful for an NMS to retrieve all calls after a specific time. Also, this object can be useful in finding large delays between the time the call was started and the time the call was connected. For ISDN media, this will be the time when the setup message was received from or sent to the network.

callActiveIndex

INTEGER (1..2147483647) · Integer32

Small index variable to distinguish calls that start in the same hundredth of a second.

cvCommonDcCallActiveConnectionId

1.3.6.1.4.1.9.10.55.1.1.1.1.1

CvcGUidRepresents a Global Call Identifier. The global call identifier is used as an unique identifier for an end-to-end call. A zero length CvcGUid indicates no value for the global call identifier. SIZE (0..16) · OCTET STRING

The global call identifier for the network call.

cvCommonDcCallActiveVADEnable

1.3.6.1.4.1.9.10.55.1.1.1.1.2

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

The object indicates whether or not the VAD (Voice Activity Detection) is enabled for the voice call.

cvCommonDcCallActiveCoderTypeRate

1.3.6.1.4.1.9.10.55.1.1.1.1.3

CvcCoderTypeRate1 = other2 = fax24003 = fax48004 = fax72005 = fax96006 = fax144007 = fax1200010 = g729r800011 = g729Ar800012 = g726r1600013 = g726r2400014 = g726r3200015 = g711ulawr6400016 = g711Alawr6400017 = g728r1600018 = g723r630019 = g723r530020 = gsmr1320021 = g729Br800022 = g729ABr800023 = g723Ar630024 = g723Ar530025 = ietfg729r800026 = gsmeEr1220027 = clearChannel28 = g726r4000029 = llcc30 = gsmAmrNb31 = g72232 = iLBC33 = iLBCr1520034 = iLBCr1333035 = g722r480036 = g722r560037 = g722r640038 = iSAC39 = aaclc40 = aacldRepresents the coder type-rate for voice/fax compression used during a call. *** ABBREVIATIONS, ACRONYMS AND SYMBOLS *** GSM - Global System for Mobile Communication AMR-NB - Adaptive Multi Rate - Narrow Band iLBC - internet Low Bitrate Codec iSAC - internet Speech Audio Codec other - none of the following. fax2400 - FAX 2400 bps fax4800 - FAX 4800 bps fax7200 - FAX 7200 bps fax9600 - FAX 9600 bps fax14400 - FAX 14400 bps fax12000 - FAX 12000 bps g729r8000 - G.729 8000 bps (pre-IETF bit ordering) g729Ar8000 - G.729 ANNEX-A 8000 bps g726r16000 - G.726 16000 bps g726r24000 - G.726 24000 bps g726r32000 - G.726 32000 bps g711ulawr64000 - G.711 u-Law 64000 bps g711Alawr64000 - G.711 A-Law 64000 bps g728r16000 - G.728 16000 bps g723r6300 - G.723.1 6300 bps g723r5300 - G.723.1 5300 bps gsmr13200 - GSM full rate 13200 bps g729Br8000 - G.729 ANNEX-B 8000 bps g729ABr8000 - G.729 ANNEX-A & B 8000 bps g723Ar6300 - G723.1 Annex A 6300 bps g723Ar5300 - G723.1 Annex A 5300 bps ietfg729r8000 - G.729 8000 bps (IETF bit ordering) gsmeEr12200 - GSM Enhanced Full Rate 12200 bps clearChannel - CLEAR channel codec g726r40000 - G.726 40000 bps llcc - Lossless compression codec gsmAmrNb - GSM AMR-NB 4750 - 12200 bps g722 - G.722 2400 - 6400 bps iLBC - iILBC 13330 or 15200 bps iLBCr15200 - iLBC 15200 bps iLBCr13330 - iLBC 13330 bps g722r4800 - G.722 (modes 1, 2, 3) g722r5600 - G.722 (modes 1, 2) g722r6400 - G.722 (mode 1) iSAC - iSAC (10 to 32 kbps) aaclc - AAC-LC Advanced Audio Coding Low Complexity aacld - AAC-LD MPEG-4 Low Delay Audio CoderReference: [1] RFC 3267: For introduction about GSM AMR-NB codec, section 3.1 [2] RFC 3952: For introduction about iLBC codec, section 2 · Integer32

The negotiated coder rate. It specifies the transmit rate of voice/fax compression to its associated call leg for the call. This rate is different from the configuration rate because of rate negotiation during the call.

cvCommonDcCallActiveCodecBytes

1.3.6.1.4.1.9.10.55.1.1.1.1.4

INTEGER (10..255) · Integer32

Specifies the payload size of the voice packet.

cvCommonDcCallActiveInBandSignaling

1.3.6.1.4.1.9.10.55.1.1.1.1.5

CvcInBandSignaling1 = cas2 = none3 = cept4 = transparent5 = gr303Represents the type of in-band signaling used between the two end points of the call and is used to inform the router how interpret the ABCD signaling data bits passed as part of the voice payload data. cas - specifies interpret the signaling bits as North American Channel Associated signaling. none - specifies no in-band signaling or signaling is being done via an external method (e.g CCS). cept - specifies interpret the signaling bits as MELCAS transparent - specifies do not interpret or translate the signaling bits. gr303 - specifies interpret the signaling bits as GR303 · Integer32

Specifies the type of in-band signaling being used on the call. This object is instantiated only for Connection Trunk calls.

cvCommonDcCallActiveCallingName

1.3.6.1.4.1.9.10.55.1.1.1.1.6

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..64) · OCTET STRING · hint 255t

The calling party name this call is connected to. If the name is not available, then it will have a length of zero.

cvCommonDcCallActiveCallerIDBlock

1.3.6.1.4.1.9.10.55.1.1.1.1.7

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

The object indicates whether or not the caller ID feature is blocked for this voice call.

cvCommonDcCallHistoryTable

1.3.6.1.4.1.9.10.55.1.2.1

Index: cCallHistoryIndex

This table is the Common extension to the call history table of IETF Dial Control MIB. It contains Common call leg information about a network call leg.

from CISCO-DIAL-CONTROL-MIB

cCallHistoryIndex

Unsigned32 (1..4294967295)

A monotonically increasing integer for the sole purpose of indexing call disconnection events. When it reaches the maximum value, an extremely unlikely event, the agent wraps the value back to 1 and may flush existing entries.

cvCommonDcCallHistoryConnectionId

1.3.6.1.4.1.9.10.55.1.2.1.1.1

CvcGUidRepresents a Global Call Identifier. The global call identifier is used as an unique identifier for an end-to-end call. A zero length CvcGUid indicates no value for the global call identifier. SIZE (0..16) · OCTET STRING

The global call identifier for the gateway call.

cvCommonDcCallHistoryVADEnable

1.3.6.1.4.1.9.10.55.1.2.1.1.2

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

The object indicates whether or not the VAD (Voice Activity Detection) was enabled for the voice call.

cvCommonDcCallHistoryCoderTypeRate

1.3.6.1.4.1.9.10.55.1.2.1.1.3

CvcCoderTypeRate1 = other2 = fax24003 = fax48004 = fax72005 = fax96006 = fax144007 = fax1200010 = g729r800011 = g729Ar800012 = g726r1600013 = g726r2400014 = g726r3200015 = g711ulawr6400016 = g711Alawr6400017 = g728r1600018 = g723r630019 = g723r530020 = gsmr1320021 = g729Br800022 = g729ABr800023 = g723Ar630024 = g723Ar530025 = ietfg729r800026 = gsmeEr1220027 = clearChannel28 = g726r4000029 = llcc30 = gsmAmrNb31 = g72232 = iLBC33 = iLBCr1520034 = iLBCr1333035 = g722r480036 = g722r560037 = g722r640038 = iSAC39 = aaclc40 = aacldRepresents the coder type-rate for voice/fax compression used during a call. *** ABBREVIATIONS, ACRONYMS AND SYMBOLS *** GSM - Global System for Mobile Communication AMR-NB - Adaptive Multi Rate - Narrow Band iLBC - internet Low Bitrate Codec iSAC - internet Speech Audio Codec other - none of the following. fax2400 - FAX 2400 bps fax4800 - FAX 4800 bps fax7200 - FAX 7200 bps fax9600 - FAX 9600 bps fax14400 - FAX 14400 bps fax12000 - FAX 12000 bps g729r8000 - G.729 8000 bps (pre-IETF bit ordering) g729Ar8000 - G.729 ANNEX-A 8000 bps g726r16000 - G.726 16000 bps g726r24000 - G.726 24000 bps g726r32000 - G.726 32000 bps g711ulawr64000 - G.711 u-Law 64000 bps g711Alawr64000 - G.711 A-Law 64000 bps g728r16000 - G.728 16000 bps g723r6300 - G.723.1 6300 bps g723r5300 - G.723.1 5300 bps gsmr13200 - GSM full rate 13200 bps g729Br8000 - G.729 ANNEX-B 8000 bps g729ABr8000 - G.729 ANNEX-A & B 8000 bps g723Ar6300 - G723.1 Annex A 6300 bps g723Ar5300 - G723.1 Annex A 5300 bps ietfg729r8000 - G.729 8000 bps (IETF bit ordering) gsmeEr12200 - GSM Enhanced Full Rate 12200 bps clearChannel - CLEAR channel codec g726r40000 - G.726 40000 bps llcc - Lossless compression codec gsmAmrNb - GSM AMR-NB 4750 - 12200 bps g722 - G.722 2400 - 6400 bps iLBC - iILBC 13330 or 15200 bps iLBCr15200 - iLBC 15200 bps iLBCr13330 - iLBC 13330 bps g722r4800 - G.722 (modes 1, 2, 3) g722r5600 - G.722 (modes 1, 2) g722r6400 - G.722 (mode 1) iSAC - iSAC (10 to 32 kbps) aaclc - AAC-LC Advanced Audio Coding Low Complexity aacld - AAC-LD MPEG-4 Low Delay Audio CoderReference: [1] RFC 3267: For introduction about GSM AMR-NB codec, section 3.1 [2] RFC 3952: For introduction about iLBC codec, section 2 · Integer32

The negotiated coder rate. It specifies the transmit rate of voice/fax compression to its associated call leg for the call. This rate is different from the configuration rate because of rate negotiation during the call.

cvCommonDcCallHistoryCodecBytes

1.3.6.1.4.1.9.10.55.1.2.1.1.4

INTEGER (10..255) · Integer32

Specifies the payload size of the voice packet.

cvCommonDcCallHistoryInBandSignaling

1.3.6.1.4.1.9.10.55.1.2.1.1.5

CvcInBandSignaling1 = cas2 = none3 = cept4 = transparent5 = gr303Represents the type of in-band signaling used between the two end points of the call and is used to inform the router how interpret the ABCD signaling data bits passed as part of the voice payload data. cas - specifies interpret the signaling bits as North American Channel Associated signaling. none - specifies no in-band signaling or signaling is being done via an external method (e.g CCS). cept - specifies interpret the signaling bits as MELCAS transparent - specifies do not interpret or translate the signaling bits. gr303 - specifies interpret the signaling bits as GR303 · Integer32

Specifies the type of in-band signaling used on the call. This object is instantiated only for Connection Trunk calls.

cvCommonDcCallHistoryCallingName

1.3.6.1.4.1.9.10.55.1.2.1.1.6

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..64) · OCTET STRING · hint 255t

The calling party name this call is connected to. If the name is not available, then it will have a length of zero.

cvCommonDcCallHistoryCallerIDBlock

1.3.6.1.4.1.9.10.55.1.2.1.1.7

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

The object indicates whether or not the caller ID feature is blocked for this voice call.

↑ To TOC