EZ5 MIB Catalog

DIRECTORY-SERVER-MIB

1999-06-07

Download DIRECTORY-SERVER-MIB.txt Open DIRECTORY-SERVER-MIB.txt in a new tab

The MIB module for monitoring Directory Services.

TABLES (3)

Tables (3)

NameOID
dsTable1.3.6.1.2.1.66.1
dsApplIfOpsTable1.3.6.1.2.1.66.2
dsIntTable1.3.6.1.2.1.66.3

END OF TOC

Table details

dsTable

1.3.6.1.2.1.66.1

Index: applIndex

The table holding information related to the Directory Servers.

from NETWORK-SERVICES-MIB

applIndex

INTEGER (1..2147483647) · Integer32

An index to uniquely identify the network service application. This attribute is the index used for lexicographic ordering of the table.

dsServerType

1.3.6.1.2.1.66.1.1.1

BITS

This object indicates whether the server is a frontend or, a backend or, both. If the server is a frontend, then the frontEndDirectoryServer bit will be set. Similarly for the backend.

dsServerDescription

1.3.6.1.2.1.66.1.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

A text description of the application. This information is intended to identify and briefly describe the application in a status display.

dsMasterEntries

1.3.6.1.2.1.66.1.1.3

Gauge32

Number of entries mastered in the Directory Server.

dsCopyEntries

1.3.6.1.2.1.66.1.1.4

Gauge32

Number of entries for which systematic (slave) copies are maintained in the Directory Server.

dsCacheEntries

1.3.6.1.2.1.66.1.1.5

Gauge32

Number of entries cached (non-systematic copies) in the Directory Server. This will include the entries that are cached partially. The negative cache is not counted.

dsCacheHits

1.3.6.1.2.1.66.1.1.6

Counter32

Number of operations that were serviced from the locally held cache.

dsSlaveHits

1.3.6.1.2.1.66.1.1.7

Counter32

Number of operations that were serviced from the locally held object replications ( copy- entries).

dsApplIfOpsTable

1.3.6.1.2.1.66.2

Index: applIndex · dsApplIfProtocolIndex

The table holding information related to the Directory Server operations.

from NETWORK-SERVICES-MIB

applIndex

INTEGER (1..2147483647) · Integer32

An index to uniquely identify the network service application. This attribute is the index used for lexicographic ordering of the table.

dsApplIfProtocolIndex

1.3.6.1.2.1.66.2.1.1

INTEGER (1..2147483647) · Integer32

An index to uniquely identify an entry corresponding to a application-layer protocol interface. This index is used for lexicographic ordering of the table.

dsApplIfProtocol

1.3.6.1.2.1.66.2.1.2

OBJECT IDENTIFIER

An identification of the protocol being used by the application on this interface. For an OSI Application, this will be the Application Context. For Internet applications, the IANA maintains a registry[22] of the OIDs which correspond to well-known applications. If the application protocol is not listed in the registry, an OID value of the form {applTCPProtoID port} or {applUDProtoID port} are used for TCP-based and UDP-based protocols, respectively. In either case 'port' corresponds to the primary port number being used by the protocol. The OIDs applTCPProtoID and applUDPProtoID are defined in NETWORK-SERVICES-MIB

dsApplIfUnauthBinds

1.3.6.1.2.1.66.2.1.3

Counter32

Number of unauthenticated/anonymous bind requests received.

dsApplIfSimpleAuthBinds

1.3.6.1.2.1.66.2.1.4

Counter32

Number of bind requests that were authenticated using simple authentication procedures like password checks. This includes the password authentication using SASL mechanisms like CRAM-MD5.

dsApplIfStrongAuthBinds

1.3.6.1.2.1.66.2.1.5

Counter32

Number of bind requests that were authenticated using TLS and X.500 strong authentication procedures. This includes the binds that were authenticated using external authentication procedures.

dsApplIfBindSecurityErrors

1.3.6.1.2.1.66.2.1.6

Counter32

Number of bind requests that have been rejected due to inappropriate authentication or invalid credentials.

dsApplIfInOps

1.3.6.1.2.1.66.2.1.7

Counter32

Number of requests received from DUAs or other Directory Servers.

dsApplIfReadOps

1.3.6.1.2.1.66.2.1.8

Counter32

Number of read requests received.

dsApplIfCompareOps

1.3.6.1.2.1.66.2.1.9

Counter32

Number of compare requests received.

dsApplIfAddEntryOps

1.3.6.1.2.1.66.2.1.10

Counter32

Number of addEntry requests received.

dsApplIfRemoveEntryOps

1.3.6.1.2.1.66.2.1.11

Counter32

Number of removeEntry requests received.

dsApplIfModifyEntryOps

1.3.6.1.2.1.66.2.1.12

Counter32

Number of modifyEntry requests received.

dsApplIfModifyRDNOps

1.3.6.1.2.1.66.2.1.13

Counter32

Number of modifyRDN requests received.

dsApplIfListOps

1.3.6.1.2.1.66.2.1.14

Counter32

Number of list requests received.

dsApplIfSearchOps

1.3.6.1.2.1.66.2.1.15

Counter32

Number of search requests- baseObject searches, oneLevel searches and whole subtree searches, received.

dsApplIfOneLevelSearchOps

1.3.6.1.2.1.66.2.1.16

Counter32

Number of oneLevel search requests received.

dsApplIfWholeSubtreeSearchOps

1.3.6.1.2.1.66.2.1.17

Counter32

Number of whole subtree search requests received.

dsApplIfReferrals

1.3.6.1.2.1.66.2.1.18

Counter32

Number of referrals returned in response to requests for operations.

dsApplIfChainings

1.3.6.1.2.1.66.2.1.19

Counter32

Number of operations forwarded by this Directory Server to other Directory Servers.

dsApplIfSecurityErrors

1.3.6.1.2.1.66.2.1.20

Counter32

Number of requests received which did not meet the security requirements.

dsApplIfErrors

1.3.6.1.2.1.66.2.1.21

Counter32

Number of requests that could not be serviced due to errors other than security errors, and referrals. A partially serviced operation will not be counted as an error. The errors include naming-related, update-related, attribute-related and service-related errors.

dsApplIfReplicationUpdatesIn

1.3.6.1.2.1.66.2.1.22

Counter32

Number of replication updates fetched or received from supplier Directory Servers.

dsApplIfReplicationUpdatesOut

1.3.6.1.2.1.66.2.1.23

Counter32

Number of replication updates sent to or taken by consumer Directory Servers.

dsApplIfInBytes

1.3.6.1.2.1.66.2.1.24

Counter32

Incoming traffic, in bytes, on the interface. This will include requests from DUAs as well as responses from other Directory Servers.

dsApplIfOutBytes

1.3.6.1.2.1.66.2.1.25

Counter32

Outgoing traffic in bytes on the interface. This will include responses to DUAs and Directory Servers as well as requests to other Directory Servers.

dsIntTable

1.3.6.1.2.1.66.3

Index: applIndex · dsIntEntIndex · dsApplIfProtocolIndex

Each row of this table contains some details related to the history of the interaction of the monitored Directory Server with its peer Directory Servers.

from NETWORK-SERVICES-MIB

applIndex

INTEGER (1..2147483647) · Integer32

An index to uniquely identify the network service application. This attribute is the index used for lexicographic ordering of the table.

dsIntEntIndex

1.3.6.1.2.1.66.3.1.1

INTEGER (1..2147483647) · Integer32

Together with applIndex and dsApplIfProtocolIndex, this object forms the unique key to identify the conceptual row which contains useful info on the (attempted) interaction between the Directory Server (referred to by applIndex) and a peer Directory Server using a particular protocol.

dsIntEntDirectoryName

1.3.6.1.2.1.66.3.1.2

DistinguishedNameA Distinguished Name represented in accordance with RFC 2253, presented in the UTF-8 charset defined in RFC 2279. SIZE (0..255) · OCTET STRING · hint 255a

Distinguished Name of the peer Directory Server to which this entry pertains.

dsIntEntTimeOfCreation

1.3.6.1.2.1.66.3.1.3

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of sysUpTime when this row was created. If the entry was created before the network management subsystem was initialized, this object will contain a value of zero.

dsIntEntTimeOfLastAttempt

1.3.6.1.2.1.66.3.1.4

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of sysUpTime when the last attempt was made to contact the peer Directory Server. If the last attempt was made before the network management subsystem was initialized, this object will contain a value of zero.

dsIntEntTimeOfLastSuccess

1.3.6.1.2.1.66.3.1.5

TimeStampThe value of the sysUpTime object at which a specific occurrence happened. The specific occurrence must be defined in the description of any object defined using this type. If sysUpTime is reset to zero as a result of a re- initialization of the network management (sub)system, then the values of all TimeStamp objects are also reset. However, after approximately 497 days without a re- initialization, the sysUpTime object will reach 2^^32-1 and then increment around to zero; in this case, existing values of TimeStamp objects do not change. This can lead to ambiguities in the value of TimeStamp objects. · TimeTicks

The value of sysUpTime when the last attempt made to contact the peer Directory Server was successful. If there have been no successful attempts this entry will have a value of zero. If the last successful attempt was made before the network management subsystem was initialized, this object will contain a value of zero.

dsIntEntFailuresSinceLastSuccess

1.3.6.1.2.1.66.3.1.6

Gauge32

The number of failures since the last time an attempt to contact the peer Directory Server was successful. If there have been no successful attempts, this counter will contain the number of failures since this entry was created.

dsIntEntFailures

1.3.6.1.2.1.66.3.1.7

ZeroBasedCounter32This TC describes an object that counts events with the following semantics: objects of this type will be set to zero(0) on creation and will thereafter count appropriate events, wrapping back to zero(0) when the value 2^32 is reached. Provided that an application discovers the new object within the minimum time to wrap, it can use the initial value as a delta since it last polled the table of which this object is part. It is important for a management station to be aware of this minimum time and the actual time between polls, and to discard data if the actual time is too long or there is no defined minimum time. Typically, this TC is used in tables where the INDEX space is constantly changing and/or the TimeFilter mechanism is in use. · Gauge32

Cumulative failures in contacting the peer Directory Server since the creation of this entry.

dsIntEntSuccesses

1.3.6.1.2.1.66.3.1.8

ZeroBasedCounter32This TC describes an object that counts events with the following semantics: objects of this type will be set to zero(0) on creation and will thereafter count appropriate events, wrapping back to zero(0) when the value 2^32 is reached. Provided that an application discovers the new object within the minimum time to wrap, it can use the initial value as a delta since it last polled the table of which this object is part. It is important for a management station to be aware of this minimum time and the actual time between polls, and to discard data if the actual time is too long or there is no defined minimum time. Typically, this TC is used in tables where the INDEX space is constantly changing and/or the TimeFilter mechanism is in use. · Gauge32

Cumulative successes in contacting the peer Directory Server since the creation of this entry.

dsIntEntURL

1.3.6.1.2.1.66.3.1.9

URLStringA Uniform Resource Locator represented in accordance with RFCs 1738 and 2368, presented in the NVT ASCII charset defined in RFC 854. SIZE (0..255) · OCTET STRING · hint 255a

URL of the peer Directory Server.

↑ To TOC