EZ5 MIB Catalog

JUNIPER-TWAMP-MIB

2014-03-01

This mib provides data associated with the TWAMP feature

Download JUNIPER-TWAMP-MIB.txt Open JUNIPER-TWAMP-MIB.txt in a new tab

SCALARS (1) · TABLES (8) · TRAPS (2)

Scalars (1)

NameOID
jnxTwampRpmIdentity1.3.6.1.4.1.2636.3.77.1.2

Tables (8)

NameOID
jnxTwampClientResultsSampleTable1.3.6.1.4.1.2636.3.77.1.1.1
jnxTwampClientResultsSummaryTable1.3.6.1.4.1.2636.3.77.1.1.2
jnxTwampClientResultsCalculatedTable1.3.6.1.4.1.2636.3.77.1.1.3
jnxTwampClientHistorySampleTable1.3.6.1.4.1.2636.3.77.1.1.4
jnxTwampClientHistorySummaryTable1.3.6.1.4.1.2636.3.77.1.1.5
jnxTwampClientHistoryCalculatedTable1.3.6.1.4.1.2636.3.77.1.1.6
jnxTwampClientControlConnectionTable1.3.6.1.4.1.2636.3.77.1.1.7
jnxTwampClientTestSessionsTable1.3.6.1.4.1.2636.3.77.1.1.8

Traps (2)

NameOID
jnxTwampClientControlConnectionClosed1.3.6.1.4.1.2636.4.27.1.1
jnxTwampClientTestIterationFinished1.3.6.1.4.1.2636.4.27.1.2

END OF TOC

Scalar details

jnxTwampRpmIdentity

1.3.6.1.4.1.2636.3.77.1.2

INTEGER1 = rpm2 = twamp · Integer32

This object is added to be binded to the traps. This object simply identifies if its an RPM type of test or a TWAMP type of test.

Table details

jnxTwampClientResultsSampleTable

1.3.6.1.4.1.2636.3.77.1.1.1

Index: pingCtlOwnerIndex · pingCtlTestName · jnxTwampResSampleType

This table provides measurements from the latest individual TWAMP probe samples. Within each sample, the specific measurement type is identified by jnxTwampClientResSampleType. Note, if the latest probe was unsuccessful, no measurement types will be available. See the definition of JnxTwampClientMeasurementType for details on the types of measurements available.

from DISMAN-PING-MIB

pingCtlOwnerIndex

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

To facilitate the provisioning of access control by a security administrator using the View-Based Access Control Model (RFC 2575, VACM) for tables in which multiple users may need to independently create or modify entries, the initial index is used as an 'owner index'. Such an initial index has a syntax of SnmpAdminString, and can thus be trivially mapped to a securityName or groupName as defined in VACM, in accordance with a security policy. When used in conjunction with such a security policy all entries in the table belonging to a particular user (or group) will have the same value for this initial index. For a given user's entries in a particular table, the object identifiers for the information in these entries will have the same subidentifiers (except for the 'column' subidentifier) up to the end of the encoded owner index. To configure VACM to permit access to this portion of the table, one would create vacmViewTreeFamilyTable entries with the value of vacmViewTreeFamilySubtree including the owner index portion, and vacmViewTreeFamilyMask 'wildcarding' the column subidentifier. More elaborate configurations are possible.

pingCtlTestName

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

The name of the ping test. This is locally unique, within the scope of an pingCtlOwnerIndex.

jnxTwampResSampleType

1.3.6.1.4.1.2636.3.77.1.1.1.1.1

JnxTwampClientMeasurementType1 = roundTripTime2 = rttJitter3 = rttInterarrivalJitter4 = egress5 = egressJitter6 = egressInterarrivalJitter7 = ingress8 = ingressJitter9 = ingressInterarrivalJitterFor each individual probe, several different measurements can be made. These include the following (all measurements are provided in units of microseconds): roundTripTime -- this is the delay between the the transmission of a probe and the arrival of its response. rttJitter -- this is the difference between the current round trip time measurement and the previous one. rttInterarrivalJitter -- An estimate of the statistical variance of a packet's interarrival time. Defined in rfc1889 as: J=J+(|D(i-1,i)|-J)/16 where J is the interarrival jitter and D(i-1, i) is the current round trip jitter measurement. egress -- this is the delay beween the transmission of a probe and its arrival at its destination. egressJitter -- this is the difference between the current egress delay the previous measurement. egressInterarrivalJitter -- similar to rttInterarrivalJitter, but applied to egress jitter measurements. ingress -- this is the delay between the transmission of a probe response and its arrival at its destination. ingressJitter -- this is the difference between the current ingress delay and the previous measurement. ingressInterarrivalJitter -- similar to rttInterarrivalJitter, but applied to ingress jitter measurements. Note, due to clock synchronization artifacts, many one-way jitter measurements & calculations may include signifacant variations, in some cases orders of magnitude greater than the round trip times. Because of this, one-way jitter measurements will only be performed on samples which are less than 10 seconds apart. · Integer32

This object identifies the specific measurement type returned by jnxTwampResSampleValue.

jnxTwampResSampleValue

1.3.6.1.4.1.2636.3.77.1.1.1.1.2

Integer32

This object returns the measurement identified by the corresponding jnxTwampResSampleType.

jnxTwampResSampleDate

1.3.6.1.4.1.2636.3.77.1.1.1.1.3

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This object provides the date and time of when this measurement was obtained.

jnxTwampClientResultsSummaryTable

1.3.6.1.4.1.2636.3.77.1.1.2

Index: pingCtlOwnerIndex · pingCtlTestName · jnxTwampResSumCollection

This table provides a summary of the results for a specific TWAMP entry (identified by pingCtlOwnerIndex/pingCtlTestName). The scope of the summary is identified by jnxTwampClientResSumCollection.

from DISMAN-PING-MIB

pingCtlOwnerIndex

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

To facilitate the provisioning of access control by a security administrator using the View-Based Access Control Model (RFC 2575, VACM) for tables in which multiple users may need to independently create or modify entries, the initial index is used as an 'owner index'. Such an initial index has a syntax of SnmpAdminString, and can thus be trivially mapped to a securityName or groupName as defined in VACM, in accordance with a security policy. When used in conjunction with such a security policy all entries in the table belonging to a particular user (or group) will have the same value for this initial index. For a given user's entries in a particular table, the object identifiers for the information in these entries will have the same subidentifiers (except for the 'column' subidentifier) up to the end of the encoded owner index. To configure VACM to permit access to this portion of the table, one would create vacmViewTreeFamilyTable entries with the value of vacmViewTreeFamilySubtree including the owner index portion, and vacmViewTreeFamilyMask 'wildcarding' the column subidentifier. More elaborate configurations are possible.

pingCtlTestName

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

The name of the ping test. This is locally unique, within the scope of an pingCtlOwnerIndex.

jnxTwampResSumCollection

1.3.6.1.4.1.2636.3.77.1.1.2.1.1

JnxTwampClientCollectionType1 = currentTest2 = lastCompletedTest3 = movingAverage4 = allTestsEach TWAMP entry can maintain several collections of probes and provide separate calculations over each collection. The types of collections include: currentTest -- the test currently being executed lastCompletedTest -- the most recently completed test movingAverage -- the 'n' most recent probes (n is configurable) allTests -- all the probes (since the entry was last reset). Objects with this type identify a specific collection. · Integer32

This object identifes the collection of probes over which the summary data represented by the other objects in this table applies. Note, if a collection type is not supported or not configured, it will not be instantiated in this table.

jnxTwampResSumSent

1.3.6.1.4.1.2636.3.77.1.1.2.1.2

Unsigned32

This object provides the number of probes sent within the collection identified by jnxTwampResSumCollection.

jnxTwampResSumReceived

1.3.6.1.4.1.2636.3.77.1.1.2.1.3

Unsigned32

This object provides the number of probes received within the collection identified by jnxTwampResSumCollection.

jnxTwampResSumPercentLost

1.3.6.1.4.1.2636.3.77.1.1.2.1.4

JnxTwampPercentTypeDisplays a percentage as decimal with 6 digits precision. (0..100000000) · Unsigned32 · hint d-6

This object provides the percentage of probes lost within the collection identified by jnxTwampResSumCollection.

jnxTwampResSumDate

1.3.6.1.4.1.2636.3.77.1.1.2.1.5

DateAndTimeA date-time specification. field octets contents range ----- ------ -------- ----- 1 1-2 year* 0..65536 2 3 month 1..12 3 4 day 1..31 4 5 hour 0..23 5 6 minutes 0..59 6 7 seconds 0..60 (use 60 for leap-second) 7 8 deci-seconds 0..9 8 9 direction from UTC '+' / '-' 9 10 hours from UTC* 0..13 10 11 minutes from UTC 0..59 * Notes: - the value of year is in network-byte order - daylight saving time in New Zealand is +13 For example, Tuesday May 26, 1992 at 1:30:15 PM EDT would be displayed as: 1992-5-26,13:30:15.0,-4:0 Note that if only local time is known, then timezone information (fields 8-10) is not present. SIZE (8 | 11) · OCTET STRING · hint 2d-1d-1d,1d:1d:1d.1d,1a1d:1d

This object provides the date and time of when the most recent probe within the collection identified by jnxTwampResSumCollection was completed.

jnxTwampClientResultsCalculatedTable

1.3.6.1.4.1.2636.3.77.1.1.3

Index: pingCtlOwnerIndex · pingCtlTestName · jnxTwampResSumCollection · jnxTwampResCalcSet

This table provides a set of calculated values for each TWAMP entry, for each collection of probes maintained within that entry, and for each supported measurement set within that collection of probes. This table will skip over any measurement set for which there are 0 samples.

from DISMAN-PING-MIB

pingCtlOwnerIndex

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

To facilitate the provisioning of access control by a security administrator using the View-Based Access Control Model (RFC 2575, VACM) for tables in which multiple users may need to independently create or modify entries, the initial index is used as an 'owner index'. Such an initial index has a syntax of SnmpAdminString, and can thus be trivially mapped to a securityName or groupName as defined in VACM, in accordance with a security policy. When used in conjunction with such a security policy all entries in the table belonging to a particular user (or group) will have the same value for this initial index. For a given user's entries in a particular table, the object identifiers for the information in these entries will have the same subidentifiers (except for the 'column' subidentifier) up to the end of the encoded owner index. To configure VACM to permit access to this portion of the table, one would create vacmViewTreeFamilyTable entries with the value of vacmViewTreeFamilySubtree including the owner index portion, and vacmViewTreeFamilyMask 'wildcarding' the column subidentifier. More elaborate configurations are possible.

pingCtlTestName

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

The name of the ping test. This is locally unique, within the scope of an pingCtlOwnerIndex.

jnxTwampResCalcSet

1.3.6.1.4.1.2636.3.77.1.1.3.1.1

JnxTwampClientMeasurementSet1 = roundTripTime2 = posRttJitter3 = negRttJitter4 = egress5 = posEgressJitter6 = negEgressJitter7 = ingress8 = posIngressJitter9 = negIngressJitterOver each collection of probes, TWAMP calculates statistics for several sets of measurements. These sets include the following: roundTripTime -- the set of round trip delays posRttJitter -- the set of positive round trip jitter measurements negRttJitter -- the set of negative round trip jitter measurements egress -- the set of outgoing (source to destination) one-way delays posEgressJitter -- the set of positive egress jitter measurements negEgressJitter -- the set of negative egress jitter measurements ingress -- the set of incoming (destination to source) one-way delays posIngressJitter -- the set of positive ingress jitter measurements negIngressJitter -- the set of negative ingress jitter measurements Objects with this type identify a specific set of measurements. · Integer32

This object identifies the measurement set upon which the calculations returned by the other objects in this table are based.

jnxTwampResCalcSamples

1.3.6.1.4.1.2636.3.77.1.1.3.1.2

Unsigned32

The number of samples used in this calculations.

jnxTwampResCalcMin

1.3.6.1.4.1.2636.3.77.1.1.3.1.3

Unsigned32

The minimum of all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampResCalcMax

1.3.6.1.4.1.2636.3.77.1.1.3.1.4

Unsigned32

The maximum of all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampResCalcAverage

1.3.6.1.4.1.2636.3.77.1.1.3.1.5

Unsigned32

The average of all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampResCalcPkToPk

1.3.6.1.4.1.2636.3.77.1.1.3.1.6

Unsigned32

The difference between the minimum and maximum of all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampResCalcStdDev

1.3.6.1.4.1.2636.3.77.1.1.3.1.7

Unsigned32

The standard deviation calculated over all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampResCalcSum

1.3.6.1.4.1.2636.3.77.1.1.3.1.8

CounterBasedGauge64The CounterBasedGauge64 type represents a non-negative integer, which may increase or decrease, but shall never exceed a maximum value, nor fall below a minimum value. The maximum value can not be greater than 2^64-1 (18446744073709551615 decimal), and the minimum value can not be smaller than 0. The value of a CounterBasedGauge64 has its maximum value whenever the information being modeled is greater than or equal to its maximum value, and has its minimum value whenever the information being modeled is smaller than or equal to its minimum value. If the information being modeled subsequently decreases below (increases above) the maximum (minimum) value, the CounterBasedGauge64 also decreases (increases). Note that this TC is not strictly supported in SMIv2, because the 'always increasing' and 'counter wrap' semantics associated with the Counter64 base type are not preserved. It is possible that management applications which rely solely upon the (Counter64) ASN.1 tag to determine object semantics will mistakenly operate upon objects of this type as they would for Counter64 objects. This textual convention represents a limited and short-term solution, and may be deprecated as a long term solution is defined and deployed to replace it. (0..18446744073709551615) · Counter64

The sum of all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampClientHistorySampleTable

1.3.6.1.4.1.2636.3.77.1.1.4

Index: pingCtlOwnerIndex · pingCtlTestName · pingProbeHistoryIndex · jnxTwampHistSampleType

This table provides measurements for individual TWAMP probe samples(test sessions). In addition to the last completed sample, a configurable number of the most recent samples are available as well. Within each sample, the specific measurement type is identified by jnxTwampHistSampleType. Note, if probe was unsuccessful, no measurement types will be available for that history entry. See the definition of JnxTwampClientMeasurementType for details on of measurements available.

from DISMAN-PING-MIB

pingCtlOwnerIndex

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

To facilitate the provisioning of access control by a security administrator using the View-Based Access Control Model (RFC 2575, VACM) for tables in which multiple users may need to independently create or modify entries, the initial index is used as an 'owner index'. Such an initial index has a syntax of SnmpAdminString, and can thus be trivially mapped to a securityName or groupName as defined in VACM, in accordance with a security policy. When used in conjunction with such a security policy all entries in the table belonging to a particular user (or group) will have the same value for this initial index. For a given user's entries in a particular table, the object identifiers for the information in these entries will have the same subidentifiers (except for the 'column' subidentifier) up to the end of the encoded owner index. To configure VACM to permit access to this portion of the table, one would create vacmViewTreeFamilyTable entries with the value of vacmViewTreeFamilySubtree including the owner index portion, and vacmViewTreeFamilyMask 'wildcarding' the column subidentifier. More elaborate configurations are possible.

pingCtlTestName

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

The name of the ping test. This is locally unique, within the scope of an pingCtlOwnerIndex.

pingProbeHistoryIndex

Unsigned32 (1..4294967295)

An entry in this table is created when the result of a ping probe is determined. The initial 2 instance identifier index values identify the pingCtlEntry that a probe result (pingProbeHistoryEntry) belongs to. An implementation MUST start assigning pingProbeHistoryIndex values at 1 and wrap after exceeding the maximum possible value as defined by the limit of this object ('ffffffff'h).

jnxTwampHistSampleType

1.3.6.1.4.1.2636.3.77.1.1.4.1.1

JnxTwampClientMeasurementType1 = roundTripTime2 = rttJitter3 = rttInterarrivalJitter4 = egress5 = egressJitter6 = egressInterarrivalJitter7 = ingress8 = ingressJitter9 = ingressInterarrivalJitterFor each individual probe, several different measurements can be made. These include the following (all measurements are provided in units of microseconds): roundTripTime -- this is the delay between the the transmission of a probe and the arrival of its response. rttJitter -- this is the difference between the current round trip time measurement and the previous one. rttInterarrivalJitter -- An estimate of the statistical variance of a packet's interarrival time. Defined in rfc1889 as: J=J+(|D(i-1,i)|-J)/16 where J is the interarrival jitter and D(i-1, i) is the current round trip jitter measurement. egress -- this is the delay beween the transmission of a probe and its arrival at its destination. egressJitter -- this is the difference between the current egress delay the previous measurement. egressInterarrivalJitter -- similar to rttInterarrivalJitter, but applied to egress jitter measurements. ingress -- this is the delay between the transmission of a probe response and its arrival at its destination. ingressJitter -- this is the difference between the current ingress delay and the previous measurement. ingressInterarrivalJitter -- similar to rttInterarrivalJitter, but applied to ingress jitter measurements. Note, due to clock synchronization artifacts, many one-way jitter measurements & calculations may include signifacant variations, in some cases orders of magnitude greater than the round trip times. Because of this, one-way jitter measurements will only be performed on samples which are less than 10 seconds apart. · Integer32

This object identifies the specific measurement type returned by jnxTwampHistSampleValue.

jnxTwampHistSampleValue

1.3.6.1.4.1.2636.3.77.1.1.4.1.2

Integer32

This object returns the measurement identified by the corresponding jnxTwampHistSampleType.

jnxTwampClientHistorySummaryTable

1.3.6.1.4.1.2636.3.77.1.1.5

Index: pingCtlOwnerIndex · pingCtlTestName · pingProbeHistoryIndex · jnxTwampHistSumCollection

This table provides historical summary data for each collection of probes(test session) within each TWAMP Control Entry, similar to the jnxTwampClientResultsSummaryTable. In addition to the current summary, this table provides the same number of historical entries as the jnxTwampClientHistorySampleTable.

from DISMAN-PING-MIB

pingCtlOwnerIndex

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

To facilitate the provisioning of access control by a security administrator using the View-Based Access Control Model (RFC 2575, VACM) for tables in which multiple users may need to independently create or modify entries, the initial index is used as an 'owner index'. Such an initial index has a syntax of SnmpAdminString, and can thus be trivially mapped to a securityName or groupName as defined in VACM, in accordance with a security policy. When used in conjunction with such a security policy all entries in the table belonging to a particular user (or group) will have the same value for this initial index. For a given user's entries in a particular table, the object identifiers for the information in these entries will have the same subidentifiers (except for the 'column' subidentifier) up to the end of the encoded owner index. To configure VACM to permit access to this portion of the table, one would create vacmViewTreeFamilyTable entries with the value of vacmViewTreeFamilySubtree including the owner index portion, and vacmViewTreeFamilyMask 'wildcarding' the column subidentifier. More elaborate configurations are possible.

pingCtlTestName

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

The name of the ping test. This is locally unique, within the scope of an pingCtlOwnerIndex.

pingProbeHistoryIndex

Unsigned32 (1..4294967295)

An entry in this table is created when the result of a ping probe is determined. The initial 2 instance identifier index values identify the pingCtlEntry that a probe result (pingProbeHistoryEntry) belongs to. An implementation MUST start assigning pingProbeHistoryIndex values at 1 and wrap after exceeding the maximum possible value as defined by the limit of this object ('ffffffff'h).

jnxTwampHistSumCollection

1.3.6.1.4.1.2636.3.77.1.1.5.1.1

JnxTwampClientCollectionType1 = currentTest2 = lastCompletedTest3 = movingAverage4 = allTestsEach TWAMP entry can maintain several collections of probes and provide separate calculations over each collection. The types of collections include: currentTest -- the test currently being executed lastCompletedTest -- the most recently completed test movingAverage -- the 'n' most recent probes (n is configurable) allTests -- all the probes (since the entry was last reset). Objects with this type identify a specific collection. · Integer32

Identifies the collection of probes whose results are summarized by this row. At this time, historical summaries are available only for the current test (currentTest(1)).

jnxTwampHistSumSent

1.3.6.1.4.1.2636.3.77.1.1.5.1.2

Unsigned32

This object provides the number of probes sent within the collection identified by jnxTwampHistSumCollection.

jnxTwampHistSumReceived

1.3.6.1.4.1.2636.3.77.1.1.5.1.3

Unsigned32

This object provides the number of probes received within the collection identified by jnxTwampHistSumCollection.

jnxTwampHistSumPercentLost

1.3.6.1.4.1.2636.3.77.1.1.5.1.4

JnxTwampPercentTypeDisplays a percentage as decimal with 6 digits precision. (0..100000000) · Unsigned32 · hint d-6

This object provides the percentage of probes lost within the collection identified by jnxTwampHistSumCollection.

jnxTwampClientHistoryCalculatedTable

1.3.6.1.4.1.2636.3.77.1.1.6

Index: pingCtlOwnerIndex · pingCtlTestName · pingProbeHistoryIndex · jnxTwampHistSumCollection · jnxTwampHistCalcSet

This table provides a set of calculated values for each TWAMP control entry, for each test session maintained within that entry, and for each supported calculated type within that collection of probes, similar to the jnxTwampClientResultsCalculatedTable. In addition to the current summary, this table provides the same number of historical entries as the jnxTwampClientHistorySampleTable.

from DISMAN-PING-MIB

pingCtlOwnerIndex

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

To facilitate the provisioning of access control by a security administrator using the View-Based Access Control Model (RFC 2575, VACM) for tables in which multiple users may need to independently create or modify entries, the initial index is used as an 'owner index'. Such an initial index has a syntax of SnmpAdminString, and can thus be trivially mapped to a securityName or groupName as defined in VACM, in accordance with a security policy. When used in conjunction with such a security policy all entries in the table belonging to a particular user (or group) will have the same value for this initial index. For a given user's entries in a particular table, the object identifiers for the information in these entries will have the same subidentifiers (except for the 'column' subidentifier) up to the end of the encoded owner index. To configure VACM to permit access to this portion of the table, one would create vacmViewTreeFamilyTable entries with the value of vacmViewTreeFamilySubtree including the owner index portion, and vacmViewTreeFamilyMask 'wildcarding' the column subidentifier. More elaborate configurations are possible.

pingCtlTestName

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

The name of the ping test. This is locally unique, within the scope of an pingCtlOwnerIndex.

pingProbeHistoryIndex

Unsigned32 (1..4294967295)

An entry in this table is created when the result of a ping probe is determined. The initial 2 instance identifier index values identify the pingCtlEntry that a probe result (pingProbeHistoryEntry) belongs to. An implementation MUST start assigning pingProbeHistoryIndex values at 1 and wrap after exceeding the maximum possible value as defined by the limit of this object ('ffffffff'h).

jnxTwampHistCalcSet

1.3.6.1.4.1.2636.3.77.1.1.6.1.1

JnxTwampClientMeasurementSet1 = roundTripTime2 = posRttJitter3 = negRttJitter4 = egress5 = posEgressJitter6 = negEgressJitter7 = ingress8 = posIngressJitter9 = negIngressJitterOver each collection of probes, TWAMP calculates statistics for several sets of measurements. These sets include the following: roundTripTime -- the set of round trip delays posRttJitter -- the set of positive round trip jitter measurements negRttJitter -- the set of negative round trip jitter measurements egress -- the set of outgoing (source to destination) one-way delays posEgressJitter -- the set of positive egress jitter measurements negEgressJitter -- the set of negative egress jitter measurements ingress -- the set of incoming (destination to source) one-way delays posIngressJitter -- the set of positive ingress jitter measurements negIngressJitter -- the set of negative ingress jitter measurements Objects with this type identify a specific set of measurements. · Integer32

This object identifies the measurement set upon which the calculations returned by the other objects in this table are based.

jnxTwampHistCalcSamples

1.3.6.1.4.1.2636.3.77.1.1.6.1.2

Unsigned32

The number of samples used in this calculations.

jnxTwampHistCalcMin

1.3.6.1.4.1.2636.3.77.1.1.6.1.3

Unsigned32

The minimum of all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampHistCalcMax

1.3.6.1.4.1.2636.3.77.1.1.6.1.4

Unsigned32

The maximum of all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampHistCalcAverage

1.3.6.1.4.1.2636.3.77.1.1.6.1.5

Unsigned32

The average of all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampHistCalcPkToPk

1.3.6.1.4.1.2636.3.77.1.1.6.1.6

Unsigned32

The difference between the minimum and maximum of all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampHistCalcStdDev

1.3.6.1.4.1.2636.3.77.1.1.6.1.7

Unsigned32

The standard deviation calculated over all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampHistCalcSum

1.3.6.1.4.1.2636.3.77.1.1.6.1.8

CounterBasedGauge64The CounterBasedGauge64 type represents a non-negative integer, which may increase or decrease, but shall never exceed a maximum value, nor fall below a minimum value. The maximum value can not be greater than 2^64-1 (18446744073709551615 decimal), and the minimum value can not be smaller than 0. The value of a CounterBasedGauge64 has its maximum value whenever the information being modeled is greater than or equal to its maximum value, and has its minimum value whenever the information being modeled is smaller than or equal to its minimum value. If the information being modeled subsequently decreases below (increases above) the maximum (minimum) value, the CounterBasedGauge64 also decreases (increases). Note that this TC is not strictly supported in SMIv2, because the 'always increasing' and 'counter wrap' semantics associated with the Counter64 base type are not preserved. It is possible that management applications which rely solely upon the (Counter64) ASN.1 tag to determine object semantics will mistakenly operate upon objects of this type as they would for Counter64 objects. This textual convention represents a limited and short-term solution, and may be deprecated as a long term solution is defined and deployed to replace it. (0..18446744073709551615) · Counter64

The sum of all the samples in the collection and measurement set associated with this row. Values are provided in units of microseconds.

jnxTwampClientControlConnectionTable

1.3.6.1.4.1.2636.3.77.1.1.7

Index: jnxTwampClientControlConnectionID

Table of Client Sessions.

jnxTwampClientControlConnectionID

1.3.6.1.4.1.2636.3.77.1.1.7.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

TWAMP Client control session ID.

jnxTwampClientCCName

1.3.6.1.4.1.2636.3.77.1.1.7.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Text string containing the session's unique name.

jnxTwampClientCCStatus

1.3.6.1.4.1.2636.3.77.1.1.7.1.3

INTEGER1 = active2 = stopped · Integer32

If the control session is active, this would return 1. If the control session does not have any currently running test sessions and is not active, this would return 2.

jnxTwampClientServerAddress

1.3.6.1.4.1.2636.3.77.1.1.7.1.4

IpAddress SIZE (4)

Server IP address for TWAMP TCP control session.

jnxTwampClientServerPort

1.3.6.1.4.1.2636.3.77.1.1.7.1.5

INTEGER (0..65535) · Integer32

Destination port for TWAMP TCP control connection.

jnxTwampClientTSConfiguredCount

1.3.6.1.4.1.2636.3.77.1.1.7.1.6

INTEGER (0..65535) · Integer32

Number test sessions configured.

jnxTwampClientTSActiveCount

1.3.6.1.4.1.2636.3.77.1.1.7.1.7

INTEGER (0..65535) · Integer32

Number of test sessions currently running.

jnxTwampClientAuthMode

1.3.6.1.4.1.2636.3.77.1.1.7.1.8

INTEGER1 = none2 = authenticated3 = encrypted4 = controlOnlyEncrypted · Integer32

Authenticated mode for the control session.

jnxTwampClientTestSessionsTable

1.3.6.1.4.1.2636.3.77.1.1.8

Index: pingCtlOwnerIndex · jnxTwampClientTestSessionID

Table of Test Sessions.

from DISMAN-PING-MIB

pingCtlOwnerIndex

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

To facilitate the provisioning of access control by a security administrator using the View-Based Access Control Model (RFC 2575, VACM) for tables in which multiple users may need to independently create or modify entries, the initial index is used as an 'owner index'. Such an initial index has a syntax of SnmpAdminString, and can thus be trivially mapped to a securityName or groupName as defined in VACM, in accordance with a security policy. When used in conjunction with such a security policy all entries in the table belonging to a particular user (or group) will have the same value for this initial index. For a given user's entries in a particular table, the object identifiers for the information in these entries will have the same subidentifiers (except for the 'column' subidentifier) up to the end of the encoded owner index. To configure VACM to permit access to this portion of the table, one would create vacmViewTreeFamilyTable entries with the value of vacmViewTreeFamilySubtree including the owner index portion, and vacmViewTreeFamilyMask 'wildcarding' the column subidentifier. More elaborate configurations are possible.

jnxTwampClientTestSessionID

1.3.6.1.4.1.2636.3.77.1.1.8.1.1

SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..32) · OCTET STRING · hint 255t

Test Session ID.

jnxTwampClientTSName

1.3.6.1.4.1.2636.3.77.1.1.8.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

TWAMP Test Session Name.

jnxTwampClientTSStatus

1.3.6.1.4.1.2636.3.77.1.1.8.1.3

INTEGER1 = active2 = stopped · Integer32

TWAMP Test Session status.

jnxTwampClientTSSenderAddress

1.3.6.1.4.1.2636.3.77.1.1.8.1.4

IpAddress SIZE (4)

Twamp Test Sender Address.

jnxTwampClientTSSenderPort

1.3.6.1.4.1.2636.3.77.1.1.8.1.5

INTEGER (0..65535) · Integer32

TWAMP Test Session Sender Port.

jnxTwampClientTSReflectorAddress

1.3.6.1.4.1.2636.3.77.1.1.8.1.6

IpAddress SIZE (4)

TWAMP Test Session Reflector Address.

jnxTwampClientTSReflectorPort

1.3.6.1.4.1.2636.3.77.1.1.8.1.7

INTEGER (0..65535) · Integer32

TWAMP Test Session Reflector Port.

Trap details

jnxTwampClientControlConnectionClosed

1.3.6.1.4.1.2636.4.27.1.1

This trap is generated when all the test iterations configured under the control connection finish running and control connection is closed.

jnxTwampClientCCName

1.3.6.1.4.1.2636.3.77.1.1.7.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Text string containing the session's unique name.

jnxTwampClientTestIterationFinished

1.3.6.1.4.1.2636.4.27.1.2

This trap is generated when one test iteration is finished for all the test sessions configured under the control connection.

jnxTwampClientCCName

1.3.6.1.4.1.2636.3.77.1.1.7.1.2

DisplayStringRepresents textual information taken from the NVT ASCII character set, as defined in pages 4, 10-11 of RFC 854. To summarize RFC 854, the NVT ASCII repertoire specifies: - the use of character codes 0-127 (decimal) - the graphics characters (32-126) are interpreted as US ASCII - NUL, LF, CR, BEL, BS, HT, VT and FF have the special meanings specified in RFC 854 - the other 25 codes have no standard interpretation - the sequence 'CR LF' means newline - the sequence 'CR NUL' means carriage-return - an 'LF' not preceded by a 'CR' means moving to the same column on the next line. - the sequence 'CR x' for any x other than LF or NUL is illegal. (Note that this also means that a string may end with either 'CR LF' or 'CR NUL', but not with CR.) Any object defined using this syntax may not exceed 255 characters in length. SIZE (0..255) · OCTET STRING · hint 255a

Text string containing the session's unique name.

↑ To TOC