applIndex
INTEGER (1..2147483647) · Integer32
An index to uniquely identify the network service application. This attribute is the index used for lexicographic ordering of the table.
2000-03-03
Download MTA-MIB.txt Open MTA-MIB.txt in a new tab
The MIB module describing Message Transfer Agents (MTAs)
| Name | OID |
|---|---|
| mtaTable | 1.3.6.1.2.1.28.1 |
| mtaGroupTable | 1.3.6.1.2.1.28.2 |
| mtaGroupAssociationTable | 1.3.6.1.2.1.28.3 |
| mtaGroupErrorTable | 1.3.6.1.2.1.28.5 |
END OF TOC
1.3.6.1.2.1.28.1
Index: applIndex
The table holding information specific to an MTA.
from NETWORK-SERVICES-MIB
INTEGER (1..2147483647) · Integer32
An index to uniquely identify the network service application. This attribute is the index used for lexicographic ordering of the table.
1.3.6.1.2.1.28.1.1.1
Counter32
The number of messages received since MTA initialization. This includes messages transmitted to this MTA from other MTAs as well as messages that have been submitted to the MTA directly by end-users or applications.
1.3.6.1.2.1.28.1.1.2
Gauge32
The total number of messages currently stored in the MTA. This includes messages that are awaiting transmission to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.3
Counter32
The number of messages transmitted since MTA initialization. This includes messages that were transmitted to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.4
Counter32 · K-octets
The total volume of messages received since MTA initialization, measured in kilo-octets. This volume should include all transferred data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA should use the number of kilo-octets of P2 data. This includes messages transmitted to this MTA from other MTAs as well as messages that have been submitted to the MTA directly by end-users or applications.
1.3.6.1.2.1.28.1.1.5
Gauge32 · K-octets
The total volume of messages currently stored in the MTA, measured in kilo-octets. This volume should include all stored data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA would use the number of kilo-octets of P2 data. This includes messages that are awaiting transmission to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.6
Counter32 · K-octets
The total volume of messages transmitted since MTA initialization, measured in kilo-octets. This volume should include all transferred data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA should use the number of kilo-octets of P2 data. This includes messages that were transmitted to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.7
Counter32
The total number of recipients specified in all messages received since MTA initialization. Recipients this MTA has no responsibility for, i.e. inactive envelope recipients or ones referred to in message headers, should not be counted even if information about such recipients is available. This includes messages transmitted to this MTA from other MTAs as well as messages that have been submitted to the MTA directly by end-users or applications.
1.3.6.1.2.1.28.1.1.8
Gauge32
The total number of recipients specified in all messages currently stored in the MTA. Recipients this MTA has no responsibility for, i.e. inactive envelope recipients or ones referred to in message headers, should not be counted. This includes messages that are awaiting transmission to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.9
Counter32
The total number of recipients specified in all messages transmitted since MTA initialization. Recipients this MTA had no responsibility for, i.e. inactive envelope recipients or ones referred to in message headers, should not be counted. This includes messages that were transmitted to some other MTA or are waiting for delivery to an end-user or application.
1.3.6.1.2.1.28.1.1.10
Counter32
The number of messages that have been successfully converted from one form to another since MTA initialization.
1.3.6.1.2.1.28.1.1.11
Counter32
The number of messages for which an unsuccessful attempt was made to convert them from one form to another since MTA initialization.
1.3.6.1.2.1.28.1.1.12
Counter32
A message loop is defined as a situation where the MTA decides that a given message will never be delivered to one or more recipients and instead will continue to loop endlessly through one or more MTAs. This variable counts the number of times the MTA has detected such a situation since MTA initialization. Note that the mechanism MTAs use to detect loops (e.g., trace field counting, count of references to this MTA in a trace field, examination of DNS or other directory information, etc.), the level at which loops are detected (e.g., per message, per recipient, per directory entry, etc.), and the handling of a loop once it is detected (e.g., looping messages are held, looping messages are bounced or sent to the postmaster, messages that the MTA knows will loop won't be accepted, etc.) vary widely from one MTA to the next and cannot be inferred from this variable.
1.3.6.1.2.1.28.2
Index: applIndex · mtaGroupIndex
The table holding information specific to each MTA group.
from NETWORK-SERVICES-MIB
INTEGER (1..2147483647) · Integer32
An index to uniquely identify the network service application. This attribute is the index used for lexicographic ordering of the table.
1.3.6.1.2.1.28.2.1.1
INTEGER (1..2147483647) · Integer32
The index associated with a group for a given MTA.
1.3.6.1.2.1.28.2.1.2
Counter32
The number of messages received to this group since group creation.
1.3.6.1.2.1.28.2.1.3
Counter32
The number of messages rejected by this group since group creation.
1.3.6.1.2.1.28.2.1.4
Gauge32
The total number of messages currently stored in this group's queue.
1.3.6.1.2.1.28.2.1.5
Counter32
The number of messages transmitted by this group since group creation.
1.3.6.1.2.1.28.2.1.6
Counter32 · K-octets
The total volume of messages received to this group since group creation, measured in kilo-octets. This volume should include all transferred data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA should use the number of kilo-octets of P2 data.
1.3.6.1.2.1.28.2.1.7
Gauge32 · K-octets
The total volume of messages currently stored in this group's queue, measured in kilo-octets. This volume should include all stored data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA would use the number of kilo-octets of P2 data.
1.3.6.1.2.1.28.2.1.8
Counter32 · K-octets
The total volume of messages transmitted by this group since group creation, measured in kilo-octets. This volume should include all transferred data that is logically above the mail transport protocol level. For example, an SMTP-based MTA should use the number of kilo-octets in the message header and body, while an X.400-based MTA should use the number of kilo-octets of P2 data.
1.3.6.1.2.1.28.2.1.9
Counter32
The total number of recipients specified in all messages received to this group since group creation. Recipients this MTA has no responsibility for should not be counted.
1.3.6.1.2.1.28.2.1.10
Gauge32
The total number of recipients specified in all messages currently stored in this group's queue. Recipients this MTA has no responsibility for should not be counted.
1.3.6.1.2.1.28.2.1.11
Counter32
The total number of recipients specified in all messages transmitted by this group since group creation. Recipients this MTA had no responsibility for should not be counted.
1.3.6.1.2.1.28.2.1.12
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32
Time since the oldest message in this group's queue was placed in the queue.
1.3.6.1.2.1.28.2.1.13
Gauge32
The number of current associations to the group, where the group is the responder.
1.3.6.1.2.1.28.2.1.14
Gauge32
The number of current associations to the group, where the group is the initiator.
1.3.6.1.2.1.28.2.1.15
Counter32
The total number of associations to the group since group creation, where the MTA was the responder.
1.3.6.1.2.1.28.2.1.16
Counter32
The total number of associations from the group since group creation, where the MTA was the initiator.
1.3.6.1.2.1.28.2.1.17
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32
Time since the last time that this group had an active inbound association for purposes of message reception.
1.3.6.1.2.1.28.2.1.18
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32
Time since the last time that this group had a successful outbound association for purposes of message delivery.
1.3.6.1.2.1.28.2.1.19
Counter32
The total number of inbound associations the group has rejected, since group creation. Rejected associations are not counted in the accumulated association totals.
1.3.6.1.2.1.28.2.1.20
Counter32
The total number associations where the group was the initiator and association establishment has failed, since group creation. Failed associations are not counted in the accumulated association totals.
1.3.6.1.2.1.28.2.1.21
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
The failure reason, if any, for the last association this group refused to respond to. If no association attempt has been made since the MTA was initialized the value should be 'never'.
1.3.6.1.2.1.28.2.1.22
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
The failure reason, if any, for the last association attempt this group initiated. If no association attempt has been made since the MTA was initialized the value should be 'never'.
1.3.6.1.2.1.28.2.1.23
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32
The amount of time until this group is next scheduled to attempt to make an association.
1.3.6.1.2.1.28.2.1.24
OBJECT IDENTIFIER
An identification of the protocol being used by this group. For an group employing OSI protocols, this will be the Application Context. For Internet applications, OID values of the form {applTCPProtoID port} or {applUDPProtoID port} are used for TCP-based and UDP-based protocols, respectively. In either case 'port' corresponds to the primary port number being used by the protocol. The usual IANA procedures may be used to register ports for new protocols. applTCPProtoID and applUDPProtoID are defined in the NETWORK-SERVICES-MIB, RFC 2788.
1.3.6.1.2.1.28.2.1.25
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
A descriptive name for the group. If this group connects to a single remote MTA this should be the name of that MTA. If this in turn is an Internet MTA this should be the domain name. For an OSI MTA it should be the string encoded distinguished name of the managed object using the format defined in RFC 2253. For X.400(1984) MTAs which do not have a Distinguished Name, the RFC 2156 syntax 'mta in globalid' used in X400-Received: fields can be used.
1.3.6.1.2.1.28.2.1.26
Counter32
The number of messages that have been successfully converted from one form to another in this group since group creation.
1.3.6.1.2.1.28.2.1.27
Counter32
The number of messages for which an unsuccessful attempt was made to convert them from one form to another in this group since group creation.
1.3.6.1.2.1.28.2.1.28
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
A description of the group's purpose. This information is intended to identify the group in a status display.
1.3.6.1.2.1.28.2.1.29
URLStringA Uniform Resource Locator represented in accordance with RFCs 1738 and 2368, presented in the NVT ASCII charset defined in RFC 854. SIZE (0..255) · OCTET STRING · hint 255a
A URL pointing to a description of the group. This information is intended to identify and briefly describe the group in a status display.
1.3.6.1.2.1.28.2.1.30
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32
Time since this group was first created.
1.3.6.1.2.1.28.2.1.31
INTEGER · Integer32
Describes how this group fits into the hierarchy. A positive value is interpreted as an mtaGroupIndex value for some other group whose variables include those of this group (and usually others). A negative value is interpreted as a group collection code: Groups with common negative hierarchy values comprise one particular breakdown of MTA activity as a whole. A zero value means that this MIB implementation doesn't implement hierarchy indicators and thus the overall group hierarchy cannot be determined.
1.3.6.1.2.1.28.2.1.32
SnmpAdminStringAn octet string containing administrative information, preferably in human-readable form. To facilitate internationalization, this information is represented using the ISO/IEC IS 10646-1 character set, encoded as an octet string using the UTF-8 transformation format described in [RFC2279]. Since additional code points are added by amendments to the 10646 standard from time to time, implementations must be prepared to encounter any code point from 0x00000000 to 0x7fffffff. Byte sequences that do not correspond to the valid UTF-8 encoding of a code point or are outside this range are prohibited. The use of control codes should be avoided. When it is necessary to represent a newline, the control code sequence CR LF should be used. The use of leading or trailing white space should be avoided. For code points not directly supported by user interface hardware or software, an alternative means of entry and display, such as hexadecimal, may be provided. For information encoded in 7-bit US-ASCII, the UTF-8 encoding is identical to the US-ASCII encoding. UTF-8 may require multiple bytes to represent a single character / code point; thus the length of this object in octets may be different from the number of characters encoded. Similarly, size constraints refer to the number of encoded octets, not the number of characters represented by an encoding. Note that when this TC is used for an object that is used or envisioned to be used as an index, then a SIZE restriction MUST be specified so that the number of sub-identifiers for any object instance does not exceed the limit of 128, as defined by [RFC3416]. Note that the size of an SnmpAdminString object is measured in octets, not characters. SIZE (0..255) · OCTET STRING · hint 255t
Message ID of the oldest message in the group's queue. Whenever possible this should be in the form of an RFC 822 msg-id; X.400 may convert X.400 message identifiers to this form by following the rules laid out in RFC2156.
1.3.6.1.2.1.28.2.1.33
Counter32
A message loop is defined as a situation where the MTA decides that a given message will never be delivered to one or more recipients and instead will continue to loop endlessly through one or more MTAs. This variable counts the number of times the MTA has detected such a situation in conjunction with something associated with this group since group creation. Note that the mechanism MTAs use to detect loops (e.g., trace field counting, count of references to this MTA in a trace field, examination of DNS or other directory information, etc.), the level at which loops are detected (e.g., per message, per recipient, per directory entry, etc.), and the handling of a loop once it is detected (e.g., looping messages are held, looping messages are bounced or sent to the postmaster, messages that the MTA knows will loop won't be accepted, etc.) vary widely from one MTA to the next and cannot be inferred from this variable.
1.3.6.1.2.1.28.2.1.34
TimeIntervalA period of time, measured in units of 0.01 seconds. (0..2147483647) · Integer32
Time since the last time that this group attempted to make an outbound association for purposes of message delivery.
1.3.6.1.2.1.28.3
Index: applIndex · mtaGroupIndex · mtaGroupAssociationIndex
The table holding information regarding the associations for each MTA group.
from NETWORK-SERVICES-MIB
INTEGER (1..2147483647) · Integer32
An index to uniquely identify the network service application. This attribute is the index used for lexicographic ordering of the table.
1.3.6.1.2.1.28.3.1.1
INTEGER (1..2147483647) · Integer32
Reference into association table to allow correlation of this group's active associations with the association table.
1.3.6.1.2.1.28.5
Index: applIndex · mtaGroupIndex · mtaStatusCode
The table holding information regarding accumulated errors for each MTA group.
from NETWORK-SERVICES-MIB
INTEGER (1..2147483647) · Integer32
An index to uniquely identify the network service application. This attribute is the index used for lexicographic ordering of the table.
1.3.6.1.2.1.28.5.1.1
Counter32
Count of the number of errors of a given type that have been accumulated in association with a particular group while processing incoming messages. In the case of SMTP these will typically be errors reporting by an SMTP server to the remote client; in the case of X.400 these will typically be errors encountered while processing an incoming message.
1.3.6.1.2.1.28.5.1.2
Counter32
Count of the number of errors of a given type that have been accumulated in association with a particular group during internal MTA processing.
1.3.6.1.2.1.28.5.1.3
Counter32
Count of the number of errors of a given type that have been accumulated in association with a particular group's outbound connection activities. In the case of an SMTP client these will typically be errors reported while attempting to contact or while communicating with the remote SMTP server. In the case of X.400 these will typically be errors encountered while constructing or attempting to deliver an outgoing message.
1.3.6.1.2.1.28.5.1.4
INTEGER (4000000..5999999) · Integer32
An index capable of representing an Enhanced Mail System Status Code. Enhanced Mail System Status Codes are defined in RFC 1893. These codes have the form class.subject.detail Here 'class' is either 2, 4, or 5 and both 'subject' and 'detail' are integers in the range 0..999. Given a status code the corresponding index value is defined to be ((class * 1000) + subject) * 1000 + detail. Both SMTP error response codes and X.400 reason and diagnostic codes can be mapped into these codes, resulting in a namespace capable of describing most error conditions a mail system encounters in a generic yet detailed way.