EZ5 MIB Catalog

ROHC-RTP-MIB

2004-06-03

Download ROHC-RTP-MIB.txt Open ROHC-RTP-MIB.txt in a new tab

This MIB module defines a set of objects for monitoring and configuring RObust Header Compression (ROHC). The objects are specific to ROHC RTP (profile 0x0001), ROHC UDP (profile 0x0002), and ROHC ESP (profile 0x0003) defined in RFC 3095 and for the ROHC LLA profile (profile 0x0005) defined in RFC 3242. Copyright (C) The Internet Society (2004). The initial version of this MIB module was published in RFC 3816. For full legal notices see the RFC itself or see: http://www.ietf.org/copyrights/ianamib.html

TABLES (2)

Tables (2)

NameOID
rohcRtpContextTable1.3.6.1.2.1.114.1.1
rohcRtpPacketSizeTable1.3.6.1.2.1.114.1.2

END OF TOC

Table details

rohcRtpContextTable

1.3.6.1.2.1.114.1.1

Index: rohcChannelID · rohcContextCID

This table lists and describes RTP profile specific properties of compressor contexts and decompressor contexts. It extends the rohcContextTable of the ROHC-MIB module.

from ROHC-MIB

rohcChannelID

RohcChannelIdentifierA number identifying a channel. The value of 0 must not be used as identifier of an existing channel. (1..4294967295) · Unsigned32 · hint d

The locally arbitrary, but unique identifier associated with this channel. The value is REQUIRED to be unique per ROHC MIB implementation independent of the associated interface. The value is REQUIRED to remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. It is RECOMMENDED that the value persist across such re-initializations.

rohcContextCID

Unsigned32 (0..16383)

The context identifier (CID) of this context.

rohcRtpContextState

1.3.6.1.2.1.114.1.1.1.3

INTEGER1 = initAndRefresh2 = firstOrder3 = secondOrder4 = noContext5 = staticContext6 = fullContext · Integer32

State of the context as defined in RFC 3095. States initAndRefresh(1), firstOrder(2), and secondOrder(3) are states of compressor contexts, states noContext(4), staticContext(5) and fullContext(6) are states of decompressor contexts.

rohcRtpContextMode

1.3.6.1.2.1.114.1.1.1.4

INTEGER1 = unidirectional2 = optimistic3 = reliable · Integer32

Mode of the context.

rohcRtpContextAlwaysPad

1.3.6.1.2.1.114.1.1.1.5

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Boolean, only applicable to compressor contexts using the LLA profile. If its value is true, the compressor must pad every RHP packet with a minimum of one octet ROHC padding. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated.

rohcRtpContextLargePktsAllowed

1.3.6.1.2.1.114.1.1.1.6

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

Boolean, only applicable to compressor contexts using the LLA profile. It specifies how to handle packets that do not fit any of the preferred packet sizes specified. If its value is true, the compressor must deliver the larger packet as-is and must not use segmentation. If it is set to false, the ROHC segmentation scheme must be used to split the packet into two or more segments, and each segment must further be padded to fit one of the preferred packet sizes. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated.

rohcRtpContextVerifyPeriod

1.3.6.1.2.1.114.1.1.1.7

Unsigned32

This object is only applicable to compressor contexts using the LLA profile. It specifies the minimum frequency with which a packet validating the context must be sent. This tells the compressor that a packet containing a CRC field must be sent at least once every N packets, where N is the value of the object. A value of 0 indicates that periodical verifications are disabled. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated.

rohcRtpContextSizesAllowed

1.3.6.1.2.1.114.1.1.1.8

Unsigned32 (1..4294967295)

The value of this object is only valid for decompressor contexts, i.e., if rohcInstanceType of the corresponding rohcContextEntry has the value decompressor(2). For compressor contexts where rohcInstanceType has the value compressor(1), this object MUST NOT be instantiated. This object contains the number of different packet sizes that may be used in the context.

rohcRtpContextSizesUsed

1.3.6.1.2.1.114.1.1.1.9

Unsigned32 (1..4294967295)

The value of this object is only valid for decompressor contexts, i.e., if rohcInstanceType of the corresponding rohcContextEntry has the value decompressor(2). For compressor contexts where rohcInstanceType has the value compressor(1), this object MUST NOT be instantiated. This object contains the number of different packet sizes that are used in the context.

rohcRtpContextACKs

1.3.6.1.2.1.114.1.1.1.10

Counter32

The number of all positive feedbacks (ACK) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB.

rohcRtpContextNACKs

1.3.6.1.2.1.114.1.1.1.11

Counter32

The number of all dynamic negative feedbacks (ACK) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB.

rohcRtpContextSNACKs

1.3.6.1.2.1.114.1.1.1.12

Counter32

The number of all static negative feedbacks (ACK) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB.

rohcRtpContextNHPs

1.3.6.1.2.1.114.1.1.1.13

Counter32

This object is only applicable to contexts using the LLA profile. It contains the number of all no-header packets (NHP) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated.

rohcRtpContextCSPs

1.3.6.1.2.1.114.1.1.1.14

Counter32

This object is only applicable to contexts using the LLA profile. It contains the number of all context synchronization packets (CSP) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated.

rohcRtpContextCCPs

1.3.6.1.2.1.114.1.1.1.15

Counter32

This object is only applicable to contexts using the LLA profile. It contains the number of all context check packets (CCP) sent or received in this context, respectively. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated.

rohcRtpContextPktsLostPhysical

1.3.6.1.2.1.114.1.1.1.16

Counter32

This object is only applicable to decompressor contexts using the LLA profile. It contains the number of physical packet losses on the link between compressor and decompressor, that have been indicated to the decompressor. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated.

1.3.6.1.2.1.114.1.1.1.17

Counter32

This object is only applicable to decompressor contexts using the LLA profile. It contains the number of pre-link packet losses on the link between compressor and decompressor, that have been indicated to the decompressor. Discontinuities in the value of this counter can occur at re-initialization of the management system, and at other times as indicated by the value of ifCounterDiscontinuityTime. For checking ifCounterDiscontinuityTime, the interface index is required. It can be determined by reading the rohcChannelTable of the ROHC-MIB. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated.

rohcRtpPacketSizeTable

1.3.6.1.2.1.114.1.2

Index: rohcChannelID · rohcContextCID · rohcRtpPacketSize

This table lists all allowed, preferred, and used packet sizes per compressor context and channel. Note, that the sizes table represents implementation parameters that are suggested by RFC 3095 and/or RFC 3242, but that are not mandatory.

from ROHC-MIB

rohcChannelID

RohcChannelIdentifierA number identifying a channel. The value of 0 must not be used as identifier of an existing channel. (1..4294967295) · Unsigned32 · hint d

The locally arbitrary, but unique identifier associated with this channel. The value is REQUIRED to be unique per ROHC MIB implementation independent of the associated interface. The value is REQUIRED to remain constant at least from one re-initialization of the entity's network management system to the next re-initialization. It is RECOMMENDED that the value persist across such re-initializations.

rohcContextCID

Unsigned32 (0..16383)

The context identifier (CID) of this context.

rohcRtpPacketSize

1.3.6.1.2.1.114.1.2.1.3

Unsigned32 (1..4294967295)

A packet size used as index.

rohcRtpPacketSizePreferred

1.3.6.1.2.1.114.1.2.1.4

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object is only applicable to compressor contexts using the LLA profile. When retrieved, it will have the value true(1) if the packet size is preferred. Otherwise, its value will be false(2). The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated.

rohcRtpPacketSizeUsed

1.3.6.1.2.1.114.1.2.1.5

TruthValue1 = true2 = falseRepresents a boolean value. · Integer32

This object is only applicable to compressor contexts using the UDP, RTP, or ESP profile. When retrieved, it will have the value true(1) if the packet size is used. Otherwise, its value will be false(2). The value of this object is only valid for UDP, RTP, and ESP profiles, i.e., if the corresponding rohcProfile has a value of either 0x0001, 0x0002 or 0x0003. If the corresponding rohcProfile has a value other than 0x0001, 0x0002 or 0x0003, then this object MUST NOT be instantiated.

rohcRtpPacketSizeRestrictedType

1.3.6.1.2.1.114.1.2.1.6

INTEGER1 = nhpOnly2 = rhpOnly3 = noRestrictions · Integer32

This object is only applicable to preferred packet sizes of compressor contexts using the LLA profile. When retrieved, it will indicate whether the packet size is preferred for NHP only, for RHP only, or for both of them. The value of this object is only valid for LLA profiles, i.e., if the corresponding rohcProfile has a value of 0x0005. If the corresponding rohcProfile has a value other than 0x0005, then this object MUST NOT be instantiated.

↑ To TOC